17:04:00 <colindixon> #startmeeting
17:04:00 <odl_meetbot> Meeting started Wed Jan 22 17:04:00 2014 UTC.  The chair is colindixon. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:04:00 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:04:07 <colindixon> #topic agenda and roll call
17:04:11 <cdub> nah, we postponed it for 2 more minutes to wait for this colindixon guy
17:04:18 <colindixon> first sorry, for being late :p
17:04:32 <colindixon> second, go ahead and #info in for who's in attendance
17:04:39 <oflibMichal> #info oflibMichal for openflowjava
17:04:39 <tykeal> #info Andrew Grimberg for infrastructure support
17:04:42 <edwarnicke> #info Ed Warnicke for controller
17:04:43 <michal_rehak> #info michal_rehak / openflowplugin
17:04:43 <goldavberg> #info goldavberg for lispflowmapping
17:04:49 <rovarga> # Robert Varga for yangtools/bgpcep
17:04:55 <rovarga> #info Robert Varga for yangtools/bgpcep
17:05:03 <dbainbri> #info dbainbri (the chicken)
17:05:12 <LuisGomez> #info Luis for Integration
17:05:17 <edwarnicke> dbainbri: LOL
17:05:28 <dkutenic> #info Dana for bgpcep
17:05:29 <phrobb> #info Phil Robb here for download page etc
17:05:37 <colindixon> welcome all
17:05:41 <Konstantin> #info Konsta for defense4all
17:05:42 <cdub> #info Chris Wright for rabble rousing
17:05:43 <prasanna> #info Prasanna for OFplugin
17:05:59 <tykeal> yay rabble rousing!
17:06:11 <abhijitkumbhare> #info Abhijit Kumbhare Openflowplugin
17:06:20 <Madhu> #info Madhu for ovsdb
17:06:21 * edwarnicke worries about the final outcome of cdub's trendline... ;)
17:06:34 <cdub> edwarnicke: nuttin' but trouble
17:06:51 <edwarnicke> cdub: Your reputation proceeds you ;)
17:07:01 <cdub> heh
17:07:14 <colindixon> ok
17:07:23 <colindixon> my plan was to go over the action items from the last two days
17:07:35 <colindixon> and then go over the things which we need to get done by the end of the week
17:08:03 <colindixon> #link https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 the big spreadsheet where' we're tracking these things
17:08:24 * edwarnicke moves that we hereafter refer to it as the spreadsheet of doom
17:08:49 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Hydrogen_Release_Work this is the wiki for tracking things related to release
17:09:06 <tykeal> if you're going to call it that you've got to make sure it's DOOM so we understand how doomed it wants to make us
17:09:10 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-21-17.00.html the meinutes from yesterday's meeting
17:09:23 <colindixon> #topic action items from last time
17:09:48 <colindixon> abhijitkumbhare, michal_rehak: how goes getting the dry runs up and working?
17:10:05 <abhijitkumbhare> We went over the dry run stuff in the OF plugin meeting - and Michal will be doing it this week
17:10:10 <michal_rehak> colindixon: going to set up jenkins job today or tomorrow
17:10:21 <abhijitkumbhare> edwarnicke demoed us it today
17:10:37 <michal_rehak> colindixon: hope I get som green canary for that
17:10:45 <colindixon> green canary ;p
17:10:55 <abhijitkumbhare> that demo may be useful for other projects as well :-) so he will send it to the discuss list
17:11:05 <abhijitkumbhare> or the controller-dev
17:11:06 <colindixon> #info abhijitkumbhare and michal_rehak will get the dry run up and working for openflow{java|plugin} this week
17:11:19 <abhijitkumbhare> only the plugin
17:11:24 <tykeal> michal_rehak: green canary? http://www.sxc.hu/assets/7/60001/canary-bird-landing-538058-m.jpg
17:11:41 <abhijitkumbhare> java is oflibMichal
17:12:03 <colindixon> oflibMichal: what's the status for dry runs on openflowjava then?
17:12:04 <oflibMichal> yup, agree
17:12:15 <oflibMichal> i will set up the jobs tomorrow
17:12:29 <colindixon> #info oflibMichal is actually the person responsible for this with openflowjava, he will do it tomorrow
17:12:30 <michal_rehak> tykeal: no - yellow canary exposed to mine should turn green if testing of air succeeds .. or exposed to blue color
17:12:41 <tykeal> heh
17:12:54 <colindixon> I see that edwarnicke and goldavberg both updated their spreadsheets for -of13 testing in controller and lispmapping
17:13:09 <edwarnicke> I aim to please :)
17:13:23 <colindixon> Konstantin: got his RELEASE pom files thing answered I think
17:13:32 <colindixon> perfect
17:13:47 <Konstantin> Yes
17:13:49 <colindixon> #topic documentation (user guides, release notes, dev guides, release review)
17:14:12 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-22-01.45.html this was discussed in the 5:45p PST meeting yesterday (link to minutes)
17:14:34 <colindixon> #link https://wiki.opendaylight.org/view/HydrogenRelease:Documentation_Scope_and_Location this was the document I put together with the scope and proposed location for each document
17:15:17 <colindixon> the key thing was that we were thinking we would have *one* global, developer guide for hydrogen
17:15:24 <colindixon> because developers will care less about editions
17:15:58 <colindixon> I'm going to actually go and create the pages  for everything after this assuming that people largely agree with what's there
17:16:05 <colindixon> I'd love to get feedback here
17:16:26 <phrobb> Colindixon:  Question, and sorry if it has been asked before.  Are all documents going to be wikis or are HTML/PDFs also planned for any?
17:16:28 <cdub> for developer guide...i think that a global one makes sense, but there's going to be project specific sections?
17:16:29 <colindixon> but I also figure we can move wiki pages pretty easily after the fact
17:16:44 <colindixon> cdub: yes, where necessary
17:16:52 <colindixon> phrobb: I think the plan was for wiki just out of ease
17:17:00 <cdub> colindixon: meaning projects produce APIs...
17:17:02 <cdub> ok
17:17:19 <phrobb> colindixon:  sounds good.  Just needed to confirm for the download page links
17:17:23 <edwarnicke> I am hoping that tbachmanOVSDB can lead us to the documentation promised land for Helium :)
17:17:23 <colindixon> #info cdub points out that (at least some) projects will obviously have their own sections of developer guides
17:17:34 <abhijitkumbhare> will the developer guide actually be linking to the wiki for the project or does this have to be duplicated?
17:17:57 <cdub> and i have to make the obligatory...editions are an oddity for a distribution
17:17:59 <colindixon> #info phrobb asks if it will be wiki, pdf or html. I think the plan is wiki out of ease with links to auto generated html docs where that makes sense, e.g., for REST APIs
17:18:47 <cdub> so .../<edition-name>/User_Guide doesn't necessarily translate well
17:18:53 <edwarnicke> cdub: Not so odd for the kind of lego block thing we are... Eclipse has been doing it for a decade successfully
17:19:02 <colindixon> cdub: I vaguely empathize there, but it's way too late to change that for right now
17:19:06 <edwarnicke> But I agree, not how Linux thinks about the world
17:19:22 <colindixon> and I think that the user guides make sense in terms of "how to get basic forwarding up and running" for base edition
17:19:40 <colindixon> "how to get virtualization up and running" for virt with specific bits for VTN, OVSDB, OpenDOVE, etc.
17:20:01 <colindixon> anyway, this is useful discussion, for the future, but probably best done async on the mailing list
17:20:23 <cdub> </rabblerouse>
17:20:43 <colindixon> #info cdub says he finds editions a bit odd, probably a good topic for the discuss mailing list post-hydrogen
17:20:43 <edwarnicke> cdub: :)
17:21:02 <colindixon> #topic other things from the 5:45p PST meeting
17:21:43 <colindixon> just so others are aware we were connecting the OpenDOVE and VTN teams about building non-java and/or non-OSGi artifacts
17:22:06 <colindixon> also I saw somebody from ConteXstream (sp?) e-mail about dependences for non-OSGI bundles this morning
17:22:14 <colindixon> I just wanted to try to get everyone with these issues together
17:22:38 <colindixon> #info trying to get everyone working with non-java and/or non-OSGi artifacts together
17:22:45 <edwarnicke> Do we know what kind of non-OSGI bundles Contextream is asking about?
17:22:49 <colindixon> #info I know that VTN and OpenDOVE are dealing with this
17:22:51 <edwarnicke> Is goldavberg around?
17:23:01 <goldavberg> we want to use cassandra astyanax
17:23:25 <goldavberg> but it won't be in hydrogen
17:23:26 <colindixon> #link https://lists.opendaylight.org/pipermail/discuss/2014-January/001118.html that's the mail from goldavberg about this
17:23:37 <Madhu> colindixon: i replied to him with suggestions
17:23:40 <phrobb> Are we going to be providing source code zip files to correspond with each edition on the download page?  They are not yet listed on the artifacts wiki.
17:23:41 <Madhu> if it is java bundle
17:23:47 <edwarnicke> So goldavberg you just need to stand up a cassandra server?
17:23:50 <Madhu> i mean java dependency
17:23:54 <goldavberg> yes
17:23:58 <colindixon> #info goldavberg wants to get this working for cassandra astryanax but not for hydrogen
17:23:59 <colindixon> ok
17:24:02 <colindixon> that's good
17:24:06 <colindixon> we can move on then
17:24:18 <edwarnicke> phrobb: We are publishing source for all artifacts to nexus automatically (not saying thats the end all and be all.. but figured it was good to know)
17:24:38 <colindixon> #Info related to that there was also discussion of adding VMs (vmdk and/or docker) for non-OSGI and/or non-java parts
17:24:51 <colindixon> I think that was everything from yesterday that I wanted to go over
17:24:58 <phrobb> edwarnicke.  That sounds good but will we also have zip files of source on the download page?
17:25:05 <cdub> goldavberg: might be good to connect w/ defense4all which (iirc) is also using cassandra (less divergence in client side the better)
17:25:09 <edwarnicke> Question: Are we rolling the VMs as part of integration, and if so can we get a pointer to them?  I'd like to poke them to check things :)
17:25:37 <colindixon> edwarnicke: hideyuki and ashaikh were the people talking about that
17:25:50 <tykeal> edwarnicke: source code zips are being pushed to nexus? I though it was just the <edition>.zip (by integration) and the individual jars from different projects
17:26:08 <edwarnicke> Are hideyuki and ashaikh rolling the VMs?  I thought shague was (I could be mistaken)?
17:26:19 <colindixon> not sure
17:26:27 <colindixon> should I give sombody an action item to check up on that
17:26:34 <ashaikh> edwarnicke: i will check with shague__ on what he recommends we do
17:26:47 <shague__> Luis has the VMs for integration and posted a link today.
17:26:56 <edwarnicke> https://nexus.opendaylight.org/content/repositories/opendaylight.snapshot/org/opendaylight/controller/config-util/0.2.3-SNAPSHOT/ shows sources
17:27:06 <edwarnicke> At least for controller they are being pushed
17:27:11 <tykeal> sure enough
17:27:15 <tykeal> I didn't realize that
17:27:25 <ashaikh> shague__: these would be for VMs containing some specific non-Java functions
17:27:42 <edwarnicke> I don't see the sources for all projects though
17:27:50 <colindixon> #action ashaikh to follow up with shague__ on how get the VMs up on the download page and who will actually roll the VMs. Also this will presumably pull in tykeal, LuisGomez and maybe hideyuki (these are VMs for non-Java and/or non-OSGi pieces)
17:27:55 <edwarnicke> We may want to get folks to update their poms/jenkins jobs to push sources
17:28:25 <colindixon> this sounds like a good thing for people to get on IRC and try to hash out today
17:28:30 <colindixon> maybe immediately after this meeting?
17:28:35 <edwarnicke> Sounds good
17:28:40 <edwarnicke> bgpcep is pushing sources
17:28:46 <edwarnicke> (I'm checking as we go)
17:28:51 <edwarnicke> affinity appears not to be
17:29:08 <goldavberg> where is it configured?
17:29:09 <colindixon> edwarnicke: what is this w.r.t.?
17:29:24 <edwarnicke> (pushing sources to nexus)
17:29:29 <Madhu> colindixon: source archives to be part of nexus
17:29:32 <edwarnicke> defense4all appears to not be pushing sources to nexus
17:29:33 <Madhu> in addition to the binaries
17:29:33 <colindixon> (the next topic I wanted to go over is things marked with a due date of 1/24 just so projects and people have them on their radar)
17:29:46 <colindixon> #topic people who are/are not pushing sources to nexus
17:29:50 <shague__> if sources are pushed to Nexus are they oging to be labeled with the same release as hydrogen or something similar so it is easy to identify on  the download page?
17:29:58 <colindixon> edwarnicke: can you pound info stuff so we can point people at it in the minutes?
17:30:07 <edwarnicke> lispflowmapping appears to not be pushing sources to nexus
17:30:18 <edwarnicke> Sure, I'll aggregate at the end
17:30:34 <goldavberg> edwarnicke where do we change the configuration?
17:30:52 <edwarnicke> goldavberg: I'd have to look... I'll do that right after the survey
17:31:03 <edwarnicke> opendove appears not to be pushing sources for java
17:31:12 <edwarnicke> (I haven't checked opendove for non-java bits)
17:31:14 <colindixon> #info projects should push source archives to nexus, we'll aggregate which projects are and aren't doing that at the end of this meeting
17:31:19 <goldavberg> edwarnicke: ok, thanks
17:31:32 <colindixon> #topic upcoming release task deadlines
17:31:55 <colindixon> #link https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 the big spreadsheet again, I'm just going to read off things with 1/24 as the date in the "last finish date" column on the "activities" tab
17:33:17 <colindixon> #info we need to erradicate and have tests to check for all System.out.print(), System.out.println(), System.err.print(), and  System.err.println()
17:33:40 <colindixon> #info related to that, we need to sanity check log levels
17:33:42 <edwarnicke> #info I believe controller has done this and merged it
17:33:59 <colindixon> #link https://wiki.opendaylight.org/view/Draft_Syslog_Level_Settings log level guidelines are here
17:34:06 <edwarnicke> #info to be more specific, I believe controller has eliminated all System.out.println outside of tests and OSGI CLI commands and merged it
17:34:27 <colindixon> edwarnicke: maybe for tomorrow I'll hunt down individual projects and try to follow up, but for now, I'm just trying to raise awareness
17:34:35 <edwarnicke> #info controller has a patch pending to remove all e.printStackTraces that are not in tests or OSGI CLI commands
17:34:43 <edwarnicke> colindixon: ACK
17:35:23 <phrobb> edwarnicke:  Could you update the Contoller tab indicating the status as "DONE"?
17:35:27 <colindixon> #info we need to update *all* internal dependencies to the current highest snapshot version
17:35:29 <Konstantin> #info defense4all has done with Sytem.out
17:35:46 <colindixon> Madhu: we have a spreadsheet for this, riht?
17:35:54 <cdub> colindixon: that's pretty far along
17:35:55 <Madhu> yes
17:35:57 <edwarnicke> phrobb: Once the stacktrace stuff is merged, yes
17:36:10 <colindixon> cdub: we're waiting on affinity for the check
17:36:13 <cdub> colindixon: but, it's also subject to current outstanding reviews breaking
17:36:15 <Madhu> #info ovsdb is done with system.out.println and e.printstacktrace
17:36:28 * edwarnicke would like to point out that cdub has been harassing folks on external dependencies in the best possible way. He complains and them pushes a patch :)
17:36:30 <cdub> colindixon: i submitted affinity patch last night, worked here, broke in jenkins
17:36:34 <goldavberg> #info lispflowmapping is also done with it
17:37:06 <colindixon> goldavberg: "it" being *print* or version skew?
17:37:12 <Madhu> just caution on the external dependencies patches
17:37:14 <oflibMichal> #info openflowjava is done with system.outs
17:37:18 <Madhu> please don't merge unless it is tested properly
17:37:26 <goldavberg> colindixon: print
17:37:30 <dkutenic> #info bgpcep done with print
17:37:46 <edwarnicke> Madhu: I've been testing them on controller, including testing with the OVSDB test code networkstatic gave me...
17:37:56 <colindixon> #info all projects need to remove SNAPSHOT from any external dependencies
17:37:59 <Madhu> edwarnicke: it is for all other projects as well
17:38:09 <edwarnicke> Madhu: I know :)  And I appreciate your reminding :)
17:38:09 <abhijitkumbhare> #info openflowplugin done with system.outs & some other items - the other items status is on the  spreadsheet
17:38:28 <Madhu> jackson upgrade was a rude shock for me
17:38:29 <colindixon> #info I know we have tests for copyrights, but all projects need to get that resolved by the end of the wek
17:38:32 <cdub> colindixon: that's not as complete...i will update the spreadsheet end of today
17:38:36 <Madhu> so.. just passing along the wisdom :)
17:38:44 <edwarnicke> Madhu: Much appreciated :)
17:39:12 <colindixon> have we frozen SNAPSHOT version for all projects?
17:39:16 <cdub> Madhu: many so far have been a downgrade, and covered by existing unittests (luckily)
17:39:50 <edwarnicke> Welcome networkstatic :)
17:40:01 <Madhu> colindixon: Affinity has not added the versions in jenkins
17:40:05 <networkstatic> hi buddy
17:40:13 <phrobb> #info  lists of files with no copyright went to all projects last week.  I ran a new scan yesterday and will send updated lists to all projects today.  OVSDB and OpenDOVE are doneā€¦ many other projects have not seemed to have started yet.
17:40:14 <Madhu> exchanging emails with suchji
17:40:16 <Madhu> suchi
17:40:28 <colindixon> #info related to external SNAPSHOT versions Madhu points out that jackson introduces some surprises here and wants to give others a heads up
17:40:35 <Madhu> also. the dry-run is not properly setup for Affinity and that is also discussed
17:40:47 <colindixon> Madhu: good, please raise alarms if that is causing us more issues and isn't making progress
17:41:00 <Madhu> luckily Affinity is an application layer
17:41:09 <Madhu> so it is not causing dependency issues on other proejcts
17:41:20 <Madhu> its an isolated case. but will impact the release over all
17:41:29 <colindixon> Madhu and cdub: have we communicated to everyone that versions shouldn't be increased anymore and do we have good tests for that?
17:41:35 <cdub> Madhu: https://git.opendaylight.org/gerrit/#/c/4554/
17:41:41 <Madhu> yes.
17:41:56 <Madhu> the integration tests dependency convergence takes care of it
17:42:17 <colindixon> #info Madhu says that we have communicated to everyone that versions shouldn't be increased anymore and we have good tests for that in integration tests for dependency convergence
17:42:19 <Madhu> thanks cdub :)
17:42:26 <Madhu> there is no versions job in affinity
17:42:31 <Madhu> but seems like you took the shortcut.
17:42:32 <Madhu> thanks
17:42:34 <cdub> Madhu: *nod*
17:42:39 <colindixon> next topic is pom.xmls pointing to the nexus group
17:42:59 <cdub> i don't think we have an owner for that
17:43:20 <colindixon> ok
17:43:25 <colindixon> can somebody take an ownership of that
17:43:26 <cdub> edwarnicke: if you point me at the details I can look into it
17:43:32 <colindixon> I know that this was something edwarnicke brought up
17:43:46 <edwarnicke> cdub: details on what?
17:43:56 <colindixon> "pom.xmls pointing to the nexus group"
17:43:58 <cdub> pom.xml nexus group
17:45:03 <rovarga> is there a template of how it should look like?
17:45:18 <colindixon> #action cdub to coordinate with edwarnicke or delegate to somebody else the task of figuring out how to test for pom.xmls pointing the the nexus group and communicating this to project leads
17:45:21 <colindixon> next topic
17:45:25 <edwarnicke> Ah... if you look repositories in in the pom.xml files
17:45:38 <edwarnicke> I'll follow up with cdub offline
17:45:46 <cdub> edwarnicke: htanks
17:45:50 <colindixon> #info it sounds like LuisGomez is on track with developing tests for -of13 by the end of the week
17:46:06 <LuisGomez> we are working on that
17:46:16 <Madhu> we are testing of13 as well. but we are not out of the woods yet.
17:46:19 <Madhu> facing a few issues.
17:46:31 <LuisGomez> same here
17:46:32 <colindixon> LuisGomez: how are we doing on VTN, OVSDB and Afinity testing for -of13
17:46:35 <colindixon> ok
17:46:47 <edwarnicke> Madhu: What issues?  I sat down last night with networkstatic and everything is working when built from integration as intended
17:47:09 <edwarnicke> LuisGomez: What issues are you facing?
17:47:13 <LuisGomez> not started yet as we are still dealing with basic NSF
17:47:40 <Madhu> edwarnicke: am debugging them
17:47:41 <LuisGomez> Madhusudhan sent a report yesterday i believe
17:47:41 <edwarnicke> LuisGomez: Good to know, thank you :)
17:47:56 <Madhu> mostly the problem is on Ouptut port action
17:48:01 <colindixon> LuisGomez: do we have the VTN, OVSDB and Affinity integration dests with default OF up and working?
17:48:02 <Madhu> it is programmed as drop
17:48:03 <edwarnicke> Madhu: Are you building in the known good way from integration/distribution ?
17:48:14 <Madhu> 01/20 integration
17:48:20 <Madhu> am not building
17:48:22 <networkstatic> i have an idea on the output
17:48:29 <Madhu> but downloading the .zip built
17:48:31 <networkstatic> will follow up on tonights meeting
17:48:32 <edwarnicke> Madhu: Please build from integration as it is the known working way and also what will be going out
17:48:47 <Madhu> edwarnicke: downloading the build .zip is much safer
17:48:55 <Madhu> it has no maven cache issues
17:49:02 <Madhu> and is the intended way too for the releases
17:49:07 <LuisGomez> colindixon: VTN Mgr yes, OVSDB partially, Affininty not yet
17:49:18 <edwarnicke> I am also verifying with networkstatic's test code for code reviews, and seeing all flows he is pushing, including for output
17:49:32 <colindixon> #info it sounds like testing with -of13 is furthest head with OVSDB, but there are still issues being ironed out
17:49:45 <Madhu> networkstatic: is on top of it.
17:50:03 <colindixon> #info LuisGomez for default OF, VTN manager has IT test set up, OVSDB is part set up with IT, and Affiinity isn't started yet
17:50:13 <colindixon> LuisGomez: how worried are you about that for friday?
17:50:59 <LuisGomez> colindixon: not very sure, today we have intgeration call, i will know more after
17:51:23 <colindixon> #info LuisGomez will have more idea about how worried we should be about these integration tests after the integration meeting today
17:51:38 <colindixon> #topic cutting artifacts on 1/27 schedule and attendance
17:51:43 <colindixon> phrobb: how are you doing on this?
17:52:23 <phrobb> I've got partial response from my initial mail sent yesterday.  I will be rousting those who have not yet responded today
17:52:27 <colindixon> #info in an amazing show of commitment both VTN and SNMP4SDN will attend at 9a PST on 1/27 to be on hand for this task despite it begin 2a-6a and 1a-5a for them
17:52:41 <colindixon> phrobb: do we have someplace we're tracking this?
17:53:09 <phrobb> No, good point.  I'll create a wiki page for it and link it off the release page
17:53:29 <abhijitkumbhare> why don't we actually move it to 7 a PST to make it more convenient for VTN & SNMP4SDN?
17:53:36 <colindixon> #action phrobb will create a wiki page and/or spreadsheet tracking this and hang it off the wiki page for cross project release info
17:54:07 <colindixon> abhijitkumbhare: um, I don't know how do others feel about shifting this around?
17:54:14 <colindixon> (this was my last topic for today)
17:54:14 <goldavberg> 7a will be better also for lispflowmapping
17:54:20 <colindixon> sorry for the long meeting
17:54:29 <phrobb> Abhijitkumbhare:  this was suggested at least once in response.  Do the Pacific coast folks mind starting at 7am?
17:54:34 <edwarnicke> colindixon: I have another small thing before we close
17:54:38 <colindixon> #info abhijitkumbhare asks why we couldn't move it to 7a PST to make things better overall
17:54:45 <colindixon> edwarnicke: ok, I'll get you after this
17:55:02 <cdub> which 7am? daily irc or the final cut?
17:55:06 <edwarnicke> Thanks :)
17:55:07 <phrobb> final cut
17:55:18 <colindixon> cdub: yes
17:55:21 <Madhu> 7am - 8.30am is the worst possible time for me guys :)
17:55:28 <Madhu> anything else is fine
17:55:31 <Madhu> even 1am :)
17:55:36 <cdub> ok, 1/27...as a one-off...
17:55:36 <colindixon> 7a PST on 1/27 rather than 9a PST
17:55:41 <colindixon> yes
17:56:00 <cdub> i think i can manage that...rude monday AM ;)
17:56:07 <colindixon> #info Madhu says that 7a-8:30a is the worst possible time for him
17:56:08 <tykeal> haha
17:56:20 <colindixon> Madhu: coudl cdub or networkstatic cover for you?
17:56:28 <Madhu> sure.
17:56:30 <colindixon> until 8:30
17:56:31 <colindixon> ok
17:56:38 <Madhu> am just saying my convenience :)
17:56:41 <cdub> colindixon: s/or/and/ takes two!
17:56:53 <phrobb> colindixon:  It looks like we can move it
17:56:57 <colindixon> phrobb: should I #agree this
17:57:07 <phrobb> works for me
17:57:12 <edwarnicke> I'm fine with it
17:57:16 <phrobb> one last call for objections...
17:57:30 <cdub> i have some ;P
17:57:44 <colindixon> #agree it seems as though we have critical mass for moving from 9a PST to 7a PST for cutting as a one-off shift on 1/27, but we will check at 5:45 and phrobb will follow up with people as part of his getting attendance promises from people
17:57:45 <phrobb> cdub:  rabblerouser
17:57:45 <tykeal> it's not like I won't already be up at that time. Just not normally in front of my computer ;)
17:57:47 * edwarnicke remembers vaguely cdub's introduction...
17:57:50 * cdub wonders what the topic is...
17:58:09 <colindixon> phrobb: maybe you should get cell phone numbers with promises :p
17:58:13 * edwarnicke burma shave
17:58:24 <colindixon> edwarnicke: what was your last topic?
17:59:12 <edwarnicke> So, I'd like to suggest we make connection and disconnection of devices from the controller an info level loggable event
17:59:40 <edwarnicke> For example, when an OF switch connects or disconnects
17:59:42 <rovarga> +1
17:59:44 <cdub> edwarnicke: what is it now?
17:59:44 <colindixon> #topic log levels (specifically for device connection and disconnection)
17:59:56 <edwarnicke> It should not be hugely log polluting
18:00:05 <Madhu> i think it is already info ?
18:00:07 <edwarnicke> But feels in line with the spirit of module startup/shutdown
18:00:07 <colindixon> #info edwarnicke would like to suggest we make connection and disconnection of devices from the controller an info level loggable event
18:00:20 <edwarnicke> Madhu: It is in the code, but not in the recommendations
18:00:27 <edwarnicke> I'd like it to be noted as such in the recommendations
18:00:29 <Madhu> ah.
18:00:31 <cdub> heh, defacto standard
18:00:36 <Madhu> btw.
18:00:38 <colindixon> Madhu: I think his point is that the log level guidelines currently imply that it shouldn't be
18:00:48 <Madhu> did we decide module start/shtudown as info ?
18:00:52 <edwarnicke> cdub: Be careful there, lots of bad things are defacto standards in the code right now for logging ;)
18:00:54 <Madhu> i think that is too much info
18:00:55 <cdub> btw, is it rate limited? for a flapping device?
18:01:02 <cdub> edwarnicke: good point
18:01:07 <colindixon> I think that for the first release, we're really more trying to cut the logs down quite a bit rather than become draconian with our recommendations
18:01:23 <edwarnicke> #link https://wiki.opendaylight.org/view/Draft_Syslog_Level_Settings
18:01:27 <colindixon> regXboi isn't here, so I don't know what his opinion would be
18:01:30 <edwarnicke> That is what everyone has been working against
18:01:43 <colindixon> does anyone object?
18:01:46 <Madhu> hmm.
18:02:07 <Madhu> i remember me & rovarga +1 on not having to log info for module up and down events
18:02:09 <edwarnicke> Created Jan 15, last updated Jan 17
18:02:40 <colindixon> ok, do people want me to #agree it or just raise it in the e-mail
18:02:43 <edwarnicke> rovarga: I thought your +1 was for having info logging on connect/disconnect
18:03:02 <colindixon> I really don't think this is going to make or break the release
18:03:03 <Madhu> colindixon: we can take this offline
18:03:03 <edwarnicke> Has anyone spoken against the proposal to make connect/disconnect info loggable?
18:03:17 <Madhu> +1 for that :)
18:03:47 * cdub has to go...catch you later
18:04:02 <colindixon> #info let's take this issue offline. I don't think this is going to make or break the release. my strong suspicion is that we will allow projects to decide to put this at log level of info if they choose.
18:04:06 <colindixon> #endmeeting