17:00:21 <colindixon> #startmeeting
17:00:21 <odl_meetbot> Meeting started Thu Jan 23 17:00:21 2014 UTC.  The chair is colindixon. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:21 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:39 <colindixon> #topic roll call and agenda
17:00:41 <tykeal> #info Andrew Grimberg for infrastructure support
17:00:49 <colindixon> feel free to #info your way in here
17:00:55 <dkutenic> #info Dana for bgpcep
17:01:00 <tykeal> FYI my attention is a bit thin right now as I'm dealing with an issue
17:01:13 <edwarnicke> #info Ed Warnicke for controller
17:01:20 <colindixon> tykeal: np, taking care of issues is important :p
17:01:34 <ermagan> #info Vina for lispflowmapping
17:01:35 <colindixon> welcome Neelajacques, asomya, goldavberg
17:01:38 <abhijitkumbhare> #info Abhijit Kumbhare openflowplugin
17:01:41 <colindixon> please feel free to #info in
17:01:42 <nite> #info Robert for yangtools
17:01:50 <cdub> #info Chris Wright for posterity
17:01:54 <goldavberg> #info goldavberg for lispflowmapping
17:01:54 <Madhu> #info Madhu here
17:01:54 <tykeal> especially when the integration project builds all started failing do to an update that was supposed to correct for a different problem
17:01:59 <phrobb> #Phil Robb for various stuff
17:02:20 <edwarnicke> cdub: You seem to be a in forward looking mood
17:02:39 <cdub> just don't spell mood backwards
17:02:43 <edwarnicke> tykeal: So was that what happened yesterday... good to know :)
17:02:43 <Neelajacques> #info Neela Jacques for moral support
17:02:47 <colindixon> #info so, my plan for today's agenda is really (1) to highlight what we *need* to get done by Friday and monday (which is pretty much everything) :p and (2) handle issues/questions people are having
17:02:54 <edwarnicke> Neelajacques: Very welcome :)
17:03:17 <tykeal> edwarnicke: yesterday? this was last night that I did the updates. Luis pinged me this morning saying all the -integration jobs are failing.
17:03:18 <oflibMichal> #info oflibMichal for the openflowjava
17:03:31 <colindixon> does that sound like a good plan to people?
17:03:46 <edwarnicke> tykeal: :(
17:03:55 <colindixon> #link https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=1 the big spreadsheet of tracking all things release
17:03:58 <edwarnicke> tykeal: I have every confidence you will sort it out :)
17:04:08 <tykeal> heh
17:04:11 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Hydrogen_Release_Work the cross project work tracking wiki page
17:04:45 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/opendaylight-meeting.2014-01-23-01.45.html meeting minutes from the 5:45 call
17:05:05 <edwarnicke> I'd like to call attention to the fact that hideyuki has discovered a way to do successful dryruns
17:05:13 <colindixon> hey Gera_ and Konstantin
17:05:19 <colindixon> feel free to #info in
17:05:25 <colindixon> edwarnicke: that was my next topic
17:05:33 <Konstantin> #info Konsta for defense4all
17:05:35 <michal_rehak> #info michal_rehak / openflowplugin
17:05:36 * edwarnicke excited! :)
17:05:52 <colindixon> #topic dry runs for cutting artifacts in anticipation of monday's artifact cutting
17:06:03 <colindixon> edwarnicke: can you hook me up with links
17:06:29 <edwarnicke> One moment and I'll paste it in
17:06:40 <colindixon> #info the high order bit is that in the 5:45p PST sync yesterday, hideyuki of VTN came up with a way to get our dry run jenkins jobs to actually succeed despite running off of SNAPSHOT versions
17:06:45 <edwarnicke> #link https://jenkins.opendaylight.org/vtn/job/vtn-bulk-release-prepare-only/configure has an example of using IGNORE_SNAPSHOTS to allow the dry run to succeed. This is very useful for dryrun, but should not be done for release.
17:07:08 <edwarnicke> #info Many thanks to hideyuki for figuring this out and sharing it :)
17:07:10 <colindixon> this should help a lot for preparing for monday and us not getting hung up
17:07:15 <goldavberg> edwarnicke i tried running it for lispflowmapping, but it failed :(
17:07:26 <edwarnicke> goldavberg: Failed how?
17:07:53 <goldavberg> edwarnick it dosn't realy say how, but when its trying to read dependencies
17:08:16 <edwarnicke> Hmm...
17:08:31 <Madhu> goldavberg: can u point us to the logs ?
17:08:35 <goldavberg> https://jenkins.opendaylight.org/lispflowmapping/job/controller-bulk-release-prepare-only/13/
17:08:39 <colindixon> #info people should please try this and then get help on the main IRC channel
17:08:59 <colindixon> #topic release artifact cutting on 1/27
17:09:04 <colindixon> sorry, not trying to cut people off
17:09:06 <edwarnicke> If it works for you, you may also want to show up to the 5:45pm to see if hideyuki can help out if you get stuck
17:09:25 <colindixon> phrobb: how are we doing on hunting people
17:09:30 <colindixon> and are we officially on for 7a PST?
17:10:25 <phrobb> Hunting people is good… I think we have everyone… I'll put a spreadsheet up hopefully before this meeting is over with: Contact Name, Project represented, and "dry run success" columns… anything else needed?
17:10:26 <colindixon> edwarnicke, goldavberg, Madhu: I'm not trying to cut off discussion, but just trying to connect people that are having isseus
17:10:34 <Madhu> please go ahead sir
17:10:51 <colindixon> I assume you guys will connect and make progress :-)
17:10:57 <edwarnicke> FYI:
17:10:59 <colindixon> if not hit me with a herring
17:11:03 <edwarnicke> #info from 5:45pm: AGREED: Concur: AGREED: it seems as though we have critical mass for moving from 9a PST to 7a PST for cutting as a one-off shift on 1/27, but we will check at 5:45 and phrobb will follow up with people as part of his getting attendance promises from people
17:11:19 <colindixon> phrobb: that sounds good
17:11:31 <edwarnicke> colindixon: You are fine on conversation management from my point of view... all good :)
17:12:03 <goldavberg> colindixon: no hard feelings :)
17:12:04 <colindixon> #action phrobb thinks he has everyone for the 7a PST 1/27 meeting and will put a spreadsheet up hopefully before this meeting is over with: Contact Name, Project represented, and "dry run success"
17:12:23 <colindixon> perfect
17:12:26 <edwarnicke> phrobb: Thank you :)
17:12:38 <colindixon> #topic per-project code cleanup tasks before friday
17:13:10 <edwarnicke> colindixon: Do you want report out here?
17:13:10 <colindixon> I have reps from all of these projects on, so I'll want an ACK from all of you: openflowplugin, defnese4all, openflowjava, ovsdb, lispflowmapping, yangtools, controller, bpgpcep
17:13:37 <colindixon> #info I have reps from all of these projects on, so I'll want an ACK (but not necessarily a readout) from all of you: openflowplugin, defnese4all, openflowjava, ovsdb, lispflowmapping, yangtools, controller, bpgpcep
17:13:49 <colindixon> basically, I just want to know that each project is aware of what they have to do
17:13:50 <abhijitkumbhare> ACK: openflowplugin
17:14:01 <goldavberg> ACK: lispflowmapping
17:14:09 <Madhu> ACK ovsdb
17:14:14 <Konstantin> ACK: defense4all
17:14:18 <dkutenic> ACK: bgpls
17:14:30 <colindixon> #info basically, I just want to know that each project is aware of what they have to do and I'll harass people latter for not having updated the spreadsheet
17:14:33 <dkutenic> ACK: bgpcep
17:14:39 <oflibMichal> ACK: openflowjava
17:14:40 <edwarnicke> ACK controller (with caveat that while INFO levels have been pushed won into place, others haven't, and copyright/license headers are still to be done)
17:14:56 <edwarnicke> I could actively use a hand with copyright/license headers
17:15:13 <edwarnicke> (and lower level log resolution would be welcome as well)
17:15:19 <colindixon> these are the topics you need to get taken care of:
17:15:21 <colindixon> * Remove all uses of System.out.println (also System.err, e.printStacktrac() and .print())
17:15:21 <colindixon> * Set log levels on all log statements to appropriate level
17:15:23 <colindixon> * Update dependency versions in all pom.xml files to current SNAPSHOT version for all ODL Dependencies
17:15:24 <colindixon> * Update dependency version on external artifacts to match across ODL
17:15:26 <colindixon> * Remove all dependencies on SNAPSHOT versions of external artfacts
17:15:27 <colindixon> * Insert copyright/licence headers in all files for which it is feasible
17:15:29 <colindixon> * Freeze SNAPSHOT versions of ODL components (communicate to all projects and insure comprehension)
17:15:30 <colindixon> * Update all projects maven pom.xml to only use the nexus 'group' rather than multiple repos.
17:15:30 <colindixon> * Fix all cases that cause exceptions to be thrown at the OSGI console
17:15:38 <goldavberg> lispflowmapping still has to add license headers to non java files. which other file types need license?
17:16:01 <colindixon> can I get an ACK for yangtools?
17:16:07 <dkutenic> goldavberg: .project, pom.xml, .gitignore as I learned
17:16:44 <colindixon> nite: that would be you for yangtools
17:16:53 <nite> sorry, got distracted
17:17:05 <Madhu> phrobb: are we still waiting on the copyright headers for pom.xml discussion ?
17:17:10 <goldavberg> dkutenic: thanks
17:17:11 <cdub> btw, i've noticed that enforcer is not getting all deps
17:17:20 <colindixon> I just want to get an ACK that you know the above starred items are per-project code cleanup issues due by friday
17:17:27 <nite> colindixon: ack for yangtools, need to go through the files
17:17:34 <nite> will do that tomorrow
17:18:08 <cdub> and yangtools bump to 0.6.0 seems to be one that's not getting caught
17:18:21 <colindixon> #info got ACKs for all projects in attendance: openflowplugin, defnese4all, openflowjava, ovsdb, lispflowmapping, yangtools, controller, bpgpcep
17:18:23 <colindixon> cdub:
17:18:27 <edwarnicke> cdub: Could you say more?
17:18:30 <colindixon> do you want a topic for that
17:18:41 <colindixon> #topic enforcer not catching all version sync issues
17:18:44 <colindixon> cdub
17:18:46 <colindixon> the floor is yours
17:19:02 <cdub> ok, i run three different tools
17:19:22 <cdub> #info project-info-reports:dependency-convergence
17:19:35 <cdub> #info mvn project-info-reports:dependency-convergence
17:19:45 <cdub> #info mvn validate (enforcer)
17:20:03 <cdub> #info mvn versions:compare-dependencies -DremotePom=org.opendaylight.controller:distribution.opendaylight:0.1.1-SNAPSHOT
17:20:20 <cdub> #info the latter is showing some skew that the former 2 aren't catching
17:20:29 <colindixon> [so people know, my remaining topics are: (1) documentation, (2) OF1.3 testing if we have time, (3) TSC readout]
17:20:45 <cdub> #info mainly it's been yangtools bump to 0.6.0 that's not getting caught
17:20:52 <cdub> ok...i think that captures it
17:20:58 <colindixon> [if you have other things you need/want to go over, let me know]
17:21:05 <colindixon> thanks!
17:21:06 <edwarnicke> cdub: How often are the version change Jenkins jobs running
17:21:08 <edwarnicke> ?
17:21:10 <nite> cdub: which project is this?
17:21:12 <cdub> daily
17:21:18 <edwarnicke> Are you sure daily?
17:21:23 <colindixon> cdub: so, are we worried about tracking these things
17:21:25 <edwarnicke> Because I'm pretty sure controller was running weekly
17:21:27 <cdub> edwarnicke: afaik...it's per-project
17:21:46 <edwarnicke> Could everybody manually run their release versions Jenkins job just to be sure?
17:21:53 <cdub> it doesn't matter how often..point is enforcer isn't good enough
17:22:27 <cdub> and versions:compare-dependencies creates a file per project, so needs some scripting to cull the files
17:22:34 <cdub> i.e. not simple build fail
17:23:23 <colindixon> ok
17:23:30 <colindixon> this sounds like it's worth going over
17:23:31 <rovarga> the thing is ... I went through pretty much all projects grepping for yangtools and I have submitted patches
17:23:32 <cdub> for example, some variations of:
17:23:33 <colindixon> but probably not any more time here
17:23:37 * edwarnicke sad because I was hoping that the version jobs were the solution :(
17:23:54 <cdub> #info mvn versions:compare-dependencies -DremotePom=org.opendaylight.controller:distribution.opendaylight:0.1.1-SNAPSHOTmvn versions:compare-dependencies -DremotePom=org.opendaylight.controller:distribution.opendaylight:0.1.1-SNAPSHOT -DreportOutputFile=${project.build.directory}/depDiffs.txt
17:23:55 <colindixon> we really do need to resolve this though
17:23:58 <rovarga> the only one outstanding I know of is affinity
17:24:24 <cdub> #info find -name defDiffs.txt | xargs ...
17:24:33 <cdub> oops, typos abound above
17:24:34 <colindixon> cdub: are you OK with moving on? or were you hoping to get more accomplished here now?
17:24:40 <edwarnicke> rovarga: What issue are you aware of with affinity?
17:24:44 <cdub> colindixon: yes
17:24:50 <colindixon> I don't want to cut you off, but I *really* do want to get this resolved because it matters
17:24:51 <colindixon> ok
17:24:52 <rovarga> edwarnicke: https://git.opendaylight.org/gerrit/#/c/4412/ still not merged
17:25:02 <colindixon> #topic documentation
17:25:16 <cdub> colindixon: i can't tell "get it resovled" or "move on"
17:25:34 <cdub> colindixon: either is fine for me
17:25:48 <colindixon> #link https://wiki.opendaylight.org/view/Release/Hydrogen/ I posted a rood documentation page for the hydrogen release here
17:26:21 <colindixon> #help we *really* need people to jump in there and start to get these things up so that we have *some* documentation come release
17:26:36 <colindixon> I think abhijitkumbhare had some suggestions about revising the guides
17:26:48 <colindixon> but this is important stuff
17:26:53 <colindixon> and please, please, PLEASE, help
17:28:17 <abhijitkumbhare> i was thinking "https://wiki.opendaylight.org/view/Release/Hydrogen/Base/User_Guide" should link to per project wikis
17:28:52 <edwarnicke> abhijitkumbhare: There are some per Edtiion things in common
17:28:56 <edwarnicke> (installing, basic running, etc)
17:29:08 <colindixon> abhijitkumbhare: I was hoping that we would not have to have per-project guides for all of that
17:29:13 <colindixon> that is basicaly the point of editions, no?
17:29:23 <colindixon> to provide some bundled up user-facing functionality
17:29:55 <edwarnicke> colindixon: I would say so :)
17:30:24 <abhijitkumbhare> yes - for the common install stuff yes - but stuff like architecture, etc. why should it be repeated in 2-3 different places?
17:30:58 <colindixon> fair enough
17:31:03 <edwarnicke> Among other things... its different in some cases
17:31:15 <edwarnicke> virtualization edition is *way* different for install and run
17:31:21 <colindixon> #action colindixon to look into creating some transcluded pages for truly common things
17:31:24 <edwarnicke> serviceprovider is somewhat different for install and run
17:31:59 <colindixon> #topic integration testing for non-base editions and for -of13
17:32:01 <colindixon> LuisGomez:
17:32:03 <colindixon> how goes this
17:32:08 <colindixon> and how worried should we be?
17:33:01 <colindixon> do we have a LuisGomez
17:33:32 <colindixon> ok
17:33:34 <LuisGomez> hi
17:33:34 <colindixon> apparently not
17:33:38 <colindixon> oh there we go
17:33:40 <colindixon> yay
17:33:56 <colindixon> I just wanted to get a readout on testing non-base editions and -of13
17:34:04 <colindixon> and figuring out what shape we think we're in
17:34:06 <LuisGomez> sorry, i am having a parallel chat with andy due to an issue in the distribution build
17:34:07 <colindixon> for cutting things on monday
17:34:24 <colindixon> LuisGomez: np, and if you don't have time and want to give a readout to discuss later, that's fine
17:34:54 <colindixon> in fact, let's do that
17:35:09 <LuisGomez> yes i will send you a report later
17:35:09 <colindixon> #action LuisGomez to send a mail to discuss with the state of integration tests later today
17:35:35 <colindixon> everyone, are there any other topics we need to cover here before moving onto the TSC readout for 25 minutes from now?
17:36:18 <colindixon> rovarga, abhijitkumbhare, edwarnicke, michal_rehak, oflibMichal, goldavberg, Konstantin, etc.
17:36:49 <colindixon> ok
17:36:50 <Gera_> defense4all has an issue with integration builds in either sp and virt editions
17:36:56 <edwarnicke> Has anything been done on creation reviews?
17:37:06 <colindixon> edwarnicke: I don't think so
17:37:10 <colindixon> I put up a template
17:37:24 <edwarnicke> Thank you :)
17:37:30 <colindixon> edwarnicke: who should Gera_ reach out to?
17:37:33 <edwarnicke> Has dmm scheduled?
17:37:48 <colindixon> #topic release reviews
17:37:50 <edwarnicke> Gera_: what issues are you seeing?
17:37:55 <Gera_> it is commented out,and we are pretty clueless as to what has to be done
17:38:18 <colindixon> #link https://wiki.opendaylight.org/view/Sample_Release_Review sample release review document which each project can copy and use
17:38:33 <colindixon> #action dmm should set these reviews up, colindixon will reach out to him about this on the TSC call
17:38:52 <colindixon> edwarnicke, Madhu, others, who can help Gera_ out?
17:39:01 <colindixon> #topic call for other topics from the group
17:39:07 <Madhu> Gera_: sure. lets take it offline
17:39:12 <Gera_> I have to admit I do not understand what that integration pom is doing, but d4a dependencies are not correct. there should be a single dependency, but I do not know if this is the right one - depending on the purpose
17:39:15 <Gera_> of the integration
17:39:23 <edwarnicke> Gera_: Lets get that fixed then :)
17:39:40 <Gera_> looking for help guys! :-)
17:39:41 <colindixon> #action Madhu and Gera_ and edwarnicke to look into why defense4all is having issue with virt and sp editions
17:39:58 <Gera_> great - when and how?
17:39:59 <edwarnicke> Gera_: We are all in this together :)
17:40:06 <Gera_> ;-)
17:40:08 <colindixon> Gera_: I think people will follow up with you in private chats and on the main irc channel
17:40:08 <Madhu> Gera_: pinging u right now
17:40:10 <edwarnicke> Gera_: What are your timezone constraints?
17:40:15 <colindixon> #topic TSC readout
17:40:29 <edwarnicke> Madhu: Would you like to take the conversation with Gera_ to #opendaylight ?
17:40:33 <Gera_> i have 2 more hours till i burn out ...
17:40:42 <Madhu> edwarnicke:  i just pinged Gera_ :)
17:40:45 <Madhu> waiting for response
17:40:46 <Madhu> ..
17:40:49 <edwarnicke> #link https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=15 TSC Report Spreadsheet
17:41:00 <colindixon> so, high-order bits
17:41:04 <Madhu> Gera_: please look @ my DM
17:41:29 <colindixon> we've been having mostly good success with getting people to do dry runs and getting versions synced with a few notable exceptions
17:41:59 <colindixon> cdub: you probably have some things you want to add here
17:42:23 <edwarnicke> So, in the spreadsheet last week, we called out at high level 'Global Code Cleanup' 'Documentation' 'Additional Testing' 'Finalization Activities' and 'Release Reviews'
17:42:27 <edwarnicke> In red/yellow/green
17:42:37 <cdub> high level, some issues w/ version sync...tools aren' 100%
17:42:49 <colindixon> #info there a variety of code cleanup tasks that each project has to do, I think we're yellow there with some projects being closer to red
17:43:08 <colindixon> I think that documentation is a bit scary
17:43:13 <cdub> aka, java dependencies are hard, let's go shopping
17:43:22 <colindixon> but I have hopes that the next 4 days will help
17:43:49 <colindixon> version sync is having some issues, but we can likely get it resolved by hook or by crook
17:44:19 <colindixon> testing is hard to figure out, it seems like base edition with OF10 is doing well
17:44:32 <colindixon> everything else is a work in progress
17:44:34 <edwarnicke> OF13 is also converging
17:44:55 * rovarga gotta split
17:45:23 <colindixon> I'd really like to get this wrapped up in ~5 mins, so we can have a 10 minute break before the TSC
17:45:44 * edwarnicke seconds
17:45:56 <colindixon> my personal take is that I think I'd put a lot of yellow here :-/
17:46:12 * cdub thirds
17:46:37 <colindixon> code cleanup is green for most things, red for a few projects, and yellow for versions
17:46:48 <colindixon> testing is green for base, yellow for most everything else
17:47:03 <colindixon> are we planning to release Virt and SP at the same time as base?
17:47:31 <colindixon> finalization is actually I think green
17:47:39 <colindixon> we've had good luck with getting people to do dry runs
17:47:55 <edwarnicke> folks, could you look at: https://docs.google.com/spreadsheet/ccc?key=0AoSzir1BfjyWdDQyVElWNG9mcWxhblREckZjbjFxUVE#gid=15 and see if it looks like it represents our state at a high level
17:48:08 <colindixon> the only possible thing is that I'm not 100% sure I'd put testing as green
17:48:12 <colindixon> I think it's green for base
17:48:52 <colindixon> the things causing me the most worry right now are: documentation, non-base editions, and OF13 testing
17:48:57 <edwarnicke> Is anyone running canary in the coal mine testing per platform?
17:49:08 <colindixon> ashaikh:
17:49:13 <edwarnicke> colindixon: I believe it comes down to a question of testing presence vs passing
17:49:22 <colindixon> fair enough
17:49:27 <edwarnicke> LuisGomez: and his team are running the integration testing for OF13
17:49:29 <ashaikh> edwarnicke: other than those already testing some of the platforms, not yet
17:49:30 <colindixon> we can raise these issues on the TSC meeting
17:49:35 <edwarnicke> We have 4-5 test failures we are working on
17:49:42 <edwarnicke> But several seem to root in the same root cause
17:49:51 <colindixon> are we testing VTN, OVSDB, and things?
17:49:54 <edwarnicke> So yellow for testing
17:50:03 <colindixon> ok
17:50:14 <colindixon> and then we need to do the canary testing
17:50:17 <Madhu> fwiw, we are still debugging issue with of13 with ovsdb integration
17:50:30 <Madhu> network static is working on it.
17:50:53 <colindixon> so the pingall in mininet failed for the first 2 pings for me recently
17:50:54 <edwarnicke> Madhu: Have you tried it the known working way?
17:50:56 <colindixon> as in last night
17:51:06 <edwarnicke> Madhu: please ask networkstatic to ping me
17:51:06 <Madhu> edwarnicke: yes. i tried all possible ways :)
17:51:12 <phrobb> #info Spreadsheet for the Hydrogen Artifact Creation Event on January 27th is posted in the 'Addendum' section of the Simultaneous Release page - Leads please fill in the "Dry-Run Status"
17:51:13 <edwarnicke> I'd like to get him unstuck
17:51:20 <Madhu> anyways. am debugging. lets c
17:51:31 <edwarnicke> And I have been running his test code as a stock part of my code review and consistently getting his flows on the switch
17:52:08 <edwarnicke> Madhu: So are you buidling from integration/distribution ?
17:52:17 <Madhu> yep.
17:52:21 <Madhu> latest as of yeterday
17:52:27 <edwarnicke> Let follow up offline and see what we can figure out
17:52:34 <Madhu> ok
17:52:40 <colindixon> #info the TSC report is on the link above, the big issues we're worried about are: (1) documentation, (2) some testing and fixing failures for non-base editions and OF13, (3) getting canary tests up per-platform
17:52:48 <colindixon> I'm moving to end the meeting now
17:53:38 <colindixon> #link https://docs.google.com/spreadsheet/ccc?key=0AveQs8CH9DEUdFg5MVBXb0k1amFJX1BRcFdmc1VKekE&usp=sharing#gid=0 the spreadsheet in question from phrobb
17:53:45 <colindixon> #endmeeting