18:01:26 <phrobb> #startmeeting OpenDaylight TSC Meeting
18:01:26 <odl_meetbot> Meeting started Thu Feb 20 18:01:26 2014 UTC.  The chair is phrobb. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:01:33 <ekarlso> that's the link
18:01:58 <vijoy> thanks
18:02:19 <dmm> #info dmm
18:02:21 <phrobb> TSC members please pound info in for the roll call
18:03:21 <vijoy> #info vijoy
18:04:17 <cdub> #info Chris Wright
18:04:49 <RobDolin> #info Rob Dolin, proxy for Rajeev Nagar (Microsoft)
18:06:06 <phrobb> #topic Acceptance of Minutes
18:06:47 <phrobb> #people have not reviewed minutes
18:07:37 <colindixon> #info people have not reviewed the minutes, plan is to push them as drafts and then approve them formally later
18:08:18 <colindixon> #info note that janmedved is here on behalf of edwarnicke_
18:09:30 <mestery> where is the link to the hackathon?
18:09:36 <mestery> I can't seem to find it
18:09:38 <mestery> anyone have it?
18:09:48 <dmm> @mestery -- standby
18:09:54 <mestery> thanks dmm
18:10:00 <tnadeau> we need to put hackathon info right on the front page of opendaylight.org
18:10:09 <tnadeau> people aren't going to grovel through the site to find that stuff
18:10:28 <tnadeau> maybe <philrobb> can work on that (please)?
18:10:29 <mestery> agreed tnadeau
18:10:37 <RobDolin> #info Hackfest details are here: https://wiki.opendaylight.org/view/HackFestAgenda#HackFest_Agenda:_March_26th_-_28th
18:11:11 <phrobb> thanks RobDolin!
18:11:25 <colindixon> #link https://wiki.opendaylight.org/view/HackFestAgenda#HackFest_Agenda:_March_26th_-_28th (a clickable version of the hackfest link)
18:11:29 <tnadeau> please avoid the fall IETF (its in Hawaii) https://www.ietf.org/meeting/upcoming.html
18:11:53 <colindixon> tnadeau: I take it you mean avoid scheduling over, rather than just avoid :p
18:11:54 <phrobb> will do
18:12:22 <phrobb> #topic Creation Review DPDK_vSwitch
18:14:43 <RobDolin> #link https://wiki.opendaylight.org/view/Project_Proposals:OpenDayLight_Intel%C2%AE_DPDK_vSwitch  Uri (Intel) is presenting on DPDK vSwitch proposal
18:16:48 <phrobb> #info dmm asks "how ready" the project is to move to incubation?
18:16:59 <vijoy> folks not talking please mute - there is a horrible echo
18:17:08 <colindixon> vijoy: I think it's just uri's phone
18:17:17 <colindixon> I don't see anyone else talking :-(
18:17:52 <phrobb> colindixon, yep that is what I am seeing also
18:19:45 <phrobb> #info team does not know that a new project is needed.  The team will first see if working with existing projects is sufficient
18:23:01 <phrobb> #info the DPDK vSwitch team will do deeper eval of work needed and impact on existing projects.  They will then come back and see if a new project is warranted, or if they could fit within the existing projects.
18:24:52 <tnadeau> does their proposal have a name?
18:27:15 <ashaikh> tnadeau: #link https://wiki.opendaylight.org/view/Project_Proposals:OpenDayLight_Intel%C2%AE_DPDK_vSwitch
18:27:34 <colindixon> To be honest, I think this a pretty good idea. In general, I think that the right approach is spawn new projects when we need them.
18:28:32 <phrobb> #topic Helium Release Planning and the Fall Summit
18:29:19 <phrobb> #info vote on shall the next release of OpenDaylight be named "Helium"?
18:29:20 <tnadeau> aye (like a pirate)
18:29:34 <RobDolin> aye
18:29:36 <phrobb> #agreed  The name of the second release is "Helium"
18:29:44 <mestery> Yay for Helium!
18:30:17 <tnadeau> thats a good motif
18:30:20 <RobDolin> DMM suggests: Major releases as elements; minor releases as isotopes.
18:30:52 <tnadeau> Post a roadmap of release names?
18:31:27 <RobDolin> H.1 H.2, H.3,... He.1, He.2, He.3, ... ?
18:31:46 <colindixon> #info there is a discussion about whether we should name the sub-releases as isotopes of the element of the main release, e.g., deuterium, tritium, etc.
18:31:57 <phrobb> #info discussion ensued on minor release naming…
18:31:57 <colindixon> #info others propose simple numbering for minor releases
18:32:18 * colindixon abdicates his #info throne to phrobb :p
18:32:46 <phrobb> no no no colindixon, please continue to help out
18:33:17 <RobDolin> H (or H.0) was released at the OpenDaylight Summit, H.1 will be next minor release, He (or He.0) will be next major release ?
18:34:17 <alagalah> minor suggestion on release naming ?
18:34:30 <alagalah> hydrogen.r1, etc is more intuitive than hydrogen.1 etc
18:34:36 <phrobb> #agreed as project goes along, major releases as elements, minor releases numbered
18:35:02 <phrobb> #info who maintains the branches and how does it get done?
18:35:10 <tnadeau> definitely too much for one person
18:35:16 <phrobb> #info the work is too much for one person
18:36:00 <tnadeau> wrangler -> cat herder
18:36:46 <phrobb> #info a release engineer can manage the overall mechanics, but each project needs to manage the creation and evolution of stable branches within their projects
18:37:24 <phrobb> #info it is noted that we need a bug-fix release soon.  What are the concrete steps?
18:40:06 <phrobb> #action janmedved agreed to work with cdub on creating a stable release branch for minor releases
18:47:30 <phrobb> #topic Helium planning and the Summit
18:48:54 <phrobb> #action phrobb will take the discussion for actual dates to the list
18:49:04 <phrobb> #topic At-Large TSC Elections
18:49:38 <phrobb> #info dmm had sent a mail proposing 2 at large TSC members to the TSC list
18:50:07 <phrobb> #info, response from the list agreed that two members were a good number
18:50:33 <phrobb> #info dmm asks how will nominations be done
18:50:37 <tnadeau> I'd say people can just nominate people (or be nominated)
18:50:45 <tnadeau> no need for a committee if you ask me
18:51:10 <tnadeau> gaming: committees are gamed. its more transparent if people do it
18:51:28 <phrobb> #info discussion ensued on various methods for nomination
18:54:34 <phrobb> #info several members are in favor of changing charter to allow all contributors to the project to be allowed to run and vote for at large TSC positions
18:55:53 <phrobb> #action cdub to build a proposal for charter-change for TSC review for next week's TSC meeting.
18:57:37 <phrobb> #topic DLUX request to change the project license to Apache or dual licensed as Apache/EPL;  Is there technical merit in that activity the TSC would agree to?
18:58:34 <phrobb> #info question from cdub - does the DLUX team see a code-flow moving at the pace of Horizon -  or is there other motivation
18:59:39 <phrobb> #info DLUX team noted that code created to augment horizon code can't be contributed back, so it is difficult stay in sync with horizon project
19:03:35 <tnadeau> either the call is done or webex is having issues again. audio line just disconnected me
19:03:49 <RobDolin> @tom - Call is still going.
19:07:49 <phrobb> #info several TSC members would like to understand technical options of using Horizon while not changing the license of the DLUX project
19:15:11 <phrobb> #agreed TSC requests DLUX team to provide more detail on what they want to do, the various options on how to do it, and the cost/benefit technically of each - creating a wiki page to cover these topics, and the technical implications
19:17:01 <phrobb> #topic Collaboration Tools
19:17:48 <phrobb> #info topic deferred until next week
19:18:10 <phrobb> #topic INCNTRE engagment update
19:19:49 <phrobb> #info dmm provided update on activities thus fare with trying to work with INCNTRE to date.
19:20:25 <phrobb> #info this effort is currently "stuck" due to NDA requirement.
19:23:05 <phrobb> #topic Branding
19:23:21 <phrobb> #action  phrobb to get branding discussions going again
19:24:59 <phrobb> #topic  Possible renaming of Application Policy project to avoid confusion between OpenDaylight and OpenStack projects
19:25:46 <phrobb> #info need to understand tech/logistic issues of changing repo, mailing lists, etc.
19:29:08 <phrobb> #info several TSC members expressed desire to not oversee naming of projects unless there is some kind of onforeseen issue
19:29:54 <phrobb> #agreed TSC does not need to intervene on this topic at this time
19:30:18 <phrobb> #endmeeting