17:17:43 <colindixon> #startmeeting
17:17:43 <odl_meetbot> Meeting started Mon Mar 10 17:17:43 2014 UTC.  The chair is colindixon. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:17:43 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:17:53 <colindixon> #topic hackfest
17:18:10 <colindixon> #info phrobb asks for people to please rsvp or contact him if they need help. it's in 2 weeks.
17:18:20 <colindixon> #topic samples and tutorials
17:20:07 <colindixon> #info networkstatic has a sample tutorial relating to OVSDB that he wants to push somewhere
17:20:15 <regXboi> flip the topic
17:20:21 <ashaikh> where is the learning switch MD-SAL tutorial that was mentioned — is it the slides that are posted in the presentations section on the wiki?
17:20:24 <colindixon> regXboi: will do
17:20:35 <rovarga> ashaikh: yes
17:20:45 <rovarga> ashaikh: there is wiki page that goes with it
17:21:06 <rovarga> let me dig it out
17:21:17 <colindixon> #info there's discussion as to whether we want a separate project
17:21:23 <ashaikh> rovarga:  thanks, i found the slides, but not the wiki
17:21:23 <colindixon> #info there's discussion as to whether we want a separate project for samples and tutors
17:21:42 <colindixon> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Hydrogen_Developer_Guide:MD-SAL_App_Tutorial sample tutorial for the MD-SAL building a learning switch as well
17:22:07 <colindixon> #info some people suggest using the integration project as a home for these things (also there was discussion in the past of using integration for docs)
17:22:09 <rovarga> colindixon: thanks
17:22:16 <colindixon> #action colindixon to look into these approaches
17:22:30 <rovarga> ashaikh: colindixon's link is the one that should go with the slides
17:22:36 <colindixon> #topic MD-SAL performance with jan medved (presentation happening on webex)
17:23:03 <ashaikh> cool, thanks
17:23:05 <colindixon> (as a side note, we should just run these meetbots for all our global calls)
17:23:27 <regXboi> colindixon: +1
17:23:39 <colindixon> ttkacik: can we get a link to that?
17:24:17 <colindixon> #info the current test is using the fork of cbench that came with edwarnicke__'s mininet VM
17:24:45 <ttkacik> #link https://git.opendaylight.org/gerrit/gitweb?p=openflowplugin.git;a=tree;f=drop-test;h=fa281245e06ce49410bcb9dfbe1099078b6508bd;hb=HEAD
17:25:08 <ttkacik> #info openflowplugin.git/drop-test
17:25:21 <colindixon> thanks ttkacik!
17:26:52 <colindixon> #info the cbench running seems to produce something like 14,000 operations per second using a simple reactive drop rule
17:27:07 <regXboi> #info that bounces around though
17:32:28 <colindixon> #link http://yuba.stanford.edu/~derickso/docs/hotsdn15-erickson.pdf for those interested, this is David Erickson's paper on Beacon's performance in HotSDN which showed getting a bit more than 10 million ops per second
17:32:49 <colindixon> #info this isn't to say that we can actually get there, but it's useful to read
17:33:26 <colindixon> #info testing floodlight and producing results that are about the same, peaking around 16,000 operations per second
17:33:39 <colindixon> #info (it should be noted that the 10 million number for Beacon is on real hardware)
17:34:43 <colindixon> #info it should be noted that when running floodlight, we're using their default forwarding, not a dummy drop program
17:40:16 <colindixon> #info colindixon asks if logging is hurting performance, rovarga says he doesn't think so because they used debug logging in the MD-SAL to deal with things and it didn't drop too much
17:41:54 <colindixon> #info running with AD-SAL gets gets 34,000-37,000 operations per second, but subsequent runs seems to not work
17:43:39 <colindixon> #info this needs to be looked into a bit (at least the failing after the first) and to see if the cbench is recording the packet_outs in addition to the flowmods, but we will look into that
17:44:23 <colindixon> #info there is a reactive dropping application for the AD-SAL at controller.git/samples/reactiveforwarding/
17:44:45 <colindixon> #info actually it's controller.git/opendaylight/samples/reactiveforwarding/
17:45:48 <colindixon> (others should feel free to #info things in here as well)
17:46:50 <colindixon> #topic MD-SAL datastore performance testing
17:46:56 <colindixon> just trying to break up the one mega-topic here
17:48:28 <colindixon> #info performance is ~100x slower than other tests, i.e., 45-50 operations per second
17:49:15 <colindixon> #info the cpu utilization seems to be relatively low, and thus likely there are not enough threads and/or too many locks
17:49:54 <colindixon> #info most time is being spent in the two phase commit logic (which means that you're presumably holding the lock)
17:54:27 <ttkacik> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Architecture:DOM_DataStore
17:55:12 <colindixon> #topic planning for the MD-SAL data store going forward
17:56:39 <colindixon> #info it's clear that we need to fix this performance, and we need to start a dialog about what we want to use to fix this
17:57:03 <colindixon> #info at the same time, we are also going to want to have it handle clustering
17:59:21 <colindixon> #info colindixon asks if it being a tree data store is likely to cost us something vs. normal key-value store. jan seems to think it might since you're also storing relationships.
17:59:56 <colindixon> #info some suggestions are Akka, Cassandra, Mongo, and Infinispan; apparently some of them have distributed tree stores
18:00:06 <colindixon> #link http://docs.mongodb.org/manual/tutorial/model-tree-structures/ this is an example for Mongo
18:01:26 <colindixon> #topic queries to the MD-SAL
18:02:20 <colindixon> #info somebody asks do we know what kind of queries we want to run
18:02:53 <colindixon> #info regXboi points out that there was a GSoC proposal around using a query language instead of walking the DOM
18:07:16 <colindixon> #info networkstatic and regXboi both point to finding interfaces for data stores
18:09:19 <regXboi> #link https://wiki.opendaylight.org/view/Project_Proposals:Data_Persistence
18:10:34 <colindixon> #endmeeting