#opendaylight-meeting Meeting

Meeting started by phrobb at 16:59:35 UTC (full logs).

Meeting summary

    1. dmm (dmm, 16:59:46)

  1. rollcall (phrobb, 17:00:10)
    1. colin dixon for IBM (in proxy for Vijoy) (colindixon, 17:00:58)
    2. Chris Wright is here (cdub, 17:02:08)
    3. Ed Warnicke (edwarnicke__, 17:04:25)
    4. Rob Dolin proxy for Rajeev Nagar (Microsoft) (RobDolin, 17:05:50)
    5. https://meetings.webex.com/collabs/meetings/join?uuid=MA3SRND964PIX06V2LS3SXX3RE-9VIB this is the webex we're using (colindixon, 17:06:52)

  2. Agenda bashing (phrobb, 17:07:25)
    1. new category "top of mind" as discussion topics to touch on (phrobb, 17:07:49)

  3. acceptance of the minutes (phrobb, 17:09:08)
    1. acceptance pushed until next week (phrobb, 17:10:06)
    2. Phil mentions that there was an amendment to the minutes, it was added on the wiki but was not reflected on MeetBot. (RobDolin, 17:11:29)

  4. Event Updates (phrobb, 17:11:38)
  5. Event Updates (RobDolin, 17:11:38)
    1. phrobb points out that it would be useful to have topics before the hackfest, also as of now we have only 28 registrants for the hackfest which is low for us (colindixon, 17:13:23)
    2. there was discussion from last week of having explicitly designated time to do actual hacking vs. designing (colindixon, 17:13:53)
    3. Ed Warnicke suggests automating release process as a good topic (RobDolin, 17:13:53)
    4. edwarnicke__ noted automated release processes are a good topic for the hackfest (phrobb, 17:14:19)
    5. performance testing plans / code/tools would be helpful (phrobb, 17:14:52)
    6. i would like to have discussion around performance test strategy (LuisGomez, 17:15:06)
    7. Colin Dixon suggests designated hacking time (RobDolin, 17:15:24)
    8. https://wiki.opendaylight.org/view/HackFestAgenda#HackFest_Agenda:_March_26th_-_28th Add your agenda items there (cdub, 17:17:03)
    9. Colin Dixos also note that hacking (code sharing) works well remotely, remote whiteboarding and design is harder (cdub, 17:19:18)
    10. Phil is making progress on OpenDaylight showcase at Layer 123 SDN World Congress. Email him if you want more info. (RobDolin, 17:20:11)
    11. Phil suggesting fall 2014 summit be a smaller event and then spring 2015 be bigger again (RobDolin, 17:22:18)
    12. Ed Warnicke suggests it would be good to have an on-ramp opportunity like a day of tutorial (RobDolin, 17:23:53)
    13. tutorials first then more involved discussion aftward (phrobb, 17:24:30)
    14. Luis Gomez and Rob Dolin: +1 (RobDolin, 17:25:04)

  6. System Integration and Testing Update (RobDolin, 17:25:16)
    1. Luis recently sent email update on integration (RobDolin, 17:26:39)
    2. I would like to volunteer to work w/ openflow team and others to port relevant bugfixes/perf fixes to a table Hydrogen release (cdub, 17:27:56)

  7. Creation Reviews (RobDolin, 17:29:02)
    1. ACTION: cdub and colindixon to work w/ openflow team and others to port relevant bugfixes/perf fixes to a table Hydrogen release (phrobb, 17:29:25)
    2. ACTION: David Meyer will again ask projects to schedule creation reviews (RobDolin, 17:29:46)

  8. Stability, scalability performance (phrobb, 17:29:58)
  9. Stability, Scalability and Performance Hydrogen Releases (dmm, 17:30:35)
    1. cdub suggests each proj has a stable branch with low risk bug fixes... (phrobb, 17:31:02)
    2. cdub says each repo needs to have a stable branch and we need criteria for what goes into those branches (colindixon, 17:31:02)
    3. Chris Wright (cdub) suggests minimizing new features into "stable" branch (RobDolin, 17:32:23)
    4. no new features in stable branch, with perf changes are case-by-case, totally broken performance should be fixed in stable branch, but otherwise performance could wait (phrobb, 17:32:27)
    5. important to get all projects responsible identify what are going into main branch that should also go to stable branch (phrobb, 17:33:24)
    6. possibly starting a page of what is in main branch that could go into stable branch… (phrobb, 17:34:08)
    7. different opinions on mandating bug #s on each patch for it to be accepted. (phrobb, 17:34:49)
    8. edwarnicke__ suggests strongly encourage bug # in patches but not mandate. (phrobb, 17:35:42)
    9. Chris Wright suggests requiring a bug # associated with check-ins to the stable branch (RobDolin, 17:36:12)
    10. cdub suggests requiring bug#s in stable branch patches as a possiblity (phrobb, 17:36:26)
    11. Colin Dixon suggests having a weekly update / status email (RobDolin, 17:36:53)
    12. AGREED: The TSC requires that patches submitted to the stable branch of a project must reference a bug number. (phrobb, 17:38:13)
    13. ACTION: phrob to work with LF infrastructure to add this change to the build environment (phrobb, 17:38:48)
    14. line-count is a low-pass filter (dmm, 17:38:50)
    15. cdub suggests that the TSC build a more comprehensive set of guidelines/mandates for patch submission (phrobb, 17:43:37)
    16. suggests that the TSC take care in the phrasing of TSC comprehensive guidelines for stable branch releases to respect the line between what the TSC can mandate and the perogatives of the projects. (edwarnicke__, 17:44:56)
    17. ACTION: cdub and edwarnicke__ to initiate the activity for the comprehensive list (phrobb, 17:46:33)
    18. ACTION: AChirputkar and colindixon also will join the comprehensive list workgroup (phrobb, 17:47:13)

  10. Quality-based Release Plan for Helium (RobDolin, 17:49:19)
    1. tabled to next week per David Meyer (RobDolin, 17:49:26)

  11. documentation (phrobb, 17:49:28)
    1. There are multiple groups beginning to work on documentation - we need to improve organization around the activitye (phrobb, 17:53:37)
    2. ACTION: Phil to create a "documentation" listserv (RobDolin, 17:54:25)
    3. ACTION: probb to get a documentation list created for the documentation group (phrobb, 17:54:27)
    4. Ed Warnicke suggests we have a listing of group project calls (RobDolin, 17:55:00)
    5. Phil has added a box to each project's main page including: mailing list, IRC channel, list of committers, etc. (RobDolin, 17:55:37)
    6. https://wiki.openstack.org/wiki/Meetings <-- example of meetings (cdub, 17:55:57)
    7. sorry missed it but yea we're done documentation work.. not passing the build just yet because of external plugin will commit shortly (mlemay, 17:57:22)
    8. https://wiki.opendaylight.org/view/IRC (ekarlso, 17:58:01)
    9. we drafted 3 guides (User Guide, Install Guide and OpenStack +ODL guide based off brent's blogs) (mlemay, 17:58:18)
    10. ACTION: RobDolin to work with Colin M. to create a Documentation cross-project page (phrobb, 17:58:30)

  12. OVSDB Project Rename (RobDolin, 17:58:59)
    1. Madhu: A few days back, there was a twitter conversation about the OVSDB project name (RobDolin, 17:59:24)
    2. Madhu_offline suggests a new name of opennetvirt (phrobb, 18:01:29)
    3. Ed Warnicke suggests this name may be overly broad (RobDolin, 18:03:58)
    4. dicsussion ensued on if the name is too broad compared with "Virtual Tenant Network" and Open Distributed Overlay Network (phrobb, 18:07:54)
    5. RobDolin suggests a more uniform type of naming scheme for projects/plugins (phrobb, 18:09:33)
    6. edwarnicke__ notes that all functions of the OVSDB Integration plug center around that SB protocol with integration into other things that would need to work with OVS (phrobb, 18:10:44)
    7. David Meyer plans to leave this item on the agenda for next week (RobDolin, 18:13:02)
    8. ACTION: dmm asks that Madhu_offline and Networkstatic to come and continue this discussion for next week's TSC meeting (phrobb, 18:13:33)
    9. Neela Jacques suggests the primary request is just to not call the project only "OVSDB" (RobDolin, 18:18:23)

  13. TSC Co-Chair (RobDolin, 18:19:42)
    1. David Meyer suggests this would be good for redundancy, back-up, and preserving institutional knowledge (RobDolin, 18:20:29)
    2. Phil suggests this would take a bylaws change to add a co-chair or vice-chair (RobDolin, 18:21:13)
    3. David Meyer clarifies that he meant vice-chair (RobDolin, 18:21:27)
    4. phrobb mentions that we need to think about whether we want a co-chair or vice-chair, i.e., equal power or a stand-in when the chair is available (colindixon, 18:21:54)
    5. I mean, when the chair is unavailable (colindixon, 18:22:20)
    6. edwarnicke__ asks what would the nuts & bolts be for the role of the vice-chair (phrobb, 18:23:35)
    7. http://www.youtube.com/watch?v=-8bqQ-C1PSE (alagalah_, 18:23:45)
    8. dmm states the main purpose is for a back-up/redundancy and succession planning (phrobb, 18:25:52)
    9. Ed Warnicke suggests we have an email discussion about this. (RobDolin, 18:30:35)
    10. there is general consensus that the notion of a vice-chair is "good" (phrobb, 18:31:06)
    11. David Meyer will keep this on the agenda for next week. (RobDolin, 18:33:15)

  14. At-Large TSC Elections (RobDolin, 18:33:35)
    1. ACTION: TSC to discuss the notion of a vice-chair (phrobb, 18:33:37)
    2. ACTION: phrobb to write up bylaw changes for vice chair to allow discussion (phrobb, 18:34:11)
    3. Phil has noticed there was a challenge in identifying committers (RobDolin, 18:35:14)
    4. Nominations will go out today for at-large committers to join the TSC (RobDolin, 18:35:52)
    5. Election will use similar tool to what was used for "Most Valuable Developer" (RobDolin, 18:36:05)
    6. Voting would end on 04 April (RobDolin, 18:36:14)
    7. Colin Dixon asks about if committers is the right pool (RobDolin, 18:36:29)
    8. Phil: decision was made _for this round_ (RobDolin, 18:36:47)
    9. Chris Wright expresses his dissent (RobDolin, 18:37:00)

  15. Branding (RobDolin, 18:37:31)
    1. Phil suggests this is for week after next (RobDolin, 18:37:40)

  16. Release Engineer (RobDolin, 18:38:05)
    1. Chris Wright is writing-up a position description (RobDolin, 18:38:24)

  17. Clustering (RobDolin, 18:38:32)
    1. David Meyer asks if we should push-off to Technical Work Stream (TWS) ConCall (RobDolin, 18:39:00)
    2. Colin Dixon agrees to push to TWS ConCall (RobDolin, 18:39:15)
    3. Colin Dixon encourages people to attend the TWS ConCall (RobDolin, 18:39:41)
    4. ACTION: colindixon to schedule clustering discussion for TWS call (phrobb, 18:39:57)
    5. edwarnicke__ notes we don't need to come to one complete consensus so the people don't block on consensus to get work done, but realizes that not getting consensus could also block, and asks for others opiions (phrobb, 18:42:21)
    6. dmm notes this is more a technical decision (phrobb, 18:43:13)

  18. Pre-incubation aka Scratch area (phrobb, 18:44:44)
    1. Chris Wright: We need to help people get involved in the project without doing anything formal like applying for a project creation review (RobDolin, 18:45:55)
    2. cdub notes the idea is to allow new people/projects some place to initially engage in preparation for bringing a formal proposal forward (phrobb, 18:46:25)
    3. cdub proposes the word "Forge" only because it is common for this type of venue (phrobb, 18:47:25)
    4. edwarnicke__ is in agreement such a place is needed, also adds some things such as DCO enforcement is needed.. also important to be clear on what is a real project and what is a forge activity (phrobb, 18:49:31)
    5. dmm notes that we need support from LF to make it real (phrobb, 18:49:54)
    6. dmm suggests we have a place (wiki) to collect ideas for creating this (phrobb, 18:51:19)
    7. ACTION: edwarnicke__ to take lead on creating a plan and getting input from the community (phrobb, 18:51:49)
    8. ACTION: cdub to help edwarnicke__ on building out plan (phrobb, 18:52:52)

  19. DLUX Licensing (RobDolin, 18:53:27)
    1. Phil: The IP and Legal subcommittee will be reviewing that material (RobDolin, 18:53:43)
    2. : David Meyer: We did raise this with the board so they know its going on (RobDolin, 18:54:03)

  20. Meeting Collaboration Tools (phrobb, 18:54:11)
    1. dmm notes that the meetbot came from this initial topic, but there may be more to do here (phrobb, 18:55:14)
    2. cdub notes that webex is poorly supported on Linux (ubuntu works, rhel/fedora not so much) (phrobb, 18:56:12)
    3. Ed Warnicke: I'm not wed to WebEx, but here are some useful features: Who is talking, Who is dialed-in, Shared screen, Ability for moderator to mute (RobDolin, 18:56:58)
    4. correction: I proposed the meetbot but cdub wanted to leave the agenda item due to the fact that Webex doesn't work well on all platforms (dmm, 18:57:00)
    5. edwarnicke__ notes that webex features that should persist include see who is talking , who is dialed-in, share descktop, mute noisy people (phrobb, 18:57:10)
    6. dmm requests that we have voice as part of the meeting (phrobb, 18:59:34)
    7. David Meyer asks if TSC would be open to: WebEx for voice, MeetBot for text, and #link in MeetBot for sharing (RobDolin, 19:03:31)
    8. AGREED: for next week TSC meeting will use webex for voice meetbot for text and pound link for sharing (phrobb, 19:03:52)


Meeting ended at 19:05:05 UTC (full logs).

Action items

  1. cdub and colindixon to work w/ openflow team and others to port relevant bugfixes/perf fixes to a table Hydrogen release
  2. David Meyer will again ask projects to schedule creation reviews
  3. phrob to work with LF infrastructure to add this change to the build environment
  4. cdub and edwarnicke__ to initiate the activity for the comprehensive list
  5. AChirputkar and colindixon also will join the comprehensive list workgroup
  6. Phil to create a "documentation" listserv
  7. probb to get a documentation list created for the documentation group
  8. RobDolin to work with Colin M. to create a Documentation cross-project page
  9. dmm asks that Madhu_offline and Networkstatic to come and continue this discussion for next week's TSC meeting
  10. TSC to discuss the notion of a vice-chair
  11. phrobb to write up bylaw changes for vice chair to allow discussion
  12. colindixon to schedule clustering discussion for TWS call
  13. edwarnicke__ to take lead on creating a plan and getting input from the community
  14. cdub to help edwarnicke__ on building out plan


Action items, by person

  1. cdub
    1. cdub and colindixon to work w/ openflow team and others to port relevant bugfixes/perf fixes to a table Hydrogen release
    2. cdub and edwarnicke__ to initiate the activity for the comprehensive list
    3. cdub to help edwarnicke__ on building out plan
  2. colindixon
    1. cdub and colindixon to work w/ openflow team and others to port relevant bugfixes/perf fixes to a table Hydrogen release
    2. AChirputkar and colindixon also will join the comprehensive list workgroup
    3. colindixon to schedule clustering discussion for TWS call
  3. dmm
    1. dmm asks that Madhu_offline and Networkstatic to come and continue this discussion for next week's TSC meeting
  4. edwarnicke__
    1. cdub and edwarnicke__ to initiate the activity for the comprehensive list
    2. edwarnicke__ to take lead on creating a plan and getting input from the community
    3. cdub to help edwarnicke__ on building out plan
  5. phrobb
    1. phrobb to write up bylaw changes for vice chair to allow discussion
  6. RobDolin
    1. RobDolin to work with Colin M. to create a Documentation cross-project page
  7. UNASSIGNED
    1. David Meyer will again ask projects to schedule creation reviews
    2. phrob to work with LF infrastructure to add this change to the build environment
    3. Phil to create a "documentation" listserv
    4. probb to get a documentation list created for the documentation group
    5. TSC to discuss the notion of a vice-chair


People present (lines said)

  1. RobDolin (79)
  2. phrobb (69)
  3. cdub (29)
  4. colindixon (25)
  5. dmm (19)
  6. edwarnicke__ (15)
  7. GiovanniMeo (5)
  8. odl_meetbot (4)
  9. abhijitkumbhare (4)
  10. alagalah_ (3)
  11. ekarlso (3)
  12. LuisGomez (2)
  13. alagalah (2)
  14. ashaikh (2)
  15. mlemay (2)
  16. tnadeau (1)
  17. ghall (1)
  18. drizzt_ (1)


Generated by MeetBot 0.1.4.