#opendaylight-meeting Meeting

Meeting started by colindixon at 17:05:01 UTC (full logs).

Meeting summary

  1. Versioning and Automated Weekly Releases (colindixon, 17:06:32)
    1. slides will follow the meeting (colindixon, 17:08:20)
    2. also were apparently sent to the mailing list (colindixon, 17:08:27)
    3. http://lists.opendaylight.org/pipermail/discuss/attachments/20140401/db9039f6/attachment-0001.ppt this is the link for the slides that were sent to the mailing list (colindixon, 17:09:41)

  2. parent pom (colindixon, 17:10:10)
    1. edwarnicke___ points out that variables in parent poms are annoying because they play badly with the version change plugin if they are not used in the parent pom itself (colindixon, 17:11:14)
    2. surekha replies that it's worked for her so far (colindixon, 17:11:32)
    3. edwarnicke___ asks why we went with versions instead of dependency management (colindixon, 17:13:28)
    4. the answer is that there are two ways to do versioning: either properties or dependency management (colindixon, 17:15:36)
    5. by using properties it is possible to target the version plugin to only update the properties section of the pom (regXboi, 17:16:17)
    6. edwarnicke__ continues to ask about the dependency management versions (regXboi, 17:17:22)
    7. the idea is to define the versions at the project level and keeping dependency management at the bundle level (regXboi, 17:20:02)
    8. regXboi asks "why weekly?" (colindixon, 17:24:09)
    9. AGREED: weekly cadence makes more sense than daily (regXboi, 17:27:38)
    10. edwarnkice__ is concerned about how to tell versioning and release plugins are working or not when semantic versioning is used (regXboi, 17:32:13)

  3. semantic versioning (colindixon, 17:34:34)
    1. edwarnicke___ points out that we've had bugs in how the versions plugin worked which has made it difficult to tell if we were skewed (colindixon, 17:35:28)
    2. edwarnicke___ says that semantic versioning at the bundle-level makes it hard to tell if this happens by human visual inspection (colindixon, 17:35:53)
    3. the answer is to have exactly one variable (for version) per-bundle in the parent pom (with one parent pom per project) (colindixon, 17:39:09)
    4. regXboi ok w/ version per project (cdub, 17:40:49)
    5. regXboi and edwarnicke___ point out that life might be much easier with the idea of one version per project (colindixon, 17:40:53)
    6. mlemay says that you probably want project-level versioning *and* bundle-level versioning and we don't have to change (colindixon, 17:45:07)
    7. that previous link is http://wiki.eclipse.org/Equinox/p2/FAQ (rovarga, 17:50:31)
    8. karaf-based features: http://fusesource.com/docs/esb/4.2/deploy_osgi/DeployFeatures-Create.html (mlemay, 17:52:20)
    9. http://fusesource.com/docs/esb/4.2/deploy_osgi/DeployFeatures-Create.html karaf-based features (colindixon, 17:52:48)
    10. http://wiki.eclipse.org/Equinox/p2/FAQ p2 feature (colindixon, 17:53:10)
    11. both links from mlemay (colindixon, 17:53:17)

  4. general ideas around federation vs. centralization of versioning (colindixon, 17:58:53)
    1. there is a large debate about where versions for bundles (or projects) should be maintained (colindixon, 17:59:40)
    2. AGREED: summary (via edwarnicke__): 1. each project should have one and only one parent pom hierarchy. 2. the root parent pom of a project should have a version variable for each external bundle a project depends on (the version string can be a range). 3. Any place a dependency version is used in the project, it should use the version defined in the root parent pom (regXboi, 18:02:56)
    3. rovarga can we speed up the verify (not further choke the existing verify queue) (cdub, 18:09:16)
    4. answer: ... maybe ... (cdub, 18:09:34)
    5. in hydrogen integration project pulled different bundles than within projects (cdub, 18:11:33)
    6. a cross project audit should catch this (cdub, 18:11:57)
    7. and this audit should be report only (cdub, 18:12:41)
    8. report inconsistencies at regular builds (aka weekly) (cdub, 18:14:32)
    9. patches coming...need some coordination to start from leaf and move to root projects (cdub, 18:15:20)


Meeting ended at 18:15:27 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. colindixon (34)
  2. cdub (23)
  3. regXboi (14)
  4. networkstatic (8)
  5. mlemay (8)
  6. edwarnicke___ (4)
  7. odl_meetbot (4)
  8. alagalah (4)
  9. rovarga (3)
  10. Madhu_ (3)
  11. tbachman (1)
  12. phudgins (1)


Generated by MeetBot 0.1.4.