16:09:00 <regXboi> #startmeeting
16:09:00 <odl_meetbot> Meeting started Tue Apr  8 16:09:00 2014 UTC.  The chair is regXboi. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:09:00 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:09:07 <alagalah> here
16:09:14 <regXboi> #topic AKKA for ODL as part of MD-SAL
16:09:36 <regXboi> #chair edwarnicke__
16:09:36 <odl_meetbot> Current chairs: edwarnicke__ regXboi
16:09:42 <regXboi> #chair colindixon
16:09:42 <odl_meetbot> Current chairs: colindixon edwarnicke__ regXboi
16:09:48 <colindixon> perfect!
16:09:54 <edwarnicke___> :)
16:09:54 <alagalah> Hi colindixon
16:09:58 <colindixon> Game of Chairs?
16:09:59 <alagalah> hi edwarnicke___
16:10:08 <edwarnicke___> alagalah: Welcome to the party :)
16:10:15 <regXboi> #topic Prototyping Akka in ODL
16:10:46 <regXboi> #info presentation from mlemay on prototyping akka for md-sal framework and data store
16:14:12 <colindixon> #info presentation will be posted to the wiki and/or mailing list later (hopefully during this call)
16:14:41 <cdub> during++
16:14:51 <phudgins> first time at this meeting - can you post the wiki URL you are referring to?
16:15:09 <colindixon> phudgins: wiki.opendaylight.org
16:15:35 <cdub> there's a couple specific (relevant) links too
16:15:38 <phudgins> colindixon: yes, that one I know of
16:15:40 <cdub> phudgins: https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Architecture:DOM_DataStore
16:15:57 <phudgins> cdub: thanks
16:16:02 <cdub> phudgins: https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Architecture:DOM_DataStore:Transactions
16:16:10 <cdub> phudgins: you're welcome
16:27:10 <colindixon> #info dmm asks if Akka is written in erlang
16:27:21 <colindixon> #info it is not, it's written in Scala which runs on the JVM
16:28:01 <colindixon> #info it provides Java bindings and you can call it from pure Java code, but mlemay says that it's easier to consume in some cases by calling from Scala
16:29:17 <colindixon> #info mlemay goes on to point out that it's actually compiled to java bytecode, so it's not even compiled, which is all good
16:29:35 <colindixon> #info jan medved asks about loading it and debugging it in Eclipse
16:30:26 <colindixon> #info mlemay responds that it might actually be easier than the yang stuff and actually aside from trapping into Scala-based Akka code, works just like it had been in Java
16:31:09 <colindixon> #topic actors
16:31:43 <colindixon> #info actors are basically a mailbox, some execution and some local state
16:33:28 <colindixon> #info jan medved asks about how threads are assigned to actors, is it single threaded?
16:33:32 <colindixon> #info by default, yes
16:33:42 <colindixon> #info jan further asks about prioritizing threads
16:33:52 <colindixon> #info answer is that it can be done, but it's not done in the current code
16:35:26 <phudgins> akka Java documentation can be found at http://doc.akka.io/docs/akka/current/AkkaJava.pdf
16:35:38 <colindixon> #info actors have built-in support for load balancing, routing, partitioning, and cluster management (which is pretty useful), but getting into these would take almost a call for each topic
16:36:02 <colindixon> #link http://doc.akka.io/docs/akka/current/AkkaJava.pdf the Akka Java Documentation (courtesy of phudgins)
16:36:16 <colindixon> thanks phudgins
16:36:34 <alagalah> So correct me if I am wrong, but isn't Akka Apache licensed and does this represent a problem ?
16:36:52 <colindixon> also, you can #info and #link things as well if you want, if you #link then you need to make sure the link is the first word after #link
16:36:56 <phudgins> colindixon: thanks for adding the link syntax.  I'll get the hand of it
16:37:04 <colindixon> alagalah: if we want to contribute code, maybe
16:37:14 <colindixon> alagalah: if we just consume it as a library, no
16:37:43 <alagalah> colindixon: Well we may want to, it should be brought up
16:37:54 <colindixon> alagalah: and, I don't actually know what license it is, do you?
16:38:03 <alagalah> http://doc.akka.io/docs/akka/snapshot/project/licenses.html
16:38:36 <colindixon> #link http://doc.akka.io/docs/akka/snapshot/project/licenses.html Akka is under the apache 2 license and that should be considered (thanks alagalah)
16:38:53 <colindixon> ZeroMQ is LGPL and we use that http://zeromq.org/area:licensing
16:39:42 <colindixon> #topic Akka-based DataStore Design
16:41:16 <colindixon> #info links to gerrit patches implementing this to follow
16:41:20 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/5971/
16:41:23 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/5970/
16:41:29 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/5953/
16:41:32 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/5967/
16:41:51 <colindixon> #info mlemay notes that it's still not fully baked yet, so take it for what it is
16:43:53 <colindixon> #info there is an independently-written Akka DataBroker, which then talks to an in-memory data store, which talks to the Akka Actor System, which runs on a (different?) OSGi Runtime
16:44:57 <colindixon> #info Jan Medved asks if this is the Akka datastore itself (becuase that seems to just be a log of all the messages)
16:45:12 <colindixon> #info answer is that no, this is a different data store using the Akka cluster
16:45:26 <colindixon> #info jan follows up by asking how it uses Akka cluster
16:46:27 <colindixon> #info answer is that it's a distributed K-V store right now
16:46:36 <regXboi> fyi, I need to run to another meeting at the top of the hour
16:46:52 <colindixon> #info not clear what consistency properties they're currently using, but it's easily changed
16:46:57 <colindixon> regXboi: noted, I do as well
16:47:25 <alagalah> Can we manage consistency using another algorithm and leverage akka's local data store ?
16:47:41 <colindixon> alagalah: I think he just answered
16:47:57 <alagalah> colindixon: So was it an ack or a nack ? I heard ack
16:48:11 <colindixon> #info the in-memory data store is described as a cache on top of a distributed data store (right now based on the Akka actors moddel)
16:48:17 <colindixon> alagalah: ack as far as I know
16:49:51 <colindixon> #info Raghu asks how do the actors provide a data store
16:50:20 <colindixon> #info mlemay answers that it's 6-7 actors that eventually write to a ConcurrentHashMap and they provide fast ways to read and write into that
16:51:47 <colindixon> #info question about whether it's trees or key-value that's being stored
16:52:12 <colindixon> #info right now it's storing key-value pairs, and they're translated back and forth from trees to key-value in the Akka DataBroker
16:53:56 <colindixon> #info question as to whether it's integrated into MD-SAL?
16:54:14 <colindixon> #info answer: yes, it is, but there's still work going on
16:54:26 <cdub> regXboi: chair me
16:54:29 <regXboi> #chair cdub
16:54:29 <odl_meetbot> Current chairs: cdub colindixon edwarnicke__ regXboi
16:57:05 <colindixon> #topic unfortunate administrivia
16:57:16 <colindixon> #info many, many people need to drop at the top of the hour
16:57:46 <colindixon> #info this will continue either later this week, or early next week
16:58:23 <cdub> #info slides coming to a wiki near you
16:59:03 <cdub> #info meeting recording coming to md-sal wiki page
16:59:19 <colindixon> #action jan, tony, and/or ed will put the slides online and email out the plan for a meeting and the pointer to the recording and slides
16:59:19 <cdub> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL
16:59:57 <colindixon> #endmeeting