#opendaylight-meeting Meeting

Meeting started by cdub at 13:31:43 UTC (full logs).

Meeting summary

    1. regXboi here for OpenDove (regXboi, 13:33:45)
    2. sarathbg here for VTN (sarathbg, 13:34:04)
    3. Chris Wright (cdub, 13:34:06)

  1. rollcall (cdub, 13:34:26)
    1. michal_rehak / openflowplugin (michal_rehak, 13:34:30)
    2. sarathbg for VTN (sarathbg, 13:34:53)
    3. Ed Warnicke for controller (edwarnicke___, 13:35:01)
    4. abhijitkumbhare for openflowplugin (in addition to michal_rehak ) (abhijitkumbhare, 13:35:26)
    5. cloudtoad (Derick) for Affinity (cloudtoad, 13:35:45)
    6. oflibMichal for openflowjava (oflibMichal, 13:35:47)

  2. project update (regXboi, 13:36:07)
    1. OpenDove is focusing on bug fixes for this release (regXboi, 13:38:59)
    2. there are three outstanding bugs against how OpenDove handles neutron (regXboi, 13:39:27)
    3. Controller branch cut, working on versions, verify not working yet... (cdub, 13:39:39)
    4. the expectation are that these will be fixed in the next week (regXboi, 13:39:39)
    5. Controller reviewing 322 patches as stable candidates (cdub, 13:40:05)
    6. OpenDove waiting to update dependency versions to -1- pending other commits (regXboi, 13:40:06)
    7. OpenFlowPlugin reviewing patches (four? of them) and stability changes (regXboi, 13:41:19)
    8. openflowplugin reviewing patches...done w/in next week or so (cdub, 13:41:33)
    9. correction forty-four (regXboi, 13:41:35)
    10. VTN has created stable branch and currently doing bug scrub (regXboi, 13:43:18)
    11. patch identification complete deadline middle of next week (regXboi, 13:43:31)
    12. openflowjava branch has been created and working on identifying patches (regXboi, 13:44:13)
    13. correction - patches applied and ready for release (regXboi, 13:44:27)
    14. bgp-ls and bgp-pcep still need stable branch to be created (target date: tomorrow) (regXboi, 13:45:21)
    15. and working on wiki documentation (regXboi, 13:45:46)
    16. regXboi wants to add documentation to the topics discussed at the end of the agenda (regXboi, 13:46:00)
    17. cdbu is examining the openflowjava stable branch and sees that the first commit is not building the correct version (regXboi, 13:46:54)
    18. openflowjava project starts with wrong commit (cdub, 13:47:29)
    19. - <version>0.4</version> (cdub, 13:47:34)
    20. + <version>0.5-SNAPSHOT</version> (cdub, 13:47:40)
    21. + <version>0.4-1-SNAPSHOT</version> (cdub, 13:47:59)
    22. https://wiki.opendaylight.org/view/OpenDaylight_Controller:Setting_Up_Stability_Branches (regXboi, 13:48:03)
    23. for instructions on how to do this (regXboi, 13:48:12)
    24. Madhu asks for a different time for future calls (regXboi, 13:49:43)
    25. Updating status for OpenFlowPlugin: Reviewing the 44 patches which went in. Focussing on stability/performance changes - some still being fixed (tentatively expecting around end-of-next-week - but may take more). We will need end-to-end bug scrub (Controller + OpenFlowJava) - starting this Monday 8am Pacific OpenFlow plugin meeting. (abhijitkumbhare, 13:50:37)
    26. ovsdb has some dependencies where fix is just rebasing to new version (cdub, 13:51:02)
    27. ovsdb has stability branch but has dependencies on controller and either openflowjava or openflowplugin - there is an open issue that may not have been flagged (regXboi, 13:51:14)
    28. ovsdb need to identify the specific project bug dependencies (cdub, 13:51:29)
    29. discussing different times (cdub, 13:53:23)
    30. suggestions to 6am PDT and 7:30am PDT...neither seem to be working... (cdub, 13:53:55)
    31. will bring this to list for discussion (cdub, 13:54:30)
    32. ACTION: will take meeting time discussion to the mailing list (regXboi, 13:55:06)
    33. bgpcep update: have three bugs, looking at how to address these with a new data store (I think) (regXboi, 13:56:17)
    34. yangtools has been in bug fixing mode only - they've created stability branch and will start cherry picking bug fixes to the stable branch (regXboi, 13:56:47)
    35. lispflowmapping is using a different branching structure (regXboi, 13:58:15)
    36. edwarnicke__ points out that the structure is the same, just using a different name (regXboi, 13:59:01)
    37. lispflowmapping has been applying bugs to the release branch but still has dependencies on yang and controller packages (regXboi, 13:59:41)
    38. cdub asks about names and conventions (regXboi, 14:00:14)
    39. lispflowmapping has converted to the community structure (regXboi, 14:00:25)
    40. nobody from defense4all or snmp4sdn is here today (cdub, 14:01:22)

  3. mechanics discussion - cherry picking (regXboi, 14:02:41)
    1. edwarnicke__ points out that while the term of "cherry picking" may be we want, we may want to stack commits on top of each other (regXboi, 14:04:07)
    2. cdub says the difference can be handled by creating a topic branch for each bug and then pushing the topic branch via git to get the stack correct (regXboi, 14:05:02)
    3. ACTION: edwarnicke__ to explore how to do this correctly and then update the wiki page with the mechanics (regXboi, 14:05:43)
    4. bgpcep is still working on their longer term branching strategies...didn't want to do this multiple times (cdub, 14:08:16)

  4. documentation (regXboi, 14:08:21)
    1. documentation in hydrogen...didn't do a great job of publishing fixed docs (cdub, 14:09:11)
    2. regXboi is working on site:deploy, nearly functional (cdub, 14:09:35)
    3. one issue is sites are pushed to site/groupid... (cdub, 14:10:10)
    4. trying to get structure that is site/release/groupid/... (cdub, 14:10:33)
    5. where groupid is created manually by tykeal (cdub, 14:11:34)
    6. (groupid is org.opendaylight...) (cdub, 14:11:50)
    7. https://wiki.opendaylight.org/view/OpenDaylight_Controller:How_To:_Site_Deploy (regXboi, 14:11:54)
    8. edwarnicke___ extols virtues of "continuous documentation" (cdub, 14:14:05)
    9. site:deploy per Major Release (and stable updates) and per development branch (cdub, 14:14:53)
    10. link above doesn't have this split done yet (cdub, 14:15:14)
    11. needs parameterized build for docs, perhaps asking documentation team to do this (cdub, 14:16:08)
    12. site:deploy docs aren't self-consistent (some dead links, for example) (cdub, 14:17:47)
    13. http://nexus.opendaylight.org/content/sites/site/org.opendaylight.opendove/hydrogen/releasepom (regXboi, 14:20:00)

  5. time for this meeting (cdub, 14:23:30)
    1. meeting time suggested ... move to mon, tue or fri (friday doesn't work for israel) (cdub, 14:24:00)
    2. suggest 6am-7am PDT and for schedule first half to accomodate those that can't make after 6:30, and second half for those that can't make it before 6:30 (cdub, 14:25:26)
    3. suggestion about having two meeting times (regXboi, 14:25:26)
    4. rough consensus seems to be pointing towards tue 6am-7am... (cdub, 14:29:06)
    5. AGREED: to reschedule to tuesday 6am-7am PDT (regXboi, 14:29:15)
    6. over time, we can rely less and less on sync call...and more and more on async distributed updates (read: email) (cdub, 14:30:28)
    7. https://wiki.opendaylight.org/view/CrossProject:Stable_Release The Stable Release page, includes webex, and all other info (cdub, 14:30:51)


Meeting ended at 14:30:56 UTC (full logs).

Action items

  1. will take meeting time discussion to the mailing list
  2. edwarnicke__ to explore how to do this correctly and then update the wiki page with the mechanics


People present (lines said)

  1. regXboi (55)
  2. cdub (51)
  3. edwarnicke___ (3)
  4. odl_meetbot (3)
  5. tykeal (2)
  6. sarathbg (2)
  7. abhijitkumbhare (2)
  8. michal_rehak (1)
  9. cloudtoad (1)
  10. oflibMichal (1)
  11. dbainbri (1)


Generated by MeetBot 0.1.4.