13:31:43 <cdub> #startmeeting
13:31:43 <odl_meetbot> Meeting started Thu Apr 10 13:31:43 2014 UTC.  The chair is cdub. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:31:43 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:33:20 <cdub> regXboi: yes
13:33:24 <cdub> regXboi: and yes
13:33:30 <regXboi> thanks
13:33:45 <regXboi> #info regXboi here for OpenDove
13:34:04 <sarathbg> #info sarathbg here for VTN
13:34:06 <cdub> #info Chris Wright
13:34:26 <cdub> #topic rollcall
13:34:30 <michal_rehak> #info michal_rehak / openflowplugin
13:34:33 <cdub> please #info in
13:34:53 <sarathbg> #info sarathbg for VTN
13:35:01 <edwarnicke___> #info Ed Warnicke for controller
13:35:26 <abhijitkumbhare> #info abhijitkumbhare for openflowplugin (in addition to michal_rehak )
13:35:45 <cloudtoad> #info cloudtoad (Derick) for Affinity
13:35:46 <regXboi> cdub - can I grab a co-chair to help scribe?
13:35:47 <oflibMichal> #info oflibMichal for openflowjava
13:35:52 <cdub> #chair regXboi
13:35:52 <odl_meetbot> Current chairs: cdub regXboi
13:35:55 <regXboi> mahalo
13:36:07 <regXboi> #topic project update
13:36:08 <cdub> heh
13:38:59 <regXboi> #info OpenDove is focusing on bug fixes for this release
13:39:15 <regXboi> #infor there are three outstanding bugs against how OpenDove handles neutron
13:39:27 <regXboi> #info there are three outstanding bugs against how OpenDove handles neutron
13:39:39 <cdub> #info Controller branch cut, working on versions, verify not working yet...
13:39:39 <regXboi> #info the expectation are that these will be fixed in the next week
13:40:05 <cdub> #info Controller reviewing 322 patches as stable candidates
13:40:06 <regXboi> #info OpenDove waiting to update dependency versions to -1- pending other commits
13:41:19 <regXboi> #info OpenFlowPlugin reviewing patches (four? of them) and stability changes
13:41:33 <cdub> #info openflowplugin reviewing patches...done w/in next week or so
13:41:35 <regXboi> #info correction forty-four
13:41:45 <edwarnicke___> I would like to note that our use of -1 for suffixes sometimes leads to unfortunate mental resonance around other less positive uses of -1 ;)
13:42:00 * regXboi tells edwarnicke "#sand"
13:42:08 <cdub> heh
13:42:11 * edwarnicke___ laughs :)
13:43:18 <regXboi> #info VTN has created stable branch and currently doing bug scrub
13:43:31 <regXboi> #info patch identification complete deadline middle of next week
13:44:13 <regXboi> #info openflowjava branch has been created and working on identifying patches
13:44:27 <regXboi> #info correction - patches applied and ready for release
13:45:21 <regXboi> #info bgp-ls and bgp-pcep still need stable branch to be created (target date: tomorrow)
13:45:46 <regXboi> #info and working on wiki documentation
13:46:00 <regXboi> #info regXboi wants to add documentation to the topics discussed at the end of the agenda
13:46:54 <regXboi> #info cdbu is examining the openflowjava stable branch and sees that the first commit is not building the correct version
13:47:29 <cdub> #info openflowjava project starts with wrong commit
13:47:34 <cdub> #info -        <version>0.4</version>
13:47:40 <cdub> #info +        <version>0.5-SNAPSHOT</version>
13:47:54 <cdub> should be
13:47:59 <cdub> #info +        <version>0.4-1-SNAPSHOT</version>
13:48:03 <regXboi> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Setting_Up_Stability_Branches
13:48:12 <regXboi> #info for instructions on how to do this
13:49:43 <regXboi> #info Madhu asks for a different time for future calls
13:50:21 <regXboi> cdub are you getting this?  It's rather garbled...
13:50:37 <abhijitkumbhare> #info Updating status for OpenFlowPlugin: Reviewing the 44 patches which went in. Focussing on stability/performance changes - some still being fixed (tentatively expecting around end-of-next-week - but may take more). We will need end-to-end bug scrub (Controller + OpenFlowJava) - starting this Monday 8am Pacific OpenFlow plugin meeting.
13:51:02 <cdub> #info ovsdb has some dependencies where fix is just rebasing to new version
13:51:14 <regXboi> #info ovsdb has stability branch but has dependencies on controller and either openflowjava or openflowplugin  - there is an open issue that may not have been flagged
13:51:28 <regXboi> thanks, cdbu
13:51:29 <cdub> #info ovsdb need to identify the specific project bug dependencies
13:51:31 <regXboi> er cdub
13:51:46 <cdub> common typo
13:51:48 * regXboi has fingers that aren't working yet this morning
13:52:08 * cdub has little that is functional yet
13:53:23 <cdub> #info discussing different times
13:53:55 <cdub> #info suggestions to 6am PDT and 7:30am PDT...neither seem to be working...
13:54:30 <cdub> #info will bring this to list for discussion
13:54:40 <regXboi> ok, i was going to #action thta
13:54:43 <regXboi> but that is ok
13:54:52 <cdub> go ahead ;)
13:55:06 <regXboi> #action will take meeting time discussion to the mailing list
13:55:19 <cdub> dbainbri: btw, you may be muted (you were cause of lots of background noise)
13:55:26 <cdub> dbainbri: oops, ignore me
13:55:31 <cdub> wrong david
13:55:46 <cdub> dbainbri: welcome back ;)
13:56:17 <regXboi> #info bgpcep update: have three bugs, looking at how to address these with a new data store (I think)
13:56:47 <regXboi> #info yangtools has been in bug fixing mode only - they've created stability branch and will start cherry picking bug fixes to the stable branch
13:57:11 * regXboi thinks edwarnicke__ is jumping the gun again :)
13:57:28 <dbainbri> cdub: thanks.
13:57:34 <regXboi> which project is that?
13:57:42 <cdub> lispflowmapping
13:58:15 <regXboi> #info lispflowmapping is using a different branching structure
13:59:01 <regXboi> #info edwarnicke__ points out that the structure is the same, just using a different name
13:59:41 <regXboi> #info lispflowmapping has been applying bugs to the release branch but still has dependencies on yang and controller packages
14:00:14 <regXboi> #info cdub asks about names and conventions
14:00:25 <regXboi> #info lispflowmapping has converted to the community structure
14:01:22 <cdub> #info nobody from defense4all or snmp4sdn is here today
14:02:41 <regXboi> #topic mechanics discussion - cherry picking
14:04:07 <regXboi> #info edwarnicke__ points out that while the term of "cherry picking" may be we want, we may want to stack commits on top of each other
14:05:02 <regXboi> #info cdub says the difference can be handled by creating a topic branch for each bug and then pushing the topic branch via git to get the stack correct
14:05:43 <regXboi> #action edwarnicke__ to explore how to do this correctly and then update the wiki page with the mechanics
14:06:14 * regXboi wonders if people will stop giving me chair abilities
14:06:36 <cdub> as a chair...someone should just sit on regXboi
14:06:44 <regXboi> lol
14:08:16 <cdub> #info bgpcep is still working on their longer term branching strategies...didn't want to do this multiple times
14:08:21 <regXboi> #topic documentation
14:09:11 <cdub> #info documentation in hydrogen...didn't do a great job of publishing fixed docs
14:09:35 <cdub> #info regXboi is working on site:deploy, nearly functional
14:10:10 <cdub> #info one issue is sites are pushed to site/groupid...
14:10:33 <cdub> #info trying to get structure that is site/release/groupid/...
14:11:34 <cdub> #info where groupid is created manually by tykeal
14:11:50 <cdub> #info (groupid is org.opendaylight...)
14:11:54 <regXboi> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:How_To:_Site_Deploy
14:12:25 * tykeal ducks into the IRC side of the meeting
14:12:58 <tykeal> eh, the groupid isn't manually created by me. I just put access controls around the paths and they get auto generated on a push
14:14:05 <cdub> #info edwarnicke___ extols virtues of "continuous documentation"
14:14:53 <cdub> #info site:deploy per Major Release (and stable updates) and per development branch
14:15:14 <cdub> #info link above doesn't have this split done yet
14:16:08 <cdub> #info needs parameterized build for docs, perhaps asking documentation team to do this
14:17:47 <cdub> #info site:deploy docs aren't self-consistent (some dead links, for example)
14:20:00 <regXboi> #link http://nexus.opendaylight.org/content/sites/site/org.opendaylight.opendove/hydrogen/releasepom
14:23:30 <cdub> #topic time for this meeting
14:24:00 <cdub> #info meeting time suggested ... move to mon, tue or fri (friday doesn't work for israel)
14:24:28 <regXboi> edwarnicke__: I'm hoping to make the TSC today, can I mousetrap the documentation group with the parameterization sub-project?
14:24:38 <regXboi> assuming they are approved ?
14:25:26 <cdub> #info suggest 6am-7am PDT and for schedule first half to accomodate those that can't make after 6:30, and second half for those that can't make it before 6:30
14:25:26 <regXboi> #info suggestion about having two meeting times
14:29:06 <cdub> #info rough consensus seems to be pointing towards tue 6am-7am...
14:29:15 <regXboi> #agree to reschedule to tuesday 6am-7am PDT
14:30:27 * regXboi waits for cdub #link so I can mark it as a favorite :)
14:30:28 <cdub> #info over time, we can rely less and less on sync call...and more and more on async distributed updates (read: email)
14:30:51 <cdub> #link https://wiki.opendaylight.org/view/CrossProject:Stable_Release The Stable Release page, includes webex, and all other info
14:30:56 <cdub> #endmeeting