16:59:16 <phrobb> #startmeeting OpenDaylight TSC Mtg - 05-15-2014
16:59:16 <odl_meetbot> Meeting started Thu May 15 16:59:16 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:59:16 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:16 <odl_meetbot> The meeting name has been set to 'opendaylight_tsc_mtg___05_15_2014'
16:59:31 <dmm> #info dmm
16:59:35 <phrobb> #topic TSC Members please #info in
17:00:44 <regXboi> #info regXboi is on the way
17:01:19 <kwatsen> #info Kent Watsen
17:01:50 * regXboi waits for the webex
17:01:59 * edwarnicke waits for the webex
17:02:47 <edwarnicke> #info Ed Warnicke
17:03:12 <regXboi> #info regXboi has made it
17:03:17 <Madhu_Idle> #info Madhu Venugopal
17:03:32 <Madhu_Idle> #info Madhu Venugopal (for Chris Wright)
17:03:45 <phrobb> #topic Agenda Bashing
17:03:59 <edwarnicke> Welcome Ryan! :)
17:04:05 <tbachman> #info welcome regXboi to TSC!
17:04:07 <phrobb> #chair regxboi edwarnicke
17:04:07 <odl_meetbot> Current chairs: edwarnicke phrobb regxboi
17:04:11 <regXboi> thanks
17:04:29 <regXboi> #info agenda bashing to a minimum in favor of creation reviews
17:04:56 <ChrsPriceAB> #info Chris Price
17:04:57 <phrobb> #topic Creation Reviews AAA Service
17:05:08 <regXboi> #link https://wiki.opendaylight.org/view/Project_Proposals:AAA_Service
17:05:32 <ChrsPriceAB> quiet appluase for @regXboi, welcome
17:09:43 <regXboi> #info regXboi makes a scribe request to have the slides linked to the project proposal page
17:09:50 <regXboi> (or I will when I get a chance)
17:11:47 <regXboi> #info question about authorization being for the bundle itself
17:12:04 <regXboi> #info question and does this include certificates, etc.
17:12:22 <regXboi> #info answer yes, bundles would be signed and use osgi security to make this work
17:14:26 <phrobb> #info concerns mentioned on having an Auth system without audit capabilties
17:18:58 * regXboi raises hand
17:19:49 <RobDolin> #info Ryan Moats (IBM) suggests he would like to see "Auditing" added to the AAA proposal
17:19:52 * edwarnicke is amused by AAAA ;)
17:20:09 <RobDolin> Triple-A was already taken by the pro wrestler anyways ;)
17:20:27 <phrobb> welcome RobDolin…
17:20:34 <phrobb> #chair RobDolin
17:20:34 <odl_meetbot> Current chairs: RobDolin edwarnicke phrobb regxboi
17:20:37 <RobDolin> #info Chris Price (Ericsson) asks if committers are interested in doing auditing
17:20:41 <RobDolin> @phrobb Thanks
17:21:01 <RobDolin> I was finishing my commute and have been audio-only.
17:22:33 <phrobb> #info discussion continues on the need for auditing vs the TSC mandating the addition of functions to a project brought forward
17:24:05 <phrobb> #info concerned raised that retro-fitting auditing is difficult so if it isn't part of the this proposal, fixing it's absence later will be hard
17:24:41 <phrobb> #info question for TSC "are we comfortable having authentication/authorization without auditing?
17:25:12 <phrobb> #info compromise suggested to have Auditing hooks at a minimum
17:26:03 <phrobb> #info regXboi volunteers to find resource to add at least auditing hooks… did i get that right regXboi ?
17:26:51 <regXboi> yes - you did - it might be my time
17:27:06 <phrobb> @regXboi thanks
17:27:38 <ChrsPriceAB> I also find myself (again) sharing interests with Ryan and will likely colaborate with a hope to contribute
17:29:24 <regXboi> ChrisPriceAB: that is sometimes considered the first step to insanity :)
17:31:44 <edwarnicke> ChrsPriceAB: You have been warned ;)
17:31:52 <phrobb> #info question asks on RBAC Auth - will there be roles, answer is "yes"
17:32:18 <regXboi> #info question: will this be mandatory for other projects to use
17:32:21 <Madhu> phrobb: can u pls #action in the need to add bundle authorization/authentication using OSGI security manager ?
17:32:34 <regXboi> #info answer: that is out of scope for creation review
17:32:40 <phrobb> #startvote Shall AAA Service project be accepted into ODL as an incubation project? +1, 0 -1
17:32:40 <odl_meetbot> Begin voting on: Shall AAA Service project be accepted into ODL as an incubation project? Valid vote options are +1, 0, -1.
17:32:40 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:32:40 <RobDolin> #startvote AAA service to incubation
17:32:40 <odl_meetbot> Already voting on 'Shall AAA Service project be accepted into ODL as an incubation project'
17:32:48 <regXboi> #vote +1
17:32:48 <edwarnicke> #vote +1
17:32:50 <Madhu> #vote +1
17:32:53 <dmm> #vote +1
17:32:54 <kwatsen> #vote +1
17:32:55 <ChrsPriceAB> #vote +1
17:32:57 <RobDolin> #vote +1
17:33:16 <phrobb> #endvote
17:33:16 <odl_meetbot> Voted on "Shall AAA Service project be accepted into ODL as an incubation project?" Results are
17:33:16 <odl_meetbot> +1 (7): regXboi, dmm, edwarnicke, ChrsPriceAB, kwatsen, RobDolin, Madhu
17:33:17 <regXboi> #endvote
17:33:22 <regXboi> oops:)
17:33:42 <phrobb> #agreed AAA service is moved to Incubation
17:33:50 <phrobb> #topic L2 Switch Creation Review
17:40:40 <phrobb> #info question - Reactive with Packet-In, but is there any pro-active behavior in this L2 switch?
17:41:19 <phrobb> #info no value-added service for pro-active planned.  It is possible, but not inplan
17:42:24 <lenrow> #info lenrow
17:42:30 <phrobb> #info the project can add proactive as an addition to flow-writer service… this will be added as an official feature
17:43:25 <phrobb> #info quiet applause for the inclusion of lenrow as the newest TSC member
17:43:58 * edwarnicke loud appluase for the inclusion of lenrow as the newest TSC member :)
17:44:10 <mlemay> +1 on that :)
17:44:35 <lenrow> thanx all
17:45:23 <phrobb> #info question how will L2 switch interact with other sevices such as simple forwarder?
17:46:15 <phrobb> #info A:  L2 switch and other services will need to be configurable to avoid conflicts
17:48:07 <phrobb> #info Q: what is the view of the project regarding dealing with tunnels and packets where L2 can talk about both an inside and outside header?
17:49:33 <phrobb> #info additionally, can we recurse through this to get interesting vswitch behavior where pealing off encapsulation to do multi-level decoding
17:49:56 <phrobb> #info not to mandate scope, just wanting to understand how that would work
17:51:20 <phrobb> #info for Multi-tenancy there are as yet unscoped features that will be interesting in this project
17:51:57 <regXboi> I'm good on my question now ;)
17:52:48 <phrobb> #info more investigation will be needed for multi-tenancy and the full system-wide implications
17:53:49 <phrobb> #info As a general project proposal comment, scoping the project is separate from feature-sets planned for a given simultaneous release
17:56:24 <phrobb> #startvote Shall L2 Switch project be accepted into ODL as an incubation project? +1, 0 -1
17:56:24 <odl_meetbot> Begin voting on: Shall L2 Switch project be accepted into ODL as an incubation project? Valid vote options are +1, 0, -1.
17:56:24 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:56:31 <edwarnicke> #vote +1
17:56:32 <regXboi> #vote +1
17:56:40 <ChrsPriceAB> #vote +1
17:56:42 <kwatsen> #vote 0
17:56:43 <dmm> #vote +1
17:56:45 <RobDolin> #vote +1
17:56:50 <lenrow> #vote +1
17:58:03 <phrobb> #endvote
17:58:03 <odl_meetbot> Voted on "Shall L2 Switch project be accepted into ODL as an incubation project?" Results are
17:58:03 <odl_meetbot> 0 (1): kwatsen
17:58:03 <odl_meetbot> +1 (6): lenrow, regXboi, dmm, ChrsPriceAB, edwarnicke, RobDolin
17:58:20 <phrobb> #agreed L2 Switch is moved to incubation within ODL
17:58:26 <ChrsPriceAB> Congrats L2 switch
17:58:41 <phrobb> #topic Creation Review Service Function Chaining Project
17:59:03 <raghu67> #info Thank you to everyone on behalf of the L2 Switch Project team!
17:59:31 <dmm> congrats Raghu and nice job!
17:59:37 <edwarnicke> raghu67: Congrats to the L2 Switch team :)
17:59:38 <regXboi> #link https://wiki.opendaylight.org/view/Project_Proposals:Service_function_chaining
18:09:54 <phrobb> #info Q how does this relate to NSH?
18:10:15 <phrobb> #info A: NSH shims between the transport headers and the original payload
18:11:26 <phrobb> #info Q what is openflow doing here?
18:13:27 <phrobb> #info Q: How does the instantiation of services occur?…A: this project assumes that the service is instantiated outside of the scope of this project
18:15:02 <phrobb> #info Q what service chaining types will be possible in this first version?
18:18:15 <phrobb> #startvote Shall Service Function Chaining project be accepted into ODL as an incubation project? +1, 0 -1
18:18:15 <odl_meetbot> Begin voting on: Shall Service Function Chaining project be accepted into ODL as an incubation project? Valid vote options are +1, 0, -1.
18:18:15 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:18:23 <edwarnicke> #vote +1
18:18:24 <regXboi> #vote +1
18:18:26 <ChrsPriceAB> #vote +1
18:18:29 <lenrow> #vote +1
18:18:34 <Madhu> #vote +1
18:18:41 <kwatsen> #vote +1
18:18:53 <dmm> #vote +1
18:19:05 <phrobb> #endvote
18:19:05 <odl_meetbot> Voted on "Shall Service Function Chaining project be accepted into ODL as an incubation project?" Results are
18:19:05 <odl_meetbot> +1 (7): lenrow, regXboi, ChrsPriceAB, Madhu, edwarnicke, kwatsen, dmm
18:19:23 <phrobb> #agreed Service Function Chaining is moved to Incubation
18:19:24 <edwarnicke> Congratulations SFC team :)
18:20:02 <phrobb> #topic Secure Network Bootstrapping Infrastructure Creation Review
18:20:06 <regXboi> #link https://wiki.opendaylight.org/view/Project_Proposals:Secure_Network_Bootstrapping_Infrastructure
18:21:11 <regXboi> #info regXboi thanks snbi team for linking slides to proposal page
18:30:28 <phrobb> #info Q: the tunnel infra is created hop by hop.  Is the encryption hop by hop?  A: Yes, encryption is hop by hop
18:34:14 <phrobb> #info Q: Do you assume the virtual forwarding elements will also be part of this?
18:35:07 <Madhu> phrobb: dmm: I didn't get a chance to review this project before. when was it proposed ? should we vote for this today ?
18:35:46 <lenrow> This is the only day if it's bound for Helium
18:36:00 <phrobb> #info Q: Does this framework only work for physical forwarding elements or will this also work for virtual forward elements… particularly when there can be many, many virtual forwarding elements?  Particularly with certificates that are replicated on virtual devices?
18:36:07 <kwatsen> #info be sure to take a look at draft-kwatsen-netconf-zero-touch too  ;)
18:36:15 <Madhu> lenrow: thanks. but there was a norm to wait for 2 weeks from proposal to review to get some time for research
18:36:25 <Madhu> i find it hard to think during the call :)
18:36:52 <regXboi> Madhu: i'm pretty sure this one has been out there, I've looked at it and thought about it
18:37:26 <Madhu> regXboi: thanks. i just checked. it was sent on 05/08
18:37:34 <phrobb> #info A: that is a very good question.  There will need to be a method to handle virtual FEs in this case
18:37:36 <Madhu> no wonder i missed it (due to all the Openstack summit stuff)
18:38:31 <phrobb> #info middle attacks in hop by hop encryption where virtual FEs are present is a concern
18:38:51 <edwarnicke> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-April/000137.html - project proposal submitted Apr 29
18:39:12 * lenrow DRL TSC appointment note is in DMM inbox now
18:40:23 <Madhu> edwarnicke: thanks. i was looking at TSC list
18:41:31 <phrobb> #info Nothing will be done new in how communication happens using certificates and encryption.
18:41:33 <edwarnicke> #link https://wiki.opendaylight.org/view/Project_Proposals:Main#Instructions_For_Submitting_New_Proposals - emailing project-proposals is (currently) the point of reference for a proposal actually being submitted :)
18:41:56 <Madhu> edwarnicke: sure. its my bad that i didn't subscribe to that :)
18:42:14 <phrobb> #info concern/suggestion is that it is better to do end to end encryption from each FE instead of hop-by-hop encrypt/decrypt.
18:42:42 <edwarnicke> Madhu: No worries, and periodically I believe we've discussed other triggers... so, not written in stone per se... just currently the point of record :)
18:43:11 <Madhu> i didn't get a chance to review this. so I have to abstain :(
18:43:21 <Madhu> and is a heavy topic to think through
18:44:27 <phrobb> #info there is a trade-off  in End to end encryption and encryption methods supported and performance vs hop by hop encryption on this management channel
18:44:55 <phrobb> #info A it is noted that end to end encryption can still be done outside of this mgmt channel
18:45:37 <phrobb> #info Q: does the user get to choose the strength of the encryption?
18:46:00 <phrobb> #info A:  It is possible for the user to be able to choose
18:46:33 <phrobb> #info concern is to deal with export restrictions etc for different uses/locations
18:47:15 <phrobb> #info the scope of encryption strength may not fall in Helium/Lithium but it will be possible
18:48:00 * phrobb missed Madhu's question.  Can someone else post it #info?
18:48:28 <regXboi> #info can a non snbi enabled FE be part of the network?
18:48:38 <phrobb> #info Q: elements may not support this feature.  If it doesn't, what will happen?… will the FEs be excluded from the topology?
18:48:45 <edwarnicke> #info Madhu asked about what happens if some intermediate node does not have this capability
18:48:53 * edwarnicke evidently types to slowly ;)
18:50:49 <phrobb> #info A: intermediate FEs may end up being separate islands in the mgmt channel, but that should not prohibit connectivity - it will just need to be manually added
18:53:02 <phrobb> #startvote Shall Secure Network Bootstrapping Infrastructure (SNBI) project be accepted into ODL as an incubation project? +1, 0 -1
18:53:02 <odl_meetbot> Begin voting on: Shall Secure Network Bootstrapping Infrastructure (SNBI) project be accepted into ODL as an incubation project? Valid vote options are +1, 0, -1.
18:53:02 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:53:18 <edwarnicke> #vote +1
18:53:19 <ChrsPriceAB> #vote +1
18:53:21 <lenrow> #vote +1
18:53:25 <kwatsen> #vote +1
18:53:26 <regXboi> #vote +1
18:53:38 <regXboi> #info Madhu vote +0
18:54:18 <regXboi> #info (Madhu lost battery, so voice vote above)
18:54:32 <regXboi> #info (dmm lost connectivity, so voice vote)
18:54:34 <regXboi> #info dmm +1
18:54:47 <phrobb> #endvote
18:54:47 <odl_meetbot> Voted on "Shall Secure Network Bootstrapping Infrastructure (SNBI) project be accepted into ODL as an incubation project?" Results are
18:54:47 <odl_meetbot> +1 (5): lenrow, kwatsen, regXboi, edwarnicke, ChrsPriceAB
18:55:09 * ChrsPriceAB congratulations to the snbi team.
18:55:10 <regXboi> #info adjustment to +1 6, 0 1
18:55:19 <phrobb> #agreed SNBI moved to Incubation
18:55:22 <edwarnicke> Congratulations to the SNBI team
18:55:24 * regXboi congratulations as well!
18:55:29 <lenrow> +1
18:55:54 <phrobb> #topic NDM Renaming request
18:56:31 <regXboi> #info NDM project assumed that ONF would name the standard NDM
18:56:52 <regXboi> #info ONF has changed the specification name to TTP
18:57:11 <regXboi> #info so project would like to change its name to TTP to align with ONF better
18:57:18 <regXboi> phrobb: that looks good?
18:57:35 <phrobb> #info The project was called NDM because ONF was planning to make the effort called NDM.  The ONF has changed the name to the TTP (Table Type Patterns)
18:57:36 <regXboi> #info so project would also like to change repo name to ttp
18:57:56 <phrobb> regXboi:  yes that looks good
18:58:00 <regXboi> thanks
18:58:13 <edwarnicke> question, are we also looking to change the project name to TTP (no objection, just want to make sure we have clarity on the question) :)
18:58:40 <kwatsen> change both project-name and repo-name
18:58:41 <regXboi> edwarnicke: as I understand it, it is change of both name and repo
18:58:50 <phrobb> #info Q:  are we also looking to change the project name to TTP (no objection, just want to make sure we have clarity on the question) 
18:59:23 <phrobb> #info A:  Repo and Project name is requested to be changed to TTP from NDM
18:59:46 <phrobb> #agreed The NDM project and repo name will be changed to TTP
18:59:49 <edwarnicke> #info call dropped... but I do not object
18:59:59 * regXboi muted himself to avoid objecting :)
19:00:37 * ChrsPriceAB finds that objectionable.
19:01:04 <phrobb> #endmeeting