#opendaylight-meeting: tsc

Meeting started by phrobb at 18:00:52 UTC (full logs).

Meeting summary

  1. Rollcall - TSC members please #info in (phrobb, 18:01:20)
    1. Kent Watsen (kwatsen, 18:01:44)
    2. alagalah (Keith Burns) in for Jan Medved (alagalah_, 18:01:45)
    3. colindixon (colindixon, 18:02:00)
    4. dlenrow (dlenrow, 18:02:10)
    5. ChrisPrice text only for a short while (ChrisPriceAB, 18:02:12)
    6. https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda (colindixon, 18:02:13)
    7. https://meetings.opendaylight.org/opendaylight-meeting/2014/tsc/opendaylight-meeting-tsc.2014-11-20-18.03.html Minutes from last week’s meeing (tbachman, 18:02:15)
    8. Youcef Laribi (Youcef, 18:02:16)
    9. https://meetings.opendaylight.org/opendaylight-meeting/2014/tsc/opendaylight-meeting-tsc.2014-11-20-18.03.html two weeks ago meeting minutes (for action items) (colindixon, 18:02:41)
    10. jburns (jburns, 18:02:57)
    11. LuisGomez (LuisGomez, 18:03:10)
    12. ACTION: colindixon to start the conversation and collect ideas on how to resolve cross-project version bumping in timely fashion (colindixon, 18:03:51)
    13. ACTION: mlemay to Investigate usage of repotool manifest for inter-repo + tags management with zxiiro (colindixon, 18:04:17)
    14. regXboi is running late (regXboi, 18:05:07)
    15. ACTION: colindixon and phrobb to work with the CAPWAP team to make sure the proposal goes through (colindixon, 18:05:48)
    16. ACTION: phrobb and tykeal to follow up on getting the new certifacte for nexus to make archetypes work on MacOS (colindixon, 18:06:54)
    17. edwarnicke (edwarnicke, 18:07:42)

  2. VPN Service Creation Review (colindixon, 18:08:35)
  3. VPN Creation Review (phrobb, 18:08:52)
    1. https://wiki.opendaylight.org/view/Project_Proposals:VPN_Service the proposal page (colindixon, 18:09:08)
    2. Chris Wright (cdub, 18:09:10)
    3. propsoing a model for deploying VPN services in ODL (colindixon, 18:10:20)
    4. motivation is network virtualization in the data center, recognizing that interworking with traditional networking elements being a problem (tbachman, 18:11:46)
    5. Application will use the MD-SAL and BGP-PCEP (colindixon, 18:12:52)
    6. OVSDB and OpenFlow used to interact with switches (tbachman, 18:13:23)
    7. The orchestrator will be OpenStack. (rgowrishankar, 18:13:58)
    8. GRE tunnels will be used between the nodes and the gateway (tbachman, 18:14:04)
    9. mohnish (mohnish, 18:14:12)
    10. The data center GW doesn’t need a lot of state since they’re using “soft GRE" (tbachman, 18:14:34)
    11. diagram of new and existing parts of ODL in providing the service (colindixon, 18:15:47)
    12. New L3 components for ODL: MP-GBP, VPN Manager Service, Next-hop Manager Service, FIB Service, and Label Manager Service (tbachman, 18:15:51)
    13. MP-BGP will use existing BGP-LS infrastructure (rgowrishankar, 18:16:04)
    14. edwarnicke asks if this is intended to have a “works out of the box” deployment scenario (tbachman, 18:18:32)
    15. edwarnicke asks what the deployment model is? right now most things “work out of the box” as long as there’s a JVM to run it in (colindixon, 18:19:04)
    16. Srikar says the new functions will be no different than the existing functions in ODL (tbachman, 18:19:04)
    17. Srikar says there’s no component that he’s aware of that would require a higher end machine in order to be run (tbachman, 18:19:42)
    18. edwarnicke was not asking about individual components but about the overall deployment whether additional systems would be needed to set it up.. (rgowrishankar, 18:21:16)
    19. srikar says most components are implemented in a prototype inside Ercsson as ODL elements that work just like ODL (colindixon, 18:21:31)
    20. using REST to configure VPN will be available as well.. using OpenStack or other component is not mandatory. (rgowrishankar, 18:23:17)
    21. colindixon asks what OpenStack APIs would be implemented? ML2? VPNaaS? (colindixon, 18:24:54)
    22. Targeting network of 100 vswitches and 1000 VRFs as scale (rgowrishankar, 18:25:42)
    23. Srikar says that the existing VPNs in OpenStack are very IPSEC-centric, there are blueprints floating around that support MPLS-BGP VPN (what is being implemented here) and they would implement the one of those that is chosen (colindixon, 18:26:00)
    24. rovarga says that the BGPCEP project already provides BGP-MP, e.g., BGP/LS is a plugin into a BGP-MP framework (colindixon, 18:26:59)
    25. using softGre instead of VxLAN because lot of existing boxes that connect to WAN support softGRE and not VxLAN (rgowrishankar, 18:27:16)
    26. cdub says “I don’t think you’ll find that tunnel overhead [for VxLAN] is significant” (colindixon, 18:28:33)
    27. rovarga asks what BGP-MP features the project is looking for (tbachman, 18:28:40)
    28. Srikar says it’s essentially the VPN functionality/RFCs (tbachman, 18:28:59)
    29. Srikar says also RFC 3107 for label propagation (tbachman, 18:29:23)
    30. rovarga says those could be realized as plugins to the existing BGP framework (tbachman, 18:29:48)
    31. There’s one tunnel from each vSwitch to the data center gateway (tbachman, 18:31:14)
    32. LuisGomez asks how they plan to do that for the gateway (tbachman, 18:31:27)
    33. It uses MPLS over softGRE which can be realized using NETCONF, where a particular subnet applies to a softGRE (tbachman, 18:32:07)
    34. The current plan is to us MPLS for the VPN service label, but not the tunnel, but there’s thinking about using an LSP for tunnels as well (tbachman, 18:32:31)
    35. Labels are distributed via BGP to a remote site (tbachman, 18:33:42)

  4. committer promotions: Defense4all (tbachman, 18:34:32)
    1. Link for the presentation (abhijitkumbhare, 18:34:55)
    2. https://wiki.opendaylight.org/view/File:VPN_Service.pptx (abhijitkumbhare, 18:34:59)
    3. https://lists.opendaylight.org/pipermail/defense4all-dev/2014-September/000074.html the mailing list votes for new committers (colindixon, 18:36:39)
    4. Defense4All lost 3 of the 5 committers (rgowrishankar, 18:36:58)
    5. proposing two new committers: Gershon Soklosky and Asaf Oron (colindixon, 18:37:09)
    6. https://git.opendaylight.org/gerrit/#/q/project:defense4all (edwarnicke, 18:37:17)
    7. http://spectrometer.opendaylight.org/?release=all&project_type=all&metric=loc&user_id=gershons Gershon Sokolsky history (dfarrell07, 18:37:57)
    8. http://spectrometer.opendaylight.org/?metric=loc&user_id=gershons Gershon’s contributions (colindixon, 18:38:04)
    9. D4A asked for 3 committers. Gershon has been contributing a lot of code and Asaf has been the main contact for the Helium release. Asaf has not been contributing to ODL directly. Gershon has been committing code from both of them. (rgowrishankar, 18:39:41)
    10. VOTE: Voted on "Shall the TSC approve Gerson Soklosky as a committer on the Defense4All Project?" Results are, +1: 11 (phrobb, 18:41:18)
    11. colindixon asks how much oversight the TSC should exert on committer nominations (tbachman, 18:41:40)
    12. AGREED: Gerson Soklosky is approved as a committer on the Defense4All project (phrobb, 18:41:40)
    13. cdub recommends light oversight with strong guidance (tbachman, 18:41:57)
    14. phrobb emplores asaf and benny to get asaf set up so that he can become a committer, as having a backup is important (tbachman, 18:45:37)
    15. phrobb says that given asaf’s role within defense4all, it seems like he is the most likely candidate to be the project lead, and to become a project lead you need to first be a committer (tbachman, 18:46:19)

  5. Creation Review for VPN Service (revisited) (tbachman, 18:47:10)
    1. colindixon asks what projects they imagine interacting with (tbachman, 18:47:40)
    2. Begun interaction with OVSDB, have not reached out to BGP-pCEP team (rgowrishankar, 18:48:11)
    3. Some contribution to openflowplugin as well (tbachman, 18:48:32)
    4. also wanted to reach out to the sdniapp team (colindixon, 18:48:45)
    5. any changes to the neutron API? (rgowrishankar, 18:49:09)
    6. Srikar doesn’t see making any changes to the existing Neutron API, but adding functionality will be part of it (tbachman, 18:49:33)
    7. regXboi asks how they can add functionality without changing (tbachman, 18:50:01)
    8. Srikar says there are blueprints in OpenStack to add VPN as a service which would use neutron (tbachman, 18:50:51)
    9. regXboi asks if this would be something between ML2 and the controller (tbachman, 18:51:26)
    10. Srikar says it uses ML2 constructs, but has an extraneous association (tbachman, 18:51:46)
    11. colindixon asks if we have a mechanism to modify project scope (tbachman, 18:53:40)
    12. CDixon: add word VPN before service in the scope definition (rgowrishankar, 18:54:40)
    13. colindixon asks to put the ODL usernames to help LF folks (tbachman, 18:54:50)
    14. any vote on the proposal will be conditional on: (i) adding ODL usernames for committers, (ii) removing the tech lead section, and (iii) adding the word VPN before service in the first two paragraphs of Scope, (iv) add prem as a committer (colindixon, 18:59:03)
    15. VOTE: Voted on "Shall the TSC approve the VPN Service project to Incubation – conditional on adding Prem Sankar as a committer, removing the tech lead section from the proposal, adding “VPN” before the word “service” in the Scope section of the proposal, and finalizing Inbound Code Review?" Results are, +1: 8 (phrobb, 19:00:37)
    16. AGREED: the VPN Service Project is approved (phrobb, 19:00:56)

  6. events (tbachman, 19:02:07)
    1. phrobb says that submission for papers for the summit opens on 12/15 and closes 2/6 (tbachman, 19:03:07)
    2. https://lists.opendaylight.org/pipermail/tsc/2014-December/002197.html Phils proposal to do weekly IRC meetings in lieu of a face-to-face meeting in January (colindixon, 19:04:03)
    3. second part of the proposal is one face-to-face meeting in the M4/M5 boundary later on (colindixon, 19:05:02)
    4. edwarnicke says if we go with IRC weekly meetings, we should get them scheduled soon (colindixon, 19:05:37)
    5. abhijitkumbhare asks if we’d have alternate time zone meetings (tbachman, 19:06:41)
    6. colindixon says we have to do alternate time zone meetings (tbachman, 19:06:50)
    7. abhijitkumbhare asks if we’re going to do 2x/day or alternate (tbachman, 19:07:04)
    8. edwarnicke opines that we need to solve the timezone issue... not certain as to the best solution (edwarnicke, 19:07:07)
    9. regXboi recommends not doing 2 meetings in a day (tbachman, 19:07:50)
    10. rovarg and abhijitkumbhare agreeswith regXboi (tbachman, 19:08:07)
    11. note M1 to M2 is 12/11 and 2/5 (colindixon, 19:09:53)
    12. AGREED: Mechanism needed to deal with time zone issues for planning meetings (tbachman, 19:10:09)
    13. ACTION: phrobb to kick off a discussion on the mailing list on how to deal with the timezone issues for these IRC meetings (phrobb, 19:10:25)

  7. interns (colindixon, 19:10:38)
    1. http://www.opendaylight.org/community/summer-intern-program intern page (dfarrell07, 19:10:55)
    2. https://wiki.opendaylight.org/view/InternProjects:Main <- Intern page (phrobb, 19:11:20)
    3. AGREED: Weekly IRC meetings will be held between M1/M2 for Lithium planning/coordination (tbachman, 19:11:32)
    4. phrobb says they’ll be engaging with google summer of code org (tbachman, 19:11:50)
    5. phrobb says they’ll also reach out to the outreach program for women (tbachman, 19:12:11)
    6. phrobb says they have budget for up to 14 interns this year as well (~double last year's) (tbachman, 19:12:36)
    7. phrobb says that interns start committing themselves to programs in the December time frames; we need mentors and projects so that interns can start signing up (tbachman, 19:13:10)
    8. dneary asks if we hvae partnerships with universities in the project (tbachman, 19:14:50)
    9. phrobb says nothing formally (tbachman, 19:14:56)
    10. colindixon says there was some technicality that dq’d us from summer of code last year; have we fixed that (tbachman, 19:15:27)
    11. phrobb says the template has been modified to call out more information, and this is being done significantly early, both of which resulted in dq’s last year (tbachman, 19:15:56)
    12. colindixon says last year almost all interns were from outside the US; is this being addressed? (tbachman, 19:16:36)
    13. phrobb says we want to keep parity with the google summer of code (tbachman, 19:16:55)
    14. ACTION: phrobb to start a thread on possibly changing compensation to attract interns more people (colindixon, 19:18:52)
    15. cdub and phrobb say maybe the way to do that is through member companies instead (colindixon, 19:19:30)
    16. ACTION: phrobb to kick off email thread on compensation and possible "internships" board (phrobb, 19:20:28)

  8. system integration and test update (tbachman, 19:20:31)
    1. no update this week (tbachman, 19:20:35)

  9. Lithium and Stable/Helium updates (tbachman, 19:21:43)
    1. colindixon asks if we’re done with the version bumps for stable helium (tbachman, 19:22:15)
    2. zxiiro says yes they’ve been completed (tbachman, 19:22:20)
    3. zxiiro has also been looking at the Lithium auto-build, which is currently failing due to 2 features that depend on each other (tbachman, 19:22:51)
    4. zxiiro thinks the stable/helium autobuilds are failing as well due to a test failure (tbachman, 19:23:06)
    5. colindixon says he thinks it’s in l2switch and is being looked at (tbachman, 19:23:16)
    6. colindixon notes helium sr2 is jan 12 (cdub, 19:23:18)

  10. Infrastructure (tbachman, 19:24:10)
    1. tykeal says ODL forge was greenlighted and the name has been purchased (tbachman, 19:24:28)
    2. andy is working on getting infra in place. odlforge.org has been bought (rgowrishankar, 19:24:30)
    3. tykeal is looking into getting certs for ODL forge (tbachman, 19:24:38)
    4. odlforge is coming up on EL7 systems (colindixon, 19:25:33)
    5. tykeal says there’s been a lot of requests for the puppet manifests; they’re starting with new manifest sets for ODL forge (tbachman, 19:25:42)
    6. tykeal is hoping to have ODL forge up and running by end of next week (tbachman, 19:26:05)
    7. we now have a way to retrigger jobs, thanks to zxiiro (tbachman, 19:27:59)
    8. https://wiki.opendaylight.org/view/RelEng:Main#Builder RelEng page (dfarrell07, 19:28:56)
    9. you can retrigger a verify by putting a comment on the gerrit with “recheck” and similar for merge with “remerge" (colindixon, 19:29:13)
    10. Jenkins Job Builder is now open to all projects who want to start picking it up and using it (tbachman, 19:29:39)
    11. tykeal notes that the dynamic slaves currently are still a little slow (tbachman, 19:30:05)
    12. the README file in the root of the builder.git repo contains detailed information on how to use the releng/builder JJBs (zxiiro, 19:30:08)

  11. Internet of Things Data Management Creation Review (colindixon, 19:30:47)
    1. https://wiki.opendaylight.org/view/Project_Proposals:Internet_of_Things_Data_Management_%28IOTDM%29 the project proposal (colindixon, 19:30:58)
    2. https://github.com/opendaylight/releng-builder/blob/master/README.md the README zxiiro just mentioned (dfarrell07, 19:31:01)
    3. https://wiki.opendaylight.org/view/File:IoT_in_ODL_for_TSC.pptx the slides on the wiki (colindixon, 19:31:57)
    4. the IOT applications usually come packaged with the device plus the SW to manage the devices (tbachman, 19:32:36)
    5. usually there isn’t much communication between a familiy of devices and their corresponding application (tbachman, 19:32:56)
    6. The goal of this project is to provide a facility that allows any application to consume ability of any device (tbachman, 19:33:17)
    7. several efforts in inductry for middleware (rgowrishankar, 19:33:33)
    8. proliferation of standards (rgowrishankar, 19:33:46)
    9. picked one of the standards, oneM2M (rgowrishankar, 19:33:58)
    10. standard covers 4 categories: data exchange between iot, device mgmt, security mech, connectivity handling (rgowrishankar, 19:35:18)
    11. the oneM2M common service functions is working on several modules (tbachman, 19:36:15)
    12. This project is mostly focusing on the data management and repository (tbachman, 19:36:24)
    13. and the subscription and notification (rgowrishankar, 19:36:52)
    14. if the project goes well scope will be extended (rgowrishankar, 19:37:07)
    15. it can run on either the managed devices or the IOT servers (rgowrishankar, 19:39:08)
    16. ODL was chosen as a platform for its rich features (e.g. MD-SAL which supports tree-based model) (tbachman, 19:39:10)
    17. There are specifications on how to map things like COAP, MQTT, etc for MD-SAL data store access (tbachman, 19:41:42)
    18. There’s also a pub/sub capabilitiy, so depending on listeners, they can deliver updates to those applications (tbachman, 19:42:19)
    19. Still trying to work out how the project will work with ODL’s authentication capabilities (tbachman, 19:42:38)
    20. kwatsen asks if this project is in scope (colindixon, 19:44:50)
    21. edwarnicke says he thinks it is because the scope of the TSC policy on projects doesn’t limit it to SDN (colindixon, 19:45:28)
    22. John Burns notes you can use SDN functionality to help with IOT devices — e.g. shutting down a “chatty” device (tbachman, 19:45:29)
    23. http://www.opendaylight.org/project/tsc/tsc-policy one of the listed project scopes is “Southbound plugins to enable the controller to speak to the OpenDaylight supplied and other network elements” (colindixon, 19:45:48)
    24. colindixon says there are alot of SB protocols in the scope of the project prooposal, one of which already exists (SB REST); is the intent to have the implementation of those protocols as part of this project, or would they be separate things that could be spun out (tbachman, 19:47:51)
    25. John Burns sayd initially they’re going to initially work with COAP (tbachman, 19:48:20)
    26. lflorit says that for COAP and MQTT there are implementations that they can bring in (tbachman, 19:49:02)
    27. colindixon asks if they’re intending the scope of the project to include those protocols in the future (tbachman, 19:49:24)
    28. jburns says MQTT exists today, but isn’t in ODL yet; there’s servers and client SW. An MQTT client side open source coulde be brougt in which would attach to an external MQTT server (tbachman, 19:50:28)
    29. colindixon says that having applications and drivers in the same project has caused problems in the past (e.g. creating dependency cycles) (tbachman, 19:51:55)
    30. from: http://www.opendaylight.org/project/bylaws: The primary purpose of the ODP (collectively, “the Purpose”) is to (a) advance the creation, evolution, promotion, and support of an open source software defined network and network functions virtualization software platform (“Platform”), (b) support and maintain the strategic framework of the Platform through the technologies made available by the organization to ma (kwatsen, 19:54:49)
    31. VOTE: Voted on "Shall the TSC approve the Internet of Things Data Management (IOTDM) project to Incubation?" Results are, +1: 9 (phrobb, 19:58:06)
    32. AGREED: the IOTDM project is approved to Incubation (phrobb, 19:58:33)

  12. cookies (tbachman, 19:59:04)


Meeting ended at 19:59:04 UTC (full logs).

Action items

  1. colindixon to start the conversation and collect ideas on how to resolve cross-project version bumping in timely fashion
  2. mlemay to Investigate usage of repotool manifest for inter-repo + tags management with zxiiro
  3. colindixon and phrobb to work with the CAPWAP team to make sure the proposal goes through
  4. phrobb and tykeal to follow up on getting the new certifacte for nexus to make archetypes work on MacOS
  5. phrobb to kick off a discussion on the mailing list on how to deal with the timezone issues for these IRC meetings
  6. phrobb to start a thread on possibly changing compensation to attract interns more people
  7. phrobb to kick off email thread on compensation and possible "internships" board


Action items, by person

  1. colindixon
    1. colindixon to start the conversation and collect ideas on how to resolve cross-project version bumping in timely fashion
    2. colindixon and phrobb to work with the CAPWAP team to make sure the proposal goes through
  2. mlemay
    1. mlemay to Investigate usage of repotool manifest for inter-repo + tags management with zxiiro
  3. phrobb
    1. colindixon and phrobb to work with the CAPWAP team to make sure the proposal goes through
    2. phrobb and tykeal to follow up on getting the new certifacte for nexus to make archetypes work on MacOS
    3. phrobb to kick off a discussion on the mailing list on how to deal with the timezone issues for these IRC meetings
    4. phrobb to start a thread on possibly changing compensation to attract interns more people
    5. phrobb to kick off email thread on compensation and possible "internships" board
  4. tykeal
    1. phrobb and tykeal to follow up on getting the new certifacte for nexus to make archetypes work on MacOS
  5. zxiiro
    1. mlemay to Investigate usage of repotool manifest for inter-repo + tags management with zxiiro


People present (lines said)

  1. tbachman (179)
  2. colindixon (71)
  3. ChrisPriceAB (32)
  4. odl_meetbot (31)
  5. cdub (30)
  6. alagalah (25)
  7. rgowrishankar (22)
  8. edwarnicke (21)
  9. phrobb (19)
  10. dneary (16)
  11. dfarrell07 (15)
  12. tykeal (14)
  13. regXboi (13)
  14. abhijitkumbhare (9)
  15. dlenrow (8)
  16. kwatsen (7)
  17. LuisGomez (4)
  18. rovarga (4)
  19. zxiiro (4)
  20. mohnish (4)
  21. Youcef (2)
  22. mlemay (1)
  23. jburns (1)
  24. alagalah_ (1)


Generated by MeetBot 0.1.4.