17:57:57 <colindixon> #startmeeting tsc
17:57:57 <odl_meetbot> Meeting started Thu Dec 18 17:57:57 2014 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:57:57 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:57:57 <odl_meetbot> The meeting name has been set to 'tsc'
17:58:03 <colindixon> #topic roll call and agenda bashing
17:58:27 <colindixon> I know we’re 3 minutes early
17:58:45 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda in it’s usual place
17:59:35 <edwarnicke> #info edwarnicke
18:00:08 <ChrisPriceAB> #info Chris Price
18:00:32 <ChrisPriceAB> Sounds like an ER in here...
18:00:46 <tykeal> haha
18:01:13 <colindixon> #info colindixon
18:01:18 <dlenrow> #info dlenrow
18:01:33 <kwatsen> #info kwatsen
18:01:37 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/tsc/opendaylight-meeting-tsc.2014-12-11-17.59.html last weeks meeint minutes for action items
18:01:59 <colindixon> #action colindixon to start the conversation and collect ideas on how to resolve cross-project version bumping in timely fashion
18:02:18 <colindixon> #info the CAPWAP project proposal was approved over e-mail vote
18:03:05 <cdub> #info Chris Wright
18:03:58 <colindixon> #info phrobb and colindixon will help to clean up the non-projects from the wiki
18:04:13 <colindixon> #undo
18:04:13 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2833190>
18:04:20 <colindixon> #action phrobb and colindixon will help to clean up the non-projects from the wiki
18:04:27 <colindixon> #action colindixon will try to explore the use categories which allow for easier curation of this
18:05:23 <dfarrell07> "gzhao will fill in the Duan Jingzhu’s username"
18:05:47 <mohnish> #info mohnish anumala
18:05:55 <regXboi> #info regXboi
18:05:56 <colindixon> #action colindixon to follow up with tykeal on getting usernames for new projects
18:06:12 <colindixon> #action colindixon will send mail about encouraging projects to get projects tracking what happens in the TSC
18:07:36 <jmedved> #info jmedved
18:08:11 <colindixon> #action colindixon will track how VTN and controller are interacting on possible AD-SAL deprecation
18:08:44 <LuisGomez> #info LuisGomez
18:08:55 * ChrisPriceAB you have me for the next 14% battery power :s
18:09:08 <dfarrell07> I'm here
18:09:10 <colindixon> #chair dfarrell07 regXboi
18:09:10 <odl_meetbot> Current chairs: colindixon dfarrell07 regXboi
18:09:35 <tykeal> use the handle! :D
18:09:44 * regXboi not on phone yet
18:09:59 <colindixon> #topic updates
18:10:07 <dfarrell07> kk
18:10:37 <dfarrell07> #info Event updates from Phil: IRC event email sent, presentations for summit now being accepted
18:10:41 <dfarrell07> I can grab links
18:10:53 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2014-December/002359.html IRC meetings between M1 and M2
18:11:07 <dfarrell07> #link http://www.opendaylight.org/events/2015-07-27/opendaylight-summit CFP for ODL Summit
18:11:14 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2014-December/002357.html conversation about f2f meetings in April
18:12:01 <dfarrell07> #info LuisGomez will remove old Hydrogen distros from stable/helium and master
18:12:11 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2014-December/002351.html Luis will remove Hydrogen distributions unless there are any objections
18:12:20 <colindixon> #undo
18:12:20 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2498d10>
18:12:24 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2014-December/002351.html Luis will remove Hydrogen distributions unless there are any objections *today*
18:13:30 <dfarrell07> #info Li and stable/helium updates: zxiiro has made progress, more TODOs; SR1.1 security release coming out
18:13:44 <dfarrell07> #info tykeal is making progress on ODL Forge
18:14:03 <dfarrell07> #info tykeal is having to build better Jenkins Puppet modules, which is a bit of the holdup
18:14:12 <dfarrell07> #info tykeal predicts ODL Forge will be ready in Jan
18:14:36 <tykeal> dfarrell07: better gerrit puppet module
18:14:47 <dfarrell07> tykeal: oops
18:14:49 <dfarrell07> #topic Helium SR1.1 Release
18:14:53 <tykeal> it's ok, I didn't specify ;)
18:15:19 <dfarrell07> #info Security vul was pointed out on mailing lists a few days ago
18:15:42 <dfarrell07> #info Three patches have been cherry picked into SR1 to fix them, that will be SR1.1
18:16:22 <dfarrell07> #info Low risk of bugs being introduced by SR1.1 changes, LuisGomez has validated that it's fairly robust
18:16:25 <dfarrell07> colindixon: kk
18:16:47 <dfarrell07> #link https://lists.opendaylight.org/pipermail/release/2014-December/001061.html Luis says it is as good or better than SR1
18:17:08 <dfarrell07> #link http://nexus.opendaylight.org/content/repositories//staging/org/opendaylight/integration/distribution-karaf/0.2.1-Helium-SR1.1/ The Helium-SR1.1 artifacts are ready to go here
18:17:33 <dfarrell07> I know
18:18:01 <dfarrell07> #startvote Shall the TSC bless the release of SR1.1? -1, 0, 1
18:18:01 <odl_meetbot> Begin voting on: Shall the TSC bless the release of SR1.1? Valid vote options are -1, 0, 1.
18:18:01 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:18:08 <jmedved> #vote +1
18:18:08 <odl_meetbot> jmedved: +1 is not a valid option. Valid options are -1, 0, 1.
18:18:10 <colindixon> #vote +1
18:18:10 <odl_meetbot> colindixon: +1 is not a valid option. Valid options are -1, 0, 1.
18:18:10 <ChrisPriceAB> #vote 1
18:18:13 <LuisGomez> #vote +1
18:18:13 <odl_meetbot> LuisGomez: +1 is not a valid option. Valid options are -1, 0, 1.
18:18:14 <edwarnicke> #vote 1
18:18:17 <jmedved> #vote 1
18:18:17 <colindixon> #vote 1
18:18:19 <dfarrell07> oops!
18:18:23 <regXboi> #vote 1
18:18:23 <dfarrell07> sorry all :(
18:18:23 <mohnish> #vote 1
18:18:24 <LuisGomez> #vote 1
18:18:24 <cdub> #vote 1
18:18:33 <kwatsen> #vote 1
18:18:55 <dlenrow> #vote +1
18:18:55 <odl_meetbot> dlenrow: +1 is not a valid option. Valid options are -1, 0, 1.
18:19:02 <dfarrell07> cdub: want to get that vote in?
18:19:05 <dlenrow> #vote 1
18:19:06 <dfarrell07> o, gtg
18:19:10 <regXboi> #endvote
18:19:10 <odl_meetbot> Voted on "Shall the TSC bless the release of SR1.1?" Results are
18:19:10 <odl_meetbot> 1 (10): dlenrow, jmedved, regXboi, LuisGomez, ChrisPriceAB, edwarnicke, cdub, mohnish, kwatsen, colindixon
18:19:11 <dfarrell07> #endvote
18:19:12 <RajeevK> #vote 1
18:19:12 * ChrisPriceAB well done all involved!
18:19:28 <regXboi> RajeevK: sorry bout that
18:19:36 <cdub> dfarrell07: ?
18:19:42 <dfarrell07> #agreed The TSC blessed the release of SR1.1
18:20:00 <dfarrell07> cdub: I had some IRC lag, nvm
18:20:09 <cdub> ah, ok
18:21:00 <dfarrell07> #info TSC discusses SR2 release date
18:21:10 <colindixon> #action colindixon to post SR1.1 to the security advisories mailing list and possibly to opendaylight-annoucne mailing list
18:21:23 <dfarrell07> #info SR2 release date will be taken to a thread
18:21:29 * ChrisPriceAB Early February please
18:21:37 <colindixon> #action gzhao (or colindixon) to start a thread on possibly moving SR2 further out than 1/12
18:22:10 <dfarrell07> #topic Security Response Process
18:22:34 <dfarrell07> #info New process has been reviewed and approved over the past few days
18:23:06 <dfarrell07> #info There is a security list, it will be better publicized than it was before
18:23:32 <dfarrell07> #info Discussion about members of security response team
18:24:23 <dfarrell07> #info rovarga cdub edwarnicke are up to be voted into security response team
18:24:50 <dfarrell07> #info regXboi has asked on-thread to be removed from team
18:26:10 <ChrisPriceAB> All-star team!
18:27:29 <alagalah> colindixon: Why not do the following :
18:27:35 <alagalah> colindixon: 1. Email to security list comes in
18:27:42 <alagalah> 2. Ticket in bugzilla gets raised
18:27:44 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2014-December/002281.html Thread where TSC voted on security team actions
18:27:52 <alagalah> 3. It has to be assigned to someone, if not, it gets auto-escalated
18:28:13 <alagalah> Seems pretty simple to me
18:28:17 <edwarnicke> cdub: colindixon rovarga Shall we hash out mechanical details on discuss under topic [Security Mechanics] ?
18:29:12 <dfarrell07> missing a name
18:29:15 <cdub> edwarnicke: yes, and given global nature, topic in email is good
18:29:16 <dfarrell07> David and ...
18:29:18 <colindixon> * Chris Wright
18:29:19 <colindixon> * Ed Warnicke
18:29:19 <colindixon> * Robert Varga
18:29:22 <colindixon> David Jorm
18:29:26 <colindixon> Kurt Seifried
18:29:33 <edwarnicke> cdub: Would you be willing to kick off ?
18:29:44 <dfarrell07> #startvote Shall the TSC approve cdub rovarga edwarnicke David Jorm Kurt Seifried to be members of the security response team? -1, 0, +1
18:29:44 <odl_meetbot> Begin voting on: Shall the TSC approve cdub rovarga edwarnicke David Jorm Kurt Seifried to be members of the security response team? Valid vote options are -1, 0, +1.
18:29:44 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:29:48 <ChrisPriceAB> #vote +1
18:29:50 <edwarnicke> #vote +1
18:29:51 <colindixon> #vote +1
18:29:51 <cdub> edwarnicke: yes
18:29:52 <dfarrell07> lol ;)
18:29:52 <LuisGomez> #vote +1
18:29:53 <dlenrow> #vote +1
18:29:54 <jmedved> #vote +1
18:29:54 <kwatsen> #vote +1
18:29:56 <regXboi> #vote +1
18:29:56 <RajeevK> #vote +1
18:29:56 <mohnish> #vote +1
18:29:57 <cdub> #vote +1
18:30:10 <regXboi> #endvote
18:30:10 <odl_meetbot> Voted on "Shall the TSC approve cdub rovarga edwarnicke David Jorm Kurt Seifried to be members of the security response team?" Results are
18:30:10 <odl_meetbot> +1 (11): dlenrow, jmedved, regXboi, LuisGomez, ChrisPriceAB, edwarnicke, cdub, mohnish, kwatsen, colindixon, RajeevK
18:30:21 <cdub> #action cdub to kick off security mechanics email discussion
18:30:31 * regXboi is happy with that
18:30:39 <dfarrell07> #agreed The TSC approved  cdub rovarga edwarnicke David Jorm Kurt Seifried to be members of the security response team
18:32:38 <cdub> yes, done
18:32:43 <dfarrell07> #action Someone will test the security mailing list (cdub?)
18:33:04 <colindixon> #topic CAPWAP creation review
18:33:14 <colindixon> #info the CAPWAP project was approved on the mailing list
18:33:19 <dfarrell07> #topic Project Creation Review for Persistence Project
18:33:59 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Persistence project proposal
18:34:22 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-December/000217.html proposed on 12/3/2014
18:34:58 <phrobb> @colindixon feel free to #chair me
18:35:07 <dfarrell07> #chair phrobb
18:35:07 <odl_meetbot> Current chairs: colindixon dfarrell07 phrobb regXboi
18:35:10 <colindixon> thanks
18:35:45 <dfarrell07> help taking notes for project proposals is always welcome
18:35:56 <phrobb> :-D
18:36:01 <dfarrell07> especially from people who are more familiar
18:36:09 <colindixon> #link https://wiki.opendaylight.org/view/File:Peristence-Project-Proposal-TSC-Presentation.pptx slides on the wiki
18:36:52 <colindixon> #info the basic idea is to have a query-able, persistent data store API (and different back databases)
18:38:27 <colindixon> #info AAA and TSDR are projects that will look into usin this project
18:38:35 <dfarrell07> #link https://wiki.opendaylight.org/view/Project_Proposals:Persistence Persistence Proposal wiki
18:39:24 <colindixon> #undo
18:39:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x23e5d50>
18:39:32 <colindixon> dfarrell07: that’s posted above
18:39:44 <dfarrell07> colindixon: ah, ic, sorry
18:39:47 <colindixon> A few questions:
18:40:03 <colindixon> 1.) I don’t think AADS is a project (or proposal) yet that I know of.
18:40:47 <colindixon> 2.) Is the intent to have a simple-to-set-up and works-out-of-the-box implementation to make it so that you can run ODL with persistance without having to also deploy a DBMS? (edwarnicke’s favorite question)
18:42:27 <regXboi> has anybody gotten cdub's mail?
18:43:15 <colindixon> 3.) #2 is especially complex if you’re saying that the things would help set stuff up is not in scope
18:44:10 <colindixon> #Info jmedved asks how does this persistance relate to the persistance provided by the clustered data store
18:44:47 <colindixon> #info answer is that this will support non-modeled data and will allow for data sets that don’t fit entirely in-memory
18:45:13 <Sunil_> Yes AADS is not a project proposal yet. We are rethinking the idea and may not go forward in the current form
18:46:16 <colindixon> #info edwarnicke asks if there has been thought about how to handle DB schemas?
18:46:48 <colindixon> #Info the answer is that implementations will almost certainly have to have knowleded of the particular schema of the particular database
18:47:00 <colindixon> Sunil_: thanks
18:49:42 <cdub> #info discussing schema definition which is currently considered "left to implementations"
18:49:51 <cdub> oops, sorry, i was scrolled up
18:50:01 <cdub> #link https://wiki.opendaylight.org/view/Project_Proposals:Persistence#Schema_Definition_is_Left_to_the_Implementations_and_not_Considered_as_Part_of_the_API discussing this part of proposal
18:50:32 <rovarga> so does that mean that the applications are tied to the backing datastore implementation?
18:50:54 <dfarrell07> #info edwarnicke points out that the deployment model for ODL could be greatly complicated by this project
18:50:55 <rovarga> e.g. what are we envisioning the mobility will be here?
18:51:40 <colindixon> #info regXboi notes that you really don’t want to get into storing all the data for stats in the clustered store, so TSDR desperately wantst this project
18:51:41 * ChrisPriceAB has to step away for a bit...
18:51:59 <dfarrell07> #info ODL also runs on tons of systems (anything that supports Java), which could be broken by deps of this project (like MySQL)
18:52:05 <colindixon> #info edwarnicke asks what the story for out-of-the-box functionality
18:52:05 <regXboi> sqlite3?
18:52:19 <regXboi> it's cheap and cheesy - but it runs on linux, windows and mac
18:52:53 <rovarga> right, but as far as I know the java impl relies on JNI
18:52:57 <colindixon> #info if we instead require people to set up an external DBMS to get things work at all, this is really much harder
18:54:33 <colindixon> #info Liem responds saying, like AAA, this should likely work out-of-the-box with one implementation, but then can swap out the DBMS as a configuration option
18:55:29 <regXboi> I didn't think that I need JNI, if I have JDBC
18:55:47 <dlenrow> Maybe things that need a high-performance persistence/IO solution (e.g. time series) don't run out of the box or on laptops. Maybe features that need advanced persistence don't work without the setup cost of deploying advanced database/back-end
18:56:06 <edwarnicke> dlenrow: That's fine, as long as nothing important depends on them...
18:56:07 <colindixon> #info lots more discussion, but the net-net seems to be that we need to figure out how to run portably across different DBs including ones that can be run out-of-the-box as well as different external ones
18:56:43 <dlenrow> colin: This seems like a  project work product not a creation review
18:56:57 <colindixon> dlenrow: cdub has it
18:57:02 <colindixon> +1
18:57:25 <dlenrow> scope: solve this problem. Approved!
18:58:01 <dlenrow> include out of box works as a goal and get on with it?
18:58:28 <dfarrell07> #info cdub points out that details should be fleshed out as Persistence project develops, not relevant to valid/not-valid Incubation project
18:59:23 <cdub> colindixon: +1
18:59:29 <dfarrell07> #startvote Shall the TSC approve the Persistence Project to Incubation? -1, 0, +1
18:59:29 <odl_meetbot> Begin voting on: Shall the TSC approve the Persistence Project to Incubation? Valid vote options are -1, 0, +1.
18:59:29 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:59:36 <dlenrow> #vote +1
18:59:39 <regXboi> #vote +1
18:59:43 <colindixon> #vote +1
18:59:45 <ChrisPriceAB> #vote +1
18:59:47 <LuisGomez> #vote +1
18:59:49 <cdub> #vote +1
18:59:52 <RajeevK> #vote +1
18:59:54 <edwarnicke> #vote +1
18:59:58 <mohnish> #vote +1
19:00:02 <dfarrell07> 9/13
19:00:06 <dfarrell07> #endvote
19:00:06 <odl_meetbot> Voted on "Shall the TSC approve the Persistence Project to Incubation?" Results are
19:00:06 <odl_meetbot> +1 (9): dlenrow, regXboi, LuisGomez, ChrisPriceAB, RajeevK, cdub, mohnish, edwarnicke, colindixon
19:00:18 <dfarrell07> #agreed TSC approved Persistence Project to Incubation
19:00:28 <regXboi> past tense?
19:00:35 <regXboi> present tense?
19:00:35 <dfarrell07> #undo
19:00:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x28066d0>
19:00:46 <dfarrell07> #agreed TSC approves Persistence Project to Incubation
19:00:49 <regXboi> :)
19:00:52 <dfarrell07> regXboi: thanks :)
19:01:02 <regXboi> no worries - you just beat me to it :)
19:01:21 <dfarrell07> Congrats Persistence project :D
19:01:22 * regXboi is of the opinion that sqlite3 should be looked at for the "out of the box" code
19:01:30 <dfarrell07> #topic Project Creation Review for SNMP Plugin Project
19:01:39 * regXboi admits that is just his opinion
19:01:50 <dlenrow> Nice job persistence team
19:01:53 <cdub> i liked "who should the ball get?"
19:01:59 <dfarrell07> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-December/000222.html Proposed 12/5/2014
19:02:04 <regXboi> #info security list test passed!!!
19:02:06 <colindixon> cdub: yeah
19:02:08 <colindixon> :-)
19:02:23 * ChrisPriceAB poor Steve, gotten by the ball...
19:02:26 <dfarrell07> #link https://wiki.opendaylight.org/view/Project_Proposals:SNMP_Plugin SNMP Plugin Project Proposal wiki
19:03:02 <dfarrell07> colindixon: I don't know where you find the slide links
19:03:32 <colindixon> dfarrell07: I don’t see the slides
19:03:39 <colindixon> dlenrow: do you know where/if sldes are?
19:05:14 <colindixon> #info the project started as just wanted to read out a single value to identify a device via SNMP, but do so in a more reusable way
19:05:16 <dlenrow> liemmn: Do you know where slides are? Can you upload/#link?
19:05:22 <dfarrell07> #info Basic idea is to add a SB SNMP plugin
19:05:43 <dfarrell07> #info Will use MD-SAL
19:05:46 <colindixon> #Info it turned out that there was an effort in Cisco to support SNMP by converting MIBs to YANG models
19:05:52 <colindixon> #info this project will start with and extend that code base
19:06:33 <colindixon> #info basic arch is to take SNMP MIBs, turn them into YANG models, and then turn that into Java code and use it it in the MD-SAL as usual
19:08:22 <ChrisPriceAB> Yangtools forgotten again ;)
19:08:25 <rovarga> yangtools is a dependency :)
19:08:34 <rovarga> ChrisPriceAB: thanks :)
19:08:39 <regXboi> spin the vote!
19:08:48 * ChrisPriceAB np ;)
19:09:01 <dfarrell07> #info Initial committers list is better than average, tykeal may still need ODL usernames
19:09:32 <tykeal> haha... dfarrell07 I see IRC handles not ODL identities ;)
19:09:50 <dfarrell07> tykeal: yeah, saw that, lol
19:09:53 <tykeal> at least it gives me another handle on people...
19:09:56 <rovarga> architecturally, snmp4sdn should actually end up using this project to access the switches
19:09:57 <dfarrell07> lol
19:09:57 <tykeal> no pun intended ;)
19:09:58 <colindixon> #info cdub asks if there’s an effort to integration the SNMP efforts between this and SNMP4SDN
19:10:01 <uchau> ODL usernames on project proposal page
19:10:17 <dfarrell07> uchau: I don't see them: https://wiki.opendaylight.org/view/Project_Proposals:SNMP_Plugin#Initial_Committers
19:10:23 <colindixon> #info the answer is none so far, except that the two uses are separate for now
19:10:53 <dfarrell07> uchau: unless IRC handles are == ODL usernames for these folks
19:11:18 <tykeal> that's not always true, in fact it seems to be fairly rarely true in my experience
19:11:41 <colindixon> #info in the long run it would be good if the SNMP4SDN project could be migrated (in a friendly way) to using the SNMP plugin rather than just the snmp4j library
19:11:41 <nateharmon> i believe they are mislabeled as IRC.
19:11:44 <rovarga> in the snmp context, this project would be the equivalent of openflowjava, whereas snmp4sdn is the equivalent of openflowplugin
19:11:53 * tykeal hopes so
19:12:00 <cdub> rovarga: thanks, better
19:12:06 <colindixon> rovarga: I guess that’ snot how I’d see
19:12:07 <colindixon> it
19:12:22 <dfarrell07> nateharmon: Cool, thanks for info. :)
19:12:28 <colindixon> rovarga: I’d see SNMP as ~= (OpenFlow Java + OpenFlowPlugin)
19:12:28 <cdub> heh, actually, i thin kthat's how they originally proposed it
19:12:56 <colindixon> OpenFlowJava has no state machines or operations, just modles
19:12:57 <cdub> and feedback was, md-sal + yang mibs, makes it look more like openflowplugin (to me, maybe i'm offbase)
19:12:57 <colindixon> whereas it sounds like this will
19:13:04 <rovarga> colindixon: well. snmp4sdn achieves OF-equivalence using SNMP as the control protocol
19:13:23 <colindixon> #info LuisGomez asks if there will be any interactions with NSFs
19:13:29 <rovarga> at least that's my understanding
19:13:51 <colindixon> #info the answer seems to be not directly, but only by creating data in the MD-SAL, not interacting with the NSFs directly
19:13:58 <abhijitkumbhare> I agree with colindixon - this looks ~= (OpenFlow Java + OpenFlowPlugin)
19:15:11 <cdub> heh, standard mibs
19:15:18 <colindixon> #info LuisGomez asks where the MIBs will come from
19:15:21 <cdub> nearly an oxymoron for real life
19:15:50 <colindixon> #info answer is this will depend on who’s using it, projects will bring in their own MIBs
19:16:16 <jmedved> abhijitkumbhare: it is slightly different.  (OpenFlow Java + OpenFlowPlugin) do not expose nodes directly to end users in their own md-sal context. they provide an rpc api. this is really more similar to the netconf connector
19:16:42 <abhijitkumbhare> Ack jmedved
19:16:56 <cdub> is there automagic mib -> yang model generation?
19:17:23 <colindixon> #info the answer is that you can bring along your MIBs after the fact in your own project, largely by bringing along YANG files generated from the MIBs
19:17:24 * ChrisPriceAB loves automagic
19:17:29 <rovarga> #info from MD-SAL perspective, we want to follow pretty much the same way we work with yang
19:17:38 <colindixon> cdub: I think there’s something called LiveSMI or something
19:17:55 <rovarga> #info which means that some use-cases need compile-time, but the runtime component is completely dynamic
19:17:59 <cdub> colindixon: thanks
19:18:08 <dfarrell07> #startvote Shall the TSC approve the SNMP Plugin Project to Incubation? -1, 0, +1
19:18:08 <odl_meetbot> Begin voting on: Shall the TSC approve the SNMP Plugin Project to Incubation? Valid vote options are -1, 0, +1.
19:18:08 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:18:13 <colindixon> #vote +1
19:18:16 <ChrisPriceAB> #vote +1
19:18:16 <LuisGomez> #vote +1
19:18:19 <kwatsen> #vote +1
19:18:21 <cdub> #vote +1
19:18:22 <RajeevK> #vote +1
19:18:23 <regXboi> #vote +1
19:18:24 <edwarnicke> #vote +1
19:18:32 <regXboi> that's 8/13
19:18:35 <dlenrow> #vote +1
19:18:40 <regXboi> 9/13 now :)
19:18:40 <colindixon> cdub: LibSMI, not LiveSMI
19:18:42 <mohnish> #vote +1
19:18:43 <dfarrell07> #endvote
19:18:43 <odl_meetbot> Voted on "Shall the TSC approve the SNMP Plugin Project to Incubation?" Results are
19:18:43 <odl_meetbot> +1 (10): dlenrow, regXboi, LuisGomez, ChrisPriceAB, edwarnicke, RajeevK, cdub, mohnish, kwatsen, colindixon
19:18:51 <dfarrell07> #agreed TSC approves SNMP Plugin Project to Incubation
19:18:56 <cdub> pretty interesting
19:19:02 <rovarga> cdub: it's specified by RFC6643
19:19:08 <dlenrow> rexXboi: You're almost as good at vote counting as meetbot :)
19:19:21 <dfarrell07> #topic Project Creation Review for Topology Processing Framework Project
19:19:22 <regXboi> who is rexXboi?
19:19:30 <dfarrell07> #link https://wiki.opendaylight.org/view/Project_Proposals:Topology_Processing_Framework Topology Processing Framework Project Proposal wiki
19:19:34 <dfarrell07> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-December/000219.html Proposed 12/4/2014
19:19:35 <regXboi> :)
19:19:38 <dlenrow> rexboi: Your xrated cousin?
19:19:49 <cdub> rovarga: cool, thank you
19:19:58 <regXboi> no - but I have a cousin jack who might answer that dlenrow :)
19:20:00 <oflibMichal1> some audio problem
19:20:08 <oflibMichal1> i can hear you
19:20:21 <oflibMichal1> reconnecting
19:20:26 <dfarrell07> #info having trouble with audio of Topo folks
19:20:49 <dfarrell07> #topic Project Creation Review for Maple Project
19:21:16 <regXboi> wow - was the depth of that shared screen pi/2?
19:21:24 <dfarrell07> #link https://wiki.opendaylight.org/view/Project_Proposals:Maple Maple Project Proposal wiki
19:21:40 <dfarrell07> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-December/000218.html Proposed 12/4/2014
19:21:56 <colindixon> #link https://wiki.opendaylight.org/view/File:MapleInODL.pptx slides in pptx format
19:22:02 <dfarrell07> #link https://wiki.opendaylight.org/view/File:MapleInODL.pdf slides in PDF
19:22:06 <colindixon> dfarrell07: thanks!
19:23:03 <colindixon> #Info Maple as a platform for doing flow programming SDN, e.g., OpenFlow, with it’s own stand-alone controller for now
19:23:22 <colindixon> #info this is a proposal to port that to OpenDaylight
19:24:30 <colindixon> #info Maple allows people to define a single, high-level packet processing function that will be logically applied to every packet that enters the network
19:24:34 <regXboi> um
19:24:47 <mohnish> http://www.ece.cmu.edu/~ece739/papers/maple.pdf
19:24:52 <regXboi> colindixon: the obvious question is greenfield
19:24:56 <regXboi> and brownfield
19:25:30 <colindixon> #info this is not actually done in this way, but instead compiled into rules that are installed in the network combined with packet_in handlers
19:25:34 <colindixon> regXboi: ack
19:25:37 <cdub> or when we have a mathematcia project
19:25:43 * regXboi not sure how useful this is if there are projects that don't use it
19:26:03 * regXboi admits it interesting, but ...
19:26:29 <dfarrell07> mohnish: It'd be cool if you'd `#link <link> description` that :) (or I can do it, of course)
19:26:47 <regXboi> #link http://www.ece.cmu.edu/~ece739/papers/maple.pdf
19:26:48 <colindixon> regXboi: so, even if it doesn’t work if other projects don’t use it, the project’s utility for people that do want to use it seems worth bringing in
19:26:50 <colindixon> regXboi: thanks
19:26:53 <colindixon> #undo
19:26:53 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x2593f10>
19:27:07 <colindixon> #link http://www.ece.cmu.edu/~ece739/papers/maple.pdf the academic paper explaining the base of the project
19:27:15 * colindixon likes context for links :-)
19:27:30 <dneary> Anyone else getting an error 31001 when trying to join the meeting with Android's WebEx client?
19:27:36 <mohnish> regXboi: thanks
19:27:41 <regXboi> colindixon: if the point is to have the context of flow table rules, then having a way to import rules back into some guessed context might be .... useful
19:27:44 <cdub> dneary: that's how i'm on
19:27:48 <cdub> (no error)
19:28:01 <dfarrell07> dneary: I hit that error last week, haven't tried this week
19:28:08 <dneary> cdub, Meeting # 194 548 370?
19:28:15 <colindixon> regXboi: +1 great suggestion to make and question to answer
19:28:15 <tykeal> dneary: I'm in on my tablet
19:28:19 <dneary> Could be "meeting full", I guess
19:28:25 <cdub> dneary: yes
19:28:54 <tykeal> I did have a problem a couple weeks back and it wouldn't go away until I rebooted my tablet
19:29:29 <colindixon> #info the packet processing function is analyzed whenever it’s run on a packet_in which gives a trace tree of know control flows through the function, the trace tree can then be turned to flows in flow tables in a very nice way
19:29:29 * dfarrell07 grumbles at WebEx (not that there are great alternatives, they all suck)
19:29:40 <tykeal> dfarrell07: so very true
19:29:45 <dlenrow> Is this purely a reactive programming model? No flow rules until flow miss and packet in?
19:29:59 <colindixon> dneary: we try to make it so we only use webex for audio and post slides/links in IRC
19:30:08 <regXboi> dlenrow: that's a reasonable question
19:30:14 <dneary> colindixon, OK, thanks
19:30:31 <edwarnicke> dlenrow: Good question to bubble up to Andi :)
19:30:35 <dneary> Looking for slides...
19:30:45 <dfarrell07> dneary: they are #link'd in above
19:31:00 <colindixon> dlenrow: I think no because you can do some static analysis of the function, but I don’t know
19:31:01 <cdub> dneary: https://wiki.opendaylight.org/images/d/d8/MapleInODL.pdf (if you don't have scroll back)
19:31:07 <colindixon> dneary: https://wiki.opendaylight.org/view/File:MapleInODL.pdf
19:31:14 <colindixon> IRC ftw
19:31:18 <tykeal> currently on slide 9
19:31:51 <colindixon> #info you can take multiple packet processing functions and compose them into a larger function, but you still need some top-level function
19:33:56 <colindixon> #info scope is to provide the Java-based programming abstraction ODL that provides the compiler, runtime, etc. to do this for OpenFlow with packet functions and maybe look at doing SFC and GBP like things on top of it as a proof-of-concept
19:34:08 <colindixon> #info jmedved asks what they do with runtime tracing
19:35:04 <colindixon> #info AndreasVoellmy says they basically capture accesses to the data that’s given to the packet processing function to know what information was used by the function to build the trace tree
19:35:11 <colindixon> #Info jmedved asks how to debug programs like this
19:35:51 <dfarrell07> Phrase of the meeting "Motherhood and Apple Pie"
19:36:16 <colindixon> #info AndreasVoellmy responds that you could debug this in the non-flow-table space, but you’d need to trust the compiler that takes the packet processing functions to flows in flow tables
19:36:50 <colindixon> #info regXboi asks how do you deal with the fact that, in ODL, many projects write flows directly and how does that perturb the approach
19:36:53 <rovarga> regXboi: would that mean that the network is controller in multiple ways at the same time?
19:37:13 <regXboi> rovarga: today there are multiple things writing flow tables
19:37:16 <colindixon> #info AndreasVoellmy says that you can reverse-engineer the function from the flow table, but you lose the context and other advantages
19:37:24 <regXboi> and I'm thinking of how this will work in that case
19:37:41 <colindixon> #Info AndreasVoellmy says that the current model is that they are the only people writing flows, but he thinks it can be extended to handle this case
19:37:52 <colindixon> oflibMichal1: do you know if you have audio fixed?
19:37:56 <cdub> regXboi: sounds like trouble
19:38:13 <rovarga> regXboi: so if there are multiple writers, who is making sure the combination actually does what the two writers actually want to do?
19:38:16 <oflibMichal1> colindixon: i tried and it worked
19:38:24 <regXboi> cdub: I'm a little bothered by the statement "we assume we own the flow table"
19:38:25 <colindixon> oflibMichal1: good to know
19:38:36 <cdub> rovarga: exactly, composition is hard
19:38:38 <regXboi> rovarga: today, nobody - that's one of the nasty little issues
19:39:03 <dfarrell07> oflibMichal1: Phone audio connection is reliable, FYI
19:39:04 <ChrisPriceAB> It would be really interesting to spin a "maple function" up in the instance of creating a tenant network...
19:39:08 <cdub> regXboi: i've seen it work where different owners own different tables
19:39:09 <colindixon> regXboi, cdub: they’re not saying that the want ODL to set it up that way all the time, just that they’re going to start that way because that’s the first thing they can do
19:39:21 <regXboi> colindixon: I get that
19:39:28 <oflibMichal1> dfarrell07: connected through skype :-)
19:39:36 <colindixon> #info appraoches to deal with maple running with other apps are the usual: e.g., address-space splitting, priority things
19:39:37 <regXboi> and I'm certainly not going to vote this down based on this
19:39:40 <dbainbri> #question: attempting to understand the maple use case. I get how if i wanted to create a learning switch or something where I know what i want to do ahead of time, but what about dynamic service creation such as with GBP a high level abstraction, would you have generate "Java" code that is processed by the maple processor?
19:39:55 <rovarga> regXboi: honestly, I would say that I would not deploy multiple writers in my network :)
19:39:57 <colindixon> #info dbainbri asks ttempting to understand the maple use case. I get how if i wanted to create a learning switch or something where I know what i want to do ahead of time, but what about dynamic service creation such as with GBP a high level abstraction, would you have generate "Java" code that is processed by the maple processor?
19:40:02 <regXboi> but I'm pointing out what people are saying on the call
19:40:22 <ChrisPriceAB> RegXboi: define network...
19:40:42 <dfarrell07> #startvote Shall the TSC approve the Maple Project to Incubation? -1, 0, +1
19:40:42 <odl_meetbot> Begin voting on: Shall the TSC approve the Maple Project to Incubation? Valid vote options are -1, 0, +1.
19:40:42 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
19:40:46 <regXboi> I didn't say network
19:40:47 <alagalah> I wish I had a vote cos I think this is awesome
19:40:48 <regXboi> others did
19:40:49 <jmedved> #vote +1
19:40:52 <colindixon> #vote +1
19:40:56 <ChrisPriceAB> #Vote +1
19:40:58 <mohnish> #vote +1
19:40:59 <regXboi> #vote +1
19:41:01 <dlenrow> #vote +1
19:41:04 <cdub> #vote +1
19:41:12 <regXboi> that's enough
19:41:18 <dfarrell07> 7/13
19:41:26 <colindixon> #info AND THIS IS IMPORTANT : approval is contingent on resolving patent issues
19:41:27 <dfarrell07> need 8 I think
19:41:31 <colindixon> need 7
19:41:35 <dfarrell07> ah
19:41:39 <regXboi> colindixon: +MAX INT
19:41:39 <colindixon> 13 members
19:41:48 <colindixon> 11+2
19:41:53 * ChrisPriceAB @regXBoi: oops you are right, question for rovarga 😁
19:41:55 <jmedved> what are the patent issues?
19:42:01 <regXboi> ChrisPriceAB: :)
19:42:13 <jmedved> (asking on im, don’t want to hold up the meeting)
19:42:15 <colindixon> jmedved: I said this at the beginning, but Yale owns some patents for the work
19:42:16 <dfarrell07> I thought we said "8 is ideal" a few weeks ago, may have miss-remembered
19:42:17 <dlenrow> please let's not discuss legal issues here/now!
19:42:23 <dlenrow> thx jan
19:42:25 <colindixon> dfarrell07: wed did, but I was wrong
19:42:32 * dfarrell07 is going to #endvote soon, last call...
19:42:33 <LuisGomez> #vote +1
19:42:37 <colindixon> thanks LuisGomez
19:42:38 <colindixon> we’re good
19:42:41 <regXboi> #info the patent issues are that Yale owns some patents for this work and those need to be cleared
19:42:50 <dfarrell07> 8/13
19:42:51 <dfarrell07> #endvote
19:42:51 <odl_meetbot> Voted on "Shall the TSC approve the Maple Project to Incubation?" Results are
19:42:51 <odl_meetbot> +1 (8): dlenrow, jmedved, regXboi, LuisGomez, ChrisPriceAB, cdub, mohnish, colindixon
19:42:59 <dfarrell07> #agreed TSC approves Maple Project to Incubation
19:43:02 <regXboi> #undo
19:43:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x2534450>
19:43:03 <colindixon> #undo
19:43:03 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Vote object at 0x272ef90>
19:43:09 <regXboi> oops!
19:43:10 <colindixon> ugh, did we undo the vote?
19:43:14 <regXboi> I think we did
19:43:16 <ChrisPriceAB> Woohoo ODL got some sugar!
19:43:28 <regXboi> somebody needs to check the live logs
19:43:39 <regXboi> what's the link for the live meeting log?
19:43:43 <alagalah> ProTip: If you are going to make disparaging noises on the call, have at least a brain and go on mute... although I'd say one precludes the other
19:44:04 <dfarrell07> I'm trying to check
19:44:07 <dfarrell07> idk see it
19:44:35 <dfarrell07> #agreed see full logs for vote, note patent issue
19:44:43 <edwarnicke> #vote +1 (belated on Maple vote)
19:44:49 <dfarrell07> #agreed TSC approves Maple Project to Incubation
19:44:56 <dlenrow> revote wouldn't be that hard
19:45:03 <cdub> we are lost in our stack
19:45:04 <edwarnicke> dlenrow: True dat
19:45:11 <regXboi> #agree TSC approves Maple Project to Incubation with the proviso that the Yale patents on Maple can be cleared - see full logs for vote (8/13)
19:45:14 <edwarnicke> cdub: Are we into our heap yet?
19:45:22 <cdub> heh
19:45:22 <dfarrell07> #topic Project Creation Review for Topology Processing Framework Project
19:45:35 <dfarrell07> #info This is try #2 for this creation review. Audio issues last time. Not sure if need to re-link slides/wiki, but will do anyway.
19:45:39 <dfarrell07> #link https://wiki.opendaylight.org/view/Project_Proposals:Topology_Processing_Framework Topology Processing Framework Project Proposal wiki
19:45:44 <dfarrell07> #link https://lists.opendaylight.org/pipermail/project-proposals/2014-December/000219.html Proposed 12/4/2014
19:45:44 <abhijitkumbhare> colindixon: We came up with a differentiation today between Michal Rehak & Michal Polkorab in OF Plugin meeting. oflibMichal1 (Polkorab) is to be pronounced  Michael while michal_rehak is Meekaal :)
19:45:45 <regXboi> that was fun!
19:45:47 <colindixon> #info there are no slides
19:45:48 <colindixon> thanks
19:45:58 <tykeal> haha
19:46:02 <cdub> colindixon: lol
19:46:10 * regXboi notes: it's the multi-master problem in just another form :)
19:46:10 <edwarnicke> colindixon: Does this mean that we need a priority field for meetingbot ? :)
19:46:31 <colindixon> #info the basic idea here is that our YANG topology model supports multiple different topologies some of which can be stacked on top of each other
19:46:53 <colindixon> #info this project will provide tools to get views of combined and/or filtered and/or flattened topologies from this model
19:47:13 <colindixon> my big question is why is this a project and not an NSF?
19:47:56 <colindixon> #action oflibMichal1 to provide ODL usernames for commtters
19:48:37 <abhijitkumbhare> Why cannot a new NSF be a project colindixon ?
19:49:14 <colindixon> abhijitkumbhare: do we really want to have one project per NSF?
19:49:50 <mohnish> should the topology and switch related information reside in base controller so that all apps are leveraging same info to be consistent?
19:49:52 <rovarga> colindixon: this will be pretty generic, not tied to a particular technology, so I guess finding a nice&fuzzy home is problematic
19:50:41 <abhijitkumbhare> rovarga expressed it well
19:50:59 <colindixon> rovarga: why not the controller?
19:51:05 <colindixon> that’s really the question
19:51:15 <ChrisPriceAB> Colindixon: if not any new Dev work depends on the controller committers to have time to support it
19:51:40 <rovarga> colindixon: the controller project wants to actually splin out functionality, not bring more stuff in
19:52:00 <phudgins> refresh the page, I added my IRC handle
19:52:10 <rovarga> colindixon: this is nothing like the topology manager ...
19:52:22 <jmedved> colindixon: isn’t the exiisting topology manager openflow-specific?
19:52:33 <tykeal> phudgins: unless your IRC handle == your ODL username that's not particularly useful (at least to me) ;)
19:52:47 <jmedved> colindixon: yes, it seems to be an entirely different animal
19:53:23 <colindixon> phudgins: we really need ODL usernames, not IRC handles, but IRC handles are also good
19:53:27 * edwarnicke waves arms and runs in circles like a mad toddler at the notion of adding things to controller
19:54:35 <dfarrell07> #info Discussion about where this work should live. Project or in controller?
19:55:22 <phudgins> got it - added both ODL Username (which are the same for myself)
19:55:23 <colindixon> #info colindixon asks if this should be it’s own project or a part of the controller
19:55:23 <dfarrell07> #info There is a push to get things out of controller, say mlemay and edwarnicke
19:56:30 <ChrisPriceAB> System control, platform capabilities...
19:58:28 <colindixon> +1 that it doesn’t make sense in YangTools
19:59:12 * regXboi suggests s/md-sal/plumbing/
19:59:15 <dfarrell07> #info Committers/Project Leads speak up to say it shouldn't be in controller/YANG Tools, in their opinion
19:59:47 * regXboi begs for the vote
19:59:50 <rovarga> regXboi: +1, but then we get into funky naming shenanigans :)
19:59:55 <colindixon> dfarrell07: start the vote
19:59:57 <dfarrell07> #startvote Shall the TSC approve the Topology Processing Framework Project to Incubation? -1, 0, +1
19:59:57 <odl_meetbot> Begin voting on: Shall the TSC approve the Topology Processing Framework Project to Incubation? Valid vote options are -1, 0, +1.
19:59:57 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
20:00:02 <regXboi> rovarga: that was a j/k
20:00:02 <colindixon> we can always have people delay
20:00:11 <regXboi> #vote +1
20:00:32 <dfarrell07> 1/13 (lol)
20:00:37 <colindixon> #vote +)
20:00:37 <odl_meetbot> colindixon: +) is not a valid option. Valid options are -1, 0, +1.
20:00:45 <colindixon> #vote 0
20:00:45 <regXboi> nice colindixon
20:00:46 <dlenrow> #vote +1
20:00:49 <mohnish> #vote +1
20:01:00 * regXboi says happy holidays to all and runs to his next call
20:01:05 <colindixon> regXboi: thanks!
20:01:20 <tykeal> wow, so rarely do I see an abstain
20:01:50 <edwarnicke> #vote +1
20:02:41 <colindixon> LuisGomez, ChrisPriceAB, other?
20:02:44 * dfarrell07 considers linking in a ~"Go Vote!" advert
20:03:26 <colindixon> we need more TSC members to vote
20:03:28 * edwarnicke suggestions we pause for a message from our scribe
20:03:50 <dfarrell07> Need to vote: cdub LuisGomez ChrisPriceAB jmedved
20:03:57 <jmedved> #vote +1
20:03:58 <edwarnicke> dfarrell07: You rick
20:04:00 <edwarnicke> rock
20:04:03 <dfarrell07> lol
20:04:05 <LuisGomez> #vote +1
20:04:17 <dfarrell07> 6/13
20:04:20 <dfarrell07> by my count
20:04:37 <dfarrell07> cdub ChrisPriceAB
20:04:42 <dfarrell07> ah, my bad
20:04:46 <kwatsen> #vote +1
20:04:56 <dfarrell07> #endvote
20:04:56 <odl_meetbot> Voted on "Shall the TSC approve the Topology Processing Framework Project to Incubation?" Results are
20:04:56 <odl_meetbot> 0 (1): colindixon
20:04:56 <odl_meetbot> +1 (7): dlenrow, jmedved, regXboi, LuisGomez, edwarnicke, mohnish, kwatsen
20:05:07 <dfarrell07> #agreed TSC approves Topology Processing Framework Project to Incubation
20:05:34 <edwarnicke> Is beyond impressed colindixon pulled this off in only 5 minutes over
20:05:39 <colindixon> #endvote
20:05:40 <dfarrell07> Have a great break, everyone :)
20:05:41 <tykeal> http://www.inkatrinaskitchen.com/wp-content/uploads/2011/04/Cookie-Monster-Cookies.jpg
20:05:44 <tykeal> :D
20:05:51 <colindixon> #endmeeting