17:01:23 <phrobb> #startmeeting TWS
17:01:23 <odl_meetbot> Meeting started Mon Jul 28 17:01:23 2014 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:23 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:23 <odl_meetbot> The meeting name has been set to 'tws'
17:03:28 <phrobb> #chair colindixon
17:03:28 <odl_meetbot> Current chairs: colindixon phrobb
17:03:32 <colindixon> #topic agenda
17:03:58 <colindixon> #link https://wiki.opendaylight.org/view/Tech_Work_Stream:Main the agenda can be found here
17:06:08 <colindixon> #info we’re moving to a new model where we’re trying to post topics on that link and pick one by end of the meeting, you should look at them or add ones that you’d like (preferably with you name and a time estimate)
17:06:20 <colindixon> #topic testing for projects in helium
17:06:54 * regXboi fighting with browser
17:07:26 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Project_Expectations#Testing this is the curent landing page for testing expecations for each project in Helium
17:08:27 <regXboi> colindixon: we need to open up the infra discussion
17:08:38 <colindixon> regXboi: ok
17:08:39 <regXboi> because to do true testing projects need to be able to deploy VMs
17:08:46 <phrobb> #chair regXboi
17:08:46 <odl_meetbot> Current chairs: colindixon phrobb regXboi
17:08:47 <colindixon> if we have time today, please do
17:08:52 <regXboi> and that's going to rebound on LF
17:09:02 <regXboi> so give me a moment to say that :)
17:09:30 <tykeal> yes, I'm aware it's going to rebound on us
17:09:30 <colindixon> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Testopia some documentation on Testopia which enables interaction with bugzilla
17:10:21 <regXboi> tykeal: sorry about that - I've been trying to think of a way to avoid that rebound, but so far with no luck
17:10:33 <tykeal> *nod*
17:10:34 <colindixon> #link https://bugs.opendaylight.org/ to access testopia go here, log in and then go to the “product dashboard” on the left
17:11:38 <colindixon> #info you can then expand “Unclassified” and click on “integration” and then “test plans” to see the example which LuisGomez has set up
17:13:01 <colindixon> #info each project *should* create tests for every feature they’re providing
17:15:58 <colindixon> #info you can create a new test plan (with lots of different types, e.g., system, performance, integration) by going to File => New Test Plan
17:16:11 <colindixon> #inf each test plan can have multiple test cases
17:16:42 <colindixon> #info each test plan have have multiple test cases, to see them you can click on the number (ID) of the test plan and then click on the test cases tab in the detail page for the plan
17:19:43 <colindixon> #info Testopia is actually just a way to document the test plans and cases rather than to automate testing
17:22:02 <colindixon> #info colindixon asks if there is a plan to automate the system testing
17:22:53 <colindixon> #info LuisGomez responds that the usual way to (1) document the test process, (2) manually go through the test, (3) then automate the test
17:23:06 <colindixon> #info Madhu asks about the Test Runs and Builds tabs
17:23:52 <colindixon> #info LuisGomez explains that Test Runs is for reporing a single execution (manual or automated) from a Test Plan
17:27:35 <colindixon> #info Madhu says he *really* likes the real-time feedback from the jenkins pattern we have now, and wonders how useful some documentation-only tool like Testopia is
17:36:44 <colindixon> #info there is a long discussion about how to automate this testing so that we can have things stay more in-sync
17:37:41 <colindixon> #info regXboi also asks how to spin up and down VMs to do more extensive testing and can we deal with that
17:38:48 <colindixon> #info tykeal says that with the exception of three projects (integration, ovsdb, and controller) we have all projects fully moved into rackspace
17:39:13 <colindixon> #info that means that projects other than those can actually be given the ability to spin up and down VMs as part of tests
17:39:24 <edwarnicke> #link http://www.rackspace.com/blog/installing-rackspace-private-cloud-in-20-minutes-or-less/ - rackspace seems to detail installing an Ubuntu image...
17:40:30 <tbachman> Is this what we want to do on the TWS real-time?
17:40:37 <tbachman> Or is this worth something offline?
17:41:19 <colindixon> #info tykeal says that if people reach out to the linux foundation and let them know what you need from VMs
17:41:35 <edwarnicke> #link: This may also help: https://developer.rackspace.com/blog/vagrant-now-supports-rackspace-open-cloud/
17:43:41 <regXboi> I didn't hear that
17:43:48 <regXboi> what did Madhu say?
17:44:41 <colindixon> #info migrating VMs into rackspace is error prone and booting custom VMs seems to take a long time in the linux foundations experience
17:45:11 <Madhu> regXboi: i am trying to differentiate test documentation vs test automation issues in LF vs Rackspace
17:45:29 <colindixon> #action some of Madhu, LuisGomez, edwarnicke, tykeal and regXboi should get together offline to see what can’t be done about spinning up VMs easily for tests on rackspace
17:45:32 <regXboi> Madhu: thank you
17:45:34 <Madhu> regXboi: whatever the project has today, we need to document it. we are just trying to find out which level of test documentation will help.
17:46:17 <Madhu> regXboi: i believe documenting it in the code and automate it via maven that generates the reports is iMHO better than Testopia documentation only
17:46:40 <colindixon> #info colindixon asks LuisGomez what *exactly* the integration project is asking the other projects to do?
17:46:54 <CASP3R> Also it would be good to understand what test does the project do come release time frame to say yes or no
17:47:28 <phrobb> #info Luis and Integration team need two things:  1 - need documentation from projects for what they are doing for own unit and integration tests.  Second, for those projects that want something in System test, they need to work with the Integration project to document the test plan for the project within a system test.
17:52:10 <colindixon> #topic the integration project’s requests from other projects
17:52:19 <colindixon> #info there are two requests
17:52:58 <Madhu> #info something like this : http://maven.apache.org/surefire/maven-surefire-report-plugin/usage.html
17:53:31 <colindixon> #info the first is that projects need to document the existing tests they run in a place that integration can easily find without having to go through each project individually
17:54:10 <colindixon> #info the second is that projects that want tests to be run when their features are loaded into a full distribution need to reach out to integration to talk about the tests
17:57:39 <CASP3R> edwarnicke is it worth just have a simple page that we can just link to the images that show the graphs of some main projects?
17:57:45 <colindixon> #action LuisGomez and Madhu to come up with good way for projects to provide useful docuementation of their testing to the integration project
17:57:52 <colindixon> #topic
17:57:59 <colindixon> #topic other issues in testing
17:58:41 <colindixon> #action edwarnicke to send out an email around his wants/needs when it comes to combined reporting of test health from all projects
18:02:29 <colindixon> phrobb: I have to run, can you take over?
18:02:41 <phrobb> Yea
18:06:03 <phrobb> #endmeeting