17:03:16 <alagalah> #startmeeting TWS call
17:03:16 <odl_meetbot> Meeting started Mon Oct 13 17:03:16 2014 UTC.  The chair is alagalah. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:03:16 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:16 <odl_meetbot> The meeting name has been set to 'tws_call'
17:05:02 <alagalah> #topic MD-SAL "Consumability" work
17:05:38 <alagalah> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:MD-SAL_Document_Review
17:11:11 <alagalah> #info Ramkumar need to document when and where the Config Subsystem configuration is warranted, and where it might be used under the covers. Is the config subsystem going to be the one and only way of configuring modules... is there a process to make a decision?
17:11:58 <alagalah> #action alagalah : dbrainbri brings up how do we get a stated direction on the config subsystem and ensure its part of this documentation process. action- alagalah
17:13:12 <alagalah> #info ram notes that the ping example from devin avery is in limbo but is a very realistic example and should be included.
17:13:13 <flaviof> #link https://git.opendaylight.org/gerrit/#/c/7249/
17:13:30 <alagalah> #action rgowrishankar take action from ping example linked by flaviof above
17:14:06 <alagalah> #topic Clustering update from Moiz
17:16:47 <alagalah> #info moiz points out that this conversation is not about the AD-SAL/Infinispan clustering but MD-SAL/Akka based clustering
17:17:06 <alagalah> #link https://wiki.opendaylight.org/view/File:Lithium_Enhancements_141013.pptx Preso
17:18:38 <alagalah> #info Notes that persistence in Li will be configurable
17:19:06 <alagalah> #info notes also persistence will be Helium 1.0
17:19:18 <alagalah> #info Notes that no operational data should be persisted
17:22:47 <alagalah> #info dbainbri mentions that one consideration might be the age of the operational data
17:25:19 <alagalah> #info moiz notes that turning off the level of persistence will improve performance (based on the example dbainbri brought up of a controller in a cable env with hundeds of Ks of user CPE trying to register)
17:25:52 <alagalah> #info dbrainbri notes it would be useful to get the timestamp of the data from the operational/config store to decide if the data is useful (fresh) or not (stale)
17:26:45 <alagalah> #info moiz points out we want to do a test of every integration build with clustering turned on (currently seeking resources from linux foundation to support this)
17:27:10 <alagalah> #info moiz also points out that nightly automated build testing is a target for clustering
17:28:00 <alagalah> #info moiz notes that there is a utility for clustering deployment in the integration repo: Search: Cluster-deployer in the integration repo
17:28:59 <alagalah> #info Bugs: All bugs targeted for Helium1 fix are tagged appropriately in bugzilla with the target fix release
17:30:04 <alagalah> #info Lithium Enhancements: programmatic creating shards: new application had its own module anddata running in a cluster, if you want to create a shard dynamically for a module (currently static in He) for the case when we are dynamically creating modules... this wil be via API
17:30:40 <alagalah> #info Lithium Enhancements: Finer grained sharding. Everything is sharded on project. May want to break things down into smaller chunks.
17:31:42 <flaviof> #link https://github.com/opendaylight/integration/tree/master/test/tools/cluster-deployer
17:31:56 <alagalah> #info Lithium Enhancements: (cont) only way to find leader of a shard is via JMX. This may be an enhancement request for an API/notifier
17:32:39 <alagalah> flaviof: thanks bud
17:32:53 <flaviof> alagalah: np!
17:33:23 <alagalah> #action alagalah add FR: Lithium Enhancements: (cont) only way to find leader of a shard is via JMX. This may be an enhancement request for an API/notifier
17:35:00 <alagalah> #info moiz notes that there is a Feature Request to rebalance Leader shards, espec. in the case of a 2 node cluster (Performance enhancement)
17:36:29 <alagalah> #info Lithium Enhancements: Querying... : ie there is a listener for say the Inventory shard, listening on every instance on that cluster. Shard only notifies the local listener, not all nodes in the cluster. This way all instances of an application doesn't get all notifications and act on it. Li enhancement is to make this configurable to be [local|all]
17:36:50 <alagalah> #info Lithium Enhancements: Querying: This enhancement not just data notifications but also YANG notificatoins
17:37:20 <alagalah> #info alagalah is a doofus and Querying (above) should be Enhanced Notification delivery
17:40:11 <alagalah> #info Lithium Enhancements: 2node cluster: moiz points out that current implementation requires that a write be to a MAJORITY before its quiesced. In a 2 node cluster a majority is 2 nodes. This is being addressed
17:40:37 <flaviof> fyi transaction 'commit' in md-sal is called 'submit'.
17:40:40 <alagalah> #info Lithium Enhancements: Querying (for real) ... enhancements to the DOM data store are required for this.
17:40:50 <alagalah> flaviof: Thanks, quite right
17:41:55 <alagalah> #link https://meetings.webex.com/collabs/#/meetings/detail?uuid=MALTOMIMY5WPSZORCBFJSNI22V-9VIB&rnd=533135.16576   Clustering meeting
17:42:05 <alagalah> #link https://bugs.opendaylight.org/buglist.cgi?list_id=18545&query_format=advanced&resolution=---&short_desc=Clustering&short_desc_type=casesubstring   Bugzilla
17:42:20 <alagalah> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Architecture:Clustering  8am Tue Pac meeting
17:44:07 <alagalah> #info flaviof asks what is happening with AD-SAL clustering
17:44:42 <alagalah> #info moiz points out there used to be a clustering service in AD-SAL but it requires applications need to be clustering aware
17:47:37 <alagalah> #info moiz points out that he is not aware of anyone working on AD-SAL clustering. dbainbri mentions perhaps the TSC may want to wade in on this
17:53:19 <alagalah> #topic Future topics
17:57:20 <alagalah> #endmeeting