15:29:58 <anipbu> #startmeeting beryllium weekly sync
15:29:59 <odl_meetbot> Meeting started Wed Dec  9 15:29:58 2015 UTC.  The chair is anipbu. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:29:59 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:29:59 <odl_meetbot> The meeting name has been set to 'beryllium_weekly_sync'
15:30:18 <anipbu> #topic agenda bashing
15:30:26 <abhijitkumbhare> #info abhijitkumbhare for OpenFlow Plugin
15:30:42 <rgoulding_> #info rgoulding for AAA
15:30:42 <abhijitkumbhare> can you undo my info anipbu ?
15:30:50 <anipbu> #undo
15:30:50 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x20355d0>
15:31:02 <anipbu> #undo
15:31:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2035250>
15:31:10 <anipbu> #info rgoulding for AAA
15:31:21 <Prem> #info Prem for VPNService
15:31:48 <anipbu> Folks, please info your projects
15:31:57 <abhijitkumbhare> anipbu: this will come out wrong - agenda and then folks info-ing in
15:32:24 <abhijitkumbhare> so you will need to first do 3 undo more - then have all the folks info
15:32:31 <anipbu> okay
15:32:33 <anipbu> #undo
15:32:33 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1fd2890>
15:32:35 <anipbu> #undo
15:32:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2035850>
15:32:38 <anipbu> #undo
15:32:38 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1fe80d0>
15:32:53 <abhijitkumbhare> good - so we are fresh now i think
15:33:12 <abhijitkumbhare> so do you want roll call?
15:33:22 <anipbu> Let's do roll call first
15:33:38 <abhijitkumbhare> you may want to topic that?
15:33:58 <anipbu> #topic roll call
15:34:08 <abhijitkumbhare> #info abhijitkumbhare for OpenFlow plugin
15:34:18 <Prem> #info Prem for VPNService
15:34:25 <hideyuki> #info Hideyuki for VTN
15:34:28 <rgoulding_> #info rgoulding for AAA
15:34:42 <anipbu> #info anipbu for usc nemo release
15:36:06 <anipbu> Any other folks please info your projects.
15:36:15 <adetalhouet> #info adetalhouet armoury nic unimgr
15:36:47 <anipbu> Let's move on to agenda bashing.
15:36:51 <abhijitkumbhare> so we don’t have too many folks today - so we may want to avoid any big decisions :)
15:37:00 <Prem> true :)
15:37:06 <anipbu> agreed.
15:37:10 <rgoulding_> +1
15:37:14 <hideyuki> +1
15:37:21 <Prem> +1
15:37:35 <anipbu> #topic agenda bashing
15:37:41 <anipbu> #info blocking issues
15:37:48 <abhijitkumbhare> Red flags?
15:37:50 <anipbu> #info open mic
15:37:58 <anipbu> any other agenda items folks?
15:38:08 <anipbu> otherwise I'll change teh topic to blocking issues
15:38:31 <abhijitkumbhare> #info Potential red flags?
15:38:58 <adetalhouet> in fact I shouldn't have logged armoury neither unimgr as they are not part of lithium
15:39:22 <anipbu> this is more for beryllium
15:39:41 <anipbu> #topic blocking issues
15:39:43 <adetalhouet> ok so right now NIC is broken due to an API change in GPB
15:40:04 <adetalhouet> so GPBRenderer in NIC need to be updated as per of those changes
15:40:06 <abhijitkumbhare> red flags = not blocking issues but major issues - like project X getting delayed (which requires a decision to drop content or delay)
15:40:44 <anipbu> abhijitkumbhare: okay
15:41:23 <anipbu> adetalhouet: i notice an email sent out to GPB about API change
15:41:29 <adetalhouet> for NIC again, re-enable VTN Renderer since they removed adsal dependencies
15:41:55 <hideyuki> adetalhouet: Yes. My colleagues are working for VTN Renderer.
15:42:08 <adetalhouet> anipbu: yeah, we might have someone to fix this within the day
15:42:19 <adetalhouet> in the meantime, NIC is broken
15:42:29 <anipbu> #info NIC is broken due to an API change in GPB
15:42:54 <adetalhouet> mail thread talking about the API change in GPB
15:42:55 <adetalhouet> https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2015-December/001533.html
15:43:30 <anipbu> #info NIC: GPBRenderer needs to be updated and VTNRenderer will be reenabled
15:43:45 <adetalhouet> +1
15:44:03 <anipbu> unfortunately we don't have representative from GPB here
15:44:34 <abhijitkumbhare> anipbu you can just call out to alagalah ?
15:46:29 <anipbu> #info alagalah may be a good contact for NIC GBPRenderer
15:47:03 <anipbu> okay, any other blocking issues?
15:47:08 <adetalhouet> yeah I'll get in touch with him
15:48:04 <anipbu> #action adetalhouet alagalah look into NIC GBPRenderer
15:48:28 <anipbu> Any other blocking issues that folks want to raise?  otherwise, let's move onto red flags.
15:48:45 <Prem> Generic qn - We have few Karaf CLI as part of Be; is there any approval process for Karaf CLIs?
15:50:17 <anipbu> I'm not too familiar with Karaf CLI, is this specific to any project?
15:50:57 <Prem> anipbu: this would be for VPNSerivce
15:51:29 <anipbu> we only need approval if there are API changes, in the form of an API waiver.
15:51:46 <anipbu> if it affects cross projects, then a weather item should be created.
15:52:27 <adetalhouet> NIC also have a CLI, as UNIMGR
15:53:33 <Prem> adetalhouet:  ok.  Did you call it out as part of API?
15:53:53 <anipbu> #info prem asked about approval process for introducing Karaf CLI
15:54:07 <Prem> anipbu: VPNService does not have any dependent projects
15:54:12 <adetalhouet> Prem: We haven't
15:54:32 <Prem> adetalhouet:  ok. Thanks!
15:55:27 <adetalhouet> anipbu: let us know if we need to present those CLI as part as the APIs once decided
15:55:46 <anipbu> I believe NIC's CLI is defined as a feature, is that right?
15:55:53 <abhijitkumbhare> I think we don’t have a central convention about the Karaf CLI structure Prem - so will not make sense to add approval till we have any CLI command convention
15:55:54 <adetalhouet> yes
15:56:06 <anipbu> Similar to NEMO's CLI
15:56:11 <adetalhouet> same goes with UniMgr
15:56:20 <adetalhouet> anipbu: maybe, I dunno NEMO's CLI
15:56:31 <adetalhouet> but the CLI is contained within a feature
15:56:37 <Prem> ok.  that clear my doubts :)
15:56:44 <abhijitkumbhare> but a uniform CLI convention may be a good idea though
15:56:55 <Prem> abhijitkumbhare:  Yes
15:56:59 <adetalhouet> abhijitkumbhare: +1
15:57:10 <anipbu> #action anipbu to send email about uniform CLI convention
15:57:44 <anipbu> don't want to make big decisions at this meeting, so I think the CLI convention can be taken offline in an email thread.
15:57:51 <anipbu> is that okay with folks?
15:58:00 <adetalhouet> anipbu: yes, perfect
15:58:01 <Prem> abipbu: +1
15:58:07 <abhijitkumbhare> +1 anipbu
15:58:17 <anipbu> okay, let's move on to red flags
15:58:22 <anipbu> #topic red flags
15:58:24 <abhijitkumbhare> anyway its a big topic
15:58:37 <anipbu> okay, any red flags from projects?
15:59:48 <anipbu> anyone with burning cross-project topics bring them up?
16:00:55 <abhijitkumbhare> one of the key persons in OpenFlow Plugin (michal_rehak) will be gone for a month from Dec 17-Jan 17 - while it will not cause any project issues - if you need any help from him it might be a good idea to reach out to him during this week
16:01:47 <abhijitkumbhare> during next 6-7 days
16:02:26 <anipbu> #info michal_rehak (OpenFlow Plugin Project) will be gone Dec17-Jan17.  Folks should reach out to him this week before he leaves.
16:03:18 <anipbu> any last minute topics to raise?
16:03:37 <anipbu> going once
16:03:43 <anipbu> going twice
16:04:00 <hideyuki> abhijitkumbhare: Thank you for the information.
16:04:08 <abhijitkumbhare> I think we are good :)
16:04:14 <anipbu> Okay, thanks folks for joining.
16:04:20 <Prem> cookies :)
16:04:22 <anipbu> #topic cookies
16:04:26 <adetalhouet> anipbu: thanks :)
16:04:37 <rgoulding_> thx
16:04:37 <anipbu> #endmeeting