#opendaylight-meeting: Lithium release review

Meeting started by gzhao at 14:31:26 UTC (full logs).

Meeting summary

  1. roll call (gzhao, 14:31:50)
    1. Project Leaders and TSC members please #info in (phrobb, 14:32:25)
    2. oflibMichal for openflowjava and topoprocessing (oflibMichal, 14:32:28)
    3. LuisGomez (LuisGomez, 14:32:53)
    4. colindixon (colindixon, 14:33:01)

  2. Openflow Java (gzhao, 14:33:46)
    1. https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Lithium_Release_Review release review (oflibMichal, 14:33:53)
    2. https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Lithium_Release_Notes release notes (oflibMichal, 14:33:57)
    3. shague (shague, 14:35:39)
    4. colindixon asks about any issues with compatibility or migration (gzhao, 14:38:09)
    5. gzhao suggests unit test coverage link with the test and oflibMichal will do the update (gzhao, 14:38:51)
    6. oflibMichal says the model changed and the writing/flushing mechanism changed, so it’s not compatible with Helium (colindixon, 14:38:55)
    7. ACTION: oflibMichal to add the bug from the release review to the release notes (colindixon, 14:40:25)

  3. Topoprocessing (gzhao, 14:42:17)
    1. https://wiki.opendaylight.org/view/Topology_Processing_Framework:Lithium_Release_Review release review (oflibMichal, 14:42:21)
    2. https://wiki.opendaylight.org/view/Topology_Processing_Framework:Lithium_Release_Notes release notes (oflibMichal, 14:42:25)
    3. ACTION: oflibMichal is to fix the broken link for https://www.markoweb.eu/topoprocessing/presentation (gzhao, 14:45:46)
    4. colindixon asks is there a reason that only two of the bugs listed on the release review are also listed in the release notes (gzhao, 14:48:13)
    5. https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/topoprocessing/odl-topoprocessing-framework-dev.adoc developer docs (colindixon, 14:50:10)

  4. SDNi (gzhao, 14:51:58)
    1. https://wiki.opendaylight.org/view/ODL-SDNi:Lithium_Release_Review <-- Release Review (SDNiShahid, 14:52:13)
    2. https://wiki.opendaylight.org/view/ODL-SDNi:Lithium_Release_Notes <-- Release Notes (SDNiShahid, 14:52:25)
    3. SDNiShahid is representing SDNi (gzhao, 14:52:49)
    4. https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/sdninterfaceapp/odl-sdninterfaceapp-all-dev.adoc developer docs (colindixon, 14:55:33)
    5. https://github.com/opendaylight/docs/blob/stable/lithium/manuals/user-guide/src/main/asciidoc/sdninterfaceapp/odl-sdninterfaceapp-all-user.adoc user docs (colindixon, 14:56:02)
    6. ACTION: SDNiShahid will link user guide, dev guide and release note in release review (gzhao, 14:57:17)
    7. SDNiShahid says SDNi has tested with 12.04 and 14.04, it should work with other environments where ODL is supported (gzhao, 14:59:14)
    8. ACTION: SDNiShahid to update the "Compatibility with Previous Releases section" in release notes (gzhao, 15:00:09)
    9. phrobb notes By including those ubuntu versions specifically, the implication is that other environments are not for execution. This may be confusing to our users. (gzhao, 15:01:01)
    10. ACTION: SDNiShahid to remove the ubuntu versions. (gzhao, 15:02:32)
    11. ACTION: colindixon to work on getting requirements more clearly stated in release notes/review (colindixon, 15:03:49)

  5. OVSDB (gzhao, 15:04:12)
    1. https://wiki.opendaylight.org/view/OpenDaylight_OVSDB:Lithium_Release_Review (shague, 15:04:26)
    2. shague is representing for OVSDB (gzhao, 15:04:47)
    3. ACTION: shague to update to use Open vSwitch not OpenvSwitch (gzhao, 15:08:08)
    4. colindixon notes there is no compatibility with Helium (colindixon, 15:09:22)

  6. Opflex (gzhao, 15:11:06)
    1. https://wiki.opendaylight.org/view/OpFlex:LithiumReleaseReview Release Review (readams, 15:12:10)
    2. https://wiki.opendaylight.org/view/OpFlex:Lithium_Release_Notes Release Notes (readams, 15:12:17)
    3. readams is representing for Opflex (gzhao, 15:12:20)
    4. https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/opflex/libopflex-dev.adoc libopflex dev guide (readams, 15:12:43)
    5. https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/opflex/genie-dev.adoc genie dev guide (readams, 15:12:49)
    6. https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/opflex/agent-ovs-dev.adoc OVS agent dev guide (readams, 15:12:55)
    7. https://github.com/opendaylight/docs/blob/stable/lithium/manuals/getting-started-guide/src/main/asciidoc/opflex/agent-ovs-install.adoc Agent install guide (readams, 15:13:01)
    8. https://github.com/opendaylight/docs/blob/stable/lithium/manuals/user-guide/src/main/asciidoc/opflex/agent-ovs-user.adoc Agent user guide (readams, 15:13:06)
    9. colindixon notes that the target environment is different here and that’s likely intentional (colindixon, 15:14:12)
    10. readams says he doesn't have code coverage numbers specifically (it's harder for C++) but based on prior experience I'd estimate on the order of ~75-85% (gzhao, 15:16:25)
    11. ACTION: readams to link dev, user doc to https://wiki.opendaylight.org/view/OpFlex:LithiumReleaseReview (gzhao, 15:16:55)
    12. phrobb asks The release notes mention that genie generates "group-based-policy" model, and agent-ovs implements "group-based-policy" model with OpenStack "group-based-policy". When you reference "group-based-policy" is that to the ODL Group Based Policy project and if so, is there a relationship/dependency between OPFLEX and ODL GBP? (gzhao, 15:19:32)
    13. readams says they implement the same policy model (colindixon, 15:19:52)
    14. readams says Group-based policy is a multi-project initialive across OpenStack and OpenDaylight (gzhao, 15:20:02)

  7. SXP (gzhao, 15:22:31)
    1. mrobertson is representing for SXP (gzhao, 15:23:03)
    2. https://wiki.opendaylight.org/view/SXP:Lithium:Release_Review <-- release review (gzhao, 15:24:22)
    3. https://wiki.opendaylight.org/view/SXP:Lithium:Release_Notes <-- release notes (gzhao, 15:24:35)
    4. ACTION: mrobertson_ to fix user guide and dev guide link in release review (gzhao, 15:27:31)
    5. ACTION: mrobertson_ to update target environment with 64 bit (gzhao, 15:29:56)
    6. ACTION: gzhao to inform SDNi to update release notes for limitation of 64 bit linux (gzhao, 15:30:19)
    7. colindixon notes that the target environment should really read “as per OpenDaylight” (colindixon, 15:32:28)
    8. ACTION: mrobertson_ to remove “TOUPDATE” from the bugzilla summary (colindixon, 15:33:19)

  8. l2switch (colindixon, 15:33:50)
    1. alefan is representing for L2switch (gzhao, 15:34:09)
    2. https://wiki.opendaylight.org/view/L2_Switch:Lithium:Release_Review release review (colindixon, 15:34:53)
    3. https://wiki.opendaylight.org/view/L2_Switch:Lithium:Release_Notes relase notes (colindixon, 15:35:03)
    4. https://wiki.opendaylight.org/view/L2_Switch:Helium:Release_Notes#New_Features_and_Enhancements (gzhao, 15:38:11)
    5. LuisGomez says we still have failing l2switch CSIT tests failing because links are not being removed correctly and asks that it be listed in known issues (colindixon, 15:39:37)
    6. ACTION: alefan to update the release notes and release review with the known issues around link removal (colindixon, 15:40:18)
    7. ACTION: alefan to fix the issues raised above, e.g., wrong links in the non-code aspects of the release review, misnamed section in release notes, and the other known issues (gzhao, 15:44:30)

  9. openflow plugin (gzhao, 15:44:49)
    1. abhijitkumbhare is representing for openflow plugin (gzhao, 15:45:05)
    2. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Lithium_Release_Review (abhijitkumbhare, 15:45:27)
    3. https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Lithium_Release_Notes (abhijitkumbhare, 15:45:43)
    4. ACTION: abhijitkumbhare to remove the “per-edition release notes” from the top of the release notes (colindixon, 15:46:40)

  10. dlux (colindixon, 15:52:38)
    1. https://wiki.opendaylight.org/view/OpenDaylight_dlux:Lithium_Release_Review release review (colindixon, 15:52:48)
    2. https://wiki.opendaylight.org/view/OpenDaylight_dlux:Lithium_Release_Notes release notes (colindixon, 15:52:59)
    3. harman_ says that issues around the YANG UI and YANG visualizer have been fixed (colindixon, 15:58:16)
    4. harman_ says that migration should be trivial for a user (colindixon, 15:58:30)
    5. harman_ says that some modifications might be required for a developer who wrote a dlux extension for Heiium to port it to LIthium (colindixon, 15:59:31)
    6. ACTION: harman_ to update the release notes with information on compatibility with and migration from Helium (colindixon, 16:00:27)

  11. USC (colindixon, 16:00:41)
    1. Helen_Chen is here for USC (Helen_Chen, 16:00:48)
    2. https://wiki.opendaylight.org/view/USC:Lithium:Release_Review relase review (colindixon, 16:00:53)
    3. https://wiki.opendaylight.org/view/USC:Lithium:Release_Notes release notes (colindixon, 16:01:02)
    4. USC is a new project for Lithium (Helen_Chen, 16:02:17)
    5. ACTION: Helen_Chen to remove the “per-edition release notes” header and “release notes for later releases” section since they’re not really applicable (colindixon, 16:06:31)
    6. just leave the major features, target environment, known issues, testing (colindixon, 16:06:55)
    7. colindixon and phrobb ask about testing, how it’s done, if there’s a USC proxy and how somebody else might use it (colindixon, 16:10:15)
    8. Helen_Chen says she’ll post that later (colindixon, 16:10:29)

  12. capwap (colindixon, 16:10:43)
    1. navinagrawal for capwap (navinagrawal, 16:10:46)
    2. https://wiki.opendaylight.org/view/CAPWAP:Lithium:Release_Review (navinagrawal, 16:10:54)
    3. https://wiki.opendaylight.org/view/CAPWAP:Lithium:Release_Notes (navinagrawal, 16:11:00)
    4. ACTION: navinagrawal to update the security section to say that security wasn’t considered in the first release (colindixon, 16:20:23)
    5. ACTION: navinagrawal to remove “not applicable” from QA (colindixon, 16:21:06)
    6. ACTION: nagrawal to remove Per-Edition from capwap release note (navinagrawal, 16:21:19)

  13. VTN (colindixon, 16:21:49)
    1. Hideyuki for VTN (hideyuki, 16:21:52)
    2. https://wiki.opendaylight.org/view/OpenDaylight_Virtual_Tenant_Network_(VTN):Lithium_Release_Review (hideyuki, 16:21:56)
    3. https://wiki.opendaylight.org/view/OpenDaylight_Virtual_Tenant_Network_(VTN):Lithium_Release_Notes (hideyuki, 16:22:03)
    4. ACTION: hideyuki to add either the description of the workaround for 3818 to the release notes/review or say see the bugzilla notes for the workaround (colindixon, 16:27:42)
    5. colindixon asks about compatibility with Helium, hideyuki says the REST API to VTN is the same (colindixon, 16:28:22)
    6. ACTION: hideyuki to add a section noting that other than that the REST API is the same, compatibility with Helium is unknown and untested (colindixon, 16:28:51)
    7. ACTION: hideyuki to note that VTN supports the NIC interface in Lithium (colindixon, 16:29:12)

  14. iotdm (colindixon, 16:31:09)
    1. https://wiki.opendaylight.org/view/Iotdm:Lithium_Release_Review release review (colindixon, 16:31:26)
    2. https://wiki.opendaylight.org/view/Iotdm:Lithium_Release_Notes release notes (colindixon, 16:31:30)
    3. ACTION: jburns to remove the “draft” statement from the top of the release notes (colindixon, 16:32:48)
    4. LuisGomez asks if a failing CSIT test is expected, jburns says maybe, they are still working on quality given that it’s the first release, they don’t see it as blocking (colindixon, 16:33:35)
    5. ACTION: jburns to provide some guidance about the bugs and how to work around them for users as appropriate for bugs in the release notes (colindixon, 16:38:54)
    6. ACTION: jburns to look at "known Issues" and provide more context and work arounds as appropriate (phrobb, 16:39:12)


Meeting ended at 16:40:44 UTC (full logs).

Action items

  1. oflibMichal to add the bug from the release review to the release notes
  2. oflibMichal is to fix the broken link for https://www.markoweb.eu/topoprocessing/presentation
  3. SDNiShahid will link user guide, dev guide and release note in release review
  4. SDNiShahid to update the "Compatibility with Previous Releases section" in release notes
  5. SDNiShahid to remove the ubuntu versions.
  6. colindixon to work on getting requirements more clearly stated in release notes/review
  7. shague to update to use Open vSwitch not OpenvSwitch
  8. readams to link dev, user doc to https://wiki.opendaylight.org/view/OpFlex:LithiumReleaseReview
  9. mrobertson_ to fix user guide and dev guide link in release review
  10. mrobertson_ to update target environment with 64 bit
  11. gzhao to inform SDNi to update release notes for limitation of 64 bit linux
  12. mrobertson_ to remove “TOUPDATE” from the bugzilla summary
  13. alefan to update the release notes and release review with the known issues around link removal
  14. alefan to fix the issues raised above, e.g., wrong links in the non-code aspects of the release review, misnamed section in release notes, and the other known issues
  15. abhijitkumbhare to remove the “per-edition release notes” from the top of the release notes
  16. harman_ to update the release notes with information on compatibility with and migration from Helium
  17. Helen_Chen to remove the “per-edition release notes” header and “release notes for later releases” section since they’re not really applicable
  18. navinagrawal to update the security section to say that security wasn’t considered in the first release
  19. navinagrawal to remove “not applicable” from QA
  20. nagrawal to remove Per-Edition from capwap release note
  21. hideyuki to add either the description of the workaround for 3818 to the release notes/review or say see the bugzilla notes for the workaround
  22. hideyuki to add a section noting that other than that the REST API is the same, compatibility with Helium is unknown and untested
  23. hideyuki to note that VTN supports the NIC interface in Lithium
  24. jburns to remove the “draft” statement from the top of the release notes
  25. jburns to provide some guidance about the bugs and how to work around them for users as appropriate for bugs in the release notes
  26. jburns to look at "known Issues" and provide more context and work arounds as appropriate


Action items, by person

  1. abhijitkumbhare
    1. abhijitkumbhare to remove the “per-edition release notes” from the top of the release notes
  2. alefan
    1. alefan to update the release notes and release review with the known issues around link removal
    2. alefan to fix the issues raised above, e.g., wrong links in the non-code aspects of the release review, misnamed section in release notes, and the other known issues
  3. colindixon
    1. colindixon to work on getting requirements more clearly stated in release notes/review
  4. gzhao
    1. gzhao to inform SDNi to update release notes for limitation of 64 bit linux
  5. harman_
    1. harman_ to update the release notes with information on compatibility with and migration from Helium
  6. Helen_Chen
    1. Helen_Chen to remove the “per-edition release notes” header and “release notes for later releases” section since they’re not really applicable
  7. hideyuki
    1. hideyuki to add either the description of the workaround for 3818 to the release notes/review or say see the bugzilla notes for the workaround
    2. hideyuki to add a section noting that other than that the REST API is the same, compatibility with Helium is unknown and untested
    3. hideyuki to note that VTN supports the NIC interface in Lithium
  8. jburns
    1. jburns to remove the “draft” statement from the top of the release notes
    2. jburns to provide some guidance about the bugs and how to work around them for users as appropriate for bugs in the release notes
    3. jburns to look at "known Issues" and provide more context and work arounds as appropriate
  9. mrobertson_
    1. mrobertson_ to fix user guide and dev guide link in release review
    2. mrobertson_ to update target environment with 64 bit
    3. mrobertson_ to remove “TOUPDATE” from the bugzilla summary
  10. navinagrawal
    1. navinagrawal to update the security section to say that security wasn’t considered in the first release
    2. navinagrawal to remove “not applicable” from QA
  11. oflibMichal
    1. oflibMichal to add the bug from the release review to the release notes
    2. oflibMichal is to fix the broken link for https://www.markoweb.eu/topoprocessing/presentation
  12. readams
    1. readams to link dev, user doc to https://wiki.opendaylight.org/view/OpFlex:LithiumReleaseReview
  13. SDNiShahid
    1. SDNiShahid will link user guide, dev guide and release note in release review
    2. SDNiShahid to update the "Compatibility with Previous Releases section" in release notes
    3. SDNiShahid to remove the ubuntu versions.
  14. shague
    1. shague to update to use Open vSwitch not OpenvSwitch


People present (lines said)

  1. colindixon (189)
  2. gzhao (87)
  3. phrobb (43)
  4. harman_ (24)
  5. readams (21)
  6. oflibMichal (20)
  7. LuisGomez (19)
  8. alefan (14)
  9. Helen_Chen (13)
  10. SDNiShahid (12)
  11. navinagrawal (11)
  12. jburns (9)
  13. hideyuki (9)
  14. abhijitkumbhare (9)
  15. shague (8)
  16. mrobertson_ (7)
  17. odl_meetbot (6)
  18. vishnoianil (4)
  19. mrobertson (1)
  20. zxiiro (1)


Generated by MeetBot 0.1.4.