14:31:26 <gzhao> #startmeeting Lithium release review
14:31:26 <odl_meetbot> Meeting started Tue Jun 23 14:31:26 2015 UTC.  The chair is gzhao. Information about MeetBot at http://ci.openstack.org/meetbot.html.
14:31:26 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:31:26 <odl_meetbot> The meeting name has been set to 'lithium_release_review'
14:31:37 <phrobb> good morning gzhao
14:31:50 <gzhao> #topic roll call
14:31:58 <zxiiro> Good morning all
14:31:58 <gzhao> phrobb: -:)
14:32:25 <phrobb> #info Project Leaders and TSC members please #info in
14:32:28 <oflibMichal> #info oflibMichal for openflowjava and topoprocessing
14:32:52 <gzhao> #chair phrobb colindixon
14:32:52 <odl_meetbot> Current chairs: colindixon gzhao phrobb
14:32:53 <LuisGomez> #info LuisGomez
14:33:01 <colindixon> #info colindixon
14:33:46 <gzhao> #topic Openflow Java
14:33:53 <oflibMichal> #link https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Lithium_Release_Review release review
14:33:57 <oflibMichal> #link https://wiki.opendaylight.org/view/Openflow_Protocol_Library:Release_Notes:Lithium_Release_Notes release notes
14:34:21 <gzhao> colindixon: one question, when is the deadline for doc?
14:34:57 <colindixon> gzhao: ASAP, but since we don’t publish it to a site as far as I know, I think we can post docs in a decoupled way
14:35:26 <gzhao> colindixon: thanks
14:35:39 <shague> #info shague
14:36:40 <gzhao> oflibMichal: do you think unit test coverage can be linked to build page
14:36:42 <colindixon> oflibMichal: are there any issues with compatibility or migration?
14:37:04 <oflibMichal> gzhao: sure, will do
14:37:31 <oflibMichal> colindixon: this release is not compatible with previous ... openflowjava went through model update
14:37:36 * shague I am in another call right now with OVSDB review at 11:00/08:00pst. I am watching this channel but might need a  second ping to wake up
14:37:48 <oflibMichal> colindixon: and also a writting / flushing mechanism changed
14:38:09 <gzhao> #info colindixon asks about any issues with compatibility or migration
14:38:51 <gzhao> #info gzhao suggests unit test coverage link with the test and oflibMichal will do the update
14:38:55 <colindixon> #info oflibMichal says the model changed and the writing/flushing mechanism changed, so it’s not compatible with Helium
14:39:19 <gzhao> #info oflibMichal says his release is not compatible with previous because openflowjava went through model update
14:39:23 <colindixon> I’d like to see the one known issue in the release notes as well as the release review
14:39:26 <gzhao> #undo
14:39:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1944cd0>
14:39:50 <oflibMichal> colindixon: ok, will add a mention of it
14:39:56 <colindixon> thanks
14:40:13 <colindixon> I guess it’s “suspected” issue not a “known” issue, but it would still be nice
14:40:22 <oflibMichal> sure
14:40:25 <colindixon> #action oflibMichal to add the bug from the release review to the release notes
14:40:26 <colindixon> ok
14:40:34 <colindixon> anything else from anyone?
14:40:47 <gzhao> LGTM
14:42:17 <gzhao> #topic Topoprocessing
14:42:21 <oflibMichal> #link https://wiki.opendaylight.org/view/Topology_Processing_Framework:Lithium_Release_Review release review
14:42:25 <oflibMichal> #link https://wiki.opendaylight.org/view/Topology_Processing_Framework:Lithium_Release_Notes release notes
14:43:21 <gzhao> oflibMichal: this link Topology Processing Framework Presentation broke for me
14:43:56 <colindixon> gzhao: both work for me
14:44:10 <oflibMichal> ou, same here ... will definitely fix that
14:44:31 <colindixon> oh
14:44:32 <colindixon> nm
14:45:06 <oflibMichal> works on the main page
14:45:15 <oflibMichal> will re copy-paste the link
14:45:46 <gzhao> #action oflibMichal is to fix the broken link for https://www.markoweb.eu/topoprocessing/presentation
14:46:04 <oflibMichal> please reload the release review page
14:46:07 <oflibMichal> should work now
14:46:17 <gzhao> oflibMichal: do you plan to link dev guide?
14:46:21 <colindixon> oflibMichal: so, is there a reason that only two of the bugs listed on the release review are also listed in the release notes
14:46:45 <gzhao> oflibMichal: it works, thanks
14:47:09 <oflibMichal> gzhao: ok, I can link the developer guide, no problem
14:47:51 <oflibMichal> colindixon: bug 3802 and 3715 on release review page
14:47:56 <gzhao> oflibMichal: thanks
14:48:09 <oflibMichal> are both covered by ...filtering can be based only on ipv4 address fields
14:48:13 <gzhao> #info colindixon asks is there a reason that only two of the bugs listed on the release review are also listed in the release notes
14:48:20 <oflibMichal> but I can provide more information
14:48:39 <gzhao> #actions oflibMichal is to link developer guide in release review
14:49:37 <colindixon> ok
14:50:10 <colindixon> #link https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/topoprocessing/odl-topoprocessing-framework-dev.adoc developer docs
14:50:24 <colindixon> ok
14:50:26 <colindixon> anything else?
14:51:01 <gzhao> colindixon: question, does release notes need to be in accsi format
14:51:17 <gzhao> general question not for the project
14:51:17 <colindixon> gzhao: ideally, yes, in practice I’m likely to wind up translating that
14:51:28 <colindixon> it should be pretty fast
14:51:28 <gzhao> colindixon: got it
14:51:36 <colindixon> we just ran out of time/discipline
14:51:58 <gzhao> #topic SDNi
14:51:59 <oflibMichal> thanks for the review
14:52:13 <SDNiShahid> #link https://wiki.opendaylight.org/view/ODL-SDNi:Lithium_Release_Review   <-- Release Review
14:52:25 <SDNiShahid> #link https://wiki.opendaylight.org/view/ODL-SDNi:Lithium_Release_Notes    <-- Release Notes
14:52:49 <gzhao> #info SDNiShahid is representing SDNi
14:53:31 <SDNiShahid> yes
14:54:01 <colindixon> ok
14:54:07 <SDNiShahid> updated the contents for release review and release notes - please let us know of comments
14:54:43 <gzhao> SDNiShahid: can you link in release notes, dev guide and user guide in the release review
14:55:20 <phrobb> SDNiShahid: is there a reason you specifically call out Ubuntu 12.04/14/04 as the execution environment?  Is there lack of support for other environments?
14:55:33 <colindixon> #link https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/sdninterfaceapp/odl-sdninterfaceapp-all-dev.adoc developer docs
14:55:57 <SDNiShahid> sure we can include the ascii doc links
14:56:02 <colindixon> #link https://github.com/opendaylight/docs/blob/stable/lithium/manuals/user-guide/src/main/asciidoc/sdninterfaceapp/odl-sdninterfaceapp-all-user.adoc user docs
14:56:16 <colindixon> SDNiShahid: were you intending to update those?
14:56:24 <colindixon> SDNiShahid: or is that all you wanted to provide?
14:56:35 <gzhao> SDNiShahid: I mean link those in the https://wiki.opendaylight.org/view/ODL-SDNi:Lithium_Release_Review
14:56:50 <SDNiShahid> sure. Will update
14:57:17 <gzhao> #action SDNiShahid will link user guide, dev guide and release note in release review
14:57:47 <gzhao> SDNiShahid: question, why Compatibility with Previous Releases section is not in release note?
14:58:17 <SDNiShahid> So far we have tested with 12.04 and 14.04 ... Hence we mentioned the same. As such there are no issues with other releases, it should work with other environments where ODL is supported
14:59:14 <gzhao> #info SDNiShahid says SDNi has tested with 12.04 and 14.04, it should work with other environments where ODL is supported
14:59:22 <colindixon> SDNiShahid: I think gzhao means how is it compatilbie with the Helium release of sdni
14:59:31 <SDNiShahid> OK, will update the "Compatibility with Previous Releases section" as well in release notes
14:59:37 <gzhao> colindixon: that is right.
14:59:47 <gzhao> SDNiShahid: thanks
15:00:02 <phrobb> Thanks SDNiShahid.  By including those ubuntu versions specifically, the implication is that other environments are not for execution.  This may be confusing to our users.
15:00:09 <gzhao> #action SDNiShahid to update the "Compatibility with Previous Releases section" in release notes
15:00:44 <colindixon> thanks
15:00:48 <SDNiShahid> phrobb: I can remove the versions
15:01:01 <gzhao> #info phrobb notes By including those ubuntu versions specifically, the implication is that other environments are not for execution.  This may be confusing to our users.
15:01:28 <phrobb> General question for docs and TSC members:  What information and how do we want to convey it for our target execution environments?... so that there is consistency across the project release notes?
15:01:54 <colindixon> phrobb: it’s a good question and I’m not sure how many TSC members we have here
15:02:32 <gzhao> #action SDNiShahid to remove the ubuntu versions.
15:02:36 <colindixon> phrobb: I think we’d like to see java version, specific linux versions if there’s a reason to believe it’s needed, and otherwise, we need a general ODL-wide set of requirements
15:02:44 <gzhao> any more questions for SDNi
15:02:49 <colindixon> phrobb: I think the kind of thing that is here is more about testing
15:03:21 <phrobb> colindixon:  agreed
15:03:22 <SDNiShahid> I think we should have a general ODL-wide set of requirements
15:03:49 <colindixon> #action colindixon to work on getting requirements more clearly stated in release notes/review
15:04:05 <colindixon> I’m ready for OVSDB
15:04:11 <phrobb> same here
15:04:12 <gzhao> #topic OVSDB
15:04:15 <SDNiShahid> Any more questions ?
15:04:17 <colindixon> SDNiShahid: just move the Ubuntu things into what’s been tested
15:04:22 <gzhao> SDNiShahid: thank you
15:04:26 <shague> #link https://wiki.opendaylight.org/view/OpenDaylight_OVSDB:Lithium_Release_Review
15:04:27 <shague> #link https://wiki.opendaylight.org/view/OpenDaylight_OVSDB:Lithium_Release_Notes
15:04:36 <phrobb> thanks SDNiShahid !
15:04:37 <SDNiShahid> sure, Thanks for the review
15:04:47 <gzhao> #info shague is representing for OVSDB
15:04:54 <gzhao> SDNiShahid: you are welcome
15:05:30 <colindixon> shague: randomly, it’s Open vSwitch not OpenvSwitch
15:06:30 <shague> colindixon: yeah, the name is used all over in different forms from previous release so difficult to follow one
15:06:40 <colindixon> shague: the guides should point to stable/lithium branch not master
15:06:51 <colindixon> shague: undestood, I was just seeing it in “project name” in the release review
15:06:52 * phrobb appreciates both the feature name and a short description of functionality in the Features section of the OVSDB release review
15:07:26 <gzhao> shague: very well written
15:07:42 <shague> colindixon: I will update that. I think some of the docs were not merged to lithium yet and are just in master
15:08:04 <colindixon> that would surprise me, but is possible, yell at me if that’s true
15:08:08 <gzhao> #action shague to update  to use Open vSwitch not OpenvSwitch
15:08:21 <colindixon> gzhao, shague just in the project name :p
15:08:59 <colindixon> this looks good otherwise
15:09:02 <colindixon> reads well
15:09:22 <colindixon> #info colindixon notes there is no compatibility with Helium
15:10:11 <gzhao> I have no questions
15:10:12 <colindixon> anything else?
15:10:17 <shague> colindixon: wasn't sure what to word there. Technically functionlly there is compatibilioty but the mdsal stuff is all new
15:11:00 <gzhao> shague: I think what you put there is correct
15:11:06 <gzhao> #topic Opflex
15:11:09 <colindixon> shague: I think what you have there is right, if you wanted to make it sound better you could say the netvirt part is compatible insofar as it’s both neutron
15:11:42 <gzhao> do we have adam on line
15:11:56 <readams> Hi folks this is Rob Adams for OpFlex
15:11:57 <colindixon> readams: is here
15:11:58 <colindixon> hey
15:12:01 <shague> colindixon: Ok, I might update that section
15:12:02 <gzhao> sorry rob
15:12:10 <readams> #link https://wiki.opendaylight.org/view/OpFlex:LithiumReleaseReview Release Review
15:12:17 <readams> #link https://wiki.opendaylight.org/view/OpFlex:Lithium_Release_Notes Release Notes
15:12:20 <gzhao> #info readams is representing for Opflex
15:12:43 <readams> #link https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/opflex/libopflex-dev.adoc libopflex dev guide
15:12:49 <readams> #link https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/opflex/genie-dev.adoc genie dev guide
15:12:55 <readams> #link https://github.com/opendaylight/docs/blob/stable/lithium/manuals/developer-guide/src/main/asciidoc/opflex/agent-ovs-dev.adoc OVS agent dev guide
15:13:01 <readams> #link https://github.com/opendaylight/docs/blob/stable/lithium/manuals/getting-started-guide/src/main/asciidoc/opflex/agent-ovs-install.adoc Agent install guide
15:13:06 <readams> #link https://github.com/opendaylight/docs/blob/stable/lithium/manuals/user-guide/src/main/asciidoc/opflex/agent-ovs-user.adoc Agent user guide
15:13:17 <colindixon> thanks :p
15:13:21 <readams> And now I'm done with my linkspam :-)
15:13:56 <colindixon> ok, this looks good
15:14:10 <gzhao> readams: could you link those in https://wiki.opendaylight.org/view/OpFlex:LithiumReleaseReview as well
15:14:12 <colindixon> #info colindixon notes that the target environment is different here and that’s likely intentional
15:14:50 <readams> Yea the target environment here is a bit different :-)
15:15:21 <readams> I'll add teh direct links to the release review page
15:15:21 <colindixon> do you have an idea what your code coverage from tests looks like in numbers?
15:16:00 <readams> I don't have code coverage numbers specifically (it's harder for C++) but based on prior experience I'd estimate on the order of ~75-85%
15:16:15 <colindixon> ok
15:16:16 <readams> i.e. everything with any meat has tests
15:16:16 <colindixon> cool
15:16:21 <colindixon> I’m happy
15:16:25 <gzhao> #info readams says he doesn't have code coverage numbers specifically (it's harder for C++) but based on prior experience I'd estimate on the order of ~75-85%
15:16:55 <gzhao> #action readams to link dev, user doc to https://wiki.opendaylight.org/view/OpFlex:LithiumReleaseReview
15:17:38 <gzhao> any more question for Opflex?
15:17:52 <colindixon> I’m good
15:17:56 <colindixon> phrobb:
15:18:01 <gzhao> do we have people from SXP?
15:18:23 <phrobb> readams: The release notes mention that genie generates "group-based-policy" model, and agent-ovs implements "group-based-policy" model with OpenStack "group-based-policy".  When you reference "group-based-policy" is that to the ODL Group Based Policy project and if so, is there a relationship/dependency between OPFLEX and ODL GBP?
15:18:59 <phrobb> sorry colindixon ... took a bit to type my question.  Hopefully it is coherent... just looking to not confuse the users with overloaded GBP terms
15:19:09 <colindixon> yeah
15:19:15 <readams> It's all part of the same big happy family :-).  Group-based policy is a multi-project initialive across OpenStack and OpenDaylight
15:19:28 <readams> I'm also the original author of the GBP project
15:19:32 <gzhao> #info phrobb asks The release notes mention that genie generates "group-based-policy" model, and agent-ovs implements "group-based-policy" model with OpenStack "group-based-policy".  When you reference "group-based-policy" is that to the ODL Group Based Policy project and if so, is there a relationship/dependency between OPFLEX and ODL GBP?
15:19:37 <readams> they implement the same policy model
15:19:52 <colindixon> #info readams says they implement the same policy model
15:20:02 <gzhao> #info readams says Group-based policy is a multi-project initialive across OpenStack and OpenDaylight
15:20:05 <readams> There is currently no explicit dependency from the GBP model to the OpFlex project however currently
15:20:13 <readams> that integration is planned for some time in the future
15:20:18 <phrobb> Cool, thanks readams.  But there is no dependency/relationship between OPFLEX and ODL GBP other than they implement the same model, correct?
15:20:53 <readams> Yes phrobb currently no dependency though integration is something we want to do in the future
15:20:58 <gzhao> do we have representative from SXP project, Mathew ?
15:21:18 <readams> release review updated
15:21:21 <phrobb> readams.  got it... sorry I was typing my previous question while you were answering it :-p
15:21:26 <phrobb> no more questions from me
15:21:28 <readams> np :-)
15:22:01 <gzhao> do we have representative from l2switch?
15:22:11 <gzhao> is Alex Fan on line?
15:22:21 <mrobertson> Yes, I am representing SXP
15:22:27 <gzhao> mrobertson: cool
15:22:31 <gzhao> #topic SXP
15:22:51 <gzhao> mrobertson: please info in your release review and release note link
15:23:03 <gzhao> #info mrobertson is representing for SXP
15:23:50 <mrobertson_> release review - https://wiki.opendaylight.org/view/SXP:Lithium:Release_Review release notes - https://wiki.opendaylight.org/view/SXP:Lithium:Release_Notes
15:24:22 <gzhao> #link https://wiki.opendaylight.org/view/SXP:Lithium:Release_Review <-- release review
15:24:35 <gzhao> #link https://wiki.opendaylight.org/view/SXP:Lithium:Release_Notes <-- release notes
15:24:58 <phrobb> mrobertson_: if SXP depends on tcpmd5, is your execution environment not limited to 64bit Linux boxes?
15:25:55 <gzhao> mrobertson_: your user guide and dev guid link seems wrong
15:27:02 <gzhao> oops, it seems we lost mrobertson_
15:27:31 <gzhao> #action mrobertson_ to fix user guide and dev guide link in release review
15:27:41 <phrobb> Actually, I think I now see that SDNi has the same Linux execution environment requirement re tcpmd5
15:27:58 <mrobertson_> we will correct the link. seems to be pointing to the wrong spot
15:28:10 <colindixon> phrobb: yes
15:28:23 <mrobertson_> re: 64bit; paritally, but only if we use a password.
15:28:52 <mrobertson_> SXP can go without Password authentification then thera are no limitation otherwise
15:28:53 <phrobb> mrobertson_:  right.  Is there a way to reflect that in the release notes so that users are aware
15:29:13 <mrobertson_> yes, we can make that change
15:29:19 <phrobb> thanks mrobertson_
15:29:56 <gzhao> #action mrobertson_ to update target environment with 64 bit
15:30:19 <gzhao> #action gzhao to inform SDNi to update release notes for limitation of 64 bit linux
15:31:36 <colindixon> sxp should remove “TOUPDATE” from bugzilla summary
15:32:28 <colindixon> #info colindixon notes that the target environment should really read “as per OpenDaylight”
15:33:19 <colindixon> #action mrobertson_ to remove “TOUPDATE” from the bugzilla summary
15:33:27 <colindixon> anything else form others?
15:33:28 <gzhao> alefan: hello
15:33:39 <alefan> hi
15:33:50 <colindixon> #topic l2switch
15:33:51 <phrobb> nothing more from me
15:34:09 <gzhao> #info alefan is representing for L2switch
15:34:24 <gzhao> alefan: please info your releae review and release notes
15:34:33 <colindixon> is there a release review in additional to release notes?
15:34:53 <colindixon> #link https://wiki.opendaylight.org/view/L2_Switch:Lithium:Release_Review release review
15:34:54 <colindixon> found it
15:35:03 <colindixon> #link https://wiki.opendaylight.org/view/L2_Switch:Lithium:Release_Notes relase notes
15:35:14 <alefan> Thanks Colin, beat me to it.
15:36:15 <alefan> Those are the two documents related to Lithium.
15:36:40 <LuisGomez> I do not see link/port status issues reported in release notes
15:36:48 <LuisGomez> csit test is failing on that
15:37:01 <mrobertson_> Sorry, topic changed before I could ask - re: SXP - just to clarify if the TSC considers SXP to be part of the Lithium release
15:37:20 <colindixon> mrobertson_: yes
15:37:24 <alefan> I believe Amit committed the fix for the links not being removed correcdtly -- he cleared one of the member variables
15:37:42 <mrobertson_> colindixon: thanks.
15:37:52 <gzhao> alefan: the release notes New Features and Enhancements seems used older version
15:38:11 <gzhao> https://wiki.opendaylight.org/view/L2_Switch:Helium:Release_Notes#New_Features_and_Enhancements
15:38:22 <LuisGomez> the csit is still failing :9
15:38:47 <gzhao> LuisGomez: for l2switch?
15:39:20 <LuisGomez> yep
15:39:37 <LuisGomez> loop removal and host tracker do not update after a link down
15:39:37 <colindixon> #info LuisGomez says we still have failing l2switch CSIT tests failing because links are not being removed correctly and asks that it be listed in known issues
15:39:44 <LuisGomez> this is old issue
15:39:50 <alefan> I'll add that to the release notes then for now & discuss with Amit later today about the failing.
15:39:55 <LuisGomez> being reported for weeks and not fixed
15:40:06 <gzhao> alefan: actually your release notes point to Helium release note in release review
15:40:18 <colindixon> #action alefan to update the release notes and release review with the known issues around link removal
15:40:43 <alefan> Hmm...let me check...
15:40:54 <colindixon> ok
15:41:07 * gzhao take a eye break
15:41:09 <alefan> You're right
15:41:21 <alefan> There are references to Helium in the Lithium document, I'll remove those
15:41:22 <LuisGomez> alefan, you can check RC0 and RC1 test reports
15:41:31 <abhijitkumbhare> gzhao: you are not allowed an eyebreak :)
15:41:42 <alefan> I'll do that Luis, thanks
15:41:42 <LuisGomez> ii added there the l2switch failures
15:41:51 <alefan> I'll check why it's failing & see if Amit's fix got committed properly
15:41:53 * gzhao notices the line grows quite long at check in counter @SFO
15:41:56 <alefan> or if it didn't fix the underlying issue
15:41:57 <colindixon> alefan: can you change the name of or remove the “Lithium Stable Update 1” section in the release notes
15:42:09 <abhijitkumbhare> OK - gzhao :)
15:42:09 <gzhao> abhijitkumbhare: -:)
15:42:18 <colindixon> gzhao: you can leave hwenver you need
15:42:28 <alefan> Yes, I will do that, colin
15:42:30 <alefan> I'll do that now
15:42:38 <gzhao> colindixon: in 2 hours
15:43:30 <gzhao> any more questions for l2switch?
15:43:43 <LuisGomez> not from me
15:43:52 <colindixon> ok, other than the issues raised above, e.g., wrong links in the non-code aspects of the release review, misnamed section in release notes, and the other known issues
15:44:09 <alefan> Thanks George & Luiz & Colin :)
15:44:18 <LuisGomez> thanks alefan
15:44:20 <colindixon> thanks
15:44:30 <gzhao> #action alefan to fix the issues raised above, e.g., wrong links in the non-code aspects of the release review, misnamed section in release notes, and the other known issues
15:44:49 <gzhao> #topic openflow plugin
15:45:04 <abhijitkumbhare> Hi
15:45:05 <gzhao> #info abhijitkumbhare is representing for openflow plugin
15:45:17 <gzhao> please info in your docs
15:45:27 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Lithium_Release_Review
15:45:43 <abhijitkumbhare> #link https://wiki.opendaylight.org/view/OpenDaylight_OpenFlow_Plugin:Lithium_Release_Notes
15:46:03 * colindixon starts reading
15:46:40 <colindixon> #action abhijitkumbhare to remove the “per-edition release notes” from the top of the release notes
15:47:01 <abhijitkumbhare> OK
15:47:19 <gzhao> phrobb: colindixon LuisGomez I have to head in to check in and pass security gate now.
15:47:27 <colindixon> gzhao: understood
15:47:36 <phrobb> sound good gzhao
15:48:00 <colindixon> abhijitkumbhare: in terms of migration, will it work from a Helium install to a Lithium install?
15:48:09 <colindixon> abhijitkumbhare: my guess is no, but the release notes would make me think yes
15:48:52 <vishnoianil> colindixon, you mean from user perspective ?
15:48:54 <abhijitkumbhare> Yes - from my understanding (from yesterday’s OpenFlow meeting) it should work
15:48:59 <colindixon> ok
15:49:03 <colindixon> cool
15:49:08 <vishnoianil> yes from user perspective
15:49:25 <colindixon> vishnoianil: yeah, I meant if I shut down a Helium controller, install Lithium over it, and bring it up, it should work
15:49:31 <colindixon> e.g., the models are all the same
15:49:47 <vishnoianil> yes, it's just location change
15:49:54 <colindixon> cool
15:49:58 <vishnoianil> eventually for md-sal it's loads up the same models
15:50:23 <colindixon> otherwise, this looks fine
15:50:31 <abhijitkumbhare> OK
15:50:35 <colindixon> phrobb?
15:50:51 <phrobb> nothing from me
15:51:33 <abhijitkumbhare> Will update the release notes to remove the “Per edition heading”
15:52:22 <colindixon> ok
15:52:37 <colindixon> next up is dlux
15:52:38 <colindixon> #topic dlux
15:52:41 <colindixon> harman_: you here?
15:52:47 <harman_> Harman Singh for DLUX
15:52:48 <colindixon> #link https://wiki.opendaylight.org/view/OpenDaylight_dlux:Lithium_Release_Review release review
15:52:59 <colindixon> #link https://wiki.opendaylight.org/view/OpenDaylight_dlux:Lithium_Release_Notes release notes
15:53:01 <harman_> #link https://wiki.opendaylight.org/view/OpenDaylight_dlux:Lithium_Release_Notes
15:53:03 <colindixon> #undo
15:53:03 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x19aabd0>
15:53:05 <colindixon> I got it
15:53:05 <harman_> u got it
15:53:10 <colindixon> ok
15:53:13 <colindixon> cool
15:53:14 * colindixon reads
15:53:28 <colindixon> harman_: do you know if we ever got the YANG UI yang visualizer to work?
15:53:35 <colindixon> they were failing the last time I tried
15:53:41 <harman_> yes, currently, its working
15:53:48 <harman_> Juraj fixed some defects
15:53:50 <colindixon> harman_: did it need to be updated?
15:53:50 <colindixon> ok
15:53:52 <colindixon> cool
15:54:01 <harman_> earlier, i saw loading issues, but now it loads up fine
15:54:15 <harman_> there are still some defects that Juraj logged
15:54:25 <colindixon> harman_: good to know
15:54:29 <harman_> i think he is planning to fix them after Lithium
15:54:43 <colindixon> should those go in the known isseus
15:54:57 <harman_> they are mostly enhancements as per Juraj
15:55:15 <harman_> i can confirm with him one more time, if he wants to keep any of those as known issue
15:55:41 <harman_> I’ll upate notes accordingly
15:55:56 <colindixon> ok
15:56:43 <colindixon> this looks good to me
15:56:48 <colindixon> oh, migration?
15:56:57 <harman_> should not be a problem
15:57:00 <colindixon> migration and compatilbity with Helium
15:57:02 <colindixon> it should be the same?
15:57:07 <harman_> all the changes are orthogonal
15:57:17 <harman_> user won’t see a difference
15:57:17 <colindixon> e.g., a Helium add-on should work with Lihium dlux?
15:57:27 <colindixon> a UI extension
15:57:37 <harman_> ok, i think
15:57:42 <colindixon> if so, you should probably note that
15:57:43 <harman_> user have to make few changes
15:57:52 <colindixon> developer you mean?
15:57:52 <harman_> yes, i’ll update that in release notes
15:58:07 <harman_> developer have to create a bundle now
15:58:08 <harman_> yes
15:58:10 <harman_> developer
15:58:16 <colindixon> #info harman_ says that issues around the YANG UI and YANG visualizer have been fixed
15:58:30 <colindixon> #info harman_ says that migration should be trivial for a user
15:58:56 <harman_> I’ll update migration section in next hour
15:59:07 <phrobb> this looks good to me harman
15:59:16 <harman_> Thank you
15:59:31 <colindixon> #info harman_ says that some modifications might be required for a developer who wrote a dlux extension for Heiium to port it to LIthium
16:00:26 <harman_> We have that documented on wiki , will add a link for that under migration as well
16:00:27 <colindixon> #action harman_ to update the release notes with information on compatibility with and migration from Helium
16:00:30 <colindixon> thanks!
16:00:41 <colindixon> #topic USC
16:00:42 <harman_> thanks guys
16:00:46 <colindixon> Helen_Chen: you there?
16:00:48 <Helen_Chen> #info Helen_Chen is here for USC
16:00:51 <Helen_Chen> yes
16:00:53 <colindixon> #link https://wiki.opendaylight.org/view/USC:Lithium:Release_Review relase review
16:01:02 <colindixon> #link https://wiki.opendaylight.org/view/USC:Lithium:Release_Notes release notes
16:01:04 * colindixon starts reading
16:01:16 <Helen_Chen> ok, :-)
16:02:17 <Helen_Chen> #info USC is a new project for Lithium
16:04:31 <colindixon> do you have the % coverage for tests?
16:04:50 <Helen_Chen> Right now, Sonar is currently not reporting our coverage correctly.  Will look into it.
16:04:58 <Helen_Chen> but we have 41 unit tests for it
16:05:44 <Helen_Chen> and 5 manual testing, including 4 nodes clustering testing
16:06:31 <colindixon> #action Helen_Chen to remove the “per-edition release notes” header and “release notes for later releases” section since they’re not really applicable
16:06:40 <Helen_Chen> ok
16:06:55 <colindixon> #info just leave the major features, target environment, known issues, testing
16:06:59 <colindixon> if that makes sense
16:07:20 <Helen_Chen> ok
16:07:50 <phrobb> Helen_Chen is your manual testing documented via test plan/test-case anywhere?... assuming you have a physical network environement with particular endpoints you are testing against.
16:08:26 <colindixon> I was going to ask something simlar, presumaby there’s a USC proxy somewhere that’s used for testing
16:08:28 <Helen_Chen> we will post it after this meeting. Yes
16:08:29 <phrobb> I don't believe such info is required.  Just curious if folks could see what environment/system test has been done
16:09:29 <phrobb> no more questions from me.  Nice job Helen_Chen
16:09:47 <colindixon> ok
16:10:15 <colindixon> #info colindixon and phrobb ask about testing, how it’s done, if there’s a USC proxy and how somebody else might use it
16:10:18 <Helen_Chen> thanks, we'll document the testing evn we have
16:10:29 <colindixon> #info Helen_Chen says she’ll post that later
16:10:30 <Helen_Chen> meanwhile will looking into sonar testing coverage
16:10:42 <Helen_Chen> issue
16:10:43 <colindixon> #topic capwap
16:10:46 <colindixon> navinagrawal: you there?
16:10:46 <navinagrawal> #info navinagrawal for capwap
16:10:49 <colindixon> sweet
16:10:54 <navinagrawal> #link https://wiki.opendaylight.org/view/CAPWAP:Lithium:Release_Review
16:10:58 <colindixon> fast
16:11:00 <navinagrawal> #link https://wiki.opendaylight.org/view/CAPWAP:Lithium:Release_Notes
16:14:58 <colindixon> navinagrawal: are the robot tests checked into integration?
16:15:08 <navinagrawal> yes colin.
16:15:11 <colindixon> cool
16:16:41 <phrobb> navinagrawal are the connections between the controller and WAP/WTP secured or securable?
16:16:43 <colindixon> are security considerations really n/a?
16:16:46 <colindixon> yeah
16:16:51 <phrobb> :-)
16:17:11 <navinagrawal> at this point of time, there is no security consideration.
16:17:23 <LuisGomez> basic csit test running for capwap: https://jenkins.opendaylight.org/releng/view/CSIT-1node/job/capwap-csit-1node-cds-ac-only-stable-lithium/
16:17:24 <colindixon> also, it seems like you should remove “QA” not applicable since you have a paragraph after it
16:17:24 <navinagrawal> capwap controller is only looking for wtp discovery packets.
16:17:53 <colindixon> navinagrawal: I’d say “security considerations were ignored for the first release” or something
16:17:56 <navinagrawal> dtls comes in later phase of capwap protocol, which we will attempt to do in next release.
16:18:17 <navinagrawal> will fix QA not applicable part.
16:18:48 <navinagrawal> also reword the security consideration part
16:19:23 <phrobb> navinagrawal I agree with colindixon , it will be helpful to note why security is N/A... ie only sniffing for WTP discovery packets
16:19:27 <phrobb> thanks navinagrawal
16:20:23 <colindixon> #action navinagrawal to update the security section to say that security wasn’t considered in the first release
16:21:06 <colindixon> #action navinagrawal to remove “not applicable” from QA
16:21:07 <phrobb> nothing else from me for CAPWAP
16:21:11 <colindixon> I’m good too
16:21:19 <navinagrawal> #action nagrawal to remove Per-Edition  from capwap release note
16:21:43 <colindixon> vtn is up next
16:21:44 <navinagrawal> thanks folks
16:21:45 <colindixon> navinagrawal: thanks
16:21:49 <colindixon> #topic VTN
16:21:52 <hideyuki> #info Hideyuki for VTN
16:21:56 <hideyuki> #link https://wiki.opendaylight.org/view/OpenDaylight_Virtual_Tenant_Network_(VTN):Lithium_Release_Review
16:22:03 <hideyuki> #link https://wiki.opendaylight.org/view/OpenDaylight_Virtual_Tenant_Network_(VTN):Lithium_Release_Notes
16:24:03 * colindixon reads
16:25:03 <colindixon> hideyuki: this looks good, two questoins
16:25:18 <colindixon> 1.) should the workaround for 3818 be listed here?
16:25:29 <colindixon> 2.) does migration from Helium to Lithium work?
16:25:39 <phrobb> Agreed, nicely done hideyuki . One question from me...
16:26:09 <hideyuki> colindixon: 1) Should we write here? if we should, I'll write it. (Now, we write in the bugzilla.)
16:26:21 <colindixon> is it in the bugzilla?
16:26:30 <colindixon> if so, just say “see workaround in the bugzilla"
16:26:40 <hideyuki> colindixon: Ok.
16:27:22 <hideyuki> colindixon: 2) I'm not sure how to answer. VTN configuration (via REST API) is compatible between helium and Lithium.
16:27:23 <phrobb> hideyuki: is it worth noting VTN support for NIC in your release notes?... given that in a sense NIC is a new abstraction/interface to VTN?
16:27:42 <colindixon> #action hideyuki to add either the description of the workaround for 3818 to the release notes/review or say see the bugzilla notes for the workaround
16:27:57 <hideyuki> phrobb: I see. I'll add this note.
16:28:07 <hideyuki> colindixon: Ok.
16:28:22 <colindixon> #info colindixon asks about compatibility with Helium, hideyuki says the REST API to VTN is the same
16:28:51 <colindixon> #action hideyuki to add a section noting that other than that the REST API is the same, compatibility with Helium is unknown and untested
16:29:04 <colindixon> hideyuki: unless you have something more nuanced to add there
16:29:12 <colindixon> #action hideyuki to note that VTN supports the NIC interface in Lithium
16:29:14 <colindixon> cool
16:29:17 <colindixon> anything else?
16:29:23 <phrobb> not from me...
16:29:35 <colindixon> hideyuki: ?
16:29:37 <LuisGomez> not from me
16:29:44 <hideyuki> not from me.
16:30:01 <phrobb> Other than to say what an absolute pleasure it is to have all PTLs on time and prepared... we actually stay right on the 10 minute/project timeline..  You all are AWESOME
16:30:15 <jburns> iotdm?
16:30:37 <phrobb> ah jburns... sorry... did not mean to forget iotdm
16:30:44 <jburns> :-)
16:31:09 <colindixon> #topic iotdm
16:31:12 <colindixon> sorry
16:31:13 <colindixon> jburns:
16:31:26 <colindixon> #link https://wiki.opendaylight.org/view/Iotdm:Lithium_Release_Review release review
16:31:30 <colindixon> #link https://wiki.opendaylight.org/view/Iotdm:Lithium_Release_Notes release notes
16:31:34 * colindixon starts reading
16:31:57 <LuisGomez> iotdm has a basic csit failing: https://jenkins.opendaylight.org/releng/view/CSIT-1node/job/iotdm-csit-1node-cds-basic-only-stable-lithium/
16:32:02 <LuisGomez> is this expected?
16:32:48 <colindixon> #action jburns to remove the “draft” statement from the top of the release notes
16:32:56 <jburns> The guys have been stuggling to get the robot tests running properly, so maybe?  This will continue to be an ongoing effort and I do not rely (yet) on it to determine the quality of the release.
16:33:21 <LuisGomez> jburns, ok, just wanted to double-check
16:33:35 <colindixon> #info LuisGomez asks if a failing CSIT test is expected, jburns says maybe, they are still working on quality given that it’s the first release, they don’t see it as blocking
16:33:38 <colindixon> jburns: does that sound right?
16:33:46 <jburns> yes
16:34:08 <colindixon> it’d be nice if the bugs had numbers/links next to them
16:34:16 <jburns> ok
16:35:17 <jburns> We will be doing integration w/ other vendors soon so I expect more issues to arise.  The specs are stillin flux so interpretations of the specs will be interesting.
16:35:20 <colindixon> in the future, you could provide a much shorter set of things for the release review, but I appreciate the depth
16:36:03 <phrobb> as did I...
16:36:26 <colindixon> in general, the idea is to cover any known architectural deficiencies, not a description of the architecture :p but it’s all good
16:36:36 <colindixon> it’s new in Lithium, so no migration issues
16:36:39 <colindixon> I’m happy
16:37:02 <jburns> great, its been fun and will continue to be!
16:37:10 <phrobb> For the release notes, are there any further suggestions/work-arounds that can be provided to users who hit these issues?
16:37:36 <phrobb> ... on the Know Issues/Limitations section that is
16:38:26 <colindixon> jburns: still there?
16:38:31 <jburns> I’ll relook at each one, and write some text if it makes sense.
16:38:44 <phrobb> Great! Much appreciate jburns
16:38:54 <colindixon> #action jburns to provide some guidance about the bugs and how to work around them for users as appropriate for bugs in the release notes
16:38:55 <colindixon> cool
16:38:59 <colindixon> I think we’re done here fols
16:39:02 <colindixon> folks
16:39:04 <jburns> Great!
16:39:09 <colindixon> I’ll restate what phrobb said above
16:39:12 <phrobb> #action jburns  to look at "known Issues" and provide more context and work arounds as appropriate
16:39:16 <colindixon> on time all the way through
16:39:22 <phrobb> just did I think colindixon
16:39:41 <phrobb> yea, I find that remarkable given the number of 10 minute meetings we just had
16:39:43 <colindixon> anything else?
16:39:44 <LuisGomez> colindixon and all, any mention to freeze the stable/lithium until we tag the release?
16:39:47 <phrobb> not from me
16:40:11 <LuisGomez> do we need to do that or not?
16:40:14 <colindixon> we already said patches other than blocking bugs should not go into stable/lithium
16:40:17 <colindixon> we can say it again
16:40:28 <colindixon> we have one blocking bug that we don’t know if it’s fixed or not in RC2
16:40:37 <colindixon> #endmeetiing
16:40:44 <colindixon> #endmeeting