16:02:12 <tbachman> #startmeeting md_sal_hackers
16:02:12 <odl_meetbot> Meeting started Mon Jan  5 16:02:12 2015 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:12 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:12 <odl_meetbot> The meeting name has been set to 'md_sal_hackers'
16:02:58 * tbachman looks for the last meeting minutes of 2014
16:03:03 <tbachman> November?
16:03:24 <tbachman> ah, december 1st
16:03:27 <tbachman> different name
16:03:42 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2014/mdsal_hackers/opendaylight-meeting-mdsal_hackers.2014-12-01-16.05.html minutes from last MD-SAL hackers meeting
16:03:58 <tbachman> #topic action items
16:05:38 <tbachman> #undo
16:05:38 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x2849c50>
16:05:42 <tbachman> #topic tutorial
16:06:08 <tbachman> #info jmedved says that he and John Burns worked on the tutorial over the break
16:06:24 <tbachman> #info jmedved said they took the tutorial from keith and structured a bit differently for better flow
16:06:45 <alagalah_> yes
16:10:37 <tbachman> #info jmedved says they changed the structure of the chapters a little bit, but not much, with the idea being to use even smaller chunks than originally thought
16:10:46 <tbachman> #info chapter 0 is to get the user familiar with karaf and poms
16:11:36 <tbachman> #info it also creates an empty feature that can be installed on a karaf distribution that gets built
16:12:28 <tbachman> #info chapter 1 starts putting in the java code, where a skeleton java impl is created that does nothing but create/print an entry in the log
16:12:51 <tbachman> #info chapter 2 starts doing the toaster implementation with “real code”. jmedved says he was able to get this to build
16:13:28 <tbachman> #info this doesn’t do notifications b/c there’s nothing on the outside that can test the notifications
16:14:39 <tbachman> #info chapter 2 is divided into 4-5 sections, starting with RPCs, then writing transactions to data store, using REST calls to check the data changes, and finally putting in the whole toaster functionality
16:14:52 <tbachman> #info chapter 3 will introduce the consumer, which will include notifications
16:14:57 <tbachman> #info chapter 4 will include the testing
16:15:17 <tbachman> #info jmedved and John Burns have only completed up to chapter 2
16:15:54 <tbachman> #info jmedved would like to get something out and get the archetype out, as people are starting to write their applications and we want to have this available to help people develop using a “good” structure
16:16:27 <tbachman> #info jmedved asks if edwarnicke can help with the archetype and alagalah can help with a TWS session
16:16:56 <tbachman> #info edwarnicke says he’s been working on an example app, and has been pushing patches to help iron out the “hard” parts of the example app
16:17:58 <tbachman> #info edwarnicke has pushed a patch to clean up the deprecated methods in providers and consumers to help reduce confusion
16:19:45 <tbachman> Happy 2015 everyone, btw! :)
16:20:38 <tbachman> #info jmedved says his changes aren’t in yet for chapter 2 (needs write access to John’s github account)
16:23:17 <tbachman> #info alagalah asks if there’s anything in a wiki that describes this right now
16:23:22 <tbachman> #info jmedved says not yet
16:25:54 <tbachman> #info edwarnicke says that when his changes get merged, the only thing you’ll need in your provider is onSessionInitiated()
16:26:45 <tbachman> #info alagalah says he’ll try to write a step-by-step wiki based on what’s in each chapter
16:27:01 <tbachman> #info jmedved says he’ll start writing the text and providing it to alagalah
16:27:15 <tbachman> #info alagalah says he’s sent a project proposal out as well
16:28:29 <tbachman> #action jmedved to send .zip file to alagalah of his version of the tutorial
16:28:43 <tbachman> #action alagalah to take jmedved’s output and put it in the wiki
16:30:02 <tbachman> #info jmedved asks if pantelis can look at the writeup to make sure that nothing from the current writeup is lost
16:30:23 <tbachman> #action pantelis to proofread and check the wiki writeup
16:32:57 <tbachman> #info jmedved asks if edwarnicke can help in the description of the pom.xml files
16:33:20 <tbachman> #info edwarnicke says that with the patches, there’s almost nothing being done there, which will make the archetypes better
16:34:04 <tbachman> #info edwarnicke says there are often a ton of workaround things done in poms (e.g. with karaf, had to hack poms to do workarounds); if we correct these in the parent, then this fix goes everywhere, which makes things much easier
16:34:48 <tbachman> #info jmedved says we need to find a repo for all of this before we have a project; will use John’s or alagalah’s github accounts for now
16:34:59 <tbachman> #info jmedved asks if we’d be ready for next week’s TWS call
16:35:13 <tbachman> #info alagalah says to be on the safe side, he’d shoot for 2 weeks from today
16:35:40 <tbachman> #info jmedved says this will also give us time to write some code for the consumer and notifications, and possibly testing as well
16:35:57 <tbachman> #info jmedved asks if edwarnicke could have the archetype ready in 2 weeks
16:36:15 <tbachman> #info edwarnicke says he thinks so, with the caveat is that the bottleneck is getting reviewers to look at the patches
16:37:31 <tbachman> #info jmedved says we probably won’t have the morning meetings before next monday, but we’ll sync up on email, IRC, etc. during the week
16:38:54 <tbachman> #endmeeting