#opendaylight-meeting: MD-SAL interest call

Meeting started by devinavery at 16:01:36 UTC (full logs).

Meeting summary

  1. bug scrub into (devinavery, 16:05:20)
    1. Carol is presenting bugzilla - looking to clean up the categories into ad-sal vs md-sal (devinavery, 16:06:07)
    2. carol notice clustering bugs were being filed under MD-SAL so proposing to move remaining clustering bugs out (devinavery, 16:06:53)
    3. Proposing karaf, mdsal, adsal, config, netconf, restconf would be the top level items, and rest would move to one of the other headers (devinavery, 16:08:16)
    4. colindixon, tony and pantelis__ seem to be leaning toward having a clustering component as well as things (colindixon, 16:10:10)
    5. tony says that config is the config subsystem and configuration should drift to the AD-SAL (colindixon, 16:11:04)
    6. colindixon notes that if it’s easier, we could just rename the deprecated components to zarchived-${name} (colindixon, 16:12:51)
    7. ACTION: tony says he’ll help doing the component cleanup (colindixon, 16:13:05)

  2. bug scrub (colindixon, 16:16:07)
    1. tony says that there are 102 bugs in config, mdsal, netconf, other, and restconf that target Lithium right now (colindixon, 16:17:13)
    2. pantelis__ notes that some of them appear grey (meaning they’re enhancements) and thus might or might not be aplicable (colindixon, 16:18:12)
    3. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&bug_severity=enhancement&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_severity%2Ccf_issue_type%2Cshort_desc%2Cbug_status%2Cpriority%2Cdeadline%2Ccf_target_milestone&component=config&component=mdsal&component=netconf&component=other&component=restconf&f1=cf_target_milest (ttkacik1, 16:18:19)
    4. note that incoming bugs usually don’t have a target milestone and tony usually gives them one in the morning (there are usually 3-4 such bugs per day) (colindixon, 16:19:26)
    5. there are 30 bugs in yangtools that target Lithium (colindixon, 16:20:27)
    6. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&bug_severity=enhancement&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_severity%2Ccf_issue_type%2Cshort_desc%2Cbug_status%2Cpriority%2Cdeadline%2Ccf_target_milestone&component=config&component=General&component=mdsal&component=netconf&component=other&component=restconf&f (ttkacik1, 16:21:06)
    7. the above link is 132 bugs spanning yangtools and controller that we’re trying to fix (colindixon, 16:21:37)
    8. catohornet asks what it means if the assignee is bugs@lists.opendaylight.org, tony says that’s basically “unsassigned” as it’s the default value (colindixon, 16:24:00)
    9. catohornet also asks how determine the severity, ttkacik1 (tony) says that generally they don’t change them and just trust the reporter to have it right (colindixon, 16:25:17)
    10. ttkacik1 says he’d like to use the first 20-30 minutes of this MD-SAL weekly call to do bug scrubbing (colindixon, 16:25:42)
    11. ttkacik1 says he’d also like to do a Thursday meeting to do bug scrubs (colindixon, 16:26:27)
    12. colindixon notes that based on the combined ODL calendar, there are no meetings after the TSC meeting on Thursday, but that there are meetings from 8-11a pacifc (integration, aaa, dlux, sfc, and tsc) (colindixon, 16:27:47)

  3. performance/bugs in addresses in controller/yantools (colindixon, 16:28:14)
    1. Anton starts presenting around 24:30 in the recording for those who want to start here (colindixon, 16:29:32)
    2. anton notes that addresses (showing IPv6 right now) are stored in the form of the text entered, which means that there can be two addresses that match the regex and are different strings, but represent the same address (colindixon, 16:30:34)
    3. that includes IPv6, mac, IPv6 address, etc. (colindixon, 16:30:48)
    4. beyond that, there’s some issues where in the java code we try to convert IPv6 addresses to IPv4 addresses if they look like IPv4 addresses (colindixon, 16:35:28)
    5. from the performance side, we are converting everything to strings which takes ~60 microseconds of latency (and also cpu) per handling of such addresses, which can add up (colindixon, 16:36:31)
    6. Anton proposes that we store such addresses in a canonicalized format and use hand written code to do things quickly and correctly (colindixon, 16:37:47)
    7. https://git.opendaylight.org/gerrit/#/c/18450/ this is the patch that contains the code (colindixon, 16:38:00)
    8. Anton notes that he’s bringing this up because he knows that it will break things (colindixon, 16:39:17)
    9. Anton says he’s testing openflow{plugin,java}, controller, and bgpcep with and without this code (colindixon, 16:40:19)
    10. Anton notes that most projects don’t have enough unit tests to reasonably guess as to whether or not he’s broken things (colindixon, 16:43:59)
    11. rovarga and colindixon offer ways to build all projects with the modified yangtools (colindixon, 16:47:34)
    12. https://wiki.opendaylight.org/view/String_data_normalization_and_alternative_storage a design effort provided by rovarga on the same topic (colindixon, 16:51:21)
    13. there is some debate between anton and rovarga about how to properly get codecs for this (colindixon, 16:53:10)
    14. rovarga wants to have the generated code stay generated and refer to hand-written code in a known way (this is currently done for unions) (colindixon, 16:54:08)
    15. tony and rovarga note that this handwritten code won’t help for the BindingIndependent format for anything since the only modifications are to the BindingAware code (colindixon, 16:55:12)

  4. wrap up (colindixon, 16:58:54)
    1. colindixon says it seems we have two questions: (1) do we fix this in Lithium, and (2) do we fix it using BindingAware, BindingIndependent, or both (colindixon, 16:59:42)
    2. colindixon says it seems we have two questions: (1) do we fix this in Lithium, and (2) do we fix it using BindingAware, BindingIndependent, or both (colindixon, 16:59:52)
    3. Anton says that, in his opinion, we can’t claim IPv6 compatibility for Lithium if we don’t fix it in Lithium (colindixon, 17:00:47)
    4. Anton says he thinks that fixing the BindingAware will help fix a lot of the bugs now even if it’s not ideal (colindixon, 17:01:17)
    5. ACTION: anton to try to look into dealing with BindingIndependent solutions (and what the polymorphic solution) would look like (colindixon, 17:02:13)
    6. ACTION: anton and/or rovarga to send this to the mailing list to figure out how to proceed w.r.t. to the two above questions (colindixon, 17:02:50)


Meeting ended at 18:38:41 UTC (full logs).

Action items

  1. tony says he’ll help doing the component cleanup
  2. anton to try to look into dealing with BindingIndependent solutions (and what the polymorphic solution) would look like
  3. anton and/or rovarga to send this to the mailing list to figure out how to proceed w.r.t. to the two above questions


People present (lines said)

  1. colindixon (45)
  2. devinavery (8)
  3. odl_meetbot (5)
  4. ttkacik1 (2)
  5. dbainbri (1)


Generated by MeetBot 0.1.4.