16:07:58 <colindixon> #startmeeting MD-SAL Interest Call
16:07:58 <odl_meetbot> Meeting started Tue May 12 16:07:58 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:07:58 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:07:58 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:08:03 <colindixon> #topic agenda bashing
16:08:06 <colindixon> #chair catohornet
16:08:06 <odl_meetbot> Current chairs: catohornet colindixon
16:08:39 <colindixon> #info first bug scrub
16:08:46 <colindixon> #undo
16:08:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1bac290>
16:09:07 <colindixon> #info last week we talked about one bug and then we went into how do the upgrade process
16:12:37 <colindixon> #topic upgrading
16:13:14 <colindixon> #info colindixon says that the he feels like being able to upgrade from Helium to Lithium with somewhat predicitble outcomes at least for “key” projects
16:13:24 <colindixon> #info but nobody has stepped forward to do that yet
16:14:06 <colindixon> #info tony says that if this is *the* most important thing people can work on it, but it will lower the bug fix rate for other critical fixes
16:16:11 <colindixon> #info colindixon says that if the implication is that we will not be able to fix all the critcal bugs by the time Lithium ships, that’s a different problem
16:16:43 <colindixon> #info tony says that’s not necessarily true, but his experience is that between RC0 and RC1 he expects to see a lot of blocking bugs
16:16:56 <colindixon> #action colindixon to keep discussion about upgrading going on the mailing list
16:18:43 <colindixon> #info pantelis says one idea would be pushing this support for upgrading from Helium to Lithium to being a Lithium-SR1 feature
16:19:27 <colindixon> #info tony says first things first, we need to do the Karaf upgrade and the controller and from that we’ll have a better idea of what other projects might have to care about
16:20:20 <colindixon> #info pantelis asks if we can ask projects to enumerate what they think their upgrade issues are, e.g., data model changes, config yang changes, etc.
16:20:53 <colindixon> #action colindixon to find a place on the wiki/bug to track progress as we discover the scope and issues
16:20:58 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=3160 this is the bug in question
16:22:05 <colindixon> #topic how/when are bugs closed
16:22:18 <colindixon> #info catohornet asks when/how are bugs closed? should we update them during the meeting?
16:26:38 <colindixon> #info tony says that, in general, older bug number it’s something which is deemed to be “easy” and/or less critical to the release
16:27:44 <colindixon> #info two bugs that are easy for people are: 568 and 1510
16:29:02 <colindixon> #info more complex ones, but still easier than most are the restconf ones that are somewhat less involved
16:29:05 <colindixon> #topic bug scrub
16:30:37 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=2970 is critical, and will we worked on Tony, Robert, Moiz or pantelis
16:35:19 <ttkacik2> #link  https://bugs.opendaylight.org/show_bug.cgi?id=2521 - SImple, mentor Vaclav Demcak or Tony Tkacik
16:35:40 <colindixon> perfect
16:37:24 <ttkacik2> #link  https://bugs.opendaylight.org/show_bug.cgi?id=2816 - Restconf or Yangtools yang-data-codec-gson - throw correct exception - simple one
16:40:02 <ttkacik2> #link  https://bugs.opendaylight.org/show_bug.cgi?id=2819 - Simple, just proper log / report exception in controller/netconf
16:51:46 <ttkacik2> #link  https://bugs.opendaylight.org/show_bug.cgi?id=2375 - Trivial if Tony Tkacik is mentor - it is just introduction of caching to one operation
17:22:04 <ttkacik2> #info Mentor : Tony Tkacik <ttkacik@cisco.com> ttkacik[0-9]? on IRC
18:18:00 <catohornet> #endmeeting