16:03:34 <colindixon> #startmeeting md-sal interest call
16:03:34 <odl_meetbot> Meeting started Tue Jun  2 16:03:34 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:34 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:34 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:03:40 <colindixon> #topic agenda bashing
16:04:38 <colindixon> #link https://lists.opendaylight.org/pipermail/controller-dev/2015-June/009557.html the e-mail from colindixon that catohornet asked about showing bugs
16:24:29 <colindixon> #topic bug scrub
16:29:46 <hideyuki> Bug 3344 is a blocking bug which cause an issue on VTN project.
16:29:53 <hideyuki> https://bugs.opendaylight.org/show_bug.cgi?id=3344
16:34:09 <colindixon> hideyuki: thanks for pointing this out
16:34:43 <hideyuki> The bug 3344 is really problem for VTN project.
16:36:38 <colindixon> hideyuki: are you on the audio?
16:37:32 <colindixon> #info colindixon says that there are 3 different lists, the list of Lithium-targeted and the list of Helium-targeted seem somewhat under control
16:38:10 <colindixon> #info the list of bugs with no target milestone are more worrying
16:38:25 <hideyuki> colindixon: no.
16:38:30 <colindixon> hideyuki: tony says that he’s having difficulty reproducing the bug, but still trying
16:38:48 <colindixon> he has seen it, but he’s having trouble finding a root cause because it doesn’t occur frequently
16:39:03 <ttkacik> hideyuki: how do you import your project into eclipse?
16:39:12 <hideyuki> colindixon: As I mentioned in the bugzilla, the I frequently observed this issue.
16:39:13 <ttkacik> I always get NullPointerException from maven in eclipse
16:39:30 <ttkacik> and also are you using JNI in vtn?
16:39:35 <hideyuki> ttkacik: I never tryied to import vtn project into eclipse.
16:40:08 <hideyuki> ttkacik: I think yes.
16:40:32 <hideyuki> ttkacik: you should do "mvn install" in the directory of manager of vtn.git.
16:41:12 <hideyuki> ttkacik: since the coordinator directory of vtn.git build not-karaf-feature component.
16:41:38 <hideyuki> ttkacik: the manager directory of the vtn.git build a karaf feature.
16:42:07 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=3344 hideyuki says that this bug is blocking VTN
16:43:05 <colindixon> #info ttkacik and hideyuki talk some about how to consistenly reprodcue the bug to get it resolved
16:43:14 <hideyuki> ttkacik: At least, when I tried on 05/22, I frequently observed the bug 3344. And, I wrote the procedure to reproduce the issue on hte bugzilla.
16:44:15 <hideyuki> ttkacik: But, I don't try the prcedure in this week, so I'm not sure if the bug is occurred with the latest artifacts. I know there are a lot of patches are merged recently, so something may be cahnged.
16:45:10 <catohornet> #info bug 2376  https://bugs.opendaylight.org/show_bug.cgi?id=2376
16:45:36 <colindixon> #info catohornet leads everyone through trying to “resolve” the older bugs that have no target milestone, for most of the older bugs the resoution is either “fixed” because they were fixed, but the bugs weren’t updated or “wontfix” because they’re seemingly no longer relevant, or not important enough to fix in deprecated code
16:49:52 <colindixon> #info hideyuki says that “mvn clean install” in the manager directory of vtn.git would reproduce bug 3344 as of 5/22, that might help ttkacik, but hideyuki will also try to reproduce it recently
16:50:08 <hideyuki> colindixon: no.
16:50:19 <colindixon> hideyuki: did I get this wrong?
16:50:23 <colindixon> #undo
16:50:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x18d7e10>
16:50:30 <colindixon> you can #info something that’s right
16:50:32 <hideyuki> colindixon: I'm really sorry for making confusing.
16:50:45 <colindixon> no, no, it’s all good
16:51:55 <hideyuki> #info As written in the bugzilla <https://bugs.opendaylight.org/show_bug.cgi?id=3344>, the bug 3344 was repeatedely reproceded on integration.git as of 5/22.
16:52:18 <hideyuki> #info I will try to reprocude it today
16:53:58 <hideyuki> #info FYI: "mvn clean install" in the manager directory of vtn.git is a easy way to build VTN Manager features (Karaf features). But, to reprocude the bug 3344, you don't need to use the vtun.git. You can use a karaf distribution on integration.git, since its contains VTN Manager features.
16:54:28 <hideyuki> colindixon: Thanks!
16:55:11 <hideyuki> (many topos... sorry.)
16:55:30 <hideyuki> (many typos......... sorry.)
16:57:21 <colindixon> it’s all good
16:57:25 <colindixon> #undo
16:57:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b94f10>
16:58:01 <colindixon> #info hideyuki says "mvn clean install" in the manager directory of vtn.git is an easy way to build VTN Manager features (Karaf features). But, to reprocude the bug 3344, you don't need to use the vtn.git. You can use a karaf distribution on integration.git, since its contains VTN Manager features.
17:07:41 <colindixon> #action colindixon to make one pass through the bugs to try to resolve them and/or bin them by who could resolve them
17:08:58 <colindixon> #endmeeting