#opendaylight-meeting: MD-SAL interest call

Meeting started by colindixon at 16:08:02 UTC (full logs).

Meeting summary

  1. yang extensions bug (colindixon, 16:08:07)
    1. shaleen saxeena says he’s run into a bug with parsing yang extensions (colindixon, 16:08:38)
    2. shaleen asks if there’s a test case he can modify to try to check how things work (colindixon, 16:10:22)
    3. ttkacik says that he suggests looking at yang-parser-impl (colindixon, 16:11:01)

  2. new bug states (colindixon, 16:11:07)
    1. greg hall says that he’s in the process of gettina MORE_INFO_NEEDED bug state (colindixon, 16:11:30)
    2. he also suggests that we turn off the automatic state for CONFIRMED, and we’d like like to make things land in the UNCONFIRMED state so that we can better do triage (colindixon, 16:12:15)
    3. ttkacik says as long as we can do that for the controller and yangtools without affecting other projects, we should (colindixon, 16:12:27)
    4. ACTION: greg hall will file a ticket now to make that change assuming that we can do it only for controller, mdsal, netconf, and yangtools (colindixon, 16:13:02)
    5. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 (colindixon, 16:13:46)
    6. it looks like there are no Lithium-blocking bugs in controller/yangtools (colindixon, 16:14:10)

  3. questions about NETCONF (colindixon, 16:14:38)
    1. catohornet says that internally she’s trying to use PUT in Ltihium and finding that it doesn’t work (colindixon, 16:15:06)
    2. ttkacik says that it depends, there was a bug in Helium and it was fixed and if you were exploiting that behavior, it might not work in Lithium despite working in Helium (colindixon, 16:16:00)
    3. ttkacik says that PUT didn’t behave in Helium like it was defined in the spec (colindixon, 16:16:39)
    4. ACTION: catohornet will provide more details about how PUT is failing with NETCONF in Lithium (colindixon, 16:17:15)
    5. https://lists.opendaylight.org/pipermail/controller-dev/2015-June/009557.html the mail with bugzilla queries (colindixon, 16:17:52)

  4. topics for the Design summit (colindixon, 16:38:31)
    1. https://lists.opendaylight.org/pipermail/controller-dev/2015-June/009683.html thread on the topic (colindixon, 16:39:37)

  5. cookies (colindixon, 16:46:18)


Meeting ended at 16:46:22 UTC (full logs).

Action items

  1. greg hall will file a ticket now to make that change assuming that we can do it only for controller, mdsal, netconf, and yangtools
  2. catohornet will provide more details about how PUT is failing with NETCONF in Lithium


People present (lines said)

  1. colindixon (25)
  2. odl_meetbot (4)
  3. hideyuki (3)
  4. ttkacik (2)


Generated by MeetBot 0.1.4.