16:23:39 <colindixon> #startmeeting MD-SAL Interest Call
16:23:39 <odl_meetbot> Meeting started Tue Aug 25 16:23:39 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:23:39 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:23:39 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:23:49 <colindixon> #topic status update on breaking out MD-SAL
16:24:21 <colindixon> #info code was copied from yangtools and controller into MD-SAL yesterday
16:24:32 <colindixon> #info sometime in the next week the code will be removed from the source projects
16:25:42 <colindixon> #info the old, backward-compatible APIs will stay in the controller project and will be implemented on top of the newer APIs stored in the mdsal project
16:26:13 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=4185 this bug tracks the idea of using Lithium code to test backward compatiblity
16:26:25 <colindixon> #topic deprecating the inventory model
16:26:41 <colindixon> #info this will affect a lot of projects
16:27:08 <colindixon> #info vishnoianil notes that there are two problems: (1) moving from inventory to topology, (2) moving from old topology to new topology
16:27:30 <colindixon> #info vishnoianil notes that it might be easier to do both at the same time
16:30:17 <colindixon> #info rovarga says that this might be harder since the scope of moving topology models is broader than the inventory model
16:30:35 <colindixon> #link https://youtu.be/UDVWVLLtFoI ttkacik presenting on the newer topology models
16:31:19 <colindixon> #info moiz asks “If we do not populate inventory then how do external apps (that is apps that were not built as part of the ODL project) deal with the topology being populated instead of inventory?”
16:31:45 <colindixon> #info colindixon says that the inventory model should still be populated in Beryllium, but in Boron, yes
16:33:49 <colindixon> #info colindixon asks if the new topology model will mask the old one in RESTCONF because RESTCONF only give access to the most recent revision
16:34:43 <colindixon> #info ttkacik says that isn’t an issue because the new topology has a different name
16:35:20 <colindixon> #action colindixon to add this to the TSC agenda at least as a warning of what’s abou tto come
16:37:37 <colindixon> #info vishnoianil suggests starting a thead on this now
16:40:35 <colindixon> #info rovarga says that next tuesday is a public holiday in slovakia, so we should schedule the 9/8 meeting of MD-SAL to talk about this following up on this progress and the mailing list
16:43:28 <colindixon> #topic cookies
16:43:30 <colindixon> #endmeeting