16:04:24 <colindixon> #startmeeting MD-SAL interest call
16:04:24 <odl_meetbot> Meeting started Tue Oct 20 16:04:24 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:04:24 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:24 <odl_meetbot> The meeting name has been set to 'md_sal_interest_call'
16:05:49 <colindixon> #topic agenda
16:06:17 <colindixon> #info Stephen Kitt's e-mail on what happened this week in code
16:06:26 <colindixon> #info Real world NETCONF device in Beryllium
16:06:40 <colindixon> #info Jersey Upgrade: Bug 4502 odl-tsdr-cassandra-persistence depends on non-odlparent guava version
16:06:48 <colindixon> #topic jersey upgrade
16:07:32 <colindixon> #info rgouiding found a bug with guava/cassadra versions in TSDR making upgrading jersery hard, he's working on it
16:07:59 <colindixon> #info version missmatch (on guava) when installing the feature, may require upgrading the cassandra plugin
16:08:14 <colindixon> #info it's delaying the jersey upgrade
16:10:57 <colindixon> #topic stephen kitt's weekly summary of code changes
16:11:19 <colindixon> #link https://lists.opendaylight.org/pipermail/dev/2015-October/001333.html
16:11:37 <colindixon> #info two things for YANG tools seem maybe relevant
16:11:53 <colindixon> #info 1. Leaf references no longer have a default value, as per RFC 6020.
16:12:08 <phrobb_> To whomever was asking about the TWS recording from this week.  It is now on the TWS wiki page, and the link direct link is here: https://meetings.webex.com/collabs/url/vmEyFTg5E0d_q6B4GhsQX4Wj57zVGp67L9mIS-7NDyK00000
16:12:17 <colindixon> #info 2. Mis-matched module/submodule revisions no longer cause a NullPointerException (but you should still fix the revisions!).
16:13:34 <colindixon> #info rovarga says that (1) above was removing pre-hydrogen code that didn't completely work and thus people couldn't have been using it
16:15:09 <colindixon> #topic real world NETCONF devices aren't mounting in Berryllium
16:15:54 <colindixon> #info ghall says that he's working with a lot of people who are using ODL to mount NETCONF devices to call RPCs, etc. and write apps using that
16:16:30 <colindixon> #info ghall is running into issues that real devices that claim to support NETCONF don't always follow the spec perfectly, and even when they do sometimes interpret the spec the same way that ODL does
16:16:45 <colindixon> #info ghall says he'd like to see us be tolerant of non-strict yang
16:17:12 <colindixon> #link https://lists.opendaylight.org/pipermail/netconf-dev/2015-October/000066.html thread on the netconf-dev list raising this issue
16:19:06 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=4492 this is the related bug
16:20:05 <colindixon> #info ghall and maros seem to be saying having a passthrough to get the data back from a NETCONF device without parsing it (at least strictly) assuming we can mount it
16:22:53 <colindixon> #info rovarga asks how this would work for things other than RESTCONF, e.g., reading from Binding Aware types
16:23:28 <colindixon> #info rovarga notes that there are individual ways to to fix up individual models and that might be a better overall way to approach things
16:25:18 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/28511/ a (partial) patch to start fixing some of the issues
16:26:42 <colindixon> #info ghall is looking for a way to mount semi-compliant devices in the Beryllium time-frame, e.g., we should try to parse and deliver what data we can (maybe dropping just the yang which is invalid)
16:29:35 <colindixon> #info ghall says that in this case and many other cases this is clearly a bug with vendor code, in the idea world we would file the bug, get the bug fixed, and then end-users would upgrade before testing or using it with opendaylight
16:30:41 <colindixon> #info ghall says in the real world, that's not going to happen and we should figure out how much we want to inconvenience end-users who happen to have devices that aren't totally supporting NETCONF to the same strictness that OpenDaylight does
16:31:15 <colindixon> #info ghall says in practice this is causing him additional problems with values on a device being set outside their range in the YANG file
16:33:37 <colindixon> #info colindixon suggests that a good litmus test would be to ask "are we unnecessarily punishing end-users for their vendors poor behavior?"
16:33:51 <colindixon> #info if the answer is yes, then we should do our best to avoid doing that
16:34:58 <colindixon> #info it seems like at least allowing a user to choose (globally, per-model, per-something-else?) whether to allow for sloppy vs. strict enforcement so that they can do what a manually constructed NETCONF call could do
16:35:07 <colindixon> #undo
16:35:07 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x251c5d0>
16:37:33 <colindixon> #info it seems like at least allowing a user to choose (globally, per-model, per-something-else?) whether to allow for sloppy vs. strict enforcement so that they can do what a manually constructed NETCONF call could do would be a maybe a reasonable approach
16:38:21 <colindixon> #info ghall notes that right now in his day-to-day development effort he's able to do things with ncclient and get his work done there in a way he can't with NETCONF mounts in ODL
16:39:27 <colindixon> #info the discussion seems to revolve around the issue that if we allow sloppy mounting for devices, that potentially risks how apps and users perceive the system by compromising the strictness which the MD-SAL currently provides
16:41:07 <colindixon> #info ttkacik and rovarga ask if we allow a get-config to work despite not parsing strictly, will we allow a edit-config to allow for them to pass the same data back?
16:41:28 <colindixon> #info ghall says that he doesn't quite understand why we're even parsing when we make RESTCONF calls to YANG mounts
16:41:56 <colindixon> #info ttkacik says that's not quite true, you have to parse it to provide RESTCONF features, e.g., converting to JSON
16:42:40 <colindixon> #info ghall asks if we were asking for XML and XML only, could we allow for just a passthrough, ttkacik says yes, but that might confuse users by not allowing for RESTCONF JSON
16:46:23 <colindixon> #info colindixon says his take is that we're really talking about having a way to do a sloppy mount over NETCONF and provide the information to anyone who wants that it's a sloppy mount and could provide a reasonable trade-off between device compatibly and user/app expectations
16:47:01 <colindixon> #info rovarga says that this should all be doable today in the NETCONF project if we wanted to, he'd want to make sure that we track what things we've violated in the process of doing a sloppy mount
16:50:45 <colindixon> #info colindixon disagrees that we necessarily need a list of violations to have it be useful, a simple sloppy bit would be enough, but he's willing to agree to disagree
16:52:57 <colindixon> #info ghall says he'd like to work on this at the hackfest 11/9 and 11/10
16:53:27 <colindixon> #info rovarga asks if he can move BUG 4492 to the netconf project instead of yangtools, his take is that the issues raised can be fixed there
16:54:33 <colindixon> #info ghall says sure "as longs as we're happy returning a supposedly mounted, but useless NETCONF devices on an NPE"
16:56:11 <colindixon> #info ghall says basically there are still bugs in YANG tools to at least provide more meaningful error messages
16:59:14 <colindixon> #action ghall to rework his patch to allow for better errors and/or better mounting in YANG tools
16:59:18 <colindixon> #topic hackfest
16:59:33 <colindixon> #info ghall asks who from the MD-SAL core team will be there
16:59:45 <colindixon> #info none planning to come now
17:00:07 <colindixon> #info colindixon asks what would help them attend, rovarga asks for a concrete agenda and work items
17:00:31 <colindixon> #action phrobb to work with rovarga and ghall and others to develop a better agenda
17:00:34 <colindixon> #endmeeting