18:00:02 <colindixon> #startmeeting tsc
18:00:02 <odl_meetbot> Meeting started Thu Jan 22 18:00:02 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:02 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:02 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:03 <odl_meetbot> phrobb: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
18:00:10 <tbachman> ugh
18:00:10 <tbachman> lol
18:00:13 <colindixon> #topic roll call and agenda bashing
18:00:21 <tbachman> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda
18:00:24 <colindixon> thanks tbachman
18:00:28 <colindixon> #info colindixon
18:00:47 <tbachman> colindixon: np!
18:00:49 * colindixon notes that his internet is acting wonky, so he’s trying to get in
18:01:04 <phrobb> want to #chair a few of us colindixon?
18:01:56 <colindixon> #chair tbachman phrobb
18:01:56 <odl_meetbot> Current chairs: colindixon phrobb tbachman
18:02:06 <LuisGomez> #info LuisGomez
18:02:14 <alagalah> Call in 4
18:02:21 <ChrisPriceAB> #info Chris Price
18:02:28 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-01-15-18.00.html Minutes for last week’s meeting
18:02:30 <edwarnicke> #info edwarnicke
18:02:42 <mohnish> #info mohnish anumala
18:02:45 <ank> #info ankit
18:03:00 <tbachman> ank: info’s are only for TSC chairs
18:03:06 <Youcef> #info Youcef Laribi
18:03:09 <ank> sorry
18:03:10 <Sachi> #info Sachi
18:03:18 <tbachman> Sachi: info’s are only for TSC chairs
18:03:26 <Sachi> ok
18:03:39 <colindixon> #action phrobb to find out if there are any projects in Helium that aren’t in Lithium, and look into setting up a condorcet vote on the policy of shipping security releases (as applies to Helium)
18:04:09 <tbachman> #info phrobb says there’s an update for Helium-to-Lithium participants
18:04:28 <regXboi> #info regXboi (running late to the webex)
18:04:36 <ShaunWackerly> With IRC and modem sounds I'm having serious flashbacks.
18:04:52 <tbachman> #info phrobb says the PCMM folks are working to get someone else into the code base with xsited (Thomas Kee)
18:05:17 <tbachman> #info Thomas Kee doesn’t have consistent time to dedicate to the project; phrobb has reached out to CableLabs to get another committer on the project
18:05:33 <tbachman> #info phrobb says they’ve missed the M1 deadline and will ask for an exception
18:05:38 * regXboi finally gets to webex
18:05:44 <tbachman> #info phrobb says there will probably not be any feature improvements — will just be maintenance
18:07:30 <tbachman> #topic Updates
18:08:25 <colindixon> https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/
18:08:42 <dlenrow> #info dlenrow
18:08:56 <dneary> Hi
18:09:03 <dneary> On IRC, but not on the call today
18:09:08 <colindixon> he dneary
18:09:11 <tbachman> can someone else take over for a bit
18:09:15 <tbachman> I’ll be back in a few
18:10:27 <colindixon> #info the call for proposals/talks/papers for the ODL summit is due on 2/5?
18:10:35 <colindixon> #info there’s a tech track at the ONS for ODL
18:10:45 <mohnish> Luis, can you point me to the meetup info? thanks.
18:11:02 <colindixon> #info still scehduling hack fest on 4/14-4/15, venue to be locked down
18:11:11 <colindixon> #info india hackfest/event plannign for 4/18
18:11:46 <colindixon> #info there is a integration meetup at Brocade in San Jose on 1/27–1/28
18:13:46 <colindixon> #info at the moment, we don’t have a build and integration test result to vote on approving a Helium-SR2 release
18:13:49 * rovarga has to apologize for breaking the world with a last-minute cherry-pick :-(
18:14:45 <LuisGomez> #info link for integration gathering:
18:14:49 <LuisGomez> #link https://lists.opendaylight.org/pipermail/integration-dev/2015-January/002179.html
18:14:49 <phrobb> #startvote Shall the TSC have a special mtg on Monday for Helium SR2? -1, 0, +1
18:14:49 <odl_meetbot> Begin voting on: Shall the TSC have a special mtg on Monday for Helium SR2? Valid vote options are -1, 0, +1.
18:14:49 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:15:05 <colindixon> #vote 0
18:15:26 <edwarnicke> #vote -1
18:15:28 <mohnish> #vote 0
18:15:29 <ChrisPriceAB> #vote 0
18:15:30 <regXboi> #vote -1
18:15:34 <RajeevK> #vote 0
18:15:36 <tykeal> mixed bag
18:15:54 <LuisGomez> #vote 0
18:16:04 <dlenrow> #vote 0
18:16:11 <colindixon> #endvote
18:16:11 <odl_meetbot> Voted on "Shall the TSC have a special mtg on Monday for Helium SR2?" Results are
18:16:11 <odl_meetbot> 0 (6): dlenrow, LuisGomez, ChrisPriceAB, RajeevK, mohnish, colindixon
18:16:11 <odl_meetbot> -1 (2): edwarnicke, regXboi
18:16:12 <phrobb> #endvote
18:16:27 <phrobb> #agreed TSC will review Helium SR2 next Thursday
18:17:36 <colindixon> shague: are you on the call?
18:17:42 <LuisGomez> mohnish: i pound link for the integration meeting next week
18:18:37 <phrobb> #info AD-SAL deprecation is ongoing, VTN has been working, OVSDB status is unknown currently
18:18:57 <colindixon> #action colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
18:19:41 <colindixon> #info edwarnicke says he’s pushed a patch that actually depreates the AD-SAL mechnically in java, it’s not merged yet
18:21:09 <phrobb> #info colindixon notes there is a deprecation policy in Lithium where functionality is deprecated in one release and removed in the following release
18:21:48 <rovarga> regXboi: that is something new ... how did you arrive at Boron?
18:21:49 <phrobb> #info edwarnicke notes that the patch doesn't remove anything.  It just marks the APIs as deprecated so that it is clear they are on their way out
18:22:29 <regXboi> rovarga: my memory of the process, which may be wrong
18:22:31 <phrobb> #info regXboi states that even if AD-SAL is deprecated in Lithium, they functions should not be removed until Boron.
18:22:45 <regXboi> phrobb: not should -> may not be able to be
18:23:07 <rovarga> edwarnicke: +1, that's how we have been operating H -> He.
18:23:27 <phrobb> #info colindixon and edwarnicke believe their intent was to deprecate in one release and remove in the next release
18:23:45 * regXboi asks for chair rights to correct the record!
18:23:53 <edwarnicke> #info edwarnicke does not recall being the one to express intent on the deprecation process ;)
18:24:05 <colindixon> #info tykeal says he’s still working on getting ODL Forge work
18:24:13 <colindixon> #info zxiiro says 20+ projects in JJB and more every week
18:24:20 <phrobb> #info Correction on regXboi statement above.  Not "should" but rather the AD-SAL functions may not be able to be moved until Boron… more a note of feasiblity
18:24:31 <regXboi> #info regXboi thanks phrobb
18:24:36 <phrobb> #chair regXboi
18:24:36 <odl_meetbot> Current chairs: colindixon phrobb regXboi tbachman
18:24:47 <colindixon> #topic committer promotions
18:25:11 <kwatsen> kwatsen is IRC only
18:25:15 <phrobb> dfarrell07:  you arond?… want to help with minutes?
18:25:58 <dfarrell07> phrobb: sure, /me was focused on work and lost track of time, sorry
18:26:53 * ChrisPriceAB phrobb, you can chair me in. my fingers are itching
18:26:54 <phrobb> #chair dfarrell07
18:26:54 <odl_meetbot> Current chairs: colindixon dfarrell07 phrobb regXboi tbachman
18:27:05 <phrobb> #chair ChrisPriceAB
18:27:05 <odl_meetbot> Current chairs: ChrisPriceAB colindixon dfarrell07 phrobb regXboi tbachman
18:27:23 * regXboi wants to start music for the musical chairs :)
18:27:31 <tykeal> colindixon: we did have a committer self-remove from several projects
18:27:37 * dfarrell07 is in the call
18:27:39 * ChrisPriceAB da dum, da dum
18:28:00 * regXboi listens to imaginary syncopated clock
18:28:49 <phrobb> #info colindixon asks is it critical to have a second committer now or is it possible to wait until Sachi has had more contributor experience
18:29:31 <ChrisPriceAB> #info Ankit responds that Sachi is important to the upcoming activity as a committer
18:30:26 <phrobb> #info colindixon will plugin2oc be cripled over the next couple of weeks without Sachi as a committer?
18:30:52 <ChrisPriceAB> #info there will be little impact on the project plan to wait for some contribution history for the nominated comitter.
18:31:12 <phrobb> #info answer - No, it is not that critical.  We can have Sachi gain more contributions before coming for Sachi's promotion to committer
18:31:30 <dfarrell07> we can #action that person (nic?) to follow up once the person has commits
18:32:26 <phrobb> #action Ankit from plugin2oc to follow up with TSC once Sachi has sufficient contribution history
18:32:30 <rovarga> I think the existence of a project leader changes the mechanics
18:32:34 <colindixon> "A Committer who is disruptive, or has been inactive for an extended period (e.g., six or more months) may have his or her Committer status revoked by the project leads."
18:32:42 <tykeal> FYI plugin2oc has not created a main wiki page and I noticed a modification of the committer list to the project proposal page around this which should not have been done
18:32:44 <dlenrow> My recollection is Project lead has discretion
18:33:07 <rovarga> dlenrow: +1, that is what I remember, too
18:33:53 <colindixon> #action colindixon to work out some more details and recommendations around removing committers
18:34:52 <dlenrow> Is there a cost to carrying a long term inactive commiter who is not disruptive?
18:35:04 <phrobb> #action colindixon and TSC to elaborate on proper procedure for removal of committers from a project
18:35:19 <dfarrell07> #topic Network Intent Composition creation review
18:35:22 <tykeal> dlenrow: not that I can see (provided they aren't disruptive)
18:35:34 <dfarrell07> #link https://wiki.opendaylight.org/view/Project_Proposals:Network_Intent_Composition Project proposal wiki
18:36:22 * tykeal notes that not all ODL usernames are listed
18:36:32 <LuisGomez> dlenrow, tykeal, there is no cost but I think it is good to show committer reality in project front page
18:36:53 <LuisGomez> at least i separated who is active and not
18:37:02 <tykeal> LuisGomez: which comes back to my mention a little earlier that plugin2oc doesn't have a main page (still) just their proposal page ;)
18:37:56 <dfarrell07> colindixon: I can remove it
18:38:10 <dfarrell07> colindixon: kk, ack @ you doing it
18:39:09 <dfarrell07> regXboi is talking about "Subsystem Dependencies or subsystems requiring changes" if you ctrl+f for it
18:39:17 <phrobb> #info regXboi asks "on the proposal, why are there "dependencies on the project proposal and not just on the release plan?"..
18:39:22 * ChrisPriceAB been away, are we on # topic?
18:39:33 <dfarrell07> ChrisPriceAB: yeah, we're good
18:39:33 <rovarga> regXboi: can they move it out as they join a release?
18:40:03 * ChrisPriceAB seet, I see it now dfarrell07
18:40:15 <phrobb> #info regXboi asks it to be removed because may be mis-interpreted as being accepted changes by other projects
18:40:23 <ank> for Plugin2oc main page:  https://wiki.opendaylight.org/view/Southbound_plugin_to_the_OpenContrail_platform:Main
18:40:24 <dfarrell07> #info colindixon edits out regXboi's issue on the fly
18:40:41 * ChrisPriceAB regXboi, I have a wall that likes good discussion too.
18:40:54 <tykeal> lol
18:41:13 * regXboi looks questioningly at ChrisPriceAB
18:42:17 * ChrisPriceAB the mute button is a virtual replica, not nearly as good as the real thing...
18:42:23 <gzhao> #info ATLO CAPWAP Maple SXP are projects that need to have main pages
18:42:45 <colindixon> gzhao: thanks!
18:42:54 <phrobb> #info alagalah asks "what all will be on the first release?… just NBI or everything indicated in the proposal?
18:42:57 <colindixon> phrobb: thanks!
18:43:19 <tykeal> gzhao: maple still doesn't have resources as I haven't heard of them passing IPR yet
18:43:21 <phrobb> #info dlenrow says he's not sure what all will be in the first release but it will not be the whole proposal
18:44:02 <tykeal> though they could technically create a main page without any of the other resources
18:44:22 <dfarrell07> #info edwarnicke suggests that project proposal template should include notes about not doing release planning on project proposal wikis
18:44:53 <colindixon> #action we should probably help projects understand the differences between project proposals and release plans
18:45:40 <colindixon> can people hear me?
18:45:45 <edwarnicke> colindixon: No
18:45:46 <dfarrell07> colindixon: no, we lost you
18:45:50 * tbachman wanders back in to the meeting
18:45:52 <edwarnicke> colindixon: Add a second modem?
18:46:00 <edwarnicke> tbachman: We missed you
18:46:03 <tbachman> lol
18:46:04 <phrobb> edwarnicke:  oooo mutlipath
18:46:07 <tbachman> sorry to drop out
18:46:26 <colindixon> abhijitkumbhare, dbainbri, and I and some others talked about some of this offline and have some ideas at least for OFplugin
18:47:01 <phrobb> welcome back tbachman
18:47:01 <tbachman> #info Rajeev asks if we can do the southbound independent of the intent framework — looking for a general solution
18:47:07 <tbachman> phrobb: sorry for the departure
18:47:10 <tbachman> double-booked
18:47:39 <tbachman> #info dlenrow says projects need to collaborate to make sure they don’t step on each other
18:48:12 <colindixon> #info abhijitkumbhare notes that the hope is to try to do two levels of conflict detection one at the intent level and one at the SB protocol level
18:48:31 <tbachman> #info dlenrow asks if we feel that the proposal as written precludes going further south
18:48:52 <tbachman> #info Rajeev says it doesn’t preclude — he’s asking for clarificaiton to scope the SB so that we can use it with the intent and more generally
18:49:08 <colindixon> #info RajeevK asks that we make sure the conflict mechanims are useful beyond just intent
18:49:10 <tbachman> #info abhijitkumbhare says in the OF side we do need to have a flow-conflict detector/manager at some point in time
18:49:12 * ChrisPriceAB tbachman can type faster than me!
18:49:18 <phrobb> me too ChrisPriceAB
18:49:31 * tbachman has many monkeys typing on many keyboards at his disposal
18:49:38 <tbachman> how I write code, too!
18:49:50 * ChrisPriceAB ooh monkeys!
18:50:00 * phrobb bows to tbachman keyboard/monkey foo
18:50:05 <tbachman> lol
18:50:09 * ChrisPriceAB I shouldn't have gone with hippo's I guess
18:50:21 * dfarrell07 has votes queued up, FYI
18:50:35 <tbachman> #info edwarnicke says doing stuff in the OF plugin for conflict resolution is out of scope of the intent project
18:50:37 <tykeal> https://presentsofmind.files.wordpress.com/2012/10/monkeys-typing.jpg ?
18:50:59 <tbachman> #info colindixon says that there’s nothing wrong with the intent project providing facilities for SB’s to use for conflict resolution
18:51:18 <tbachman> #info regXboi says he has a problem with colindixon’s statement coupled with an offset 2 project
18:51:42 <tbachman> #info colindixon says that no one is forcing projects to conusme the intent project’s APIs
18:51:51 * ChrisPriceAB conflict resolution requires comprehension of the conflict being resolved, which indicates an awareness of the function being implemented.
18:51:58 <phrobb> all you dfarrell07
18:52:00 <dfarrell07> #startvote Shall the TSC approve the Network Intent Composition project to Incubation? -1, 0, +1
18:52:00 <odl_meetbot> Begin voting on: Shall the TSC approve the Network Intent Composition project to Incubation? Valid vote options are -1, 0, +1.
18:52:00 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:52:11 <tbachman> dfarrell07: thx!
18:52:14 <dfarrell07> :)
18:52:27 <ChrisPriceAB> #vote +1
18:52:32 <colindixon> #vote +1
18:52:32 * ChrisPriceAB ball = rolling
18:52:33 <dlenrow> #vote +1
18:52:44 <regXboi> #vote +1
18:52:53 <tbachman> special powers?
18:52:54 <tbachman> lol
18:53:22 <dfarrell07> 4/(eight required, right?)
18:53:28 <colindixon> 7
18:53:28 <tbachman> dfarrell07: I think so
18:53:29 <colindixon> but yeah
18:53:30 * ChrisPriceAB padowan you have much to learn about the force of intent
18:53:31 <tbachman> ah
18:53:34 <tbachman> k
18:53:35 <regXboi> tbachman: not special powers, special COW powers :)
18:53:37 <phrobb> seven
18:53:38 <edwarnicke> #info +1
18:53:42 <LuisGomez> #vote +1
18:53:44 <Youcef> #vote +1
18:53:53 <tbachman> edwarnicke: vote, not info
18:53:56 <RajeevK> #vote +1
18:53:59 <edwarnicke> #vote +1
18:54:09 <dfarrell07> #endvote
18:54:09 <odl_meetbot> Voted on "Shall the TSC approve the Network Intent Composition project to Incubation?" Results are
18:54:09 <odl_meetbot> +1 (8): dlenrow, regXboi, LuisGomez, ChrisPriceAB, RajeevK, edwarnicke, colindixon, Youcef
18:54:21 <regXboi> ok, now for the lithium discussion
18:54:29 <dfarrell07> Can I do the normal #agreed, colindixon?
18:54:32 * ChrisPriceAB congrats intent project!
18:54:33 <regXboi> #info congrats and good luck!
18:54:35 <dfarrell07> #agreed The Network Intent Composition project is approved to Incubation
18:54:36 <tbachman> #info colindixon asks how the intent project behaves going forward, which is separate from entering incubation
18:54:39 <dlenrow> Thanks all
18:54:44 <tbachman> #info dlenrow et. al. congrats!
18:54:45 * ChrisPriceAB especially luck!
18:54:46 <phrobb> #agreed the Network Intent Composition Project is promoted to incubation
18:54:52 <RajeevK> congrats Dave
18:54:52 <abhijitkumbhare> Congrats intent project
18:54:56 <tbachman> #info regXboi asks what offset they should be
18:55:13 <tbachman> #info dlenrow asks if they have to have a draft release plan in order to petition to join the Lithium release
18:55:23 <tbachman> #info colindixon says if they had one for next week that would help a liot
18:55:24 <tbachman> wow
18:55:30 <tbachman> west coast dropped off
18:55:32 <tykeal> sounds like a lot of folks don't want to think about this
18:55:34 * ChrisPriceAB one would expecx offset 2
18:55:36 <dfarrell07> womp womp..fail webex
18:55:42 <bigalh> lol
18:55:49 * regXboi thinks "d*mn people ran away!"
18:56:25 * regXboi notes forgetting a comma hurts - that should have be "d*mn, but people just ran away!"
18:56:53 * ChrisPriceAB :(
18:57:35 <ChrisPriceAB> the oxford comma rocks!
18:57:36 <tbachman> #info edwarnicke says that he is deeply allergic to the TSC exercising editorial control to a project’s release plan
18:57:55 <abhijitkumbhare> regXboi - depends on what was your "intent" regarding the comma :)
18:58:03 <dfarrell07> proposed: #action Network Intent Composition should go create a release plan to clarify discussion about inclusion in Lithium release
18:58:09 <tbachman> #info colindixon asks if the release plan contains things that would prevent there from being a successful Lithium release
18:58:20 <regXboi> abhijitkumbhare: nice!
18:58:30 <colindixon> #action dlenrow to bring a draft NIC release plan before to the next week’s (or a later) TSC meeting
18:58:32 <tbachman> abhijitkumbhare: lol
18:58:42 <tbachman> colindixon: stole dfarrell07’s thunder ;)
18:58:55 <colindixon> #info edwarnicke says that he’d like avoid the TSC exerting editorial control over the release plan
18:58:58 <dfarrell07> it was there, designed to steal ;)
18:59:21 <tbachman> colindixon: didin’t like my “deeply allergic” ;)?
18:59:33 <colindixon> #info colindixon says that his goal is just to make sure that the plan going forward doesn’t jeapordize the Lithium release
18:59:50 <tbachman> lol
19:00:20 <tbachman> #info colindixon says he’d like to encourage the intent project to create a release plan
19:01:06 <phrobb> #endmeeting