#opendaylight-meeting: tsc

Meeting started by colindixon at 18:00:18 UTC (full logs).

Meeting summary

  1. roll call and agenda (colindixon, 18:00:22)
    1. alagalah for jmedved (alagalah, 18:00:39)
    2. colindixon (colindixon, 18:00:43)
    3. edwarnicke for fun (edwarnicke, 18:00:47)
    4. regXboi <- only IRC for now (regXboi, 18:00:47)
    5. https://wiki.opendaylight.org/view/TSC:Main#Agenda Today’s TSC agenda (tbachman, 18:00:54)
    6. https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda in it’s usual place (colindixon, 18:01:08)
    7. kwatsen (kwatsen, 18:01:13)
    8. LuisGomez (LuisGomez, 18:01:25)
    9. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-01-29-18.00.html last week’s minutes for action items (colindixon, 18:01:26)
    10. Youcef Laribi (Youcef, 18:01:49)
    11. dlenrow (dlenrow, 18:02:01)
    12. ACTION: colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?) (tbachman, 18:02:52)
    13. ACTION: colindixon and TSC to elaborate on proper procedure for removal of committers from a project (tbachman, 18:03:01)
    14. ACTION: gzhao colindixon to work out what the next Helium SR and the target dates (tbachman, 18:03:08)

  2. updates (colindixon, 18:04:32)
    1. phrobb says deadline for CFP is tomorrow, 2/6/2015 (tbachman, 18:04:55)
    2. there are 20 submissions so far (tbachman, 18:05:04)
    3. phrobb says we’re locked down for the Marriott Santa Clara for April 15/16 for Lithium Milestone sync up (tbachman, 18:05:32)
    4. abhijitkumbhare for Chris Price (abhijitkumbhare, 18:05:46)
    5. mohnish anumala (mohnish, 18:05:56)
    6. edwarnicke asks how we’re doing on the tutorials (tbachman, 18:06:28)
    7. phrobb wasn’t sure about those yet (tbachman, 18:06:32)
    8. chris wright (cdub, 18:09:00)

  3. Lithium and Stable Helium updates (tbachman, 18:09:25)
    1. zxiiro says we’re still in the process of tagging SR2 (tbachman, 18:09:34)
    2. we’re missing 2 projects that just need to tag and 5 other projects that need to merge SR2 stats (colindixon, 18:10:03)
    3. gzhao says that we have 43 projects in Lithium, 3 offset 0, 16 in 1, the rest in offset 2 (tbachman, 18:10:06)
    4. gzhao says 4 projects are in yellow status — two are missing questions SDNi and OpenContrail (tbachman, 18:10:29)
    5. SXP hasn’t set up JJB and hasn’t finalized release plan, and SNBI hasn’t finalized their release plan (tbachman, 18:10:52)
    6. gzhao says SNBI will finalize release plan on February 13th (tbachman, 18:11:14)
    7. colindixon asks if they are an offset 1 or 2 (tbachman, 18:11:18)
    8. gzhao says SNBI is an offset 1 project (tbachman, 18:11:26)
    9. ACTION: gzhao to look at dependency spreadsheet to see if SNBI has any dependencies, and communicate with SNBI about this (tbachman, 18:12:07)
    10. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Offset_1_Projects <-- offset 1 status (gzhao, 18:12:51)
    11. gzhao says we have only one project — SXP — doesn’t support clustering (tbachman, 18:13:41)
    12. gzhao says 4 projects has special requirements for CI, and 3 projects won’t use LF CI for testing (tbachman, 18:14:09)
    13. gzhao is working on the dependency diagram, as per action item from prior TSC (tbachman, 18:14:24)
    14. ACTION: gzhao will follow up with the SNBI project to have them convey to the release staff and TSC any impact if any their delay will have on other projects and a plan to to get them back on track (colindixon, 18:14:26)
    15. https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Project_Dependency_Diagram < -- WIP dependency diagram (gzhao, 18:14:31)
    16. phrobb asks what does the TSC want to do with IRC meetings in the future — do we want to do them the week before the milestone? (tbachman, 18:15:25)
    17. colindixon says it’s useful to get folks together on IRC, asks if every other week, every week <insert option here> is best? (tbachman, 18:16:57)
    18. abhijitkumbhare asks for every week (tbachman, 18:17:20)
    19. LuisGomez likes the sync up (tbachman, 18:17:51)
    20. edwarnicke likes to have these kept on the google calendar, so whatever is decided, asks to have it updated there (tbachman, 18:18:11)
    21. colindixon recommends 1/2-hour meeting every week; if it seems excessive, we’ll modify (tbachman, 18:18:24)
    22. mohnish asks if we can slide it a bit later (tbachman, 18:18:43)
    23. colindixon asks if there are other opinions on the time change (tbachman, 18:19:09)
    24. rovarga says they’d probably be okay with 1/2 slide (7:30 am PST) (tbachman, 18:20:00)
    25. AGREED: The weekly IRC meeting for Lithium sync up will be 7:30 am PST (tbachman, 18:20:49)

  4. System Integration and Test (tbachman, 18:21:24)
    1. LuisGomez reminds projects to move to SR2 tagging and version bumping, as this affects integration testing (tbachman, 18:21:42)
    2. colindixon asks if we can set this up as an opt-in or opt-out fashion (tbachman, 18:22:51)
    3. edwarnicke says the history is that people tend to opt-in (tbachman, 18:23:46)
    4. http://en.wikipedia.org/wiki/Soft_paternalism (edwarnicke, 18:24:59)
    5. ACTION: colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags (colindixon, 18:27:45)

  5. Infrastructure (tbachman, 18:28:31)
    1. zxiiro says that there are about 32 projects in JJB (tbachman, 18:28:48)
    2. zxiiro is working with hideyuki to get VTN at the moment (tbachman, 18:28:58)
    3. zxiiro is waiting to hear from the remaining projects (tbachman, 18:29:10)
    4. tykeal says that odlforge is being affected by the addition of projects (tbachman, 18:30:05)
    5. VPN service project has resources, yay! We’re still waiting on MAPLE for IPR reasons (colindixon, 18:30:07)

  6. Creation Reviews (tbachman, 18:30:46)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-February/002499.html PCMM would like permission to join the Lithium release late (colindixon, 18:31:09)
    2. colindixon prefers not to vote on this without any attendance of contributors or committers from the PCMM project (tbachman, 18:31:47)
    3. edwarnicke agrees (tbachman, 18:31:51)
    4. odl-patches.sh script now available in scripts/odl-patches in the releng/autorelease repo (zxiiro, 18:32:35)
    5. AGREED: Action item to review addition of PCMM to Lithium release is pushed out a week, due to no one from PCMM in attendance (tbachman, 18:32:43)

  7. Helium Lifetime Poll results (tbachman, 18:32:54)
    1. phrobb says that there was confusion in the poll about what the “current” release; in his mind, that would be what has been released, meaning “Helium" (tbachman, 18:33:29)
    2. phrobb says there were a large quantity fo projects that didn’t respond, and sent a clarification of what the current release is to projects this a.m., and asks what they think they can support (tbachman, 18:34:44)
    3. colindixon wants to schedule more stability releases for Helium until we get past the Lithium release, and has worked with phrobb to come up with dates that wouldn’t stall Lithium (tbachman, 18:36:04)
    4. ACTION: phrobb will send out sample dates for later Helium SRs that try to avoid critical dates in Lithium (colindixon, 18:36:32)
    5. rovarga says the decision to schedule the next SRs should have come before SR2 went out; when SR2 was frozen, they thought that was it for the stability branch, and now they have to look at whether they can backport patches from master (tbachman, 18:37:47)
    6. colindixon says that was part of the intent of the poll (tbachman, 18:37:59)
    7. colindixon asks if rovarga feels this is the wrong thing to do (tbachman, 18:38:16)
    8. rovarga advises to be more explicit next time around (tbachman, 18:38:24)
    9. cdub agrees with colindixon (tbachman, 18:39:23)
    10. colindixon encourages PL’s to express opinions on the continued stable releases for Helium (tbachman, 18:40:08)
    11. rovarga prefers that the release after Lithium is out to become the official code freeze, and not to expect anything more from that service release (tbachman, 18:41:37)
    12. colindixon says that we’re not sure whether we’re in agreement on what the code freeze should be, based on the poll (and confusion around “Current”) (tbachman, 18:42:51)

  8. Use Cases (tbachman, 18:43:22)
    1. colindixon says that there’s been a lot of talk in the Board meetings for ODL to meet Use Cases, rather than be just a collection of code (tbachman, 18:43:57)
    2. colindixon says mohnish, mlemay, mcohn, dmm, dlenrow, et. al. have been discussing this so that ODL can do something out of the box to meet a use case (tbachman, 18:44:35)
    3. colindixon says that even when there’s agreement on things that matter, such as neutron, in the past it’s been difficult to get resources to commit in order to move these things forward (tbachman, 18:45:05)
    4. The board is trying to find a way to encourage such participation, possibly through use cases (tbachman, 18:45:27)
    5. edwarnicke says using the distribution question to address the use case question is going about it wrong (tbachman, 18:46:39)
    6. colindixon says maybe we should declare that 1 or 2 use cases per release are things that we’d like to target (tbachman, 18:47:00)
    7. edwarnicke says he feels we’re better off just having a single feature tied to a single use case, rather than a distribution question (tbachman, 18:48:16)
    8. colindixon says the question as to whether it’s a feature or a distribution is fine (tbachman, 18:48:33)
    9. colindixon asks if we can agree on some common goals for Lithium (tbachman, 18:48:55)
    10. edwarnicke says there are goals that we’ve targeted before, but haven’t been properly realized (tbachman, 18:49:20)
    11. edwarnicke actually said that for most common goals, we *have* pulled together in the past (edwarnicke, 18:49:41)
    12. but perhaps not at other times (edwarnicke, 18:49:47)
    13. RajeevK likes the idea of common goals, where ODL stands behind a few use cases; asks how we can get to those use cases (tbachman, 18:49:51)
    14. edwarnicke says this goes to the question that people ask is how the TSC directs resources; notes the TSC can’t direct resources (tbachman, 18:50:41)
    15. colindixon says would creation of use cases encourage them to participate to make that happen (tbachman, 18:51:08)
    16. RajeevK asks what uses cases we would focus on, how many, and how would we track progress (colindixon, 18:52:22)
    17. mohnish says we should also track what we are doing, so that we drive advice and insight as to what ODL is good at beyond what we call attention to (tbachman, 18:55:54)
    18. colindixon suggests the first use case would be neutron with network virtualization, as there are already tests and CI infrastructure from openstack that would allow us to get that up and running quickly (tbachman, 18:56:35)
    19. edwarnicke asks if we can throw this out to the project leads (tbachman, 18:57:05)
    20. colindixon agrees with edwarnicke on contacting the project leads (tbachman, 18:57:55)
    21. regXboi expresses doubts about the suggested first use case (regXboi, 18:58:22)
    22. I think that NFV is a critical use case for us in Lithium :) (edwarnicke, 18:59:37)
    23. bacon cookies, in fact (tbachman, 19:00:06)
    24. ACTION: colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list (colindixon, 19:01:53)


Meeting ended at 19:04:40 UTC (full logs).

Action items

  1. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
  2. colindixon and TSC to elaborate on proper procedure for removal of committers from a project
  3. gzhao colindixon to work out what the next Helium SR and the target dates
  4. gzhao to look at dependency spreadsheet to see if SNBI has any dependencies, and communicate with SNBI about this
  5. gzhao will follow up with the SNBI project to have them convey to the release staff and TSC any impact if any their delay will have on other projects and a plan to to get them back on track
  6. colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags
  7. phrobb will send out sample dates for later Helium SRs that try to avoid critical dates in Lithium
  8. colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list


Action items, by person

  1. colindixon
    1. colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
    2. colindixon and TSC to elaborate on proper procedure for removal of committers from a project
    3. gzhao colindixon to work out what the next Helium SR and the target dates
    4. colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags
    5. colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list
  2. gzhao
    1. gzhao colindixon to work out what the next Helium SR and the target dates
    2. gzhao to look at dependency spreadsheet to see if SNBI has any dependencies, and communicate with SNBI about this
    3. gzhao will follow up with the SNBI project to have them convey to the release staff and TSC any impact if any their delay will have on other projects and a plan to to get them back on track
  3. phrobb
    1. phrobb will send out sample dates for later Helium SRs that try to avoid critical dates in Lithium
  4. zxiiro
    1. colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags


People present (lines said)

  1. tbachman (147)
  2. colindixon (34)
  3. edwarnicke (31)
  4. regXboi (26)
  5. dlenrow (16)
  6. tykeal (16)
  7. alagalah (15)
  8. odl_meetbot (12)
  9. cdub_ (12)
  10. rovarga (10)
  11. dfarrell07 (9)
  12. RajeevK (5)
  13. zxiiro (5)
  14. phrobb (4)
  15. cdub (3)
  16. gzhao (3)
  17. hideyuki (2)
  18. abhijitkumbhare (2)
  19. mohnish (2)
  20. LuisGomez (1)
  21. Youcef (1)
  22. ebrjohn (1)
  23. ShaunWackerly (1)
  24. snoble (1)
  25. kwatsen (1)


Generated by MeetBot 0.1.4.