18:01:45 <colindixon> #startmeeting tsc
18:01:45 <odl_meetbot> Meeting started Thu Feb 26 18:01:45 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:01:45 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:45 <odl_meetbot> The meeting name has been set to 'tsc'
18:01:53 <colindixon> #topic roll call and agenda bashing
18:02:08 <colindixon> #chair tbachman dfarrell07 regXboi phrobb gzhao
18:02:08 <odl_meetbot> Current chairs: colindixon dfarrell07 gzhao phrobb regXboi tbachman
18:02:13 <colindixon> #info colindixon
18:02:21 * regXboi trying to reach webex
18:02:26 <dfarrell07> #info dfarrell07 for cdub and Red Hat (on TSC mailing list)
18:02:29 * regXboi is glutton for punishment
18:02:30 <edwarnicke> #info edwarnicke for fun
18:02:44 <colindixon> #info sdean778 asked for us to add a topic on how to hanlde vendor-specific code, it’s on the agenda
18:03:05 <snoble> you might designate someone to be the alternate physical recorder if you can't get the recording to start
18:03:07 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-02-19-18.00.html meetings from last week
18:03:10 <tbachman> #undo
18:03:10 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x19c1490>
18:03:14 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-02-19-18.00.html minutes from last week’s meeting
18:03:32 * regXboi has made the webex
18:03:40 <tbachman> colindixon: we had an issue with that in SFC
18:03:42 <tbachman> didn’t work
18:03:43 * regXboi says mark the damn calendar!
18:03:48 <regXboi> #info regXboi
18:03:50 <tbachman> we couldn’t use the host key
18:03:58 <tbachman> same thing you saw lasst week
18:03:59 <tbachman> on TSC
18:04:00 <tbachman> yeah
18:04:08 <tbachman> it’s not the SFC meeting that’s the issue
18:04:15 <zxiiro> the thing about webex for me is the webex "test" meeting works on linux but I can't join a real meeting with it :(
18:04:25 <tbachman> we can try it
18:04:34 <tbachman> I was wondering if it has to do with too many simultaneous meetings
18:04:37 <tbachman> with host role
18:04:44 <colindixon> #action colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
18:04:44 * dfarrell07 braces to be punted from WebEx
18:04:48 <tbachman> lol
18:04:50 <colindixon> as an ongoing thing
18:05:09 <kwatsen> #info kwatsen
18:05:13 <colindixon> #action colindixon and TSC to elaborate on proper procedure for removal of committers from a project
18:05:16 <tbachman> phrobb: saves the day
18:05:21 <colindixon> #action colindixon, zxiiro and others to coordinate figuring out how to set up opt-in/opt-out automatic version bump patches and tags
18:05:26 <colindixon> #action colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list
18:05:39 <tbachman> phrobb: the issue during the SFC meeting was that it said something about exceeding number of meetings
18:05:45 <tbachman> when we tried to use the host key
18:05:52 <tbachman> there were 3 meetings at the same time
18:05:53 <tbachman> AAA
18:05:55 <tbachman> DLUX
18:05:56 <ChrisPriceAB> #info Chris Price (late again)
18:05:57 <tbachman> and SFC
18:06:08 <tbachman> (at least there are on the calendar)
18:06:13 <Youcef> #info Youcef Laribi
18:07:06 <tbachman> #info gzhao still hasn’t received response from Maple and Defense4All
18:07:16 <tbachman> #info phrobb is still trying to work out IPR issues with Maple project
18:07:33 <colindixon> #action phrobb to keep working with Maple (he is “cautiously pessimistic”)
18:07:38 <tbachman> color commentary ;)
18:08:02 <tbachman> #info LLDP with Auto-Attach was approved via the mailing list last week
18:08:07 <tbachman> #undo
18:08:07 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1bab090>
18:08:19 <colindixon> #action phrobb to reach out to Rob Sherwood about closing down net-virt-platform
18:08:27 <tbachman> #info LLDP with Auto-Attach project was approved by the TSC into incubation via the mailing list last week
18:08:32 <colindixon> #action phrobb to reach out to plugin2oc, SDNi, and defense4all about JJB migration
18:09:24 <colindixon> #action phrobb to hunt down projects to see if they would continue to support Helium (at least) until Lithium is released (we are at 13 of 20 remaining projects agreeing to support Helium until Lithium releases)
18:09:49 <tbachman> #info colindixon asks if we got feedback on new tentative dates for new SR’s for Helium
18:10:02 <jmedved> #info jmedved
18:10:03 <gzhao> #link https://lists.opendaylight.org/pipermail/release/2015-February/001461.html < proposed Helium SR3 & SR4
18:10:06 <tykeal> huzzah!
18:10:07 <tbachman> #topic Updates
18:10:28 <tbachman> #info phrobb says that everything moving along for April Hackfest — encourages folks to register
18:10:48 <tbachman> #info CFP has closed, received 90 submissions; notifying speakers week after next for those that were accepted
18:11:07 <tbachman> #info phrobb says that the CFP for the event in India has opened
18:11:14 * regXboi hey does that mean we can offer cookies?
18:11:18 <regXboi> :-)
18:11:35 <tbachman> regXboi: we have a plan — cookie cutters shaped like coins :)
18:11:41 <tykeal> lol
18:11:53 <regXboi> tbachman: how about cookies shaped like super cows?
18:11:53 <tbachman> #info Lithium and Stable/Helium
18:11:55 <tbachman> #undo
18:11:55 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19bc910>
18:12:01 <ChrisPriceAB> cookies are the coin of my realm!!!
18:12:03 <tbachman> #topic lithium and stable/helium
18:12:14 <tbachman> #info colindixon asks how we’re doing with picking SR3/SR4 dates
18:12:20 <tbachman> #link https://lists.opendaylight.org/pipermail/release/2015-February/001461.html < proposed Helium SR3 & SR4
18:12:32 <tbachman> gzhao: thx for that link :)
18:13:00 <abhijitkumbhare> what was yesterday's hackfest regXboi ?
18:13:01 <gzhao> tbachman: sure
18:13:12 <tbachman> #info Proposed dates are March 26th and July 17th for SR3 and SR4, respectively
18:13:13 <regXboi> abhijitkumbhare: will explain on the call
18:13:18 <tbachman> abhijitkumbhare: was wondering the same
18:13:27 <tbachman> regXboi: switches hats
18:13:42 <tbachman> #info regXboi says there was a hackfest to try to get the openstack CI test jobs for ODL to work
18:14:03 <tbachman> #info regXboi says this involves patching stable helium; came across issues with UserManager
18:14:20 <tbachman> regXboi: switche hats again
18:14:35 <abhijitkumbhare> regXboi has many hats :)
18:14:40 <tbachman> abhijitkumbhare: :)
18:14:49 <tykeal> abhijitkumbhare: I'm waiting for his cookie hat ;)
18:14:50 * ChrisPriceAB +1...
18:15:06 * Prem_ Missed counting the # of hats
18:15:12 * ChrisPriceAB both to the cookie hat and the date
18:15:27 <regXboi> is somebody offering a cookie hat?
18:15:33 <tbachman> RedHat
18:15:38 <tbachman> <bah-dump-bump>
18:15:39 <ChrisPriceAB> M7 lel
18:15:40 <regXboi> that would actually make eating one's hat relatively interesting :)
18:16:01 <tykeal> regXboi: http://www.hercampus.com/sites/default/files/2012/11/12/Pilgrim%20hat%20cookies_2.jpg
18:16:02 <ChrisPriceAB> vote vote vote!!!
18:16:07 <dfarrell07> colindixon: 7 by my count
18:16:41 <RajeevK_> Rajeev is here
18:16:45 <dfarrell07> colindixon: ed
18:16:54 <tbachman> should we info again?
18:17:02 <LuisGomez> #info LuisGomez
18:17:04 <RajeevK_> #info
18:17:13 <tykeal> RajeevK_: it's #info <name> ;)
18:17:16 <gzhao> #info RajeevK
18:17:18 <RajeevK_> #info RajeevK
18:17:33 <abhijitkumbhare> #undo ?
18:17:41 <gzhao> #undo
18:17:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ab5050>
18:17:43 <gzhao> #undo
18:17:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1aaf550>
18:17:45 <gzhao> #undo
18:17:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x18ad890>
18:17:50 * dfarrell07 doesn't have a strong opinion about the exact dates, seem fine to me
18:17:59 * ChrisPriceAB echo
18:18:02 <tbachman> gzhao: keeping it clean :)
18:18:03 <tbachman> thx
18:18:10 <tbachman> July 17th
18:18:10 <gzhao> #info RajeevK_
18:18:33 <tbachman> ah, yes 16th
18:18:34 <RajeevK_> gzhao: Thx!
18:18:46 <gzhao> RajeevK_: np
18:19:15 <phrobb> #startvote Shall Helium SR3 release be on March 26th and tentatively SR4 be July 16th? -1, 0, +1
18:19:15 <odl_meetbot> Begin voting on: Shall Helium SR3 release be on March 26th and tentatively SR4 be July 16th? Valid vote options are -1, 0, +1.
18:19:15 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:19:21 <regXboi> #vote +1
18:19:23 <colindixon> #vote +1
18:19:26 <dfarrell07> #vote +1
18:19:26 <jmedved> #vote +1
18:19:27 <edwarnicke> #vote +1
18:19:27 <LuisGomez> #vote +1
18:19:27 <Youcef> #vote +1
18:19:30 <ChrisPriceAB> #vote +1
18:19:32 <RajeevK_> #vote +1
18:19:36 <phrobb> #endvote
18:19:36 <odl_meetbot> Voted on "Shall Helium SR3 release be on March 26th and tentatively SR4 be July 16th?" Results are
18:19:36 <odl_meetbot> +1 (9): jmedved, regXboi, ChrisPriceAB, LuisGomez, edwarnicke, dfarrell07, colindixon, Youcef, RajeevK_
18:20:01 * ChrisPriceAB wonders if he can cheekily undo other peoples votes....
18:20:05 <phrobb> #agreed Helium SR3 release will be on March 26th and tentatively SR4 be July 16th
18:20:13 <tbachman> phrobb: thx!
18:20:23 <gzhao> #action gzhao to put SR3, SR4 tentative date to Helium release plan
18:20:27 <phrobb> tbachman:  my pleasure
18:21:40 <tbachman> #info regXboi notes that as a committer in neutron, he can’t merge backports to stable/helium, since it’s in the controller
18:21:50 <colindixon> #info regXboi and edwarnicke note that getting the fixes for Neutron for SR3 done will involve porting patches from Neutron to Controller and that will have complexities
18:22:43 <tbachman> #info gzhao says that defense4All and Maple are the only 2 projects with M2 status
18:22:57 <tbachman> #info gzhao says the Neutron project is still working on M2, but they are spinout so not due until M3
18:23:14 <tbachman> #info gzhao says offset 1 projects have M3 status due next Thursday
18:23:36 <tbachman> #info gzhao encourages all offset 1 and 2 projects to attend next Monday’s TWS, on integration project’s testing requirements
18:24:22 <gzhao> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1598222722 < -- single feature test tracking
18:25:12 <tbachman> #info gzhao says that the spreadsheet provided in the link; AAA needs to submit a patch to turn on the single-feature-test
18:27:48 <colindixon> #action ALL PROJECTS need to make sure your single feature test is turned on and running
18:27:56 <abhijitkumbhare> edwarnicke gzhao for OpenFlow plugin michal_rehak has done https://git.opendaylight.org/gerrit/#/c/15728/1 - have not updated the spreadsheet
18:28:37 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-February/001488.html the mail ddescribing the issue and how to fix it
18:30:10 * tbachman fell down… uses clapper to turn on the lights to get back up
18:30:22 <gzhao> abhijitkumbhare: that spreadsheet is for each project to fill
18:30:27 <rovarga_> #info https://git.opendaylight.org/gerrit/#/c/15773/
18:30:27 <colindixon> #info rovarga_ asks for odlparent to merge two patches outstanding: one which fixes eclipse and one which makes the feature test run faster
18:30:46 <abhijitkumbhare> yes - gzhao (will fill it)
18:30:48 <colindixon> #action dfarrell07 to get cdub to review and merge odlparent patches
18:31:14 <gzhao> abhijitkumbhare: don't worry, already done
18:31:29 <tbachman> #topic System integration and Test
18:31:43 <abhijitkumbhare> thx gzhao
18:31:45 <tbachman> #info LuisGomez asks what to do when there are projects that block integration and are unreachable
18:32:58 <tbachman> #link https://lists.opendaylight.org/pipermail/tsc/2015-February/002643.html Email from LuisGomez on this issue
18:33:48 <ChrisPriceAB> I'm all good.
18:33:54 * ChrisPriceAB limited trust issues
18:34:21 <tbachman> #info colindixon says he feels that it’s within integration’s scope to remove them in order to move forward
18:34:30 <tbachman> #undo
18:34:30 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a8cd90>
18:34:57 <tbachman> #info colindixon says he feels that it’s within integration’s scope to remove a project from integration build if they don’t respond within 48 business hours in order to move forward
18:35:32 <tbachman> #info LuisGomez asks if it would be possible to label/mark the projects “we know” nobody maintains/supports anymore (OSCP, Affinity, etc…)
18:36:04 <rovarga_> btw ... there are about 16 projects still using yangtools features-test, afaict
18:36:17 <tbachman> rovarga_: thx!
18:36:27 <colindixon> #link https://wiki.opendaylight.org/view/Project_list this list says nothing about how “maintained” a project is, LuisGomez would like to add information about certain projects being abandoned, e.g., affinity and OSCP
18:36:47 <tbachman> #info rovarga_ says there are about 16 projects still using yangtools features-test, by his count (applied towards previous topic)
18:36:57 <gzhao> rovarga_: if they are not on https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=1598222722 could you add them?
18:37:38 <tykeal> after 1.5 years
18:37:40 * dfarrell07 directly pinged cdub about patches, also added him as a reviewer on Gerrit /cc rovarga_
18:37:42 <RajeevK_> I would like some description added. Even "Last Modified" could be useful
18:38:04 <colindixon> #info edwarnicke suggests that we maybe reach out to aks projects to terminate themselves if projects seem like they shoudl abe archived
18:38:07 * tbachman missed that
18:38:07 <alagalah> hehe
18:38:25 <tykeal> yes
18:38:31 <tykeal> it's the 1.5 for an outside termination
18:40:57 * tbachman fell down again
18:40:58 <tbachman> back
18:40:59 <tbachman> sorry
18:41:02 <colindixon> #action colindixon to send a mail to the list and (possibly) put it on the agenda for next week about ways to trackwhich projects are active
18:41:47 <tbachman> #topic Vendor Specific Code
18:42:10 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-February/002618.html the thread that sparked this topic
18:42:10 <tbachman> #link https://lists.opendaylight.org/pipermail/tsc/2015-February/002613.html email from Steve Dean on vendor-specific code
18:42:16 <colindixon> #undo
18:42:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x19ace10>
18:42:18 <colindixon> :-)
18:42:19 <tbachman> oops
18:42:26 <tbachman> lol
18:42:33 * tbachman is sleeping today
18:42:42 <tbachman> #info sdean778 asks what the TSC’s opinion is on this
18:42:55 <tbachman> #info regXboi asks what the code license is
18:43:31 <tbachman> #info colindixon says this is to submit code under the eclipse license
18:43:41 <ChrisPriceAB> Does it not just go through review and get added under eclipse based on that review?
18:43:59 * ChrisPriceAB +1
18:44:50 <colindixon> #info regXboi says it should be split into a legal and a technical part, on the legal side the code must be able to be EPL code if we’re going to host it in ODL repos
18:45:14 <rovarga_> I think on the technical side, we may want to enforce an API/IMPL separation
18:45:17 <colindixon> #info edwarnicke says from a technical perspective, he cares more that things can be side loaded without changes to the core repo than anything else
18:45:28 <colindixon> #undo
18:45:28 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ab7190>
18:45:45 <rovarga_> e.g. the vendor-specific code is pure plugin and does not wag the dog
18:45:46 <colindixon> #info edwarnicke says from a technical perspective, he cares more that things can be side loaded without changes to the repo than anything else
18:46:49 <ChrisPriceAB> #info is this "vendor specific code" being provided as free and open source code for ODL?  That can be developed beyond "vendor specific"?
18:46:54 <tbachman> #info sdean778 asks if we want the distribution to support vendor devices out-of-the-box
18:47:16 <tbachman> #info phrobb asks if there’s a construct in our repo and test environment to enable this — we need the vendor devices to do this
18:47:51 <tbachman> #info ashaikh wonders if there’s a way to indicate that this isn’t licensed the same way
18:47:56 <tbachman> ashaikh: ^^  is that what you said?
18:48:08 <tbachman> ashaikh: hi btw :)
18:48:25 <tbachman> #info colindixon says there’s the question of licensing, but also how to do we make sure it’s tested
18:48:34 <ashaikh> tbahchman:(hey!) yes, using a third-party directory convention
18:48:43 <ChrisPriceAB> Would a ttp definition in the ttp project not also be "vendor specific" code?
18:48:45 <tbachman> #info abhijitkumbhare says it doesn’t have to be a separate licesnse
18:48:47 <ashaikh> that should be :-)
18:48:51 <nathanharmon> rovarga_: yes, the DIDM design already has separate api/impl. a vendor plugin could be part of the project or kept separate already.
18:48:55 <colindixon> ChrisPriceAB: it’s a good question, quite posibly
18:49:06 <tbachman> #info regXboi says licensing is where you get tripped up
18:51:38 <abhijitkumbhare> Do we have Open Source device drivers for proprietary devices in Linux?
18:51:47 <tbachman> #topic Best Practices
18:52:11 <zxiiro> colindixon: Can we consolidate the code style pages? I created this https://wiki.opendaylight.org/view/ODL_Coding_Guidelines
18:52:12 <tbachman> #link https://wiki.opendaylight.org/view/Developer_Best_Practices Developer Best Practices wiki page
18:52:27 <tbachman> #link https://wiki.opendaylight.org/view/Logging_Best_Practices Logging Best Practices wiki page
18:52:43 <tbachman> #link https://wiki.opendaylight.org/view/General_Style_Guidelines General Style Guidelines wiki page
18:53:05 <tbachman> #link https://wiki.opendaylight.org/view/CrossProject:HouseKeeping_Best_Practices_Group:Main Housekeeping Best Practices wiki page (main)
18:53:38 <tbachman> #link https://lists.opendaylight.org/pipermail/controller-dev/2014-July/005766.html email describing commiter checklist
18:53:52 <alagalah> Is edwarnicke's audio borking or is it just me
18:54:00 <colindixon> alagalah: it’s just you
18:54:06 <alagalah> vunderbar
18:54:06 <tykeal> alagalah: not just you
18:54:15 <colindixon> tykeal: huh
18:54:21 <RajeevK_> breaking
18:54:38 <alagalah> colindixon: tykeal Its entirely possible its me... the time delay from my position out in orbit causes issues :)
18:54:43 * alagalah space cadet
18:54:52 <tykeal> colindixon: only audio problems I've been having have been with edwarnicke for some reason
18:55:25 * rovarga_ hears JNI and puts on his TCP/MD5 hat
18:56:01 * alagalah there's more hats in here than a rodeo
18:56:45 <tykeal> lol
18:56:55 <dfarrell07> as the person doing a ton of deployment stuff for Integration team, major +1 to that colindixon
18:58:01 <edwarnicke> I would be comfortable
18:58:05 * ChrisPriceAB either document or formally vote...
18:58:31 <rovarga_> non-portable dependencies should always be optional
18:58:35 * tbachman is totally unhelpful today
18:58:45 <rovarga_> (for a particular release)
18:59:58 <phrobb> Shall the TSC acknowledge there are best practices such as not using JNI and maintaining just the “download and run” model is strongly preferred
19:00:30 <colindixon> the TSC strongly suggests that projects avoid things that will break cross-platform compatibility, e.g., the use of JNI, and avoid breaking the simple “download, unzip and run”, i. i.e., allow for external dependencies, but don't require them
19:00:52 <colindixon> the TSC strongly suggests that projects avoid things that will break cross-platform compatibility, e.g., the use of JNI, and avoid breaking the simple “download, unzip and run” deployment model, i.e., allow for external dependencies, but don't require them
19:01:01 * ChrisPriceAB ok with me
19:01:03 <dfarrell07> yes
19:01:15 * ChrisPriceAB all good to agree
19:01:24 * ChrisPriceAB but that's cause I would vote +1
19:01:45 <colindixon> the TSC strongly suggests that projects avoid things that will break cross-platform compatibility, e.g., the use of JNI, and avoid breaking the simple “download, unzip and run” deployment model
19:02:02 <edwarnicke> I'm down with the above from colindixon
19:02:46 <colindixon> #actoin colindixon to start a discussion for the TSC to agree on a variant the statement “the TSC strongly suggests that projects avoid things that will break cross-platform compatibility, e.g., the use of JNI, and avoid breaking the simple “download, unzip and run” deployment model” on the mailing list
19:02:53 <colindixon> #action colindixon to start a discussion for the TSC to agree on a variant the statement “the TSC strongly suggests that projects avoid things that will break cross-platform compatibility, e.g., the use of JNI, and avoid breaking the simple “download, unzip and run” deployment model” on the mailing list
19:03:03 <dfarrell07> Maybe append: Where this isn't possible, please document the situation clearly
19:03:15 <colindixon> #action colindixon start a thread to have some kind fo subgroup deal with other best practices
19:03:36 <phrobb> #topic Cookies
19:03:40 <ChrisPriceAB> thanks
19:03:40 <colindixon> #endmeeting