18:00:53 <colindixon> #startmeeting tsc
18:00:53 <odl_meetbot> Meeting started Thu Mar  5 18:00:53 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:53 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:53 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:59 <colindixon> #topic roll call and agenda bashing
18:01:01 <colindixon> #info colindixon
18:01:04 <tbachman> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda Today’s agenda
18:01:16 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-02-26-18.01.html Minutes from last week’s meeting
18:01:24 <edwarnicke> #info edwarnicke is having fun
18:01:36 <dlenrow> #info dlenrow
18:02:00 * tbachman is a bit lost with the beginning of today’s TSC call ;)
18:02:00 <abhijitkumbhare> #info abhijitkumbhare for Chris Price
18:02:33 * regXboi wanders in
18:02:36 <regXboi> #info regXboi
18:03:05 <LuisGomez> #info LuisGomez
18:03:33 * alagalah thinks everytime someone tries to claim host mode on webex should always preface it with "Hold my beer and watch this!"
18:03:39 <colindixon> #action colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
18:03:52 <tykeal> lol
18:04:24 <mohnish> #info mohnish anumala
18:04:33 <tykeal> alagalah: http://thumbpress.com/wp-content/uploads/2013/05/Hold-my-beer-10.jpg
18:04:42 <colindixon> #action colindixon, zxiiro will set mail about setting up opt-in/opt-out automatic version bump patches and tags this week
18:04:51 <tbachman> #link https://lists.opendaylight.org/pipermail/tsc/2015-March/002663.html Email fro colindixon on various action items from last week’s meeting (e.g. committer removal)
18:04:52 <colindixon> #action colindixon to start a discussion around possible use cases as focus areas for lithium on the mailing list
18:04:57 <alagalah> tykeal: yes, otherwise known as the famous last words of a redneck (I should know, I is one)
18:05:25 <colindixon> #action phrobb to keep working with Maple (he is “cautiously pessimistic”)
18:05:59 <colindixon> #action phrobb to hunt down projects to see if they would continue to support Helium (at least) until Lithium is released (we are at 13 of 20 remaining projects agreeing to support Helium until Lithium releases)
18:06:39 <tbachman> #info gzhao put tentative dates for SR3 and SR4 into Helium release plan
18:07:02 <colindixon> #action colindixon start a thread to have some kind fo subgroup deal with other best practices
18:07:10 <tbachman> #link https://lists.opendaylight.org/pipermail/tsc/2015-March/002681.html Email from colindixon on tracking active projects
18:07:33 <tbachman> #link https://lists.opendaylight.org/pipermail/tsc/2015-March/002682.html Email from colindixon on archiving net virt project
18:07:36 <tbachman> #undo
18:07:43 <tbachman> hmmm
18:07:47 <tbachman> no-chairy-chair
18:08:04 <tbachman> want to change that net vrit above to OSCP
18:08:06 <colindixon> #chair phrobb- tbachman
18:08:06 <odl_meetbot> Current chairs: colindixon phrobb- tbachman
18:08:08 <tbachman> thc
18:08:09 <tbachman> thx
18:08:10 <tbachman> #undo
18:08:10 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x189f050>
18:08:21 <regXboi> "no chairy chair?"
18:08:24 <Neelajacques> FYI Phil will be on in 10 minutes
18:08:29 <tbachman> #link https://lists.opendaylight.org/pipermail/tsc/2015-March/002682.html Email from colindixon on archiving OSCP project
18:08:32 <tbachman> regXboi: that was for you ;)
18:08:39 <colindixon> #chair regXboi
18:08:39 <odl_meetbot> Current chairs: colindixon phrobb- regXboi tbachman
18:08:45 <regXboi> wait what?
18:08:53 <RajeevK> #info RajeevK
18:08:55 <tbachman> regXboi: should have kept quiet ;)
18:08:56 * regXboi wonders hth that happened
18:09:08 <tbachman> #topic Updates
18:09:22 <tbachman> #undo
18:09:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x19d7450>
18:09:29 <abhijitkumbhare> what is  "phrobb - regXboi" (current chairs) :)
18:09:29 <tbachman> #topic Stable Helium & Lithium
18:09:41 <tbachman> #info gzhao says there are 6 out of 17 offset 1 projects that have reported M3 status
18:09:52 <regXboi> #info so far
18:09:57 <tbachman> regXboi: thx
18:10:01 <tykeal> abhijitkumbhare: the current handle for phrobb is phrobb- (note the trailing - )
18:10:16 <tbachman> #info gzhao says PCMM hasn’t finalized the release plan
18:10:18 <abhijitkumbhare> yeah I know tykeal - just kidding :)
18:10:28 <tykeal> oh... heh
18:10:37 <mohnish> any link for the project status?
18:10:46 <tbachman> mohnish: you mean who’s reported?
18:10:48 <tykeal> though it is an interesting question. what's the set of phrobb to regXboi ;)
18:11:05 <mohnish> tbachman: yes
18:11:16 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1196332566 the project status tracking spreadsheet
18:11:22 <tbachman> mohnish: ^^^ :)
18:11:24 <tbachman> colindixon: thx
18:11:26 <mohnish> thanks
18:11:51 <tbachman> #info colindixon asks if we’re in contact with projects that haven’t reported or are red
18:12:51 <colindixon> #info gzhao says he’s in contact with Defense4All, but it’s not clear where they are
18:13:12 <colindixon> #action phrobb- and colindixon to reach out to ALTO and MAPLE to figure what’s going on
18:13:44 <colindixon> #action colindixon, phrobb-, and gzhao to work with Defense4All to figure out what their options are
18:13:50 <jmedved> #info jmedved
18:15:10 <gzhao> regXboi: https://lists.opendaylight.org/pipermail/release/2015-February/001354.html <== this is the email I received
18:15:16 <tbachman> #info zxiiro  says that every project generates javadocs in a different way; need to get all projects doing it the same way
18:15:25 <colindixon> #link https://lists.opendaylight.org/pipermail/discuss/2015-March/004759.html Thanh got the lithium autorelease working (with some issues)
18:15:41 <regXboi> gzhao: that's NIC
18:15:57 <tykeal> you're welcome ;)
18:16:08 * ebrjohn where can I get one of those???
18:16:10 <rovarga> zxiiro: will your proposal also address cross-project linkage in javadocs?
18:16:33 <gzhao> regXboi: wrong row, https://lists.opendaylight.org/pipermail/release/2015-February/001478.html
18:16:41 <tbachman> sorry
18:16:43 <tbachman> missed that
18:16:52 <tykeal> ebrjohn: it's my critical alert pager noice
18:16:54 <tbachman> #topic System Integration and Testing
18:16:56 <tykeal> s/noice/noise/
18:17:09 <tbachman> colindixon: I missed what you wanted me to capture — sorry
18:17:11 <zxiiro> rovarga: no my priority is to just make ti so we can generate the javadocs for all the projects. we can probably look into linkage after that
18:17:27 <regXboi> gzhao: well that's odd
18:17:27 <dfarrell07> #info (actually last topic) M3 release artifacts will be cut in two weeks
18:17:32 <dfarrell07> tbachman: ^^that was it
18:17:32 <colindixon> #undo
18:17:32 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19c1ed0>
18:17:34 <colindixon> #unod
18:17:35 <colindixon> #undo
18:17:35 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1a9df50>
18:17:46 <ebrjohn> I think it was SR3, not M3
18:17:56 <colindixon> #info the Helium-SR3 RC will be cut two weeks from tomorrow, please get patches in by then
18:17:56 <dfarrell07> ebrjohn: yes, you're right
18:18:01 <tbachman> colindixon: thx
18:18:06 <tbachman> #topic System Integration and Testing
18:18:38 <colindixon> #info we seem to be doing better now that we have a formal policy about being able to (temporarily) kick projects out of the build if they break it for everyone
18:18:52 <tbachman> phrobb: welcome :)
18:19:11 <phrobb> Hey tbachman! :-)
18:19:15 <colindixon> #info LuisGomez says that all integration and system test jobs are now in JJB
18:19:16 <rovarga> zxiiro: fair enough. that cross-linkage may turn out to be some challenge
18:19:19 <abhijitkumbhare> Complete phrobb welcome :)
18:19:28 <abhijitkumbhare> No minus I mean
18:19:33 <regXboi> gzhao: https://lists.opendaylight.org/pipermail/release/2015-March/001516.html
18:19:34 <LuisGomez> #link https://jenkins.opendaylight.org/releng/view/CSIT-Jobs/
18:19:36 <regXboi> there it is :)
18:19:41 <tbachman> #topic Updates
18:19:56 <tbachman> #info phrobb encourages folks to sign up for the mid-April hackfest
18:20:14 <tbachman> #info phrobb says they’ve had 27 submissions for the form this April in India
18:20:30 <tbachman> #undo
18:20:30 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1821ad0>
18:20:31 <dfarrell07> #info ODL Summit speakers will be notified soon
18:20:43 <gzhao> regXboi: thanks, if possible, can you fill https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=835215943 as well.
18:20:43 <tbachman> #info phrobb says they’ve had 27 submissions for the forum this April in India
18:20:54 <gzhao> regXboi: I missed that email, somehow.
18:21:09 <regXboi> sorry, I thought I had updated that
18:21:12 <tbachman> #info phrobb says they’re running a technical track at NFV world in May and ONS summit in June
18:21:59 <regXboi> gzhao: updated the first tab
18:22:05 <regXboi> the other tabs will be updated as we go
18:22:31 <tbachman> #info phrobb has some folks creating training content; first plan of action is to turn that content into a tutorial
18:22:44 <colindixon> #info for the tutorial session at ONS is to use traning content that the LF has people building, but there will be a tutorial (during Sunday) at the ONS
18:23:01 <colindixon> next up is the committer promotoin
18:23:11 <tbachman> #info the tutorials are for ONS, and will also be done at the ODL summit
18:23:51 <tbachman> #info phrobb says anyone on the call who wants to submit something for tutorials, reach out to phrobb
18:24:32 <colindixon> #link https://events.linuxfoundation.org/events/opendaylight-summit the ODL summit in June
18:24:51 <colindixon> #link https://events.linuxfoundation.org/cfp/cfp-add the submission page to submit tutorials
18:24:56 * tbachman notes regXboi plays a great straight-man
18:24:57 <regXboi> colindixon: thanks!
18:25:08 <colindixon> #link http://www.opendaylight.org/news/events events for future reference
18:25:13 <regXboi> tbachman: one of my few true talents :)
18:25:23 <tbachman> regXboi: too humble, sir
18:25:37 <tbachman> #topic Committer Promotion for SFC
18:25:38 <regXboi> #topic committer promotions
18:25:39 <rovarga> colindixon: 'andrei'
18:25:41 <regXboi> #undo
18:25:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x19474d0>
18:25:47 <regXboi> oops :)
18:25:56 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-March/002678.html the request
18:26:15 <colindixon> #link https://lists.opendaylight.org/pipermail/sfc-dev/2015-March/000958.html the thread showing 7 +1 votes
18:26:27 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/owner:%22Andrej+Kincel+%253Cakincel%2540cisco.com%253E%22+status:merged Andrej’s merged patches on SFC
18:26:39 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/reviewer:%22Andrej+Kincel+%253Cakincel%2540cisco.com%253E%22 Andrej’s reviews on SFC
18:27:45 <colindixon> #info ebrjohn says Andrej has been involved in the SFC since December working with Reinaldo Penno as his mentor and they’d be lucky to have him as a commiter
18:28:02 * tbachman never remembers the syntax
18:28:21 <tykeal> tbachman: #startvote <question>? <comma separated options>
18:28:26 <colindixon> it’s #startvote <question>? <option>, <option>, <option>
18:28:29 <dfarrell07> #startvote Shall the TSC approve Andrej as a committer to SFC? -1, 0, +1
18:28:29 <odl_meetbot> Only the meeting chair may start a vote.
18:28:29 <dlenrow> I love it when you talk CLI
18:28:35 <tykeal> lol
18:28:37 <colindixon> #chair dfarrell07 phrobb
18:28:37 <odl_meetbot> Current chairs: colindixon dfarrell07 phrobb phrobb- regXboi tbachman
18:28:38 <dneary> :-)
18:28:38 <abhijitkumbhare> #vote +1
18:28:38 <dfarrell07> was that wrong?
18:28:41 <edwarnicke> dlenrow: wins the thread ;)
18:28:41 <dlenrow> #vote +1
18:28:43 <edwarnicke> #vote +1
18:28:44 <dfarrell07> #startvote Shall the TSC approve Andrej as a committer to SFC? -1, 0, +1
18:28:44 <odl_meetbot> Begin voting on: Shall the TSC approve Andrej as a committer to SFC? Valid vote options are -1, 0, +1.
18:28:44 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:28:49 <mohnish> #vote +1
18:28:50 <edwarnicke> #vote +1
18:28:50 <colindixon> #vote +1
18:28:50 <jmedved> #vote +1
18:28:52 <regXboi> #vote +1
18:28:54 <abhijitkumbhare> #vote +1
18:28:54 <RajeevK> #vote +1
18:28:54 <tbachman> dfarrell07: thx
18:28:59 * tbachman needs to learn startvote
18:29:03 <dfarrell07> tbachman: np :)
18:29:11 <dfarrell07> #endvote
18:29:11 <odl_meetbot> Voted on "Shall the TSC approve Andrej as a committer to SFC?" Results are
18:29:11 <odl_meetbot> +1 (7): jmedved, regXboi, edwarnicke, RajeevK, mohnish, colindixon, abhijitkumbhare
18:29:18 <dlenrow> Well done Andrej
18:29:25 <regXboi> congrats!
18:29:31 <regXboi> and now I can resign :)
18:29:32 <dfarrell07> #agreed The TSC approves Andrej as a committe to SFC
18:29:34 <phrobb> #agreed Andrej is a committer for SFC
18:29:40 <regXboi> #undo
18:29:40 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x1b6fdd0>
18:29:42 <dfarrell07> #undo
18:29:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x1b6fa50>
18:29:45 <tbachman> lol
18:29:46 <dfarrell07> #agreed The TSC approves Andrej as a committer to SFC
18:29:46 <regXboi> doh!
18:30:03 <edwarnicke> Does Andrej have a last name? :)
18:30:04 <dfarrell07> regXboi: I did s/committe/committer on mine ;)
18:30:12 <dfarrell07> edwarnicke: I didn't have time to Google it
18:30:19 <gzhao> Kincel
18:30:21 <rovarga> yup
18:30:31 <alagalah> Andrej Kincel <akincel@cisco.com>
18:30:32 <tbachman> #info colindixon requests that TSC members look for [vote] topics on TSC mailing list, so that certain items can be handled there rather than on the TSC call
18:30:47 <tbachman> #topic Signing Artifacts
18:30:48 <rovarga> colindixon: takes too long to find the mute button :)
18:30:58 <alagalah> rovarga: Get a push to talk app...
18:31:15 <tbachman> #info tykeal says there are two types of signing that we need to do: GPG signing and certificate signing
18:31:19 * edwarnicke suggests we look at adding #mute to meetbot
18:31:33 <mohnish> yes
18:31:39 <tbachman> #info colindixon asks  tykeal to explain why we need code signing
18:32:16 <tbachman> #info tykeal says code signing is done during the build process — we add a cryptographic signature so that downstream users can verify the artifacts
18:32:22 <rovarga> alagalah: dude, you have no idea of how clean my desk(top) is... a lonely PTT would get lost faster than it could appear :)
18:32:31 <tbachman> #info GPG keys can be used to validate the public portion against  the private portion used to sign the artifacts
18:32:52 <tbachman> #info The other way is to purchase an SSL cert that adds the signing component to the jar via standard SSL validation mechanisms
18:33:05 <tbachman> #info both can be used by end users to verify artifacts
18:33:06 <edwarnicke> #link http://maven.apache.org/guides/mini/guide-central-repository-upload.html <- PGP signing is required (which I believe is the same as GPG signing)
18:33:36 <colindixon> #info tykeal says GPG == PGP in this case
18:33:47 <tbachman> sliding window
18:33:53 <zxiiro> PGP is the proprietary implementation and GPG is the open source implementation
18:34:03 <tbachman> #info tykeal says the ODL web of trust key ring was started at they first ODL summit
18:34:19 <edwarnicke> +1 increase the web of trust
18:34:33 <tbachman> #info tykeal is looking to do another web of trust key ring signing at the next summit
18:35:06 <tbachman> #info tykeal says the GPG key ring will be disseminated to key servers, so that folks can use it
18:35:27 <tbachman> #info tykeal says they still have to test how this can be done programmatically; suggests doing it only from the auto-build process
18:35:34 <abhijitkumbhare> Perhaps we want to do this at the hackfest (in addition to the summit)?
18:35:44 <edwarnicke> abhijitkumbhare: +1
18:35:46 <tbachman> #info tykeal says he doesn’t want to manage private keys on multiple different silos, as it’s unsafe
18:35:49 <colindixon> abhijitkumbhare: +1
18:35:56 <colindixon> I think he meant hackfest
18:37:04 <tbachman> #info colindixon asks at a key signing event, what are the implications of what it is that we’re saying?
18:37:23 <tbachman> #info tykeal says that you have either met or believe that the person stating they have this key is who they say they are
18:37:51 <tbachman> #info colindixon says you’re connecting a private key with a human, and also a private key with a set of software
18:38:09 <tbachman> #info LuisGomez asks if we need users of the signed artifacts to be part of this key ring
18:38:25 <tbachman> people helping people, y'all
18:38:46 <tbachman> don’t trust regXboi
18:39:08 <regXboi> wow, is that a variation on don't trust anyone over 30?
18:39:16 <tbachman> regXboi: that means I’m out
18:39:40 <tbachman> #info tykeal says we’d publish the public portion of the key on our website
18:40:06 <tbachman> #info tykeal says that allows folks who aren’t part of the web of trust can verify that the artifacts have been signed by the public key
18:40:26 <tbachman> #info LuisGomez asks if this precludes anyone from using the artifacts
18:40:51 <tbachman> #info tykeal says that shouldn’t happen unless someone implements something in java to reject things that aren’t signed by the key
18:41:33 <colindixon> #info LuisGomez asks how you’d verify the artifacts are genuine, tykeal says he’s not sure how that happens in maven or Java, but he assumes it’s possible
18:41:36 <tbachman> #info tykeal says the only location that signing happens is on the ODL servers
18:42:21 <tbachman> #info edwarnicke says he believes the GPG signing just results in an extra file
18:43:16 <tbachman> #info colindixon says that b/c this is being done in the releng job, projects don’t need to take any action to enable this
18:43:29 <tbachman> #info tykeal says he still has a bit of digging to make sure — worst case is some pom file modifications
18:44:32 <dfarrell07> tykeal: I could run a key signing at the hackfest
18:44:36 <dfarrell07> I've run them before
18:44:40 <tbachman> colindixon: ^^^^
18:44:51 <zxiiro> Also, If we want to verify the keys as part of opendaylight we'd have add code to ODL to support verifying the keys in that case ODL could make decisions on to reject a feaeture or not depending on the signature.
18:45:08 <edwarnicke> Am I not being heard on the audio?
18:45:51 <tbachman> takers?
18:45:57 <dfarrell07> #action dfarrell07 will make sure there's a key signing at the hack fest
18:46:08 <tbachman> dfarrell07: thx!
18:46:22 <tbachman> #topic Best practices for easy cross-platform deployability
18:46:52 <tbachman> #link https://lists.opendaylight.org/pipermail/tsc/2015-March/002680.html e-mail to TSC with revised language on best practices
18:48:02 <tbachman> #info colindixon says the key changes is the language that allows projects to include external apps, but can’t require them.
18:48:29 <tbachman> #info mohnish says in TSDR, it makes sense to have an internal database for demos, but for production deployments, would need an external dependency
18:49:03 <tbachman> #info mohnish asks if we just document dependencies, and automation/scripts can be provided, then this should be okay
18:49:16 <tbachman> #info colindixon asks if the text as written is agreeable to mohnish
18:49:26 <tbachman> #info mohnish says yes
18:50:37 <tbachman> dfarrell07: phrobb?
18:50:46 * dfarrell07 isn't, starts
18:51:26 <tbachman> dfarrell07: phrobb may be doing it
18:51:48 <dfarrell07> tbachman: I hope so, my effort isn't going well *parsing language*
18:52:08 <phrobb> #startvote Shall the TSC approve the method described here: https://lists.opendaylight.org/pipermail/tsc/2015-March/002680.html as best practice for cross platform deployments? -1, 0, +1
18:52:08 <odl_meetbot> Begin voting on: Shall the TSC approve the method described here: https://lists.opendaylight.org/pipermail/tsc/2015-March/002680.html as best practice for cross platform deployments? Valid vote options are -1, 0, +1.
18:52:08 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:52:19 <colindixon> #vote +1
18:52:30 <mohnish> #vote +1
18:52:36 <abhijitkumbhare> #vote +1
18:52:38 <RajeevK> #vote +1
18:53:14 <dlenrow> #vote +1
18:53:14 <edwarnicke> #vote +1
18:53:17 <LuisGomez> #vote +1
18:53:19 <tbachman> didn’t we already agree on stability updates
18:53:20 <tbachman> ?
18:53:22 <regXboi> #cote +1
18:53:24 <regXboi> #vote +1
18:53:27 <tbachman> in a previous meeting?
18:53:29 <dneary> I favour security updates to last stable release
18:53:31 <phrobb> #endvote
18:53:31 <odl_meetbot> Voted on "Shall the TSC approve the method described here: https://lists.opendaylight.org/pipermail/tsc/2015-March/002680.html as best practice for cross platform deployments?" Results are
18:53:31 <odl_meetbot> +1 (8): dlenrow, regXboi, LuisGomez, edwarnicke, RajeevK, mohnish, colindixon, abhijitkumbhare
18:53:36 <tbachman> ah
18:53:44 <regXboi> so is stability different from security?
18:53:53 <tbachman> #topic Setting dates for Lithium stability updates
18:53:57 <dneary> Sorry, misread
18:54:34 <phrobb> #agreed best practice for cross platform deployments documented here: https://lists.opendaylight.org/pipermail/tsc/2015-March/002680.html has been approved.
18:54:48 <dneary> I would say you want fixes for the last stable branch - Lithium after release - and maintain security updates only until M1 of the next unstable release
18:55:02 <dneary> on Helium I mean
18:55:04 <tbachman> #info colindixon asks if we want to continue stability releases until Beryllium is released
18:55:27 <tbachman> #info dneary says he believes that you’d want fixes for the last stable branch - Lithium after release - and maintain security updates only until M1 of the next unstable release
18:55:35 <tbachman> #info regXboi asks what other communities are doing for this
18:55:42 <dneary> so - Helium gets stability & security updates until Lithium is released, then security only until Be M1
18:55:43 <tbachman> #info colindixon asks if anyone knows what openstack does for this
18:55:44 <phrobb> tbachman:  stability releases on which release? Helium or Lithium?
18:55:55 <tbachman> phrobb: ah, good point — Lithium
18:55:59 <tbachman> #undo
18:55:59 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1bace50>
18:56:00 <tbachman> #undo
18:56:00 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1bac910>
18:56:04 <tbachman> #undo
18:56:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19acf90>
18:56:08 <tbachman> 3undo
18:56:11 <abhijitkumbhare> I think Helium tbachman
18:56:24 <tbachman> #info colindixon asks if we want to continue stability releases on Lithium until Beryllium is released
18:56:28 <dneary> Li gets security & stability fixes until Be comes out, then security only until B M1
18:56:37 <tbachman> #info dneary says he believes that you’d want fixes for the last stable branch - Lithium after release - and maintain security updates only until M1 of the next unstable release
18:56:47 <tbachman> #info regXboi asks what other communities are doing for this
18:56:57 <tbachman> #info colindixon asks if anyone knows what openstack does for this
18:57:05 <tbachman> abhijitkumbhare: colindixon said it was Lithium
18:57:14 <tbachman> abhijitkumbhare: I think we already agreed on Helium in a previous call
18:57:33 <tbachman> #info dneary says he thought M1 would be enough to allow people to upgrade to the next stable version
18:57:57 <tbachman> #info edwarnicke says you continue to support Lithium until Beryllium SR1 comes out
18:58:31 <tbachman> #info colindixon says in the long run, he believes a goal could be to support two stable releases, but in the short term, may be a bit ambitious
18:59:05 <tbachman> #action colindixon to bring dates for stable release updates for Lithium to next week’s TSC meeting
18:59:11 <tbachman> I missed the second action
18:59:23 * regXboi has to run to another meeting - next week folks
18:59:25 <tbachman> #info rovarga asks if that includes fixes to deprecated APIs
18:59:39 <regXboi> #info regXboi is no longer here
18:59:44 <tbachman> regXboi: lol
18:59:47 <tbachman> sayonara
19:00:24 * tykeal drops for a different meeting
19:00:39 <tbachman> #info colindixon says you do need to support deprecated APIs for some amount of time, as you transition between stable releases
19:01:05 <tbachman> #action colindixon  to start mailing list thread on the dates and deprecated APIs issues for Stable releases
19:01:24 <tbachman> #topic cookies
19:01:29 <phrobb> #topic COOKIES
19:01:31 <tbachman> #endmeeting