17:00:05 <colindixon> #startmeeting tsc
17:00:05 <odl_meetbot> Meeting started Thu Mar 26 17:00:05 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:05 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:05 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:13 <colindixon> #topic roll call and agenda bashing
17:00:16 <colindixon> #info colindixon
17:00:32 <colindixon> #chair phrobb dfarrell07 tbachman
17:00:32 <odl_meetbot> Current chairs: colindixon dfarrell07 phrobb tbachman
17:00:34 <tbachman> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda Today’s agenda
17:00:39 <colindixon> thanks
17:00:45 <tbachman> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-03-19-17.00.html Last week’s meeting minutes
17:00:47 <tbachman> colindixon: np!
17:01:00 * tbachman wonders if we’ll reach quorum
17:01:30 * dfarrell07 has no idea
17:01:34 * tbachman has no idea
17:01:36 <tbachman> spring break?
17:01:45 <dfarrell07> ^^with regard to light attendance
17:01:47 <snoble> cricket?
17:01:52 <tbachman> snoble: LOL
17:01:56 <tbachman> I hear it’s over
17:01:57 <dfarrell07> colindixon: you have me as a proxy
17:02:10 <tbachman> spoiler alert: Australia won
17:02:11 <dfarrell07> #info dfarrell07 for cdub and Red Hat
17:02:21 <ChrisPriceAB> #info Chris Price (almost on audio)
17:02:29 <LuisGomez> #info LuisGomez
17:02:44 <tbachman> 3 more?
17:03:07 <colindixon> #action colindixon to continue to follow AD-SAL deprecation between VTN, OVSDB, and controller (are ther others?)
17:03:13 <colindixon> #action colindixon keep the thread on best practices alive
17:03:37 <tbachman> dlenrow: you on?
17:03:51 <edwarnicke> #info edwarnicke
17:03:55 <colindixon> #action dlenrow to follow up on the mail about how to procede with persitence
17:03:55 <tbachman> 2 more
17:04:16 <regXboi> #info regXboi (partly here)
17:04:18 <jmedved> #info jmedved
17:04:24 <tbachman> quorum
17:04:25 <edwarnicke> edwarnicke: requests weather report be added to the agenda
17:04:25 <mohnish> #info mohnish
17:04:31 <tbachman> over-quorum
17:04:39 <colindixon> #action LuisGomez to start drafting a list of qualifiers for an issue for being a blocker to an SR - edwarnicke to assist
17:07:07 <colindixon> #action rovarga (with help from Thanh) to work on tracking latency from merge to all CSIT
17:07:24 <colindixon> #undo
17:07:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x194ad50>
17:07:34 * dfarrell07 is somewhat reassured that *everyone else* has a ton of stuff on their plate as well ;)
17:07:43 <tbachman> dfarrell07: lol (and ACK)
17:08:08 <colindixon> #action rovarga (and/or Thanh) to add an something to a backlog somewhere about measuring latency between merge and CSIT completely finishing
17:08:29 * zxiiro is pretty busy as well
17:08:40 <tbachman> zxiiro: lol!
17:08:42 <tbachman> zuul
17:08:43 <colindixon> #info LuisGomez says that this may be easier in Beryllium assuming we move Zuul
17:09:24 <dfarrell07> colindixon: yes
17:09:33 <colindixon> #topic updates
17:09:59 <zxiiro> #action zxiiro to create revert patches for autorelease <relativePaths> and abandon existing patches. Will resolve <relativePaths> inside of autorelease scripts instead.
17:10:30 <tbachman> #info wojciech would like to add discussing the AAA project to the agenda
17:10:48 <edwarnicke> colindixon: Could we also get a weather report
17:10:55 <edwarnicke> colindixon: We have a scheduled weather event
17:10:57 <colindixon> #info colindixon will cover requests to the TSC from the board
17:11:05 <colindixon> #info edwarnicke requests to cover the weather briefly
17:11:07 <colindixon> #topic Events
17:11:13 <tbachman> #info phrobb says that the hackfest is coming up 4/15-4/16; 49 people are registered; those who want to start with action items to work on should start to formulate what that looks like and send an agenda
17:11:56 <tbachman> #info phrobb says for the ODL summit in July: notifications to speakers are going out now (not all out yet — in process today and tomorrow) for accepted presentations and tutorials
17:12:24 <tbachman> #link http://www.opendaylight.org/news/events ODL Events web page
17:12:52 <tbachman> #topic Lithium and Stable/Helium
17:13:06 * tbachman can’t hear gzhao
17:13:22 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-March/002769.html summary from phrobb
17:13:42 <tbachman> #info gzhao is still waiting for 5 offset 2 projects to report
17:13:49 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1196332566 the project stats spreadsheet
17:14:14 <tbachman> #info reservation says they’ll report soon; core tutorials not as concerned about; 2 other projects still to report
17:14:36 * tbachman missed the totals
17:15:02 <tbachman> #info colindixon says the most concerning one is AAA, which is on the agenda
17:15:08 <tbachman> #info gzhao says discovery is also in red
17:15:14 <phrobb1> welcome Youcef.  Please #info in when you get the chance.
17:15:27 <tbachman> #info zxiiro says there are 5 projects still to complete the SR3 merging/tagging
17:15:29 <Youcef> #info Youcef Laribi
17:15:46 <tbachman> #info zxiiro says l2switch can merge, which is holding up other projecgts
17:16:17 <tbachman> #info colindixon asks if there’s anything else around projects moving to JJB, etc.
17:16:31 <tbachman> #info zxiiro says Defense4All has moved to JJB; just plugin2oc is left
17:16:49 <tykeal> well, and opflex but that's a project we're working with already
17:17:13 <tbachman> #info tykeal points out that OpFlex is also not in JJB, but they’re working with them already
17:17:18 <tbachman> tykeal: thx ;)
17:17:21 <tykeal> yep
17:17:59 <tbachman> didn’t we agree we wouldn’t do this for stable/helium?
17:18:02 <tbachman> just lithium
17:18:07 <tbachman> and beyond
17:18:14 <colindixon> #action LuisGomez to start a thread about how to unblock integration testing until patches are merged
17:18:20 <tbachman> ah
17:18:27 <tbachman> #topic System Integration and Test
17:18:37 <LuisGomez> #info https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Performance_Test:Results
17:18:40 <tbachman> #undo
17:18:40 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ba0690>
17:19:03 <tbachman> #info https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Performance_Test:Results Performance Test results in lab by Integration group
17:19:23 <tbachman> #info LuisGomez says they’ll be measuring performance from now on and will be reporting in this wiki, and will report bugs
17:20:12 <tbachman> #info LuisGomez says he’ll keep track of the bugs and bring them up if they’re not being filed by developers
17:20:56 <tbachman> #info mohnish says longevity is also important — asks if it’s also being tested
17:21:20 <tbachman> #info LuisGomez says they’re working on setting up longevity testing, but nothing currently; Spirent may also help with this effort
17:21:46 <tbachman> #info jmedved asks if LuisGomez is using the scripts he provided a while back
17:21:57 <tbachman> #info LuisGomez says they’re using the scripts for some things
17:22:47 <tbachman> #info jmedved says the codecs for REST have changed recently — should retest to see if there’s significant performance improvements
17:24:09 <tbachman> #topic Infrastructure
17:24:35 <colindixon> #info the sandbox has been having issues because of how much stuff has been going through releng
17:24:39 <tbachman> #info tykeal says they’re aware of the sandbox having issues b/c of the BW pushed through the releng silo
17:24:47 <colindixon> tbachman: I’ll let you fix it
17:24:57 <tbachman> #undo
17:24:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19b33d0>
17:25:18 <tbachman> #info tykeal says odlforge has been put on the backburner until releng stuff gets worked out
17:25:25 <tbachman> #topic AAA status
17:26:07 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-March/002775.html the status from AAA
17:26:32 <tbachman> colindixon: beat me too it (couldn’t figure out how to spell “Wojciech” :P )
17:27:36 <colindixon> #info Wojciech says that the token caches looks like it will make it
17:27:37 <tbachman> #info Wojciech said they had a dependency on the persistence project, which also has resource changes, which puts this in jeopardy
17:28:35 <tbachman> #info Wojciech says there are only three people currently on the project; there is a choice of an MD-SAL AAA keystore, or completeing the keystone project (notes MD-SAL AAA would be “experimental")
17:29:13 <tbachman> #info Mahesh (from HP) asks for using MD-SAL for AAA — with in-memory data store, is that sufficient?
17:29:39 <tbachman> #info colindixon says we’re going to enable the clustered data store by default, but without clustering (i.e. single-node), so it will be persistent by default for Lithium
17:30:05 <tbachman> #info Mahesh asks if AAA can then use the MD-SAL and meet the Lithium goals
17:30:07 <colindixon> tbachman: thanks!
17:30:30 <tbachman> #info Wojciech says he doesn’t feel comfortable committing to this deliverable by Lithium — though they can make progress there
17:30:33 <tbachman> colindixon: np!
17:31:01 <tbachman> #info colindixon asks who is dependent on delivery of these features (e.g. SNMP for keymanager)?
17:31:21 <tbachman> #info Wojciech says other than the general public interested in deploying AAA in clusters, he’s not aware of any
17:31:39 <tbachman> #info Wojciech says SNMP is no longer dependent as they’ve gone with a very simple mechanism for storing their credentials
17:32:35 <tbachman> #info colindixon asks why keystone federation was critical for Lithium?
17:33:12 <tbachman> #info edwarnicke says we need to make sure we have something that works following the standard “out of the box” deployment model — keystone radically changes this model
17:33:16 * colindixon notes that we really need wrap this up sooner rather than later
17:33:40 <tbachman> #info edwarnicke says that mestery says it’s super-important to talk sooner rather than later to openstack keystone folks in order to make sure there aren’t any issues there
17:33:59 <tbachman> regXboi: highly agitated ;)
17:34:46 <tbachman> #action regXboi, Wojciech. edwarnicke, and Mahesh to talk about AAA keystone federation
17:34:50 <tbachman> #undo
17:34:50 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x19be690>
17:35:09 <tbachman> #action regXboi, Wojciech. edwarnicke, and Mahesh to organize meeting to talk about AAA keystone federation
17:35:31 <tbachman> #info Wojciech asks for guidance from TSC on “chicken-and-egg” problem
17:35:46 <tbachman> #action edwarnicke, rovarga, and ttkacik1 to look into bootstrapping AAA
17:36:00 <tbachman> colindixon: ^^^
17:36:51 <tbachman> #info Mahesh said for AAA, there was a dependency on SQLite, which is not present on all the platforms; asks if we’re removing that dependency
17:37:09 <tbachman> #info edwarnicke says that there’s a patch that mlemay has provided that *almost* works when using H3
17:37:17 <colindixon> #info there’s a patch that mlemay provided that will help us to move to Karaf to 3.0.3
17:37:33 <tbachman> #info edwarnicke says it would be huge if someone can pick that patch up and complete it
17:37:43 <tbachman> #info Mahesh said HP will try to pick up this item
17:37:58 <tbachman> #topic Weather (by edwarnicke)
17:38:03 <edwarnicke> #link https://wiki.opendaylight.org/view/Weather#Clustered_Data_Store_Switch_over
17:38:09 <tbachman> #undo
17:38:09 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x194b090>
17:38:12 * ChrisPriceAB nervous laughter -> Ed > 3 minutes
17:38:26 <tbachman> #link https://wiki.opendaylight.org/view/Weather#Clustered_Data_Store_Switch_over Clustered Data Store Switchover on Weather page
17:38:52 <tbachman> #info edwarnicke says there’s one change that’s positive that folks need to be aware of — controller restarts will come up with persisted data, by default
17:39:03 <abhijitkumbhare> Cool  (cfg datastore persisted)
17:39:19 * tbachman pictures edwarnicke in front of bluescreen, with bad coat and tie, reporting on weather
17:39:35 <regXboi> tbachman: stop that!
17:39:40 <tbachman> regXboi: ;)
17:39:45 * regXboi is glad he wasn't drinking
17:40:01 <tbachman> #info rovarga says the BGP-PCEP project currently won’t work with the clustered data store
17:40:33 <tbachman> #action rovarga to add the fact that BGP-PCEP currently won’t work with clustered data store to weather page
17:40:34 <tykeal> for you tbachman: http://www.avcams.com/avcams/Pictures/BlueScreen.JPG
17:41:13 <tbachman> #topic Board Requests for the TSC
17:41:26 <tbachman> tykeal: lol!
17:41:27 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-March/002806.html the board requests of the TSC
17:41:40 <abhijitkumbhare> tbachman - edwarnicke is working on cloud (on the blue screen)
17:41:47 <tbachman> #info colindixon says there are 6 requests from the TSC in that email
17:41:51 <tbachman> abhijitkumbhare: LOL!
17:42:34 * ChrisPriceAB I can also provide interpretations
17:43:26 * tbachman wonders if he’ll be able to adequately capture the discussion he anticipates ensuing ;)
17:44:33 * tbachman waits for regXboi of many hats
17:44:54 * tbachman wonders if regXboi is related to Dr. Suess
17:45:21 <tbachman> #info ChrisPriceAB asks who sets the requirements on projects
17:45:35 <tbachman> #info colindixon says he hopes its a combination of the TSC and projects
17:45:59 <tbachman> #info edwarnicke says that can get political. You need a consistent measure of performance and stability that can be tracked
17:46:16 <tbachman> #info edwarnicke says it’s not clear that there are clear definitions for how you measure performance and stability
17:46:18 <dfarrell07> +1 to everything edwarnicke just said about perf
17:46:30 <dfarrell07> ^^from person who has done a lot of perf stuff
17:46:37 <phrobb1> #startvote Shall the TSC have a two hour meeting next week (4/2) given the addition discussions needed? +1, 0, -1
17:46:37 <odl_meetbot> Only the meeting chair may start a vote.
17:46:47 <colindixon> #vote +1
17:46:49 <tbachman> #info ChrisPriceAB says that instead of setting a bar at the outset as far as a use case being achieved in some way, can we set up a set of metrics
17:46:55 <phrobb1> Vote didnt go
17:46:57 * tbachman will stop minute taking
17:46:59 <phrobb1> I'm not a chair.
17:47:01 <tbachman> ah
17:47:02 <phrobb1> hold on voting
17:47:07 <mohnish> If it is an extended session next week, is it possible to start earlier like 9am pST?
17:47:12 <dfarrell07> #chair phrobb1
17:47:12 <odl_meetbot> Current chairs: colindixon dfarrell07 phrobb phrobb1 tbachman
17:47:20 <tbachman> dfarrell07: thx!
17:47:29 <tbachman> (and good catch ;) )
17:47:47 <tbachman> #info ChrisPriceAB asks if we’re being to approve requests that we don’t yet know what they are
17:48:09 <phrobb1> #startvote Shall the TSC have a two hour meeting next week (4/2) given the addition discussions needed? +1, 0, -1
17:48:09 <odl_meetbot> Begin voting on: Shall the TSC have a two hour meeting next week (4/2) given the addition discussions needed? Valid vote options are +1, 0, -1.
17:48:09 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:48:09 <tbachman> #info colindixon says we’ve been tasked to meet these requests, and explain how we will meet them.
17:48:39 <regXboi> #vote +1
17:48:55 <mohnish> #vote +1
17:48:59 <colindixon> #vote +1
17:49:12 <LuisGomez> #vote -1 (i am on pto next week)
17:49:12 <odl_meetbot> LuisGomez: -1 (i am on pto next week) is not a valid option. Valid options are +1, 0, -1.
17:49:13 <dfarrell07> edwarnicke: at at 10 ft, you realize that there are just a limited number of cycles for perf work (Integration team is working on it)
17:49:22 <dfarrell07> s/at at/and at/
17:49:33 <LuisGomez> #vote -1
17:49:42 <dfarrell07> #vote +1
17:49:53 <edwarnicke> dfarrell07: All of life is tradeoffs... I can make a really narrow use case scream by excluding all others and making the system brittle as hell ;)
17:50:08 <edwarnicke> #vote -1
17:50:19 <tbachman> jmedved: ^^^
17:50:46 <tbachman> Youcef: ^^^^
17:51:11 <jmedved> #vote +1
17:51:16 * ChrisPriceAB back to hydrogen style
17:51:26 <tbachman> ChrisPriceAB: ^^^
17:51:29 <tbachman> (votage)
17:51:33 <ChrisPriceAB> #vote +1
17:51:45 * ChrisPriceAB sorry edwarnicke
17:52:02 <tbachman> one more for majority?
17:52:18 <tbachman> Youcef: ^^^
17:53:04 <phrobb1> vote about to close…. Youcef, are you able to vote?
17:53:12 <tbachman> dlenrow:  ^^^^
17:53:33 <phrobb1> anyone else missing tbachman?
17:53:39 * tbachman goes back to look
17:53:45 <hideyuki> What is the ODL Advisory Group?
17:54:01 <Youcef> #vote -1
17:54:30 <Youcef> sorry had to step out
17:54:34 <tbachman> Youcef: np!
17:54:36 <tbachman> and thx!
17:55:01 <tbachman> phrobb1: I think that’s it (aside from Uri, who’s not on IRC)
17:55:04 <tbachman> (but on the call)
17:55:11 <phrobb1> hideyuki:  a group of end users providing feedback to ODL that will ultimately come to the TSC
17:55:23 <phrobb1> #endvote
17:55:23 <odl_meetbot> Voted on "Shall the TSC have a two hour meeting next week (4/2) given the addition discussions needed?" Results are
17:55:23 <odl_meetbot> +1 (6): jmedved, regXboi, ChrisPriceAB, dfarrell07, mohnish, colindixon
17:55:23 <odl_meetbot> -1 (3): LuisGomez, edwarnicke, Youcef
17:55:31 <tbachman> #info abhijitkumbhare asks about project maturity — expresses concern that very few projects will be mature in the Beryllium time frame
17:55:42 <tbachman> (back to our regularly scheduled programming ;) )
17:57:11 <tbachman> #info ChrisPriceAB asked about the difference between items one and five
17:57:24 <tbachman> #info colindixon says one is about lifecycles and five is about execution
17:57:31 * rovarga finds the timing ... interesting
17:58:41 <rovarga> regXboi: coming at this time, +2
17:58:42 <tbachman> #info regXboi_committer says the whole set of requirements is “borderline poison”
17:59:12 <tbachman> #info regXboi says if this comes from the community, that’s good; but coming from top-down, it’s an anathema to open-source
17:59:32 <tbachman> #info regXboi says items #2 and #3 declare winners and losers, and do so in a sneaky, underhanded way
18:00:07 <tbachman> #info Uri recommends consulting board members who were involved in the discussion, as there was a long discussion around these items
18:00:36 <tbachman> #info Uri says there was only an intent to provide focus and direction and drive deliverables — can’t be open-ended, b/c no investment can be completely open-ended
18:00:52 <tbachman> #info colindixon encourages folks to go to the mailing list to discuss these items
18:01:11 <tbachman> #info phrobb1 says the next board meeting is next Wednesday, April 1st
18:01:25 <tbachman> #info colindixon says we’re unlikely to have a response in time for the next board meeting
18:02:00 <tbachman> #info colindixon says his ask of TSC members and committers is to not knee-jerk react to these, but come with the “best” interpretation that can help move the project forward
18:02:45 * tbachman pictures WSS’s Jets vs. Sharks
18:02:57 <tbachman> #topic cookies
18:03:32 <tbachman> colindixon: who to poll? you? phrobb1?
18:04:01 <tbachman> #info edwarnicke points out that the extra hour for TSC members who do development is extra painful
18:04:06 <tbachman> #endmeeting