17:00:00 <phrobb1> #startmeeting tsc
17:00:00 <odl_meetbot> Meeting started Thu Apr  9 17:00:00 2015 UTC.  The chair is phrobb1. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:00 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:00 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:36 <phrobb1> #topic Roll Call - TSC Members please #info in
17:00:44 <regXboi> #info regXboi
17:00:52 * regXboi trying to get to weex
17:00:59 * regXboi er webex
17:01:15 <LuisGomez> #info LuisGomez
17:01:16 <edwarnicke> #info edwarnicke
17:01:37 <colindixon> #info colindixon
17:01:51 <colindixon> sorry, time got past me
17:02:04 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda in it’s usual place
17:02:18 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-04-02-17.00.html last week’s minutes for action items
17:02:32 <tykeal> regXboi: I think you're first way of "saying" it is appropriate ;)
17:02:43 <cdub> #info chris wright
17:02:54 <Youcef> #info Youcef Laribi
17:03:38 <colindixon> #action LuisGomez to start drafting a list of qualifiers for an issue for being a blocker to an SR - edwarnicke to assist
17:03:42 <dneary> Dave Neary here
17:03:51 <snackewm> #info Eric Multanen (for Uri)
17:03:54 <mohnish> #info mohnish anumala
17:04:46 <colindixon> #action colindixon to e-mail regXboi, Wojciech. edwarnicke, and Mahesh t talk about AAA keystone federation and if we need to worry about anything
17:04:52 * regXboi wakes up
17:05:01 <abhijitkumbhare> #info abhijitkumbhare for Chris Price
17:05:59 <edwarnicke> colindixon: Could we fit a weather report into the agenda somewhere?
17:06:06 <colindixon> #action LuisGomez to start a thread about how to unblock integration testing until patches are merged
17:07:23 <colindixon> edwarnicke: sure, we’ll do it during Li update
17:07:24 * regXboi goes and pokes the fire
17:07:29 <dlenrow> #info dlenrow
17:07:51 <phrobb1> #chair colindixon
17:07:51 <odl_meetbot> Current chairs: colindixon phrobb1
17:08:00 <colindixon> #chair regXboi dfarrell07 tbachman
17:08:00 <odl_meetbot> Current chairs: colindixon dfarrell07 phrobb1 regXboi tbachman
17:08:10 <colindixon> #info there’s a hackfest with 91 people registered for next week
17:09:05 <colindixon> #info we’ll meet on wednesday morning on a few high-level topics, then unconference the rest
17:09:32 <colindixon> #info high-level topics include licensing, export control, etc. while we have people in the room
17:10:08 <colindixon> #action everyone that cares do the gpg keysigning stuff here: https://lists.opendaylight.org/pipermail/tsc/2015-April/002841.html
17:11:34 <colindixon> #info tykeal points out that it’s odd to have 2 year expirations, either infinite or 10 years is more common
17:11:58 <snoble> anyone using keybase.io?
17:12:12 <tykeal> yes, but they don't hook into the keyserver mesh :(
17:12:17 <zxiiro> snoble: I am
17:12:22 <colindixon> #info hackfest starts at 9a
17:12:36 <colindixon> #topic events
17:12:38 <snoble> yes you still have to put the keys in the keyserver(s)
17:12:45 <colindixon> #undo
17:12:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1c3e890>
17:12:51 <tykeal> snoble: that also isn't a replacement to keysigning parties
17:12:52 <colindixon> #topic stable/helium
17:13:16 <colindixon> #info zxiiro says we got the version bump done for SR3 and so we’re ostensibly chugging to SR4
17:13:21 <colindixon> #topic lithium update
17:13:26 <phrobb1> #chair dfarrell07
17:13:26 <odl_meetbot> Current chairs: colindixon dfarrell07 phrobb1 regXboi tbachman
17:14:36 <colindixon> #Info dlenrow says he hopes to get existing comitters to move things along with perisstence
17:14:51 <colindixon> #action phrobb1 to e-mail jan about SXP
17:15:06 <colindixon> #link https://wiki.opendaylight.org/view/Weather the weather page for Lithium
17:15:48 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Karaf_3.0.3_Upgrade we will be moveing to Karaf 3.0.3 next week, there’s extensive information about ho to test it and recoring known issues
17:16:37 <rovarga> #info on previous topic: we have some movement with current SXP committers, so it looks like option #1 will work
17:18:17 <colindixon> #action regXboi and/or edwarnicke will post things about moxy to the weather page and/or add it to release notes with a workaround
17:20:21 <colindixon> rovarga: thanks!
17:20:56 <colindixon> #topic system integration and test
17:21:33 <colindixon> #info nothing this week, other than that we are starting to work on S3P tests and integration folks plan to use the whole second day to build tests
17:21:39 <colindixon> #topi infrastructure
17:21:44 <colindixon> #topic infrastructure
17:21:44 * regXboi wonders if integration/test should be the "world report" if it follows "weather" :)
17:22:08 <colindixon> #into still tracking issues with jenkins slaves and other issues
17:22:45 <colindixon> #action phrobb1 to send mail to release encouraging people to send keys
17:23:08 <colindixon> #topic beryllium planning
17:24:48 <phrobb1> #info regXboi asks should we discuss isotope option for release planning?
17:25:08 <cdub> does that mean there's just no interest?
17:26:16 <phrobb1> #info colindixon notes there is a discussion on 2 releases per year.  Should we have one release more focused on stability/scale/performance vs new features
17:26:31 <regXboi> #undo
17:26:31 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b946d0>
17:26:35 <regXboi> #info the high order bit of the release discussion is that the target has been two major releases per year and some are asking if we should be aiming at one major and additional minor
17:26:45 <regXboi> phrobb1: I wanted to be more specific
17:26:45 <phrobb1> thanks regXboi
17:28:30 <colindixon> #info abhijitkumbhare and LuisGomez say they like the element/isotope appraoch with one major and one minor release per year
17:29:29 <cdub> that's going the wrong direction
17:29:40 <cdub> releasing more often is the right direction
17:30:06 <colindixon> #info rovarga says he likes it but he worries that it might slow down feature development
17:30:30 <phrobb1> #info cdub notes that doing fewer major releases per year is the wrong direction.  Releasing more often is the right direction
17:30:40 <colindixon> thanks phrobb1
17:33:36 <colindixon> #info cdub notes that we don’t seem to have a goal for what we’re focusing on in designg releases which is why the discussion is somewhat less productive than we might hope
17:33:52 <colindixon> #info cdub says that he’d like to see more, lighter-weight releases per year
17:34:09 <dneary> I agree with cdub
17:34:31 <dneary> do hard things often until they're easy - core DevOps principle
17:34:54 <phrobb1> #info cdub notes that doing 1 major release per year means only one per year we can manage architectural (stable/scale/performance/etc) issues
17:35:04 <colindixon> #info LuisGomez says that in his opinion we do need to focus on S3P, so that’s one clear goal
17:37:37 <dfarrell07> +inf to continuous release
17:37:50 <colindixon> #info rovarga advocates for frequent (or continuous) releases
17:37:57 <colindixon> dfarrell07: how do you manage version skew
17:38:11 * dfarrell07 is thinking
17:38:33 <snoble> are we dependent on all features being ready for a release?
17:38:59 <colindixon> #info there is discussion about how you do focus on things, if you give focus teeth and stop people from working on other things, you risk losing people
17:39:18 <snoble> I know hydrogen -> helium was a huge change, but will Lithium be backwards compatible?
17:39:54 <colindixon> #info colindixon says nobody has suggested stopping people from working on things, but to enoucage people to work on some areas with non-zero resources
17:39:55 <phrobb1> #info Discussion ensues on the need to make the tooling and process more agile and geared toward continuous release if we are to explore more frequent light-weight releases
17:40:22 <colindixon> #info regXboi and edwarnicke note that when we declared a focus on Neutron, not as many resources came out as we’d hoped for
17:40:43 * dfarrell07 doesn't have a good answer about version skew
17:40:53 * cdub sniffs a long non-converging discussion
17:41:14 <rovarga> dfarrell07: I am afraid we will need to roll our own something based on maven dependency plugin
17:41:14 * regXboi agrees with cdub
17:41:29 <dfarrell07> rovarga: ouch
17:41:49 <dfarrell07> rovarga: I have no idea how we'd do that
17:41:59 <rovarga> snoble: depends on which aspect of the system ... I think most of the end-user facing interfaces will be reasonably compatible
17:42:57 <rovarga> dfarrell07: run mvn dependency:analyze (or something) on each project, output to .xml, analyze XMLs ... but that's just a stab without actually looking into it
17:43:09 <snoble> for Quagga we are building a large testbed with all sorts of linux distributions for testing, is that something that would be useful for ODL?
17:43:33 <snoble> (we are also doing *bsd, solaris, 32bit, etc)
17:43:56 <dfarrell07> colindixon: for the record, Integration is already focusing on S3P tooling, basically prepping it for goals from use-cases once we have that data
17:44:02 <colindixon> #info mohnish says that part of Beryllium should look at maturity of projects
17:44:45 <dfarrell07> rovarga: +1
17:44:45 <phrobb1> #info colindixon notes that in the absense of more information suggests Beryllium should target a time frame similar or less than Lithium and focus on S3P to the extent the community is comfortable on focusing on that.
17:46:26 <cdub> ack
17:47:16 <cdub> and make sure we have milestones on US Labor Day and US Thanksgiving and release on Christmas
17:47:27 <colindixon> cdub:
17:48:02 <colindixon> #agree phrobb1 to draft a Beyrillum release plan based on Lithium that is shorter and includes a focus on S3P and use cases
17:48:20 <dfarrell07> I think this talk about goals from above is already changing behavior in projects, at least integration. We talk about "TSC is thinking about X, we need to make sure we're ahead and doing Y"
17:48:43 <abhijitkumbhare> Should that be # agreed colindixon (not # agree) ?
17:49:01 <phrobb1> #action phrobb1 to draft a Beyrillum release plan based on Lithium that is shorter and includes a focus on S3P and use cases
17:49:09 <dfarrell07> #agreed phrobb1 to draft a Beyrillum release plan based on Lithium that is shorter and includes a focus on S3P and use cases
17:49:14 <dfarrell07> abhijitkumbhare: yes^^
17:50:51 <dfarrell07> #info Discussion about lower-risk ways to learn about/try cont release
17:51:10 <colindixon> dfarrell07: thanks!
17:51:31 <cdub> just a notice from my math that 6mo -> 3mo release doesn't == infinitesimal release increment ;)
17:51:44 * dfarrell07 is interested in cont release, CD also
17:53:36 <snoble> we are going to do compliance testing on the bgpcep project in April
17:54:06 <phrobb1> dlenrow:  you were making some background noise so I muted you
17:54:13 <dfarrell07> I strongly suspect Integration would love resources for perf/scale testing in CI work. We're doing it, but it's a domain that would benefit from more warm bodies.
17:54:39 <dfarrell07> s/warm bodies/warm bodies that push code/
17:56:27 <phrobb1> #info colindixon notes what was requested was identification of resource needs to address requests from the board.  Can we identify resources needs now (low hanging fruit) for improving S3P in integration & testing
17:57:47 <dfarrell07> edwarnicke: I hadn't put much thought into that, FYI ;)
17:58:55 <colindixon> The TSC notes that the integration and testing team has current issues related to performance and scale which aren’t being worked on now because of a lack of people who can write code to do performance and scale testing as well as interpreting the results. If the board could help here, it could drastically improve S3P, perhaps even Lithium.
17:59:49 <colindixon> : The TSC notes that the integration and testing team has current issues related to performance and scale which aren’t being worked on now because of a lack of people who can write code to do performance and scale testing as well as interpreting the results and translate them into code improvemets. If the board could help here, it could drastically improve S3P, perhaps even Lithium.
18:00:03 <dfarrell07> It was bug 1395, not 1391, FYI
18:00:07 <dfarrell07> https://bugs.opendaylight.org/show_bug.cgi?id=1395
18:00:47 <colindixon> #startvote shall the TSC send the following message to the board: https://lists.opendaylight.org/pipermail/tsc/2015-April/002869.html? -1, 0, +1
18:00:47 <odl_meetbot> Begin voting on: shall the TSC send the following message to the board: https://lists.opendaylight.org/pipermail/tsc/2015-April/002869.html? Valid vote options are -1, 0, +1.
18:00:47 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:00:53 <cdub> #vote +1
18:00:55 <colindixon> #vote +1
18:00:55 <dlenrow> #vote +1
18:00:58 <LuisGomez> #vote +1
18:01:02 <mohnish> #vote +1
18:01:02 <edwarnicke> #vote +1
18:01:10 <snackewm> #vote +1
18:01:10 <abhijitkumbhare> #vote +1
18:01:59 <phrobb1> #endvote
18:01:59 <odl_meetbot> Voted on "shall the TSC send the following message to the board: https://lists.opendaylight.org/pipermail/tsc/2015-April/002869.html?" Results are
18:01:59 <odl_meetbot> +1 (8): dlenrow, LuisGomez, edwarnicke, cdub, mohnish, colindixon, abhijitkumbhare, snackewm
18:02:39 <mohnish> During M1 or M2, each project can give their S3P goals.
18:02:47 <colindixon> mohnish: +100
18:02:49 <cdub> colindixon: agreed
18:02:51 <colindixon> #topic cookies
18:02:52 <phrobb1> #endmeeting