17:00:02 <colindixon> #startmeeting tsc
17:00:02 <odl_meetbot> Meeting started Thu Apr 23 17:00:02 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:02 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:02 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:08 <colindixon> #topic agenda bashing and roll call
17:00:16 <colindixon> #info colindixon
17:00:31 <colindixon> #chair dfarrell07 tbachman ChrisPriceAB edwarnicke phrobb
17:00:31 <odl_meetbot> Current chairs: ChrisPriceAB colindixon dfarrell07 edwarnicke phrobb tbachman
17:00:46 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda in it’s usual place
17:01:19 <ChrisPriceAB> #info Chris Price (too soon?)
17:01:27 * ChrisPriceAB no audio yet
17:01:43 <colindixon> we’re going
17:02:04 <edwarnicke> #info edwarnicke
17:02:45 <dlenrow> #info dlenrow
17:02:49 <LuisGomez> #info LuisGomez
17:03:28 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-04-09-17.00.html meeting minutes from last time
17:04:53 <colindixon> #action dfarrell07 to draft a heuristic to determine if an issue for being a blocker to an SR
17:05:10 <dfarrell07> ^^ack
17:05:59 <jmedved> #info jmedved
17:06:18 <colindixon> #action dfarrell07 to write up something about how to raise a bug as a (potential) blocker for lithium
17:06:24 <mohnish> #info mohnish
17:07:16 <colindixon> #action regXboi and/or edwarnicke will post things about moxy to the weather page and/or add it to release notes with a workaround
17:08:39 <dfarrell07> #info LuisGomez suggests that if a project is blocking integration system tests from running, we should give them 24hrs to fix it before we kick them (easy to apply again once fixed)
17:11:07 <dfarrell07> #topic Updates
17:11:16 <dfarrell07> #info Phil isn't here, so no event updates
17:11:18 <colindixon> #link http://www.opendaylight.org/news/events/ the events page
17:11:18 <Youcef> #info Youcef Laribi
17:11:43 <dfarrell07> #topic Li and Stable Helium updates
17:12:17 <dfarrell07> #info gzhao says that all projects should have status reported, a number of projects haven't
17:12:20 <colindixon> #info two offset 1 and and two offset 2 projects have failed to provide M4 reports so far
17:13:06 <dfarrell07> #info gzhao reports on projects shifting between green<->yellow
17:13:14 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1196332566 the status spreadsheet
17:13:19 <dfarrell07> ^^thanks
17:13:45 <dfarrell07> #link See the status link above for details of those status changes
17:13:48 <dfarrell07> #undo
17:13:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1bac550>
17:13:53 <dfarrell07> #info See the status link above for details of those status changes
17:14:39 <dfarrell07> #info There are a number of projects that are in the process of withdrawing from the release, discussions ongoing
17:15:17 <dfarrell07> colindixon: he's #info'd in
17:15:21 <tykeal> maple still hasn't been cleared for resources by phrobb
17:15:39 <colindixon> #info at this point in time the following projects seem like the may withdraw: SXP, plugin2oc, Maple, Discovery
17:15:49 <dfarrell07> #info Discovery has sent an email to ask to formally withdraw
17:15:54 * dfarrell07 digs for link
17:15:54 <gzhao> https://lists.opendaylight.org/pipermail/release/2015-April/002030.html <-- persistence
17:16:30 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-April/002925.html Discovery project request to withdraw from Li
17:16:46 <colindixon> #Info phrobb is working with Maple to figure out what makes sense, they are likely to withdraw as they still don’t have resources because of IPR issues (even though they are now resolved)
17:16:55 <colindixon> #info phrobb is working with Maple to figure out what makes sense, they are likely to withdraw as they still don’t have resources because of IPR issues (even though they are now resolved)
17:16:55 <dfarrell07> idk
17:17:20 <dlenrow> Team reports status before can come off mute, priceless
17:18:00 <dfarrell07> #info As discussed past weeks, Plugin2OC is dropping from SR
17:18:09 <dfarrell07> #topic Integration and Test updates
17:18:54 <dfarrell07> #info Super Committers are now able to merge patches for release, which is good
17:19:16 <colindixon> #info two things to improve our ability to do integration tests: (1) allow for faster (or automated) version bumping and (2) pull back time to be remove people from integration if they break things to 24 hours
17:19:17 <dfarrell07> #info 24hr limit on breaking Integration tests before kick mentioned by LuisGomez
17:20:02 <dfarrell07> #info No objections raised to LuisGomez kicking projects if they break Integration tests for >=24hrs
17:20:07 <dneary> My question would be "responds to what?"
17:20:13 <dneary> 24h is not very long
17:20:32 <dfarrell07> dneary: it's very long if they are preventing all Integration tests from running
17:20:37 <dfarrell07> dneary: and it's easy to add them back
17:20:51 <dneary> dfarrell07, OK
17:22:04 <colindixon> #info edwarnicke says he’s pretty sure he knows how to write the test to catch the last remaining loophole that allows projects to break the integration build
17:22:34 <colindixon> #action colindixon to send mail and/or maybe just push that test forward himself
17:22:36 <colindixon> #undo
17:22:36 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1ab7f10>
17:22:47 <dfarrell07> #info ping edwarnicke if you're willing to take that "last loophole" TODO above
17:22:56 <colindixon> #action colindixon to send mail and/or maybe just push the last test that lets projects break integration
17:23:35 <dfarrell07> #info Integration team is working to get additional perf jobs in CI
17:23:44 <dfarrell07> #topic Infrastructure
17:24:40 <gzhao> edwarnicke: I would like to help on that
17:24:46 <dfarrell07> #info Our LF heros, tykeal and zxiiro, have been fighting a bunch of fires in infra during the past few days
17:24:53 <colindixon> dfarrell07: +100
17:24:57 <gzhao> edwarnicke: close the "last loophole" issue
17:25:31 <snoble> This is one of the reasons we had to move to bamboo (btw)
17:25:35 <dfarrell07> #info tykeal gives overview of Jenkins problem, still working on it
17:26:23 <dfarrell07> #info we're still processing jobs way faster than in past releases, FYI (just not stable atm)
17:26:26 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Jenkins_slave_instability
17:27:02 <dfarrell07> edwarnicke: rofl
17:27:08 <snoble> the fact that tykeal and zxiiro have a functional workaround is awesome
17:27:24 <dneary> The space elevator is ready?
17:27:34 <dneary> I missed that progress report
17:27:43 <snoble> Uber for Space Elevators
17:27:54 <dfarrell07> #topic Committer Promotions
17:28:05 <dfarrell07> #info noone from GBP on call
17:28:18 <dfarrell07> #info no one from CAPWAP on call
17:28:26 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-April/002909.html proposal Luis Gomez on RelEng/Builder
17:28:29 <dbainbri> would Lyft be more appropriate for a space elevator …
17:28:35 <dfarrell07> #info Reviewing adding LuisGomez to as committer on RelEng
17:29:15 <dfarrell07> not ready
17:29:38 <colindixon> #action colindixon to start e-mail voting threads on CAPWAP and GBP to the mailing list
17:29:44 <dfarrell07> #startvote Shall the TSC approve LuisGomez as a committer on RelEng/Builder? -1, 0, +1
17:29:44 <odl_meetbot> Begin voting on: Shall the TSC approve LuisGomez as a committer on RelEng/Builder? Valid vote options are -1, 0, +1.
17:29:44 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:29:50 <dlenrow> #vote +1
17:29:53 <colindixon> #vote +1
17:29:53 <ChrisPriceAB> #vote +1
17:29:53 <jmedved> #vote +1
17:29:54 <mohnish> #vote +1
17:29:57 <LuisGomez> #vote +1
17:30:02 <edwarnicke> #vote +1
17:30:04 <Youcef> #vote +1
17:30:09 <dfarrell07> #endvote
17:30:09 <odl_meetbot> Voted on "Shall the TSC approve LuisGomez as a committer on RelEng/Builder?" Results are
17:30:09 <odl_meetbot> +1 (8): dlenrow, jmedved, LuisGomez, ChrisPriceAB, edwarnicke, mohnish, colindixon, Youcef
17:30:11 <tykeal> lol loves that LuisGomez is voting for himself ;)
17:30:24 <dfarrell07> #agreed LuisGomez is approved as a committer on RelEng/Builder
17:30:32 <edwarnicke> tykeal: quorum demands it :)
17:30:39 <tykeal> I know :D
17:31:23 <colindixon> #topic Beryllium Release Plannig
17:31:41 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-April/002931.html some sample dates for a Lithium-like Beryllium release
17:31:52 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-April/002931.html Sample dates for Be release planning
17:32:11 * dfarrell07 checks periodic table to check "Be"
17:33:06 <dfarrell07> #info colindixon gives updates on status of Be release planning, see dates link above
17:33:55 <dfarrell07> #info No feedback from TSC to colindixon on Be planning, take it to the lists
17:34:31 <jmedved> sorry, have to drop
17:35:51 <dfarrell07> #info colindixon points out that both M1 and M3 are so fuzzy as to be almost useless, dropping them may give us a faster release candice with lower overhead
17:36:07 <dfarrell07> #undo
17:36:07 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c35810>
17:36:19 <dfarrell07> #info colindixon points out that both M1 and M3 are so fuzzy as to be almost useless, dropping them may give us a faster release cadence with lower overhead
17:36:50 <dfarrell07> #info edwarnicke likes the "declare participating" part of M1, discussion about that being in M0
17:38:15 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-April/002923.html here is the more blunt e-mail saying maybe we should drop M1 and M3
17:38:44 <dfarrell07> #info edwarnicke talks about importance of having a sufficient release to M0 gap
17:39:37 <dfarrell07> #info General positive feedback about shorter release cycles in general
17:40:59 <dfarrell07> #info colindixon points out that offset 0 projects likely don't need much time to figure out if they will take part in release, don't need much gap between release and M0
17:41:35 <dfarrell07> #info so offset concept will build in enough time between release and M0, address edwarnicke's points
17:45:21 <dfarrell07> #info Discussion about various times between Ms, if they are enough for various activities for various offset projects
17:46:09 <dfarrell07> I don't think people stop making code
17:48:21 <dfarrell07> having trouble hearing this person
17:48:24 <dneary> I don't think Colin & Ed are in disagreement - the deadlines matter the week of the deadline
17:48:33 <dlenrow> Long term answer is layered ecosystem where "core" releases infrequently and layered stuff more frequently. High frequency SR is wrong goal for platform/ecosystem goalsnIMHO
17:48:34 <dneary> Outside of that, they don't, much
17:49:56 <dfarrell07> colindixon: may need some help capturing this, trouble hearing
17:54:00 <dneary> Smaller batch sizes require reduced planning/set-up/tear-down
17:54:14 <dfarrell07> #info High order bits, per colindixon, are that we want to lower overhead of release. Might can do that by not causing people to plan for things that are far away, and maybe reducing the number of milestones.
17:54:59 <dfarrell07> #info People should look at the dates and talk about this on the lists
17:58:10 <dfarrell07> #info To be clear, you don't have to avoid working before you declare intent to participate in a release
17:59:27 <ChrisPriceAB> yeah, and for new ones they dont carry through old projects anyway
17:59:33 <dfarrell07> #info colindixon and likely others would like to have Be release plan done in next few weeks, as offset 0 projects are getting fairly close to thinking about next release
17:59:46 <dneary> colindixon, Inkscape used to have a pretty cool roadmapping process I have described as fractal
17:59:58 <dneary> colindixon, As you got closer to the current release, you got more detail
18:00:08 <colindixon> dneary: please, please, please let me know
18:00:33 <dfarrell07> #info No time for board request discussion this week
18:00:42 <ChrisPriceAB> thanks all
18:00:44 <colindixon> #topic cookies
18:00:45 <dfarrell07> #topic Cookies
18:00:47 <dfarrell07> lol
18:00:47 <dneary> So you would have a one-line "theme" for the B release, a short list of high-level features for Be, and for Li a list of patches to be reviewed & bug tracker entries
18:00:48 <colindixon> #endmeeting