#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:29 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:37)
    1. colindixon (colindixon, 17:00:39)
    2. TSC members please #info in (phrobb1, 17:00:51)
    3. https://wiki.opendaylight.org/view/TSC:Main#Agenda the agenda in it’s usual place (colindixon, 17:00:54)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-04-23-17.00.html last week’s meeting minutes (colindixon, 17:01:44)
    5. edwarnicke (edwarnicke, 17:02:05)
    6. gzhao volunteered to work with mlemay and edwarnicke on the better single feature test (colindixon, 17:02:19)
    7. we had new committers promoted on both CAPWAP and GBP on the mailing list (colindixon, 17:02:44)
    8. jmedved (jmedved, 17:02:50)
    9. https://wiki.opendaylight.org/view/Weather#Blocking_Bugs_definition Working definition of blocking bugs, #action of dfarrell07 and LuisGomez (dfarrell07, 17:02:55)
    10. dlenrow (dlenrow, 17:03:00)
    11. LuisGomez (LuisGomez, 17:03:11)
    12. mohnish anumala (mohnish, 17:03:46)
    13. ACTION: colindixon to add the moxy issue to the wiki page with the workaround listed as being ping Ryan and/or Ed (colindixon, 17:04:09)
    14. Uri is on the phone (colindixon, 17:04:52)
    15. Youcef Laribi (Youcef, 17:05:14)

  2. events (colindixon, 17:06:13)
    1. http://www.opendaylight.org/news/events/ the main events page (colindixon, 17:06:22)
    2. NFV World Congress is next week in CA, dev track will happen (dfarrell07, 17:06:32)
    3. OpenStack summit will be soon, ODL will have a presence (dfarrell07, 17:06:53)
    4. ONS will have an ODL dev track, submit CFPs ASAP (dfarrell07, 17:07:09)
    5. ODL Summit CFP has been completed, dev track talks will start at a later date (dfarrell07, 17:07:28)
    6. [if you’re looking for more info, these are all linked in from the events page above (colindixon, 17:07:33)
    7. http://www.opendaylight.org/news/events ODL Events (dfarrell07, 17:07:52)
    8. phrobb1 and dneary are working together to make it easier for downstream ODL consumers to give us feedback (think OPNFV) (dfarrell07, 17:08:21)

  3. lithium and stable/helium updates (dfarrell07, 17:08:48)
    1. https://wiki.opendaylight.org/view/Weather the weather page to track any known isssues in Lithium (colindixon, 17:09:14)
    2. gzhao doesn't have much to report about Li/stable He updates (dfarrell07, 17:09:15)
    3. Discussion about stable branch SR release cutting, that they could be better, colindixon asks for help from LF admins to make those docs better (dfarrell07, 17:10:52)
    4. ACTION: zxiiro to write better description of how to cut your stable/lithium project, e-mail that out and help projects do that appropriately (colindixon, 17:11:24)
    5. https://wiki.opendaylight.org/view/Weather#Blocking_Bugs_definition candidate definition of what would be release blocking bugs that LuisGomez and dfarrell07 worked on the last week (colindixon, 17:12:17)
    6. please edit the wiki or reach out to the communtiy (mailing list thread to be started) if you want to provide input (colindixon, 17:12:54)
    7. edwarnicke suggests that spreadsheet used by gzhao in the past to tracking blocking bugs was useful, discussion about using that vs wiki (dfarrell07, 17:14:34)
    8. There isn't currently an Li bug tracking spreadsheet (dfarrell07, 17:16:09)
    9. Using the to-be-created spreadsheet above seems to be (by consensus) the right/authoritative source for blocking bug info, link to it from wiki (dfarrell07, 17:17:05)
    10. ACTION: gzhao to provide a link from the weather page to the release blocking bugs tab (colindixon, 17:17:49)
    11. ACTION: gzhao to add a tab to the release tracking spreadsheet for tracking release blocking bugs (colindixon, 17:18:10)
    12. ACTION: gzhao to send mail to TSC and release noting that the spreadsheet will be the authoritative list of blocking bugs (colindixon, 17:19:01)

  4. System Integration and Testing (dfarrell07, 17:19:36)
    1. LuisGomez has lots of cool perf stuff to report (dfarrell07, 17:19:56)
    2. Integration team has been doing a lot of work to add perf/scale tests to CI (dfarrell07, 17:20:38)
    3. during the hackfest and since then the integration team has been working to get scalability and performance tests into CI (colindixon, 17:20:43)
    4. so far, this has been focused on openflowplugin, but in the future the goal is to test more projects and have projects provide these tests not just integration (colindixon, 17:21:34)
    5. Integration is hoping in future releases, projects will be able to build on the examples we created during Li to build their own tests (dfarrell07, 17:21:46)
    6. LuisGomez shows OF PktIn test result graphs in CI (dfarrell07, 17:22:08)
    7. https://jenkins.opendaylight.org/releng/view/openflowplugin/ the jobs can be see in the openflowplugin for now (colindixon, 17:22:37)
    8. NB REST API add/del tests also added to CI, LuisGomez shows plot (dfarrell07, 17:23:33)
    9. https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-1node-cds-cbench-performance-only-master/plot/ plots of cbench performance (colindixon, 17:23:43)
    10. https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-1node-cds-config-performance-only-master/plot/Config%20Performance/ plots of RESTCONF performance for add and delete (colindixon, 17:25:06)
    11. jmedved says that he needed 8 python clients to get the max RESTCONF performance and he was finding something like 2,000 RESTCONF ops/sec (colindixon, 17:26:36)
    12. The current NB REST tests in CI may be blocked on threads dedicated to Python client, Integration will address that feedback and adjust test out-of-band (dfarrell07, 17:27:25)
    13. colindixon asks how we’re persisting this data, LuisGomez says not any differently right now (colindixon, 17:27:56)
    14. ACTION: LuisGomez and tykeal to work out retaining the performance metrics for as long as we can (colindixon, 17:28:22)
    15. Data from plots isn't currently long-term persistent, there have been discussions about that via zxiiro and LuisGomez but there's still uncertainty about how to do so (dfarrell07, 17:28:37)
    16. LuisGomez demos long-term CBench (so OF PktIn) test, jamoluhrsen gives details, same test but 1 hour long daily (dfarrell07, 17:30:03)
    17. https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-periodic-1node-cds-cbench-daily-only-master/plot/ this is the same cbench numbers but instead of running for 4 minutes, it runs for an hour once per day to get longer time (colindixon, 17:30:17)
    18. jamoluhrsen says that we can store the graphs forever (or a whole release) if we want (colindixon, 17:30:45)
    19. jamoluhrsen reports that there seems to be support for storing results long-term in the Jenkins Plot Plugin (dfarrell07, 17:30:49)
    20. LuisGomez shows max-number-of-switches scale test in CI (dfarrell07, 17:31:03)
    21. This test is really cool, basically ups number of switches until controller breaks and plots how high we get (dfarrell07, 17:31:28)
    22. https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-periodic-1node-cds-scalability-daily-only-master/plot/Inventory%20Scalability/ scalabilty testing the max number of switches in a linear topology: right now we hit an OOM at 400 mininet switches (colindixon, 17:32:25)
    23. Switch # scale test uses Mininet (someone asked) (dfarrell07, 17:33:20)
    24. mohnish asks about details around how this is done (colindixon, 17:33:33)
    25. Discussion about other types of scale (Integration is well aware that we want *all the scale tests*) (dfarrell07, 17:34:33)
    26. mohnish notes that we need to be careful about what we report in terms of # of switches, people might take that to mean that we can handle that number of physical switches, or the number of vswitches, or the number of hosts (colindixon, 17:34:48)
    27. LuisGomez says yes, we definitely want to test more kinds of scale and we would love help getting them up and going (colindixon, 17:35:15)
    28. LuisGomez also notes that right now the goal isn’t the numbers per say but to make sure we look for any regressions (colindixon, 17:35:47)
    29. Super important: we're not trying to report max numbers with these tests, we're looking for regressions. Don't quote these numbers as our max values! (dfarrell07, 17:36:02)
    30. along those lines, this is running things in a VM without super amounts of tuning, so these results are likely well below what actual max performance/scale numbers would be (colindixon, 17:37:46)
    31. edwarnicke notes that mininet tends to flap a lot (e.g., switches disconnecting and reconnecting) when get beyond about 100 switches depending on the environment, we should make sure we’re testing our controller not the test tools (colindixon, 17:39:05)
    32. colindixon has run out of adjectives to express his joy (edwarnicke, 17:40:24)
    33. colindixon notes that Uri is jumping with joy over the testing metrics shown by LuisGomez (phrobb1, 17:41:08)
    34. Future TODOs around putting all this in a central dashboard-like place, writing docs to describe all of these (dfarrell07, 17:42:03)
    35. ACTION: LuisGomez (or somebody else) to send out an e-mail with links to the tests and a few sentence descriptions of what they are (colindixon, 17:42:28)
    36. ACTION: snoble and LuisGomez to connect and talk about trying to do some Ixia testing for Lithium (colindixon, 17:42:54)

  5. Committer promotions (dfarrell07, 17:46:05)
    1. No one here from OVSDB, mailing lists (dfarrell07, 17:46:19)

  6. Beryllium Planning (dfarrell07, 17:46:29)
    1. Phill will send out info to lists, please review (dfarrell07, 17:46:42)

  7. introductions (colindixon, 17:46:49)
    1. ODL TSC welcomes odlcasey (dfarrell07, 17:47:32)
    2. Casey Cain is new to the project with the LF folks and will be helping out with overall project management and community management, on IRC he’s odl-casey (colindixon, 17:47:57)

  8. cookies (colindixon, 17:50:09)


Meeting ended at 17:50:12 UTC (full logs).

Action items

  1. colindixon to add the moxy issue to the wiki page with the workaround listed as being ping Ryan and/or Ed
  2. zxiiro to write better description of how to cut your stable/lithium project, e-mail that out and help projects do that appropriately
  3. gzhao to provide a link from the weather page to the release blocking bugs tab
  4. gzhao to add a tab to the release tracking spreadsheet for tracking release blocking bugs
  5. gzhao to send mail to TSC and release noting that the spreadsheet will be the authoritative list of blocking bugs
  6. LuisGomez and tykeal to work out retaining the performance metrics for as long as we can
  7. LuisGomez (or somebody else) to send out an e-mail with links to the tests and a few sentence descriptions of what they are
  8. snoble and LuisGomez to connect and talk about trying to do some Ixia testing for Lithium


Action items, by person

  1. colindixon
    1. colindixon to add the moxy issue to the wiki page with the workaround listed as being ping Ryan and/or Ed
  2. gzhao
    1. gzhao to provide a link from the weather page to the release blocking bugs tab
    2. gzhao to add a tab to the release tracking spreadsheet for tracking release blocking bugs
    3. gzhao to send mail to TSC and release noting that the spreadsheet will be the authoritative list of blocking bugs
  3. LuisGomez
    1. LuisGomez and tykeal to work out retaining the performance metrics for as long as we can
    2. LuisGomez (or somebody else) to send out an e-mail with links to the tests and a few sentence descriptions of what they are
    3. snoble and LuisGomez to connect and talk about trying to do some Ixia testing for Lithium
  4. snoble
    1. snoble and LuisGomez to connect and talk about trying to do some Ixia testing for Lithium


People present (lines said)

  1. dfarrell07 (54)
  2. colindixon (52)
  3. odl_meetbot (10)
  4. dneary (5)
  5. phrobb1 (5)
  6. edwarnicke (4)
  7. ChrisPriceAB (3)
  8. ttkacik1 (1)
  9. dlenrow (1)
  10. jmedved (1)
  11. mohnish (1)
  12. icbts (1)
  13. snoble (1)
  14. LuisGomez (1)
  15. hideyuki (1)
  16. Youcef (1)
  17. evanz (1)
  18. gzhao (1)
  19. jamoluhrsen (1)
  20. tbachman (0)


Generated by MeetBot 0.1.4.