17:01:36 <colindixon> #startmeeting tsc
17:01:36 <odl_meetbot> Meeting started Thu May  7 17:01:36 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:36 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:36 <odl_meetbot> The meeting name has been set to 'tsc'
17:01:43 <colindixon> #topic roll call and agenda bashing
17:01:45 <colindixon> #info colindixon
17:01:57 <phrobb2> #info TSC Members please #info in
17:02:03 <colindixon> #chair ChrisPriceAB phrobb phrobb2 tbachman edwarnicke dfarrell07
17:02:03 <odl_meetbot> Current chairs: ChrisPriceAB colindixon dfarrell07 edwarnicke phrobb phrobb2 tbachman
17:02:11 * colindixon jumps on the webex
17:02:15 <ChrisPriceAB> #info Chris Price
17:02:20 <dfarrell07> #info dfarrell07 for cdub and Red Hat
17:02:28 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Main#Agenda agenda in the usual place
17:02:49 <colindixon> #undo
17:02:49 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x19c1ed0>
17:02:57 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=30131#Agenda time-static agenda in it’s usual place
17:02:59 <LuisGomez> #info LuisGomez
17:03:02 * colindixon notes we should star doing that
17:03:29 <dfarrell07> ^^interesting (time-static)
17:04:04 <edwarnicke> #info edwarnicke
17:04:26 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-04-30-17.00.html meeting minutes from last week (for action items)
17:05:44 * ChrisPriceAB action it again :D
17:06:12 <colindixon> #info jamoluhrsen changed the scripts for performance to record at least 6 months of performance data
17:06:27 <colindixon> #actoin LuisGomez and tykeal and jamoluhrsen to work out retaining the performance metrics for as long as we can
17:06:56 <colindixon> #action LuisGomez and tykeal and jamoluhrsen to work out retaining the performance metrics for as long as we can
17:07:10 <tykeal> double action!
17:07:28 <colindixon> #action snoble and LuisGomez to connect and talk about trying to do some Ixia testing for Lithium
17:07:56 <colindixon> #topic events
17:08:11 <colindixon> #link http://www.opendaylight.org/news/events/ ODL events page
17:08:25 <colindixon> #info lots of people at NFV world congress, our mini-summit there is this afternoon
17:08:26 <dfarrell07> #info ODL Mini Summit is today at NFV World Congress
17:08:39 <dfarrell07> #info Dev Track for ONS closes tomorrow
17:08:46 <dfarrell07> #undo
17:08:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b71fd0>
17:08:47 <colindixon> thanks dfarrell07
17:08:49 <colindixon> lag :p
17:08:51 <dfarrell07> #info ODL Dev Track for ONS closes tomorrow
17:08:56 <colindixon> #undo
17:08:56 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b71110>
17:09:08 <colindixon> #info CFP for ODL Dev Track for ONS closes tomorrow
17:09:11 <dfarrell07> #info OpenStack Summit comming up, ODL stuff going on there
17:09:22 <dfarrell07> colindixon: thanks
17:09:34 <colindixon> #topic lithium
17:10:13 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1196332566 the project status tracking status
17:10:14 <dfarrell07> I think gzhao is at NFV World Congress, which is why he's hard to hear
17:10:55 <colindixon> #info gzhao says that right now most things look good, we’ll know more next week when all projects hit M5, and his guess is that 4-5 projects will drop from the release sometime around there
17:11:25 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 blocking bugs for lithium, same sheet, different tab
17:11:37 <dfarrell07> colindixon: nothing to add
17:12:01 <dfarrell07> #link https://wiki.opendaylight.org/view/Weather#Lithium_Blocking_Bugs Blocking Bugs wiki
17:12:28 <Youcef> #info Youcef Laribi
17:12:40 <dfarrell07> #info gzhao suggests that "lead" for blocking bugs should be the project lead by default, dfarrell07 agrees
17:13:41 <dfarrell07> #action zxiiro will talk to offset-1 projects about cutting their branches
17:13:50 <lori> ... and bunp their versions on master
17:13:51 <gzhao> zxiiro: do you plan to create JJB for offset2 sometime before next Thursday
17:13:58 <dfarrell07> #undo
17:13:58 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x19b3310>
17:14:03 <zxiiro> gzhao: yes
17:14:05 <dfarrell07> #action zxiiro will talk to offset-1 projects about cutting their branches and bump their versions
17:14:06 <lori> s/bunp/bump/
17:14:11 <dfarrell07> lori: thanks
17:14:25 <zxiiro> #action zxiiro will create JJB for offset2 projects
17:14:28 <colindixon> #topic migration from helium to lithium
17:14:31 <jmedved> #info jmedved
17:14:36 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-May/003014.html the thread starting things
17:14:58 <gzhao> zxiiro: ok, let me trace those projects not done with cutting stable branch
17:15:57 <dfarrell07> #info colindixon describes various options for how to do migration
17:16:15 <dfarrell07> #info migration options could range from just-docs to auto-magic-script
17:18:13 <dfarrell07> some of our nicer deployment options (Puppet mod) would handle migrations nicely without too much work
17:20:48 <dfarrell07> this is ready: #agreed TSC encourages projects to document how to upgrade at a minimum, script (or similar) to upgrade would be nice.
17:21:44 * ChrisPriceAB agree with encouragement and discussion for Lithium. Can we set actual needs on Beryllium?
17:23:00 <colindixon> #info tykeal asks if config files are versioned, the answer is that yes they are, but that the helium and lithium versions are teh same most of the time and we don’t have tools
17:24:01 <colindixon> #info it seems like there is some common work aorund upgrading the karaf container and laying down new binaries, and the projects might need to do their own special logic to handle config files and maybe data
17:25:38 <rovarga> edwarnicke: that willingness may be the reason for oversubscription ;-)
17:25:45 * edwarnicke is working on it
17:25:58 <dfarrell07> #info technical discussion about upgrade approaches
17:26:01 * icbts still thinks ed is a machine ;)
17:26:06 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade
17:26:50 <colindixon> #info jmedved suggests that they way to do it is in a cluster where you bring down an old node, bring up a new one and then focus on ingesting the old data
17:27:16 <colindixon> #info tony points out that migrating the data is going to be tricky
17:28:08 <colindixon> #topci system integration/test
17:28:16 <colindixon> #topic system integration and test
17:28:40 <colindixon> #info LuisGomez says they’re working to get more scalability, performance, etc. tests
17:29:10 <colindixon> #info LuisGomez asks if we can branch all together to get better tracking
17:29:11 <dfarrell07> #info LuisGomez points out that projects should likely branch at about the same time to keep CI healthy
17:30:12 <dfarrell07> #info This CI issue mentioned above is a result of jobs triggering from master, so once new branch is cut a set of jobs aren't triggered
17:31:25 <colindixon> #action colindixon to work with LuisGomez to understand the issue around triggering things across branches during releases and find fixes
17:32:03 <dfarrell07> #info Possible issue with blocking offset-0 projects by doing all cutting at the same time, rovarga points out
17:33:50 <dfarrell07> colindixon: reverify?
17:33:58 <tykeal> dfarrell07: diffent one
17:34:53 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-April/002044.html email saying that iit’s possible test a patch before merging
17:35:24 <dfarrell07> #info the keyword is `test-integration`, to save a click
17:36:00 <dfarrell07> #action LuisGomez and/or zxiiro will add that keyword to proper wiki
17:36:06 <colindixon> #action LuisGomez to migrate those instructions to this wiki page: https://wiki.opendaylight.org/view/RelEng/Builder
17:36:22 <colindixon> https://wiki.opendaylight.org/view/RelEng/Builder/Jenkins
17:36:35 <dfarrell07> #topic Infrastructure
17:37:12 <colindixon> #info Thanh is a minor god who fixes jenkins
17:37:20 <dfarrell07> #info zxiiro got a new plugin into Jenkis that should fix Zombie slave issue
17:37:33 <dfarrell07> "zombie slave" is pretty funny
17:37:39 <colindixon> https://lists.opendaylight.org/pipermail/tsc/2015-May/003015.html
17:37:53 <tykeal> dfarrell07: not should, but has ;)
17:38:02 * dfarrell07 wonders if his proxy rights atm let him vote on that ;)
17:38:04 <tykeal> 1+ week and now needs to restart jenkins
17:38:15 <phrobb2> #topic Nemo Creation Review
17:38:20 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:NEMO proposal
17:38:23 <tykeal> s/now /now and no/
17:38:29 <dfarrell07> #topic NEMO Creation Review
17:38:32 <dfarrell07> #undo
17:38:32 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1b78b50>
17:38:34 <dfarrell07> sorry
17:38:49 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-March/000299.html e-mail asking for the proposal a long time ago
17:39:01 <dfarrell07> #info Proposed on 3/21/2015
17:40:30 <dfarrell07> We're giong to need usernames for committers
17:40:36 <colindixon> #action helen_chen to make sure the commiters have their ODL user ID
17:40:39 <colindixon> dfarrell07: yup
17:40:47 * tykeal was just going to say that
17:40:49 <dfarrell07> lol
17:41:02 * tykeal likes how the community looks out for him ;)
17:41:10 <dfarrell07> tykeal: we love you dude ;)
17:43:01 * dfarrell07 has a vote ready
17:45:04 <colindixon> jmedved, dfarrell07 (for cdub), dlenrow, Youcef, can you vote on makin Anil a committer on OVSDB?
17:45:12 <colindixon> so I don’t have to ask for a vote here
17:45:17 <colindixon> it’s on the maling list
17:45:25 <colindixon> https://lists.opendaylight.org/pipermail/tsc/2015-May/003015.html
17:45:26 <dfarrell07> colindixon: yeah, as long as my proxy carries over
17:45:37 <colindixon> for this hour, I say yes :-)
17:46:53 <dfarrell07> colindixon: cool, done :)
17:47:30 <dfarrell07> helen_chen: we hear you :)
17:48:22 <colindixon> jmedved, dlenrow, and Youcef, can you vote?
17:50:34 <dfarrell07> helen_chen:
17:50:47 <ChrisPriceAB> think dlenrow is not here today.
17:50:49 <dfarrell07> helen_chen: even more so, *almost everyone* gets committer IDs wrong
17:52:54 <colindixon> I know dlenrow didn’t #info in, but I was hoping he might be paying attention here despite that
17:53:34 <ChrisPriceAB> think he is unavailable, is generally unavailable today
17:54:38 <phrobb2> #startvote Shall the TSC approve the NEMO project to enter the incubation lifecycle state? -1, 0, +1
17:54:38 <odl_meetbot> Begin voting on: Shall the TSC approve the NEMO project to enter the incubation lifecycle state? Valid vote options are -1, 0, +1.
17:54:38 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:54:38 <ChrisPriceAB> ChrisPriceab asked a question and got a good answer
17:55:30 <tykeal> lol
17:55:31 <colindixon> #vote +1
17:55:47 <dfarrell07> #vote +1
17:55:56 <Youcef> #vote +1
17:55:57 <tykeal> it's a good thing I'm not video ;) you would find me laughing very hard ;)
17:56:04 <dfarrell07> LuisGomez
17:56:06 <edwarnicke> #vote +1
17:56:09 <ChrisPriceAB> '#vote +1
17:56:15 * ChrisPriceAB oops
17:56:18 <LuisGomez> #vote +1
17:56:19 <ChrisPriceAB> #vote +1
17:56:27 * ChrisPriceAB :P
17:56:28 <alagalah> Nervous tic
17:56:40 * ChrisPriceAB just going on record
17:56:41 <dfarrell07> jmedved
17:56:56 <dfarrell07> no, it's 6
17:57:05 <dfarrell07> ahh
17:57:11 <phrobb2> #endvote
17:57:11 <odl_meetbot> Voted on "Shall the TSC approve the NEMO project to enter the incubation lifecycle state?" Results are
17:57:11 <odl_meetbot> +1 (6): dfarrell07, LuisGomez, ChrisPriceAB, edwarnicke, colindixon, Youcef
17:57:31 <dfarrell07> helen_chen: congrats! :D
17:57:36 <phrobb2> #agreed NEMO has entered the incubation lifecycle state
17:57:57 <colindixon> #topic beryllium release planning and other things
17:58:06 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-May/002985.html active, very good thread on the topic
17:58:45 <dfarrell07> I can attend /me isn't going
17:58:46 <colindixon> #topic TSC meeting during the OpenStack summit
17:58:51 <ChrisPriceAB> Ed wants a room!
17:59:00 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-May/003044.html vote on whether you want to have the TSC meeting during OpenStack
17:59:05 * zxiiro will be at OpenStack Summit
17:59:08 <colindixon> #action phrobb2 to see if we can find a room
17:59:11 * tykeal will not be
17:59:24 * ChrisPriceAB can I # action Phil, get a room?
17:59:27 <dfarrell07> colindixon: rocks! <1 hr!
17:59:33 <odl-casey> :)
17:59:49 <colindixon> #topic cookies
17:59:57 <tykeal> #link http://sweetsugarbelle.com/blog/wp-content/uploads/2011/06/5682713842_c918c4904c_b.jpg <- cookies in honor of recent Cinco de Mayo
18:00:02 * phrobb2 makes mental note to not tell ChrisPriceAB where the room will be...
18:00:05 <colindixon> #endmeeting