17:00:31 <colindixon> #startmeeting tsc
17:00:31 <odl_meetbot> Meeting started Thu May 14 17:00:31 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:31 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:31 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:38 <colindixon> #topic agenda bashing and roll call
17:00:41 <colindixon> #info colindixon
17:01:12 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=30397#Agenda the agenda
17:01:16 <dlenrow> #info dlenrow
17:01:28 <colindixon> #info edwarnicke has asked that we talk about IPv6 downstream patches, I’m putting it on the agenda under lithium
17:01:29 <xsited> #info Thomas Kee
17:01:34 <colindixon> #undo
17:01:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c3dbd0>
17:01:39 <ChrisPriceAB> #info Chris Price
17:01:43 <edwarnicke> #info edwarnicke
17:01:43 <LuisGomez> #info LuisGomez
17:01:52 <colindixon> xsited: glad to have you! but #info is for TSC members to track quorum
17:02:20 <colindixon> #chair phrobb phrobb1 dfarrell07 tbachman ChrisPriceAB edwarnicke
17:02:20 <odl_meetbot> Current chairs: ChrisPriceAB colindixon dfarrell07 edwarnicke phrobb phrobb1 tbachman
17:02:25 <odl-casey> #info Casey
17:02:44 <colindixon> #undo
17:02:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ba9310>
17:03:36 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-05-07-17.01.html meeting minutes from last week for action items
17:03:54 <alagalah_> I'm here but IRC only
17:04:04 <colindixon> alagalah_: are you here for Jan
17:04:15 <alagalah_> colindixon: let me check
17:04:24 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade
17:05:26 <colindixon> #action LuisGomez and tykeal and jamoluhrsen to work out retaining the performance metrics for as long as we can
17:06:21 <jmedved> #info jmedved
17:06:55 * ChrisPriceAB what time do we need a room in Vancouver time? is it 10:00-11:00?
17:07:23 <phrobb1> yes, that's what I'm checking on
17:07:36 <colindixon> #topics events
17:07:47 <colindixon> #link http://www.opendaylight.org/news/events/ the events in the usual place
17:09:44 <mohnish> #info mohnish anumala
17:09:53 <colindixon> #startvote could you attend a TSC meeting next week for ~30-45 minutes (-1 no, +1 yes)?
17:09:53 <odl_meetbot> Begin voting on: could you attend a TSC meeting next week for ~30-45 minutes (-1 no, +1 yes)? Valid vote options are Yes, No.
17:09:53 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:10:02 <ChrisPriceAB> #vote +1
17:10:03 <mohnish> #vote -1
17:10:05 <colindixon> #vote +1
17:10:10 <edwarnicke> #vote +1
17:10:10 <LuisGomez> #vote +1
17:10:11 <jmedved> #vote +0
17:10:15 <dlenrow> #v I tell +1
17:10:23 * dfarrell07 doesn't have cdub's char atm
17:10:26 <dfarrell07> chair*
17:10:39 * ChrisPriceAB we can hog-tie him and drag him along
17:10:40 <dlenrow> #vote +1
17:10:54 <colindixon> #endvote
17:10:54 <odl_meetbot> Voted on "could you attend a TSC meeting next week for ~30-45 minutes (-1 no, +1 yes)?" Results are
17:10:55 * edwarnicke thinks dfarrell07 is far to talented to be sheparding furniture...
17:11:18 <colindixon> there were 6 +1, a +0 and a -1 (mohnish)
17:11:19 <mohnish> find a room at openstack meeting?
17:11:24 <dfarrell07> edwarnicke: rofl, took me a sec to get that ;)
17:11:31 * edwarnicke is subtle
17:11:35 <colindixon> #agreed the TSC will meet next week, but it may be abridged
17:11:47 * ChrisPriceAB oh don't make him smlie dfarrell07 !!!
17:11:52 <colindixon> #action phrobb to find a room at openstack if possible
17:12:07 <dfarrell07> #info ONS notifications should be out by end of week
17:12:23 <mohnish> colin: then I might be able to attend as well
17:12:26 <dfarrell07> #info OpenStack Summit is next week, many ODL ppl attending
17:12:31 <colindixon> #info OpenStack next week, ONS mid june, our main summit at the end of July
17:12:55 <colindixon> #info OPNFV is having a meeting on Monday afternoon where it would be good for OpenDaylighter’s to be ther if possible
17:13:14 <alagalah_> colindixon: Link  ?
17:13:19 <ChrisPriceAB> #link http://openstacksummitmay2015vancouver.sched.org/type/opnfv+day#.VVTXoluBBDY opnfv event at openstack
17:13:22 <colindixon> thanks
17:13:24 <colindixon> #topic lithium update
17:13:29 <alagalah_> ChrisPriceAB: Thanks mate
17:13:37 <colindixon> #info offset 2 M5 deadline is today
17:13:37 <alagalah_> ChrisPriceAB: So cool (OpenStack) kids only :(
17:13:52 * ChrisPriceAB hope to see you there alagalah_
17:14:19 <colindixon> #info two offset 1 projects haven’t submitted M5, which is now 2 weeks late: SNBI and SNMP4SDN, nobody depends on them, so we can treat them as offset 2 and they’re not causing any pain
17:14:30 <alagalah_> ChrisPriceAB: Not going :( (see... cool kids only)
17:14:39 * edwarnicke is pretty sure he's not cool...
17:14:42 * edwarnicke adjusts bow tie
17:14:43 * ChrisPriceAB :(
17:15:07 * ChrisPriceAB It's the lack of shoes that sets you apart edwarnicke !!!
17:15:15 <colindixon> #link projects we’re looking to remove from Lithium because they haven’t responded
17:17:03 * dfarrell07 has been moving around, sorry for poor notes help
17:17:17 <colindixon> #link https://lists.opendaylight.org/pipermail/coretutorials-dev/2015-May/000021.html discussion around coretutorials in Lithium and whether to ship it
17:18:23 <colindixon> #action colindixon to work with alagalah_, tom pantelis and LuisGomez around what do with coretutorials
17:18:28 <Youcef> #info Youcef Laribi
17:19:05 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-May/003060.html the other projects are discovery, maple, and plugin2oc
17:19:35 <colindixon> #action phrobb to contact those three projects to figure out if they will withdraw on their own (discovery, maple, and plugin2oc)
17:21:14 <colindixon> #action colindixon to start a thread on what it means to ship something as part of a release
17:22:01 <colindixon> #topic version bumping and IPv6 issues
17:23:21 <colindixon> #info yangtools fixed a bug on master, e.g., Beryllium, which now correctly enforces IPv6 prefix format, which breaks lots of downstream projects that were providing incorrect IPv6 prefixes
17:23:43 <colindixon> #info the result is that downstream projects need to fix these bugs *before* they can bump versions on master
17:24:02 <colindixon> #undo
17:24:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1baca50>
17:24:22 <colindixon> #info the result is that downstream projects need to fix these bugs *before* they can cut their stable/lithium branches
17:24:26 <dfarrell07> #info edwarnicke's details of version bumping issue demonstrate more general issue with how we do cut/merge, solution being discussed on lists
17:24:56 <colindixon> #info the result is that openflow plugin is currently blocked on this, so most (if not) all offset 2 and many offset 1 projects are also blocked
17:25:11 <colindixon> #info on the plus side, we’re fixing a lot of possible IPv6 bugs
17:26:11 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-May/003063.html version bumping/branch cutting being discussed here
17:26:41 <colindixon> #action gzhao to send out a mail to release saying that many projects will be unable to cut stable/lithium right now, and point to this e-mail chain about it here: https://lists.opendaylight.org/pipermail/release/2015-May/002315.html
17:27:36 <gzhao> #link https://lists.opendaylight.org/pipermail/coretutorials-dev/2015-May/000021.html < email thread for coretutorial discussion.
17:27:52 <dfarrell07> #info LuisGomez asks if projects should branch without bumping, colindixon says "no" and gives reasons too quickly to document
17:29:12 <colindixon> #info colindixon says to send M5 status anyway without the branch cut, report whether you are holding it or not based on that bug and then we’ll track branch cutting separately
17:29:37 <colindixon> #topic helium to lithum migration
17:29:48 <phrobb1> Welcome cdub
17:29:53 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-May/003014.html we could use help here if anyone wants to volunteer
17:30:04 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=3160 this is the bug gracking things
17:30:24 <colindixon> #topic bugs it yangtools and controller
17:30:52 <colindixon> #link https://meetings.opendaylight.org/opendaylight-docs/2015/docs/opendaylight-docs-docs.2015-05-13-15.08.html during the last bug scrub ttkacik said he would help mentor people on easy bugs in section 4 of those minutes
17:31:03 <colindixon> #info that’s a really good way to get involved
17:31:13 <colindixon> #undo
17:31:13 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1c48d10>
17:31:14 <colindixon> #undo
17:31:14 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1c483d0>
17:31:44 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/md_sal_interest_call/opendaylight-meeting-md_sal_interest_call.2015-05-12-16.07.html during the last bug scrub ttkacik said he would help mentor people on easy bugs in section 4 of those minutes
17:31:52 <colindixon> #info that’s a really good way to get involved
17:32:24 <ttkacik> ideally would be mention my irc handle tonytkacik or ttkacik and email :)
17:33:00 <colindixon> #info reach out to ttkacik or tonytkacik or his e-mail which you can find plastered over every mailing list everywhere
17:33:11 <tykeal> google ttkacik ;)
17:33:12 <colindixon> #topic system integration and test
17:33:46 <colindixon> #info there was a weird problem with single feature test that lori found the workaround for, yay!
17:33:59 <colindixon> #info otherwise everything is the same as before
17:34:11 <colindixon> #info phrobb asks for information about spirent and performance testing
17:35:11 <colindixon> #info spirent activity has died down, but people are using the stuff when they don’t have the gear, also some interns are getting VMs through the spirent lab to do more testing
17:35:13 <dfarrell07> #info LuisGomez didn't explicitly mention this, but dfarrell07 wants to call out the success of Integration wrt spinning-up new people. We have more devs pushing more useful code in parallel than ever before. Huzzah!
17:35:24 <snoble> I am waiting for IXIA to get back to me on the license, working with Spirent also, have some issues running their virtual system, will meet both at ONF appfest next week
17:36:00 <colindixon> #info snoble is waiting for IXIA to get back to me on the license, working with Spirent also, have some issues running their virtual system, will meet both at ONF appfest next week
17:36:59 <phrobb1> great to hear dfarrell07 and snoble, we mentioned this on the call if you aren't there… assuming you aren't
17:37:02 <dfarrell07> #info Integration is still pushing to get perf tests in CI, especially to make the recent batch of additions more stable
17:37:29 <dfarrell07> phrobb1: I'm here, just didn't get unmuted in time :)
17:37:49 <colindixon> #link https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-1node-cds-cbench-performance-only-master/plot/ the performance dropped recently, people are debugging it
17:38:30 <phrobb1> dfarrell07:  cool :-)  wasn't sure and I wanted to make sure your comments were seen/heard by all
17:38:52 <dfarrell07> phrobb1: appreciated, def a good move generally :)
17:39:02 <colindixon> #info LuisGomez says “my kingdom for a dashboard”
17:39:21 <colindixon> #topic infrastructure
17:39:43 <zxiiro> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-daily-master/26/artifact/dependencies.log
17:39:56 <colindixon> #info Thanh wrote a tool which scans pom files and lists what other projects it thinks you depend on (see above link for lastest results)
17:40:56 <colindixon> #info tykeal says some people may have seen a slight outage this morning to deal with the venom cdd and he apologizes for the outage and everything should be back up
17:41:42 <colindixon> #topic committer promotion on packetcable
17:41:50 <dfarrell07> colindixon: if we have extra time, Integration just finished a vote on a committer promotion
17:42:19 <colindixon> #info Thomas Kee would like to to move Steven Pisarski on packetcable
17:42:24 <colindixon> dfarrell07: done, can you prep a vote
17:42:31 <dfarrell07> ack
17:42:37 <colindixon> #link http://spectrometer.opendaylight.org/?user_id=spisarski&project_type=opendaylight&release=all&metric=loc&company= ~7000 lines of code
17:42:47 <colindixon> #ink http://spectrometer.opendaylight.org/?user_id=spisarski&project_type=opendaylight&release=all&metric=commits 25 patches
17:45:03 * ChrisPriceAB I'm ok to vote tbh, what do we achieve by waiting
17:45:20 <colindixon> #link https://wiki.opendaylight.org/view/PacketCablePCMM:Main the only issue is that while Thomas Kee is demonstrobly the only committer, there are several others that we haven’t gotten to vote
17:45:32 <dfarrell07> #startvote Shall the TSC approve Steven Pisarski as a committer for the PacketCable project? -1, 0, +1
17:45:32 <odl_meetbot> Begin voting on: Shall the TSC approve Steven Pisarski as a committer for the PacketCable project? Valid vote options are -1, 0, +1.
17:45:32 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:45:32 <phrobb1> #startvote Shall the TSC approve Steven Pisarski as a committer on the Packet Cable PCMM Project? -1, 0, +1
17:45:32 <odl_meetbot> Already voting on 'Shall the TSC approve Steven Pisarski as a committer for the PacketCable project'
17:45:37 <dfarrell07> ahh
17:45:37 <dfarrell07> idk
17:45:40 <xsited> #info Thomas Kee +1
17:45:42 <ChrisPriceAB> #vote +1
17:45:43 <tykeal> the last vote is taken
17:45:46 <jmedved> #vote +1
17:45:47 <colindixon> #vote +1
17:45:48 <Youcef> #vote +1
17:45:48 <mohnish> #vote +1
17:45:50 <LuisGomez> #vote +1
17:45:51 * ChrisPriceAB Thomas you need to try again
17:45:56 <edwarnicke> #vote +1
17:45:59 <dlenrow> #vote +1
17:46:04 <phrobb1> #endvote
17:46:04 <odl_meetbot> Voted on "Shall the TSC approve Steven Pisarski as a committer for the PacketCable project?" Results are
17:46:04 <odl_meetbot> +1 (8): dlenrow, jmedved, LuisGomez, ChrisPriceAB, edwarnicke, mohnish, colindixon, Youcef
17:46:04 <tykeal> oh, you're asking about the vote question
17:46:08 <tykeal> that would be the first one
17:46:13 <dfarrell07> #agreed The TSC approves Steven Pisarski as a committer for the PacketCable project
17:46:31 <phrobb1> #agreed Steven Pisarski is now a committer on the PacketCable project
17:46:34 * gzhao thinks we should have a procedure to make sure committers in projects are "active" committers.
17:46:43 <dlenrow> I wonder what I just #voted for on that openstack IRC channel by accident....
17:46:50 * ChrisPriceAB congrats
17:47:03 * ChrisPriceAB cookie time!
17:47:25 <alagalah_> cookie
17:47:41 * alagalah_ ChrisPriceAB Same thing I tell me daughter before soccer though, only winners get icecream
17:47:55 <xsited> #info Thomas Kee as the only active committer I vote +1 for steven pisarski committer promotion
17:47:57 <dlenrow> coffee is for closers?
17:48:00 <colindixon> :-)
17:48:30 <tykeal> colindixon: you sound like a sysadmin with that statement ;)
17:48:35 <dfarrell07> colindixon: Integration committer vote?
17:48:46 <colindixon> #topic new committer on integration
17:49:17 <dfarrell07> #info Vratko has been very active/useful on Integration code reviews, created new tests
17:49:22 <dfarrell07> #link https://lists.opendaylight.org/pipermail/integration-dev/2015-May/003211.html Thread with votes from current active Integration committers
17:49:22 <LuisGomez> #link https://lists.opendaylight.org/pipermail/tsc/2015-May/003078.html
17:49:40 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/project:integration+owner:%22Vratko+Pol%25C3%25A1k+%253Cvrpolak%2540cisco.com%253E%22 his commits on integration
17:50:10 <colindixon> #link http://spectrometer.opendaylight.org/?metric=commits&user_id=vrpolak&module=integration looks like 11 commits and ~1389 lines of code
17:50:22 * ChrisPriceAB lol alagalah, that's why I suffered as a kid
17:50:31 <colindixon> #info LuisGomez says he has also help to review a ton of patchs (dfarrell07 says that’s be huge)
17:50:35 <dfarrell07> #startvote Shall the TSC approve Vratko Polak as a committer for the Integration project? -1, 0, +1
17:50:35 <odl_meetbot> Begin voting on: Shall the TSC approve Vratko Polak as a committer for the Integration project? Valid vote options are -1, 0, +1.
17:50:35 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:50:40 <colindixon> #vote +1
17:50:42 <jmedved> #vote +1
17:50:44 <ChrisPriceAB> #vote +1
17:50:44 <LuisGomez> #vote +1
17:50:45 <mohnish> #vote +1
17:50:47 <Youcef> #vote +1
17:51:01 <dlenrow> #vote +1
17:51:01 <edwarnicke> #vote +1
17:51:03 * ChrisPriceAB +1
17:51:06 <cdub> #vote +1
17:51:09 <phrobb1> #endvote
17:51:09 <odl_meetbot> Voted on "Shall the TSC approve Vratko Polak as a committer for the Integration project?" Results are
17:51:09 <odl_meetbot> +1 (9): dlenrow, jmedved, LuisGomez, ChrisPriceAB, edwarnicke, cdub, mohnish, colindixon, Youcef
17:51:09 <colindixon> #endmeeting