17:00:13 <colindixon> #startmeeting tsc
17:00:13 <odl_meetbot> Meeting started Thu Jun 11 17:00:13 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:13 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:13 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:18 <Neelajacques> Alagalah: G'day mate!
17:00:18 <colindixon> #topic roll call and agenda bashing
17:00:20 <colindixon> #info colindixon
17:00:22 <gzhao> tbachman: :)
17:00:28 <alagalah> Neelajacques: :)
17:00:28 <ChrisPriceAB> #info ChrisPrice
17:00:30 <colindixon> #chair tbachman dfarrell07 phrobb1 phrobb
17:00:30 <odl_meetbot> Current chairs: colindixon dfarrell07 phrobb phrobb1 tbachman
17:00:43 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tcc/opendaylight-meeting-tcc.2015-06-04-16.59.html last week’s meeting minutes
17:00:57 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-05-28-16.59.html the week before’s meeting minutes because we didn’t do action items last week
17:01:02 <mohnish> #info mohnish anumala
17:01:16 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=31181 today’s agenda as it was when the meeting started
17:01:49 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium
17:01:51 <phrobb1> FYI folks just reset my modem a few minutes ago as my internet is behaving badly… not sure if I will be heard or not
17:02:47 <tbachman> LOL
17:02:47 <LuisGomez> #info LuisGomez
17:03:00 <edwarnicke> Running a few min late
17:03:08 <colindixon> #action ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
17:03:49 <dlenrow> #info dlenrow
17:03:56 <tbachman> colindixon: should we topic that?
17:04:03 <tbachman> k
17:04:11 <colindixon> #action colindixon to draft changes to language around project lifecycles
17:04:18 <phrobb1> TSC quorum tally at 5
17:04:31 <colindixon> #action phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for
17:04:43 <colindixon> #action gzhao and phrobb1 to find suitable times for Lithium release reviews
17:04:52 <colindixon> #action colindixon to bump and branch docs
17:05:03 <colindixon> edwarnicke: are you lurking?
17:05:17 <gzhao> #link https://docs.google.com/spreadsheets/d/1PYxjiSYEks44uJByVO1P44rnI5xTJRulpKyrSsDQF9g/edit#gid=743945554 <--- release review sign up sheet
17:05:25 <tbachman> colindixon: he said he was going to be a few min late
17:05:26 <colindixon> abhijitkumbhare: we can hear you
17:05:40 <abhijitkumbhare> OK - will dial back in
17:05:41 <colindixon> cdub, are you around
17:05:58 <tbachman> dfarrell07: do you have cdub rights?
17:06:12 * tbachman goes hunting
17:06:21 <dfarrell07> tbachman: no, but I'm pinging him too
17:06:34 <tbachman> alagalah: dfarrell07: thx!
17:06:41 <alagalah> #info alagalah for jmedved
17:07:13 <tbachman> #topic Updates from the Board on Increased Coverage for Fixing Issues
17:08:27 <tbachman> #info Neelajacques says the request came through to the board and the Linux Foundation for increased support coverage outside of US hours
17:08:32 <edwarnicke> #info edwarnicke
17:08:38 <colindixon> edwarnicke: welcome!
17:08:59 * colindixon notes that we’re now at 7
17:09:00 <tbachman> #info Neelajacques had a talk with the CIO, who has hired a LF resource in Australia (though not yet trained on OpenDaylight Infra and tools), who can take a subset of requests
17:09:07 <colindixon> tbachman: thanks!
17:09:11 <tbachman> colindixon: np!
17:09:41 <tbachman> #info Neelajacques says they’re also working on a more explicit document to have a clear escalation plan for developers/users anywhere in the world
17:09:54 <phrobb1> FYI just stared the recording folks
17:10:05 <phrobb1> s/stared/started
17:10:06 <colindixon> phrobb1: thanks
17:10:11 <tbachman> #info Neelajacques says if there’s still an unfulfilled need beyond that, it would require a significant outlay of funds
17:10:43 <rovarga_> Neelajacques: awesome, thanks! :)
17:11:16 <Youcef> #info Youcef Laribi
17:11:18 <tbachman> #topic Event Updates
17:11:19 <dfarrell07> Big thanks for the LF admin resources, Neelajacques :)
17:11:30 <colindixon> #link http://www.opendaylight.org/news/events/
17:11:36 <tbachman> #info phrobb1 says that the ONS is next week
17:11:38 <tbachman> phrobb1: ?
17:11:42 <tbachman> dropping in/out
17:11:51 <phrobb1> my internet is bad
17:12:06 <tbachman> #info colindixon says there are tutorials on Sunday, developer track on Monday
17:12:09 <tbachman> #undo
17:12:09 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b88610>
17:12:16 <tykeal> rooms are going fast
17:12:16 <phrobb1> Also please reg for the dev forum… to save your place
17:12:26 <tbachman> #info colindixon says the ONS will have tutorials on Sunday and a developer track on Monday
17:12:30 <colindixon> #link https://www.regonline.com/register/checkin.aspx?EventId=1627424&MethodId=0&EventSessionId=&startnewreg=1 please register for the developer forum if you haven’t already
17:12:34 <tbachman> colindixon: thx
17:13:04 <phrobb1> yep nothing else to note this time
17:13:24 <colindixon> #info the OpenDaylight summit is later in July
17:13:29 <snoble> 3 is neela no?
17:13:29 <colindixon> #topic Lithium updates
17:13:57 * Neelajacques apologizes...muted
17:14:03 <tbachman> #info zxiiro says today is the RC1 cutoff; is doing a test build right now, will have results in ~3hrs
17:14:04 <colindixon> #info zxiiro says that RC1 build is tonight, he’s doing a test run now and he’ll know in about 3 hours if that went well
17:14:07 <tbachman> Neelajacques: no worries :)
17:14:09 <colindixon> #undo
17:14:09 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b88850>
17:14:43 <tbachman> #info zxiiro says that most projects have version bumped and branched; the persistence project hasn’t done it yet (Defense4All and docs also haven’t yet)
17:14:49 <colindixon> #info zxiiro trying to figure out if there is a probem with how autorelease builds dlux
17:15:31 <colindixon> #action gzhao and dlenrow to hunt down the persistence project
17:16:05 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the current “weather"
17:16:09 <tbachman> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 Blocking Bugs
17:16:38 <tbachman> #info colindixon says that we did merge the enforcing of IPv6 to stable/lithium, but nothing broke in stable/lithium
17:16:45 * tbachman is conflating again :)
17:16:46 <tbachman> sorry
17:16:56 <edwarnicke> "Shall we talk about the weather.  Shall we talk about the government" ;)
17:17:05 <tbachman> :)
17:17:17 <tbachman> #info colindixon asks if anyone can shed light on the Neutron Northbound bug
17:17:36 <tbachman> #info edwarnicke says this bug comes down to when we get a port that corresponds to a floating IP, there’s no Tenant ID with it (and it should)
17:17:50 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=3656 is a blucking bug which edwarnicke is currently hunting and should be resolved soon
17:17:54 <tbachman> #info edwarnicke says that he’s demonstrated that when we get it from neutron to opendaylight, the tenant isn’t there
17:18:05 <tbachman> #info edwarnicke says that by the time our ML2 driver has it, it doesn’t have the tenant ID
17:18:07 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 zxiiro and harman are huting this issue in dlux
17:18:37 <tbachman> #info edwarnicke says he sees the tenant ID in an add-port, but not in the floating IP command
17:18:51 <tbachman> #info edwarnicke isn’t sure if this is an issue with the CLI command, or if it’s an issue with how the command is being used
17:18:53 <colindixon> #link https://bugs.opendaylight.org/show_bug.cgi?id=3368 edwarnicke and regXboi are hunting a bug where neturon isn’t giving tenant IDs for floating bugs
17:19:10 <tbachman> colindixon: thx for hunting down that bugid
17:19:33 <tbachman> #info colindixon says gzhao, et. al. are trying to schedule release reviews
17:19:36 * tbachman will go find it
17:19:51 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-June/002655.html this is gzhao’s mail
17:19:56 <tbachman> colindixon: beat me as usual
17:20:14 <tbachman> #info colindixon urges projects to sign up for slots as soon as possible
17:20:28 <tbachman> colindixon: should we bring up testing spreadsheet?
17:20:37 <tbachman> (i.e. the RC0 testing spreadsheet)
17:20:46 <colindixon> #info gzhao says if you haven’t picked a slot by Friday, you’ll get one assigned to you
17:20:48 <mohnish> ed: Is it the same behavior in both Juno & Kilo?
17:20:57 <tbachman> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit?usp=sharing RC0 testing spreadsheet
17:21:51 <tbachman> #info colindixon says if you haven’t already tested your project against the RC0 product, please do and log any blocking bugs and put it in the spreadsheet
17:22:34 <colindixon> #action gzhao to hunt people for RC0 reports
17:22:47 <colindixon> #action gzhao to add tony as an editor for blocking bugs
17:23:29 <tbachman> #topic LuisGomez asks for those projects not part of the release, what should we do for RC1
17:23:34 <tbachman> #undo
17:23:34 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1b949d0>
17:23:48 <tbachman> #info LuisGomez asks for those projects not part of the release, what should we do for RC1
17:23:52 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=1360517736 we’re tracking RC0 issues (not just reports) here
17:24:09 <tbachman> #info zxiiro says he believes SNMP4SDN could be added, as they’ve added their code back in
17:24:25 <tbachman> #info LuisGomez asks how we should add them; normally the projects push patches to add themselves to integration#
17:24:43 * cdub scrolls back up
17:24:43 <colindixon> #action zxiiro and LuisGomez to make sure we add projects that aren’t in integration that don’t break things
17:25:08 <tbachman> #info colindixon says if they’ve fixed their issue,  we probably should push a patch that adds them back to integration (on their behalf)
17:25:17 <colindixon> #action gzhao and phrobb1 to reach to projects that can’t be put back in and let them know they will be dropped from the release
17:25:26 <tbachman> #info colindixon asks if any of the projects can’t be added back in
17:25:33 <tbachman> #info zxiiro says as far as he knows, he can build all the projects
17:26:07 * tbachman waves to cdub
17:26:27 <tbachman> #topic System Integration and Test
17:26:47 <tbachman> #info LuisGomez  says no major things have been found other than what’s been reported so far
17:27:02 <tbachman> #info LuisGomez says they’ve only received 1 or 2 feedback items from the 40+ projects
17:27:16 <gzhao> zxiiro: integration only picks up projects from stable/lithium
17:27:29 <tbachman> #info LuisGomez says they can speak about some of the projects (e.g. openflowplugin), but they can’t speak to the quality of the other projects
17:28:43 <tbachman> drop from Lithium, or drop from the builds?
17:29:16 <cdub> yes
17:29:16 <colindixon> tbachman: I was saing Lithium
17:29:31 <ChrisPriceAB> eek, can it not be a pre-requisite for RC2?  Otherwise it is cut very close...
17:29:38 <dfarrell07> draft of vote (feel free to copy, tbachman, phrobb) Shall the TSC consider dropping project that don't give any feedback about any RC by the Monday we're to release Li? -1, 0, +1
17:29:39 <colindixon> and it’s maybe
17:30:04 <tbachman> dfarrell07: that’s what I had…. but sounds like it’s still being hashed out :)
17:30:09 <dfarrell07> +1
17:30:16 <dfarrell07> tbachman: as long as you have it :)
17:30:26 <ebrjohn> I agree with Ed
17:30:57 <tbachman> draft of startvote: Should the TSC drop projects from the release if they don’t provide test results by the Monday before the RC2 release? +1, 0, -1
17:31:13 <tbachman> colindixon: ack
17:31:19 <abhijitkumbhare> +1 to suggestion by edwarnicke (as well as the suggestion just made by colindixon )
17:31:37 * ChrisPriceAB thinks maybe language like, require that projects provide test results before...
17:31:51 <tbachman> draft #2: Should the TSC reserve the right to drop projects from the release if they don’t provide test results by the Monday before the RC2 release? +1, 0, -1
17:32:42 <tbachman> draft #3: Should the TSC reserve the right to drop projects from the release if they don’t provide RC1 feedback by the TSC Meeting on June 18th? +1, 0, -1
17:32:56 <tbachman> #startvote Should the TSC reserve the right to drop projects from the release if they don’t provide RC1 feedback by the TSC Meeting on June 18th? +1, 0, -1
17:32:56 <odl_meetbot> Begin voting on: Should the TSC reserve the right to drop projects from the release if they don’t provide RC1 feedback by the TSC Meeting on June 18th? Valid vote options are +1, 0, -1.
17:32:56 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:33:01 <colindixon> #vote +1
17:33:03 <LuisGomez> #vote +1
17:33:07 <Youcef> #vote +1
17:33:13 <edwarnicke> #vote +1
17:33:15 <alagalah> #vote +1
17:33:16 <dlenrow> #vote +1
17:33:19 <mohnish> #vote +1
17:33:20 <cdub> #vote +1
17:33:28 <tbachman> #endvote
17:33:28 <odl_meetbot> Voted on "Should the TSC reserve the right to drop projects from the release if they don’t provide RC1 feedback by the TSC Meeting on June 18th?" Results are
17:33:28 <odl_meetbot> +1 (8): dlenrow, Youcef, LuisGomez, edwarnicke, cdub, mohnish, colindixon, alagalah
17:33:31 <tbachman> #agreed The TSC reserves the right to drop projects from the release if they don’t provide RC1 feedback by the TSC Meeting on June 18th? +1, 0, -1
17:33:57 <tbachman> #action gzhao to send email to release telling them that the TSC reserves the right to drop projects from the release if they don’t provide RC1 feedback by the TSC Meeting on June 18th? +1, 0, -1
17:34:00 <tbachman> oops
17:34:01 <tbachman> #undo
17:34:01 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1cd45d0>
17:34:09 <tbachman> #action gzhao to send email to release telling them that the TSC reserves the right to drop projects from the release if they don’t provide RC1 feedback by the TSC Meeting on June 18th
17:34:24 <colindixon> #action LuisGomez and tykeal and jamoluhrsen to work out getting a patch merged in openstack to view all historical performance data
17:34:33 <tbachman> #topic Infrastructure
17:34:43 <tbachman> #info tykeal says they’re awaare that the queues are running long
17:35:15 <tbachman> #info tykeal says the plugin managing their slaves has gotten jammed up b/c the API behind the slaves has returned junk under load
17:35:27 <tbachman> #info tykeal says the 2 projects admitted last week have had their resources built out
17:35:28 <colindixon> #info the two projects that were approived last week have resources
17:35:33 <colindixon> #undo
17:35:33 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1cd4690>
17:36:02 <tbachman> #topic Creation Review for SDK for SDN Apps
17:36:13 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:SDNApp-SDK the proposal
17:36:54 <colindixon> #link https://wiki.opendaylight.org/view/File:ODL-Be-Incubation-SDNAppSDK-May182015.pdf the slides
17:37:28 <tbachman> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-May/000317.html email for project proposal request
17:38:40 <tbachman> #info The current approach for developing apps for SDN is missing a framework, which allows reusability for interfaces and database services
17:39:18 <tbachman> #info There also currently aren’t any libs for validation, or audit management for apps
17:40:08 <tbachman> #info Developers, Operators, and Security all have different approaches and needs, all of which would benefit from an SDN SDK
17:41:04 <tbachman> #info The propsal is a model-driven approach where app developers will write a model object for development
17:41:19 <tbachman> #info The framework will provide inspection API for third party tools
17:43:04 <tbachman> #info The framework provides start/stop/audit services for application management
17:43:21 <colindixon> tbachman: thanks
17:43:37 <tbachman> colindixon: np!
17:43:52 <tbachman> #info rovarga_ says he’s a bit unclear what the OpenDaylight NB API is
17:44:18 <tbachman> #info rovarga_ asks if the applications would be deployed inside the controller, or is this a set of infrastructure outside the controller using RESTCONF
17:44:35 <tbachman> #info This would be for applications that live outside of the controller
17:45:03 <tbachman> #info rovarga_ asks if these would be an external process to the controller itself
17:45:11 <tbachman> #info This will be external to the controller
17:45:36 <tbachman> #info dlenrow says he doesn’t think that will work, as the Intent engine is the NB for the controller, which requires it to run on the controller
17:46:51 <tbachman> #info edwarnicke says he’s having trouble figuring out what the scope of this project is, and how its well defined and not overly broad
17:48:18 <tbachman> #info colindixon asks how is this noticeably different than building a second opendaylight outside of opendaylight
17:49:00 <rovarga_> colindixon: +1
17:49:19 <alagalah> colindixon: pretty much
17:49:23 <tbachman> #info Their aim is to just be an enabler for things not in ODL — like third party tools
17:49:56 <tbachman> #info colindixon says ODL is an extensible framework for people to come in create applications
17:50:00 <alagalah> colindixon: There is an API, its generated from the MDSAL. Thats the one API for the controller.
17:50:36 <tbachman> #info rovarga_ notes that a lot of the pieces in the architecture diagram are already pieces in the controller
17:51:46 <phrobb1> Shall Colindixon and I work offline to help this project define a reasonable scope?
17:51:52 <colindixon> yes
17:52:16 <phrobb1> since my audio kinda sucks, feel free to make that recommendation colindixon
17:52:19 <colindixon> give m a second
17:52:21 <tbachman> #info edwarnicke says if the project was well scoped, he would feel much better
17:52:23 <phrobb1> ye[
17:52:25 <phrobb1> yep
17:52:42 <rovarga_> edwarnicke: yup, logging needs a lot of love, in both performance in analytics departments
17:52:49 <alagalah> rovarga_: +1
17:53:15 <tbachman> #action colindixon and phrobb1 to work with the SDN SDK project to to help this project define a reasonable scope
17:53:55 <colindixon> #info edwarnicke makes it clear that his issue is not with repliating functionality, but that the scope is overly broad
17:54:21 * ChrisPriceAB thinks some clarity on the intention and scope would be helpful. (for everyone)
17:55:38 <ChrisPriceAB> What does this API layer look like, some examples would be interesting.  ODL needs a little of this kind of love so I am positive to the idea, but agree in general that understanding how/where the effort will be applied would be useful.
17:57:35 <colindixon> #info Sumit says that his experience is that he had a lot of things that he had to do that ODL didnt’ do and this was trying to make that easier
17:57:35 * tbachman isn’t sure what to capture at this point
17:57:38 <tbachman> thx
17:58:19 <alagalah> colindixon: I'll help. Just count me in.
17:58:48 <phrobb1> yea, that would be good
17:59:12 <tbachman> #action alagalah to work with Sumit and his team to present something at a TWS session
17:59:13 <alagalah> #info alagalah to work with Sumit to schedule a TWS call to hear more
17:59:18 <alagalah> tbachman: Thanks mate
17:59:21 <colindixon> #action colindixon to work with alagalah and phrobb1 to schedule time both offline and during a TWS
17:59:21 <tbachman> alagalah: np ;)
17:59:38 * rovarga_ worries about the sheer amount of integration needed, which is not touched on, less fleshed out
17:59:44 * ChrisPriceAB loves that everyone actioned themselves
17:59:52 <tbachman> ChrisPriceAB: lol
17:59:57 * tbachman waits for ChrisPriceAB to action himself
18:00:05 <tbachman> #topic cookies
18:00:08 * ChrisPriceAB runs screaming for the hills
18:00:18 <ChrisPriceAB> nom nom nom
18:00:19 <tbachman> #endmeeting