#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:27 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:36)
    1. colindixon (colindixon, 17:00:55)
    2. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=31552#Agenda the agenda in it’s usual place (colindixon, 17:01:26)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-06-11-17.00.html last week’s meeting minutes (colindixon, 17:01:39)
    4. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (colindixon, 17:01:48)
    5. Chris Wright (cdub, 17:01:57)
    6. LuisGomez (LuisGomez, 17:02:00)
    7. ACTION: ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and (colindixon, 17:02:33)
    8. Chris Price (ChrisPriceAB, 17:03:00)
    9. ACTION: phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for (colindixon, 17:03:13)
    10. Youcef Laribi (Youcef, 17:03:20)
    11. Mohnish Anumala (irc only) (mohnish, 17:03:53)
    12. jmedved (irc only) (jmedved, 17:04:04)
    13. edwarnicke (edwarnicke, 17:05:18)
    14. ACTION: colindixon and phrobb1 to work with the SDN SDK project to to help this project define a reasonable scope (colindixon, 17:05:25)
    15. ACTION: colindixon to work with alagalah and phrobb1 to schedule time both offline and during a TWS (colindixon, 17:06:16)

  2. events (colindixon, 17:08:25)
    1. http://www.opendaylight.org/news/events/ the events page (colindixon, 17:08:35)
    2. people are at ONS with tutorials on wednedsay and a developer track on Monday with 100-150 people at the beginning, all went pretty well (colindixon, 17:09:03)
    3. the ODL summit is coming up at the end of July (colindixon, 17:09:35)
    4. https://wiki.opendaylight.org/view/Events:Main#OpenDaylight_Developer_Forum_-_Santa_Clara.2C_CA_July_30th_and_31st.2C_2015 Please add topics that you want to discuss at the developer forum (colindixon, 17:10:31)
    5. ACTION: phrobb will create a page for us to aggregate topics for the developer design forum (colindixon, 17:10:38)
    6. EVERYONE REGISTER FOR THE DEV FORUM IF YOU WANT TO ATTEND, IT WILL “SELL” OUT (colindixon, 17:10:57)
    7. alagalah for jmedved (alagalah, 17:11:02)
    8. alagalah will be jmedved’s proxy on this TSC (jmedved, 17:11:26)
    9. https://www.regonline.com/register/checkin.aspx?EventId=1627424&MethodId=0&EventSessionId=&startnewreg=1 register for the developer forum here if you need to (colindixon, 17:11:35)
    10. Question about having a Summit in the UK or Europe (dfarrell07, 17:11:37)
    11. Phil points out that attendance may be lower in Europe, so maybe not full summit, maybe something smaller? (dfarrell07, 17:12:21)
    12. edwarnicke points out that many Open Source projects grow distributed events by starting an expected-smaller *-<some place> and growing it slowly (dfarrell07, 17:13:21)

  3. Lithium (colindixon, 17:13:45)
    1. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit?pli=1#gid=676729675 blocking bugs (colindixon, 17:14:44)
    2. https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit?pli=1#gid=1757763090 we have the vast majority of projects reporting RC1 test results (but not all) (colindixon, 17:14:49)
    3. gzhao says we really need people to mark the “to be verified” bugs as “verified” quickly (colindixon, 17:15:16)
    4. OFPlugin and GPB were in red, colindixon asks if they would still be red in RC2 (dfarrell07, 17:15:56)
    5. there are 5 projects still haven't completed RC1 testing (gzhao, 17:16:19)
    6. AAA and OVSDB send email response that testing is uderway (gzhao, 17:16:36)
    7. L2swtich, topoporcessing and Persistence still waiting for response (gzhao, 17:17:30)
    8. LuisGomez points out that Integration's yellow status isn't a release-blocker, but of course it would be nice to not require the Internet (dfarrell07, 17:18:04)
    9. it sounds like the two current blcoking bugs right now that aren’t believed to be fixed are: 3656 (blocking on an odlparent merge) and 3548 (blocking on an openflowplug merge) (colindixon, 17:18:06)
    10. RC2 will be cut at UTC 11:59 today (gzhao, 17:18:13)
    11. AGREED: we wil cut another RC1 daily tonight (instead of RC2) if those two bugs (3656 and 3548) aren’t belived to be fixed (colindixon, 17:20:42)
    12. colindixon asks if we should make RC2 just -Lithium insead of -Lithium-RC2 so that we don’t have to worry about the fact that re-spinning it to remove -RC2 would require *more* testing since it would not necessarily be the same (colindixon, 17:22:41)
    13. zxiiro has been sending release artifacts links to the release list (dfarrell07, 17:23:40)
    14. ACTION: zxiiro to add a link to the top of the weather page and the top of the RCX release report google sheet to point to the current most recent Lithium RC (colindixon, 17:24:02)
    15. AGREED: assuming zxiiro doesn’t have any strong reason to not do this, we wil have RC2 builds be with the only -Lithium so we can release one once we are happy with how it tests (this is how we did things in Helium and other making sure you have URL and sha1 it worked well) (colindixon, 17:26:57)
    16. ACTION: snoble to create a bug around topology not showing up that seems to be new in RC1 and add it to the blocking issues (colindixon, 17:28:48)
    17. ACTION: snoble will file a bug for not being able to scroll the topology (but not make it blocking) (colindixon, 17:29:30)
    18. https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the current weather report for those who are interested (colindixon, 17:30:24)
    19. phrobb asks how confident we are in shipping Lithium on Thursday, 6/25 so that the PR folks can prep, even if we say it is high, they plan to announce things on Monday, 6/28 (colindixon, 17:32:01)
    20. rovarga says that he things he’s good to go for all of his projects (colindixon, 17:32:38)
    21. colindixon says that his broad reading of things is that other than waiting on RC1 feedback from some projects (most notably ovsdb and aaa), things look pretty good to release on 6/25 (colindixon, 17:33:54)
    22. edwarnicke says that he feels good from a blocking bug list, but he would need more input from individual projects (colindixon, 17:34:16)
    23. ACTION: LuisGomez and gzhao to make the options for RC2 to be go/no-go as far as releases (colindixon, 17:35:30)
    24. gzhao says “if we can have the two blocking bug resolved, I am pretty confident release on 6/25” (colindixon, 17:36:08)
    25. Prem_ says from vpnservice it’s a go (colindixon, 17:37:00)
    26. ebrjohn says sfc says he’s a go (colindixon, 17:37:13)
    27. abhijitkumbhare barring the blocking bug, ofplugin is a go (colindixon, 17:37:23)
    28. gzhao USC is a go (gzhao, 17:37:38)
    29. GBP is a go. (alagalah, 17:38:07)
    30. VTN is go. (hideyuki_, 17:38:28)
    31. Controller is go. (ttkacik, 17:38:42)
    32. if we get fixes merged for the blocking bugs before tonight's build, we will call tonight's build RC2 and that version will stay as the true candidate release bits and we will finish our testing on that version until a new blocking bug is reported (phrobb, 17:40:40)
    33. colindixon says to be very clear, if we get all blocking bugs belived to be fixed by midnight UTC tonight, we will cut RC2 and we will only respin it if there is a *blocking* bug found, so only fixes in my midnight UTC tonight will be guaranteed to make the cut (colindixon, 17:42:14)
    34. AGREED: the TSC encourages all projects to excercise *extreme* caution in merging patches to stabe/lihtium as they may cause the release to regess and thus be delayed, the *only* clear reason to merge a patch is to fix a blocking bug, in other cases projects are encouraged to use their judgment with extreme caution (colindixon, 17:52:51)
    35. ACTION: gzhao to send out the caution about merging to stable/lihtium to the release list (colindixon, 17:53:04)

  4. NetIDE project proposal (colindixon, 17:53:34)
    1. this will be tabled to next week (colindixon, 17:53:39)

  5. Be release plan (colindixon, 17:53:43)
    1. timing-wise, ttkacik asks if we can push M2 (for all projects) to be after the develper design forum so release plans can incorpoarte feedback from the desigin forum (colindixon, 17:54:58)
    2. colindixon says that make sense to him and he was planning to make that modification (colindixon, 17:55:10)
    3. rovarga asks if we’re willing to mandate JDK8 compliance in Beryllium (colindixon, 17:55:45)
    4. rovarga and edwarnicke clarify that we're talking about supporting JDK8 and later (dfarrell07, 17:56:48)
    5. which would imply *not* supporting JDK 7 in Beryllium (edwarnicke, 17:57:08)
    6. edwarnicke asks if we’re saying that we need to support JKD7 and JDK8 or move completely to JDK8 (colindixon, 17:57:41)
    7. tykeal notes that JDK7 isn’t even available in modern distros on many platforms (colindixon, 17:58:05)
    8. AGREED: barring sombody asking for JDK7 support prior to offset 0 M1 of the Beryllium release plan, we will move to JDK8+ starting with Beryllium\ (colindixon, 17:59:21)

  6. cookies (colindixon, 18:00:01)


Meeting ended at 18:00:11 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium
  2. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
  3. phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for
  4. colindixon and phrobb1 to work with the SDN SDK project to to help this project define a reasonable scope
  5. colindixon to work with alagalah and phrobb1 to schedule time both offline and during a TWS
  6. phrobb will create a page for us to aggregate topics for the developer design forum
  7. zxiiro to add a link to the top of the weather page and the top of the RCX release report google sheet to point to the current most recent Lithium RC
  8. snoble to create a bug around topology not showing up that seems to be new in RC1 and add it to the blocking issues
  9. snoble will file a bug for not being able to scroll the topology (but not make it blocking)
  10. LuisGomez and gzhao to make the options for RC2 to be go/no-go as far as releases
  11. gzhao to send out the caution about merging to stable/lihtium to the release list


Action items, by person

  1. alagalah
    1. colindixon to work with alagalah and phrobb1 to schedule time both offline and during a TWS
  2. ChrisPriceAB
    1. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
  3. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium
    2. colindixon and phrobb1 to work with the SDN SDK project to to help this project define a reasonable scope
    3. colindixon to work with alagalah and phrobb1 to schedule time both offline and during a TWS
  4. gzhao
    1. LuisGomez and gzhao to make the options for RC2 to be go/no-go as far as releases
    2. gzhao to send out the caution about merging to stable/lihtium to the release list
  5. jmedved
    1. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
  6. LuisGomez
    1. LuisGomez and gzhao to make the options for RC2 to be go/no-go as far as releases
  7. phrobb
    1. phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for
    2. phrobb will create a page for us to aggregate topics for the developer design forum
  8. snoble
    1. snoble to create a bug around topology not showing up that seems to be new in RC1 and add it to the blocking issues
    2. snoble will file a bug for not being able to scroll the topology (but not make it blocking)


People present (lines said)

  1. colindixon (73)
  2. dfarrell07 (21)
  3. gzhao (15)
  4. odl_meetbot (11)
  5. alagalah (8)
  6. tykeal (6)
  7. phrobb (5)
  8. edwarnicke (5)
  9. cdub (4)
  10. snoble (3)
  11. jmedved (2)
  12. LuisGomez (2)
  13. ChrisPriceAB (2)
  14. ebrjohn (1)
  15. tbachman (1)
  16. vina_ermagan (1)
  17. hideyuki_ (1)
  18. Youcef (1)
  19. mohnish (1)
  20. ttkacik (1)
  21. phrobb- (0)


Generated by MeetBot 0.1.4.