17:00:14 <colindixon> #startmeeting tsc
17:00:14 <odl_meetbot> Meeting started Thu Jun 25 17:00:14 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:14 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:14 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:20 <colindixon> #topic agenda bashing and roll call
17:00:24 <colindixon> #info colindixon
17:00:38 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=32699 the snapshot of today’s agenda on the wiki
17:00:48 <colindixon> #undo
17:00:48 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1cb9690>
17:01:00 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=32699#Agenda the snapshot of today’s agenda on the wiki
17:01:03 * edwarnicke is excited!
17:01:06 <edwarnicke> #info edwarnicke
17:01:13 <colindixon> #chai phrobb dfarrell07_pto
17:01:19 <colindixon> #chair phrobb dfarrell07_pto
17:01:19 <odl_meetbot> Current chairs: colindixon dfarrell07_pto phrobb
17:01:25 <colindixon> #chair gzhao
17:01:25 <odl_meetbot> Current chairs: colindixon dfarrell07_pto gzhao phrobb
17:01:37 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-06-18-17.00.html last week’s meeting minutes
17:01:50 <tykeal> arg! my webex client can't seem to get logged in
17:01:56 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1)
17:02:10 <colindixon> #action ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
17:02:19 <colindixon> #action phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for
17:03:00 * ChrisPriceAB on my way, running a little late
17:03:22 <jmedved> #info jmedved
17:03:36 <dfarrell07_pto> #info dfarrell07_pto for Red Hat, irc only atm
17:03:57 <phrobb> #link https://wiki.opendaylight.org/view/Events:Main#OpenDaylight_Developer_Forum_-_Santa_Clara.2C_CA_July_30th_and_31st.2C_2015 Put your design forum topics here.  We will probably also create one or more sub-pages as more topics are added
17:04:17 <mohnish> #info mohnish anumala
17:04:24 <catohornet> #info catohornet carolsanders
17:04:55 <colindixon> #topic events
17:05:12 <colindixon> #link http://www.opendaylight.org/news/events/ the events list
17:05:19 <colindixon> #info major event next is the ODL summit
17:05:19 <alagalah> phrobb: IETF Hackathon
17:05:34 <colindixon> #link https://wiki.opendaylight.org/view/Events:Main#OpenDaylight_Developer_Forum_-_Santa_Clara.2C_CA_July_30th_and_31st.2C_2015 Put your design forum topics here.  We will probably also create one or more sub-pages as more topics are added
17:05:45 <alagalah> https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Hackathons/IETFPrague15
17:05:54 <ChrisPriceAB> #info chris price
17:05:57 <colindixon> #link https://www.regonline.com/register/checkin.aspx?EventId=1627424&MethodId=0&EventSessionId=&startnewreg=1 please register for dev/design forum
17:06:10 <alagalah> #info IETF Hackathon GBP+SFC: https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Hackathons/IETFPrague15
17:06:24 <colindixon> #undo
17:06:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1bac7d0>
17:06:39 <colindixon> #link https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Hackathons/IETFPrague15 IETF hacakathon in prague in on July 18th and 19th (GBP and SFC in particular)
17:06:56 <colindixon> #info there will be other folks from ODL there as well, it should be a good time
17:06:56 <alagalah> :)
17:07:42 <colindixon> #topic infrastructure
17:07:50 <colindixon> #info zxiiro says things look great at the moment
17:07:56 <colindixon> #topic Lithium Release
17:08:24 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=676729675 no active blocking bugs
17:08:42 <phrobb> #info colindixon Notest that we have no blocking bugs..
17:09:17 <phrobb> #info colindixon  notes one issue in OpenStack and has been moved from blocking to deferred given the fix needs to be done in OpenStack
17:09:23 <alagalah> colindixon: Just on that, one of the team tried to reclone their DevStack this morning and got pain... so its hard to know where we stand (today).
17:09:42 <phrobb> #info OPFLEX artifacts are not in Nexus and it's being worked.  It is not considered to be a blocker
17:10:49 <phrobb> #info documentation, and release notes are still being worked on and will probably be done so up until our official announcement on Monday
17:11:43 <ChrisPriceAB> Who gives a $&@ about an English comma?
17:12:08 <ChrisPriceAB> Oops, Oxford
17:12:49 <phrobb> #info colindixon  notes that making adjustments to release notes between now Monday is fine... at some point colindixon  will cobble the wiki contents up into an asciidoc so get your last modifications in sooner rather than later
17:13:12 <tykeal> they were all in awe that I finally managed to dial into the meeting phrobb ;)
17:14:09 <colindixon> #link https://docs.google.com/spreadsheets/d/1KPpO9LH539Vlcoa4RvLa6PPCdLifi5JD-ihRhlybqeo/edit#gid=478292312 of the 41 projects listed there, d4a is not actually in Lithium and they know that, otherwise all projects have voted go
17:14:32 * gzhao is surprised to see all projects voted.
17:14:38 <ebrjohn> Go, Go, Go :)
17:14:39 <phrobb> #info defense4all has stepped out of the release due to their own development issues.  As a free-standing app, there is no other impact on the Li release
17:14:45 <Youcef> #info Youcef Laribi
17:15:06 <gzhao> ebrjohn: 36 more times
17:15:09 <phrobb> #info All other projects have voted "go" so we are ready to go re Li
17:15:11 <alagalah> gzhao: You are very effective, the full-vote should not surprise you :)
17:15:17 <zxiiro> \o/
17:15:25 <gzhao> alagalah: thanks
17:15:27 <colindixon> #link https://nexus.opendaylight.org/content/repositories/automatedweeklyreleases-1074/org/opendaylight/integration/distribution-karaf/0.3.0-Lithium/ this is the lithium release distribution which everyone has tested
17:15:31 * ebrjohn gzhao dont tempt me, I'll do it ;)
17:15:38 * dfarrell07_pto had audio in time to hear colindixon's exciting "release Li" statement :)
17:15:43 <gzhao> ebrjohn: -:)
17:15:47 <colindixon> #info core tutorials voted n/a because there’s only one small piece included which is only used by integration
17:15:55 * alagalah in the time honored tradition of "riot as a form of celebration" (╯°□°)╯︵ ┻━┻
17:15:55 <phrobb> #startvote Shall the TSC approve the Release of Lithium? -1, 0, +1
17:15:55 <odl_meetbot> Begin voting on: Shall the TSC approve the Release of Lithium? Valid vote options are -1, 0, +1.
17:15:55 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:16:10 <colindixon> #vote +1
17:16:11 <mohnish> #vote +1
17:16:12 <edwarnicke> #vote +1
17:16:16 <ChrisPriceAB> #vote +1
17:16:16 <dfarrell07_pto> #vote +1
17:16:24 <catohornet> #vote +1
17:16:31 <jmedved> #vote +1
17:16:39 * ChrisPriceAB has an urge for cookies!
17:16:44 <dfarrell07_pto> huzzah! :D
17:16:45 <alagalah> catohornet: <== address all Lithium questions to... :D
17:16:46 <phrobb> #endvote
17:16:46 <odl_meetbot> Voted on "Shall the TSC approve the Release of Lithium?" Results are
17:16:46 <odl_meetbot> +1 (7): catohornet, jmedved, edwarnicke, ChrisPriceAB, mohnish, colindixon, dfarrell07_pto
17:16:50 * gzhao congratulates catohornet
17:17:01 <Youcef> #vote +1
17:17:06 * drizzt__ is a happy camper!
17:17:12 <alagalah> drizzt__: :)
17:17:13 <colindixon> #info note that Uri and Youcef vote +1 as well
17:17:21 <ebrjohn> YAYYY!!!
17:17:24 <alagalah> colindixon: Well done!
17:17:27 <phrobb> #agreed Liithum is released re the artifacts located here: https://nexus.opendaylight.org/content/repositories/automatedweeklyreleases-1074/org/opendaylight/integration/distribution-karaf/0.3.0-Lithium/
17:17:28 <abhijitkumbhare> ChrisPriceAB: I think that calls for drinks - rather than cookies :)
17:17:33 <dfarrell07_pto> Well done all!
17:17:36 <zxiiro> congrats!
17:17:39 * tykeal starts the nexus release of repo 1074
17:17:52 * ebrjohn abhijitkumbhare I agree!!
17:17:53 * ChrisPriceAB cheers and applauds from Sweden!
17:17:56 <mohnish> congratulations
17:17:56 <gzhao> #info colindixon congratules for first on time Opendaylight major release with 40+ projects
17:18:05 * drizzt__ thanks Colin, George, Phil and all the devs for a job VERY well done!
17:18:13 <dfarrell07_pto> congrats all, thanks colindixon!
17:18:15 * alagalah Celebration! In the form of documentation :)
17:18:16 * ebrjohn wine and siesta from Spain :)
17:18:18 * odl-casey claps
17:18:21 <gzhao> #info colindixon says everyone should go and celebrate!!!!
17:18:31 <dfarrell07_pto> ^^ACK :)
17:18:33 * ChrisPriceAB runs off to celebrate, thanks colindixon.
17:18:54 <alagalah> Envelope opens, ChrisPriceAB celebrates ;)
17:19:11 <colindixon> #info zxiiro notes that the release engineering team will be tagging and bumping versions as part of the release
17:19:20 <ChrisPriceAB> lol alagalah
17:19:22 <gzhao> #info zxiiro asks project don't merge patches on stable/lithium
17:19:24 <colindixon> #info zxiiro asks that people not merge patches to stable/lithium in the meantime
17:19:26 <colindixon> #Undo
17:19:26 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1bab710>
17:19:38 <tykeal> holy awesome, this is the first release where I haven't had to beat nexus in the head to get the repo to actually release
17:19:49 <ebrjohn> zxiiro: Are you going to have to wait for all projects to merge your patches now?
17:19:56 <abhijitkumbhare> ebrjohn: isn’t that Sangria?
17:20:09 * ebrjohn abhijitkumbhare that too!
17:20:22 <tykeal> or not :-/
17:20:37 <alagalah> colindixon: you forgot the interproject-gap :)
17:20:41 <catohornet> :)
17:20:50 * tykeal just adds his nexus stream of consciousnesses to the meeting minutes ;)
17:20:54 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-June/002990.html the e-mail explaining the details
17:21:51 <alagalah> zxiiro: THANK YOU!
17:22:42 <colindixon> #info edwarnicke asks how long version bumping and patches will take, Thanh says today, colin says it will take at least 8 hours, colindixon says it’s going to take maybe closer to a few days
17:22:43 <zxiiro> :)
17:22:53 <phrobb> phrobb notes that colindixon says someone should #info something then starts talking slowly so we realize he is actually typing that in
17:22:58 <colindixon> #info colindixon says early next week is a resonable estimate for when it could be done
17:24:05 <colindixon> #topic Martin Sunal as a comitter on SXP
17:24:32 <phrobb> #info TSC tabling SXP committer discussion until SXP members present
17:24:40 <colindixon> #topic creation review fro NetIDE
17:24:53 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:NetIDE the project proposal
17:25:10 <colindixon> #link https://wiki.opendaylight.org/images/9/9c/NetIDE_ODL_proposal.pdf slides at the bottom of the proposal
17:25:40 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-June/000318.html proposed on May 19th, so much more than two weeks ago
17:26:10 <colindixon> #info NetIDE consortium is broader than just Intel, many other academics and companies
17:26:38 <colindixon> #info looking to create an IDE for SDN applications
17:27:22 <colindixon> #link https://github.com/fp7-netide it’s already an open source project on github
17:27:35 <colindixon> #info it’s already under the EPL
17:28:50 <colindixon> #info colindixon notes that they have 4 repos on github, but would likely only get one repo in ODL, will that be an issue?
17:29:17 <colindixon> #Info alec says he doesn’t think so, because not all of the stuff on github will be migrated to ODL
17:29:58 <colindixon> #info jmedved asks if this is targeting apps that use the REST API or the ones that are plugings, Alec says ideally both
17:30:23 <colindixon> #info two main parts: network engine and IDE
17:30:30 <colindixon> #topic NetIDE network engine
17:30:38 <colindixon> #info starts on slide 7
17:31:12 <colindixon> #Info the architecture has a notion of a client SDN controller and server SDN controller using backends and shims for them to be layered
17:31:36 <dfarrell07_pto> +1 do doing this demo
17:31:42 <dfarrell07_pto> to*
17:32:16 <colindixon> #info Alec says he can run a demo of this on mininet using ODL as the server SDN controller with Floodlight, Pyretic, etc. as client SDN controllers
17:32:37 <colindixon> #undo
17:32:37 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b6ff90>
17:32:46 <colindixon> #info Alec says he can run a demo of this on mininet using ODL as the server SDN controller with Floodlight, Pyretic, and Rya as client SDN controllers
17:32:53 <colindixon> #Info demo app is branch office connectivity
17:33:19 <colindixon> #info the language being used between the shims and the backends (glue between client and server SDN controllers) is currently the pyretic language
17:33:36 <colindixon> #info the pyretic language for now is OpenFlow 1.0 only, which has limitations
17:33:55 <colindixon> #Info jmedved asks if this is OpenFlow specific, Alec says yes for now
17:34:41 <dfarrell07_pto> Can they merge that fork?
17:34:42 <colindixon> #info jmedved asks what they mean by supporting NETCONF, Alec says that they would think about forking Pyretic to add in 1.3 and some new features, e.g., NETCONF messages
17:34:43 <dfarrell07_pto> Why not?
17:34:51 <colindixon> dfarrell07_pto: good question
17:34:53 <colindixon> speak up
17:34:55 <colindixon> if you wnat
17:34:59 <zxiiro> Is it not possible to work with upstream Pyretic?
17:35:05 <dfarrell07_pto> zxiiro: +1
17:35:38 <colindixon> #info jmedved says that things aren’t very useful with OpenFlow alone, Alec says maybe, but there are lots of OpenFlow controllers out there and this enables those to run on topo of ODL
17:36:37 <colindixon> #info edwarnicke asks about the value of using pyretic messages vs. translating directly to models for ODL
17:36:54 <colindixon> #info Alec answers because there is another shim for Ryu and pox (it’s not just ODL)
17:38:38 <dfarrell07_pto> colindixon: +1
17:38:48 <edwarnicke> colindixon: +1
17:39:52 <colindixon> #info edwarnicke notes that that he believes that using pyretic as the carrier message will result in pain since it is “semantically poor” when compared to OpenDaylight’s models
17:40:45 * tykeal notes that the staging repo 1074 has now been released. Li now officially in the opendaylight.release repository
17:40:50 <colindixon> #info colindixon makes sure to note that this technical discussion is good and important, but the technical discussion will not much (if any) bearing on whether the TSC approves the project and should be taken as engineer-to-engineer feedback
17:41:10 <zxiiro> tykeal: thanks!
17:41:13 <colindixon> #info there is conversation about openflow-only vs. more general
17:41:17 <alagalah> colindixon: Can we get a Scope defintion please?
17:41:34 <alagalah> colindixon: https://wiki.opendaylight.org/view/Project_Proposals:NetIDE https://wiki.opendaylight.org/images/9/9c/NetIDE_ODL_proposal.pdf
17:41:38 <alagalah> colindixon: Didn't see scope defined
17:41:44 <tykeal> zxiiro: yep, that does of course mean that staging repo 1074 no longer exists since by releasing it the artifacts get moved to the target ;)
17:41:45 <colindixon> alagalah: https://wiki.opendaylight.org/view/Project_Proposals:NetIDE#Scope
17:41:51 <colindixon> it might not be pefect
17:42:02 <colindixon> but that’s what I can see
17:42:36 <alagalah> colindixon: Weird... I searched on their page and missed it, apologies
17:42:47 <abhijitkumbhare> From OpenFlow Plugin side we may find this very useful :)
17:42:53 <alagalah> colindixon: Point me to someone with a perfect scope and I'll point you to someone who isn't doing much :D
17:43:01 <colindixon> I *think* that scope says it’s creating a shim/backend around their protocol, and a IDE
17:43:11 <alagalah> colindixon: No, its my bad totally
17:44:04 <colindixon> #info to be clear, Alec says that their plans with the pyretic language would be to try to incorporate things back to the main project
17:44:42 <dfarrell07_pto> Generic warning against long-lived forks and the benefits of doing it upstream, but glad to see they are thinking about i
17:44:46 <colindixon> #info edwarnicke asks how the pyretic guys are feeling about these modifications and extensions, Alec says generally thats’s a good relationship
17:44:55 <dfarrell07_pto> it*
17:45:27 <colindixon> #info zxiiro and dfarrell07_pto brought up the question about forking pyretic, not me just to give credit where credit is due
17:45:52 <colindixon> #info jmedved points out that different controllers have different clustering/HA models, Alec says they haven’t looked at that yet
17:46:35 <colindixon> #topic the NetIDE IDE
17:47:00 <colindixon> #info starts on slide 10
17:47:18 <colindixon> #topic this is a suite of plugins to Eclipse
17:47:41 <colindixon> #info shows a screenshot of an interface GUI with switches, hosts, etc.
17:48:11 <colindixon> #info this then auto-generates the relevant code using Django to generate python for Ryu in the screentshot
17:48:22 <colindixon> #info this could be done with YANG and Java in a similar way for OpenDaylight
17:49:13 <colindixon> #info another tool they aren’t showing, allows you to take an ODL topology and then deploy it in mininet to check your real topology in simulation
17:50:18 <dfarrell07_pto> #info Just to make sure it gets in the notes (regarding Pyretic fork), dfarrell07_pto notes that long-lived forks are typically harder to integrate than working upstream initially, and suggests that Pyretic committer rights seem appropriate for people doing such substantial refactoring
17:50:43 <colindixon> dfarrell07_pto: thanks!
17:51:21 <dfarrell07_pto> colindixon: ty for *all the notes* lol
17:52:29 <colindixon> #info the scope seems to be NetIDE consortium’s shim and backend for allowing the client/server SDN controller architecture and Eclipse-based IDE tools to help developers
17:53:40 <colindixon> #info jmedved says we could expand things if we could consider topology stacks beyond the typical L2/L3, openflow scope
17:53:45 <colindixon> #info Alec says he’s open to that
17:54:55 <dfarrell07_pto> #vote Shall the TSC approve NETIDE? -1, 0, +1
17:55:02 <dfarrell07_pto> #startvote Shall the TSC approve NETIDE? -1, 0, +1
17:55:02 <odl_meetbot> Begin voting on: Shall the TSC approve NETIDE? Valid vote options are -1, 0, +1.
17:55:02 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:55:11 <colindixon> #vote +1
17:55:12 <jmedved> #vote +1
17:55:12 <Youcef> #vote +1
17:55:13 <catohornet> #vote +1
17:55:14 <mohnish> #vote +1
17:55:17 <dfarrell07_pto> #vote +1
17:55:17 <ChrisPriceAB> #vote +1
17:55:22 <edwarnicke> #vote +1
17:55:29 <uri_> vote +1
17:55:29 <dfarrell07_pto> last call
17:55:30 <tykeal> yes, I hear that
17:55:36 <dfarrell07_pto> #endvote
17:55:36 <odl_meetbot> Voted on "Shall the TSC approve NETIDE?" Results are
17:55:36 <odl_meetbot> +1 (8): catohornet, jmedved, ChrisPriceAB, edwarnicke, mohnish, colindixon, Youcef, dfarrell07_pto
17:55:45 <colindixon> #info note that Uri_ also voted +1
17:57:01 * ChrisPriceAB Lithium victory cookies!
17:57:04 <dfarrell07_pto> #agreed The TSC vote above was to move the NetIDE project to incubation
17:57:20 <ChrisPriceAB> December shipment?
17:58:45 <ChrisPriceAB> :(
17:58:52 <edwarnicke> #topic Lithium Pills
17:58:55 <dfarrell07_pto> #topic Lith cookies!
17:58:56 <alagalah> ChrisPriceAB: no Dec
17:59:07 * ChrisPriceAB weeps into his cookies
17:59:17 <alagalah> ChrisPriceAB: Perhaps you could donate some sleep ?
17:59:20 <ChrisPriceAB> #action me to send a mail
17:59:29 <edwarnicke> ChrisPriceAB: Will code for sleep
17:59:30 <tykeal> google search for lithium cookies doesn't turn up anything useful :(
17:59:31 <ChrisPriceAB> hehe
17:59:41 <rovarga> ah, so no Be xmas presents, I guess :)
17:59:42 * drizzt__ very very hungry
17:59:48 <dfarrell07_pto> great job all :)
17:59:52 <colindixon> #endmeeting