17:00:15 <colindixon> #startmeeting tsc
17:00:15 <odl_meetbot> Meeting started Thu Jul  2 17:00:15 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:15 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:15 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:19 <colindixon> #topic roll call and agenda bashing
17:00:30 <colindixon> #chair edwarnicke regXboi dfarrell07
17:00:30 <odl_meetbot> Current chairs: colindixon dfarrell07 edwarnicke regXboi
17:00:33 <colindixon> #info colindixon
17:00:38 <tykeal> and I know I'm using the correct password because it's input via LastPass ;)
17:00:44 <regXboi> #info regXboi for edwarnicke
17:00:48 <oflibMichal1> #info oflibMichal
17:00:49 <tykeal> phil is on vaca
17:00:52 <ebrjohn> #info ebrjohn for Chris Price
17:00:59 <regXboi> #chair colindixon dfarrell07 regXboi
17:00:59 <odl_meetbot> Current chairs: colindixon dfarrell07 edwarnicke regXboi
17:01:09 <regXboi> #unchair edwarnicke
17:01:09 <odl_meetbot> Current chairs: colindixon dfarrell07 regXboi
17:01:25 * regXboi looks for his "I'm Ed hat"
17:01:26 <dfarrell07> #info dfarrell07 for cdub/Red Hat
17:01:40 * tykeal had to hunt down the call in information since the java app doesn't like me since I use openjdk ;)
17:02:11 <colindixon> #info note that oflibMichal1 is not a TSC member today and should not counted for quorum
17:02:18 <alagalah_> colindixon: Jan is on his way
17:02:45 <dfarrell07> idk if Luis has appointed anyone?
17:03:16 <tykeal> dfarrell07: Luis appointed Carol (catohornet)
17:03:39 <dfarrell07> I pinged Carol in odl-integration, no response so far
17:03:42 <jmedved> #info jmedved
17:04:03 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-06-25-17.00.html last week’s minutes for action items
17:04:14 <tykeal> jmedved: you seem to have an "interesting" character in the middle of your handle for that info
17:04:26 * tykeal doesn't know what it is though
17:04:27 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=33135#Agenda the static, unchanging agend for this meeting
17:04:31 <alagalah_> tykeal: I don't see it
17:04:42 <ebrjohn> I see it, looks like a clock
17:04:48 <tykeal> interesting
17:04:56 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1)
17:05:03 <mohnish> #info mohnish anumala
17:05:13 <regXboi> aw shoot -
17:05:34 <colindixon> #action ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
17:05:40 <colindixon> #action phrobb to investigate what it takes to get to the license for JIRA, and what the licence would be for
17:05:52 <tykeal> heh
17:05:59 <dfarrell07> It was ChrisPriceAB, you'd say we'd not remember ;)
17:07:01 * alagalah_ is about to start a week of PTO, so I'm just following the bouncing ball :)
17:07:19 <colindixon> #topic events
17:07:29 <colindixon> #link http://www.opendaylight.org/news/events/ here’s the list of upcoming events
17:07:47 <colindixon> #link https://www.regonline.com/register/checkin.aspx?EventId=1627424&MethodId=0&EventSessionId=&startnewreg=1 please sign up for the developer design forum if you haven’t already
17:08:17 <colindixon> #info the dveloper forum should be fre, so if it’s asking you for money, don’t
17:08:25 <alagalah_> http://events.linuxfoundation.org/events/opnfv-summit/program/cfp
17:08:40 <dfarrell07> #link https://opendaylightsummit2015.sched.org/ Summit schedule
17:08:56 <regXboi> #link http://events.linuxfoundation.org/events/opnfv-summit/program/cfp call for papers at OPNFV
17:09:17 <alagalah_> http://events.linuxfoundation.org/events/opnfv-summit/program/cfp
17:09:20 <colindixon> #link http://events.linuxfoundation.org/events/opnfv-summit/program/cfp OPNFV summit CFP is 8/5, summit is 11/11 and 11/12
17:09:43 <colindixon> #undo
17:09:43 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x19b8c90>
17:09:44 <colindixon> #undo
17:09:44 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x19b8890>
17:09:51 <colindixon> #link http://events.linuxfoundation.org/events/opnfv-summit/program/cfp OPNFV summit CFP is 8/5, summit is 11/11 and 11/12
17:10:11 <colindixon> #topic stable/helium and stable/lithium
17:10:13 <dlenrow> #info dlenrow
17:11:11 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-July/003076.html gzhao is letting people know the current cutoff for Helium-SR4 is 7/12 11:59p UTC, if that needs to be moved, please let us know
17:12:12 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Schedule SR1 for Lihiumt is scheduled to ship on 8/13 and thus it will build sometime before then
17:12:22 <colindixon> #action gzhao to list an exact cutoff for Lithium SRs
17:13:02 <colindixon> #topic sytstem integration and test
17:13:17 <colindixon> #info dfarrell07 most integration committers have been on PTO
17:13:37 <colindixon> #info we have some failing test jobs, dfarrell07 encourages projects to look
17:14:09 <colindixon> #action colindixon and dfarrell07 to talk about automating notifiying projects of test failures
17:14:15 <colindixon> #topic infrastructure
17:14:33 <colindixon> #info tykeal is working on getting system updates from EL6 to EL7, also maybe getting Ubuntu into CI
17:14:40 <dfarrell07> Huzzah for EL7!
17:14:53 <colindixon> #info tykeal is going vacation two weeks starting 6 days from now, this will likely actually happen after the summit
17:15:14 <colindixon> #info also updates to jenkins, gerrit, nexus, etc. now that the risks are somewhat lower
17:15:58 <colindixon> #topic committer promotions
17:16:26 <colindixon> #action colindixon to send mail asking somebody to represent Martin Sunal’s case as a committer on SXP at a future TSC call
17:16:42 <colindixon> catohornet: if you wanted to #info in, that would be great
17:16:52 <catohornet> #info
17:17:11 <catohornet> Sorry audio issues.
17:17:27 <colindixon> #topic moving towards continous release
17:19:50 <tykeal> hehe
17:19:58 <tykeal> I know it wasn't me, I'm on hardware mute :D
17:19:59 <dfarrell07> TSC DDoS lol
17:20:00 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-June/003236.html the mailing list thread where Ryan first brings this up
17:20:01 <dfarrell07> me too
17:20:13 <odl-casey> lol
17:21:22 <colindixon> #info regXboi taks about using CR as a way to get around delays in propogation as the dependency graph as it gets longer, colindixon says he thinks it’s 10 levels deep at the moment
17:21:59 <colindixon> #info regXboi also says that this would help for issues where tracking master can make things unstable, e.g., if an upstream project breaks you, you can roll back to the last good released version to be able to keep making progress
17:22:14 <colindixon> #info he’d like to start doing CR at the leaf projects (where it’s easier)
17:22:21 <dfarrell07> I like the idea of rolling it in over those two releases
17:22:27 <dfarrell07> And I like the idea in general
17:22:30 <colindixon> #info he’d like to experiment with it in Beryllium, with the goal of actually using it some in Boron
17:25:13 <colindixon> #info colindixon asks if the idea is that master would be temporarily pointed at a previously released versions or having that be permanently the case, if it’s the latter how do we make sure we keep dependencies drifting forward
17:26:13 <dfarrell07> #info Using the (imho, proper) versioning system regXboi described would solve problems related to packaging/deployment
17:26:21 <colindixon> #info regXboi says, we’ve gone into areas where there’s not clear agreement, regXboi’s personal view is that major.minor.micro should be bumed on element release, SR/isotope release, every commit
17:29:41 <colindixon> #info colindixon will reiterate his major concern with CR, which is how do we deal with version skew across projects and make sure that we don’t let projects drift too far into the past
17:30:14 <colindixon> #info alagalah_ asks about how branches, e.g., feature branches, fit inot this
17:31:07 <colindixon> #info colindixon says that this should be (mostly) orthogonal from branches, but cautions about feaure branches as they require a lot of discipline to get right
17:34:17 <alagalah_> colindixon: Who is speaking ?
17:37:10 <colindixon> #info regXboi answers colindixon’s question around how do we prevent projects from drifting arbitrarily into the past? his two ideas are (i) projects can run a release job and after that everyone has to use the new version and (ii) just flagging version skew in integration
17:37:26 <colindixon> #info regXboi says start with integration as it’s the ultimate leaf
17:39:45 <colindixon> #info zxiiro says that there is a way to push SNAPSHOT artifacts that have a timestamp at then end and have that be common across the whole project so that you can reasonably roll back to it in a sane way
17:41:38 <tykeal> our snapshot retention policy is as follows: keep a minimum of 1 version of a snapshot (unless it's released at that version at which point we'll keep it for 30 days before purge). Snapshots at a given version are kept for 7 days
17:42:52 <colindixon> #info tony notes that he also worries about projects drifting backward in time and when we are going to resolve it
17:43:34 <colindixon> #info colindixon notes that it’s not just rollback for a single project, but it and all of it’s dependent projects, e.g., you need to roll back to a common version band across multiple (possibly all) projects
17:44:58 <colindixon> #info regXboi says his worry about zxiiro’s suggestion (which tony seconds) is that he wants all of these artifacts to stay around for a long time (at least until the last release) so that he can roll back
17:48:09 <colindixon> #info tykeal notes that we are using > 1.5 TB for only 1 week of snapshot artifacts and thus we cant reasonably expand that to something like a full release without dropping some things
17:48:48 <colindixon> #info tykeal says one workflow that sonatype (the makers of nexus) encourage is that to push artifacts to staging repos and have those staging repos be dropped later on, e.g., if integration fails for it
17:49:56 <colindixon> #info this will continue on this the mailing list, lots of good conversation, watch the recording if the notes don’t make sense
17:50:03 <colindixon> #topic Beryllium release plan
17:50:04 <tykeal> we shall keep the CR convo going continuously? ;)
17:50:19 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Per-Project_Beryllium_Release_Plan_Template the current draft Be release plan
17:50:24 <colindixon> #undo
17:50:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1c3dbd0>
17:50:40 <colindixon> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan the current Beryllium release plan draft
17:51:23 <alagalah_> colindixon: So is it possible to schedule a vote for RP next week ?
17:51:36 <colindixon> alagalah_: yes, I’d really like to
17:53:53 <dfarrell07> aCK
17:55:25 <tykeal> what about the SR?
17:55:55 <dfarrell07> Proposal wording: Shall the term of a PTL be one release, after which the term expires and a new election is required?
17:56:31 <alagalah_> colindixon: can I make a suggestion ?
17:57:16 <colindixon> #info colindixon would like to strive to vote on the Beyrllium release plan next week, please review things and make comments on the TSC/release
17:57:21 <colindixon> #topic PTL terms
17:57:27 <colindixon> #info regXboi asks do we need to set a PTL term length
17:57:44 <colindixon> #info colindixon asks people, tony, jmedved, and alagalah_ say they’d like to to leave this up to the projects
17:57:55 <dfarrell07> Note that I don't think anyone's talking about term *limits*, just lengths after which one must be re-elected
17:58:05 <dfarrell07> alagalah_^^
17:58:28 <alagalah_> dfarrell07: Someone brought it up, I was just making my feelings on the topic known in the short window I talk :)
17:58:35 <dfarrell07> kk :)
17:59:22 <colindixon> as of this point, it is the TSC’s view that there is no official statement as to the term lengths for PTLs and individual projects can come to their own conclusions as to when to hold elections as long the elections happen according the TSC charger and there is an active PTL at all times while a project is participating in an SR
17:59:45 <dfarrell07> s/charger/charter
18:00:03 <vina_ermagan> colindixon: do you want to #info that statement
18:02:21 <dfarrell07> Send this for clarity colindixon? #info If a project would like to remove a PTL, the committers can call for a vote and remove the PTL. People could also come to the TSC with PTL issues.
18:02:40 <dfarrell07> kk, that's fine
18:02:58 <regXboi> #agreed as of this point, it is the TSC’s view that there is no official statement as to the term lengths for PTLs and individual projects can come to their own conclusions as to when to hold elections as long the elections happen according the TSC charter and there is an active PTL at all times while a project is participating in an SR
18:05:33 <colindixon> #topic for next week
18:05:40 <ebrjohn> Off to have cookies with Chris Price
18:05:59 <colindixon> #info please look at the Be release and railse issues on the maling list
18:06:06 <colindixon> #info regXboi says he’s going to raise an issue about sonar reporting
18:06:10 <colindixon> #topic cookies
18:06:16 <colindixon> #endmeeting