#opendaylight-meeting: tsc

Meeting started by colindixon at 17:00:21 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:00:25)
    1. colindixon (colindixon, 17:00:38)
    2. edwarnicke (edwarnicke, 17:01:03)
    3. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=33950#Agenda the agenda in it’s usual place (colindixon, 17:01:12)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-07-16-17.00.html meeting minutes from last time (colindixon, 17:01:23)
    5. dfarrell07 for cdub/Red Hat (dfarrell07, 17:01:34)
    6. abhijitkumbhare for ChrisPriceAB / Ericsson (abhijitkumbhare, 17:02:26)
    7. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1) (colindixon, 17:03:04)
    8. LuisGomez (LuisGomez, 17:03:12)
    9. ACTION: ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and (colindixon, 17:03:13)
    10. mohnish anumala (mohnish, 17:04:01)
    11. ACTION: gzhao to send out exact cutoff dates/times for Lithium SRs and get him to if he hasn’t (colindixon, 17:04:49)
    12. ACTION: phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours (colindixon, 17:05:01)
    13. ACTION: phrobb to keep working on JIRA and let us know when we can use it (colindixon, 17:05:25)
    14. ACTION: tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information (colindixon, 17:05:41)
    15. ACTION: tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting (colindixon, 17:06:16)

  2. events (colindixon, 17:07:13)
    1. Youcef Laribi (Youcef, 17:07:22)
    2. http://www.opendaylight.org/news/events/ the usual events page (colindixon, 17:07:25)
    3. the ODL summit is next week, phil is putting the topics into the developer deisgn forum (colindixon, 17:07:46)
    4. https://wiki.opendaylight.org/view/Events:Be_Dev_Forum if you wanted to add a topic to the deisgn forum, get it here in the next few hours (colindixon, 17:08:06)
    5. https://www.regonline.com/register/checkin.aspx?EventId=1627424&MethodId=0&EventSessionId=&startnewreg=1 if you still haven’t registered for the design forum and would like to come, sign up *now* (colindixon, 17:08:34)
    6. there was an IETF hackfest a few days back on SFC/GBP, Jan, Tony, ChrisP and others say it went well (colindixon, 17:09:43)

  3. Be, stable/He, and stable/Li updates (colindixon, 17:10:03)
    1. https://lists.opendaylight.org/pipermail/release/2015-July/003272.html there was a regression in l2switch’s behavior the Helium-SR4 release candidate (colindixon, 17:11:00)
    2. LuisGomez says that this issue is easy for us to reproduce in the release, hard to reproduce in the stable/helium branch, and hard to reproduce locally (colindixon, 17:11:58)
    3. ACTION: LuisGomez is looking into whether this is a regression from SR2/SR3 or not, if it’s not and we can find a workout, we might just ship it, otherwise we need a workaround (colindixon, 17:14:18)
    4. ACTION: ttkacik will stay in touch with LuisGomez and try to look into things, it appears that this is new to SR4, but is alos not present in the snapshots (colindixon, 17:15:39)
    5. https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#M1:_Joining_the_Release template for M1 status reports, offset 0 ones are due today (colindixon, 17:17:07)
    6. technically, all new project proposals are supposed to be in by today, but I believe the TSC will make exceptions for interesting projects that come out of the summit if they want to join beryllium (colindixon, 17:17:46)
    7. https://lists.opendaylight.org/pipermail/release/2015-July/003198.html the cutoff time and dates for Lithium-SR1 (colindixon, 17:19:48)

  4. infrastructure (colindixon, 17:19:52)
    1. tykeal is back and nothing is broken, zxiiro did an awesome job (colindixon, 17:20:12)
    2. tykeal will be starting upgrades of the environment after the summit (colindixon, 17:20:23)
    3. phrobb says we’re in the final steps of getting a trial JIRA up and running (colindixon, 17:20:42)
    4. regXboi asks (on irc) what *kinds* of upgrades? (regXboi, 17:21:04)
    5. tykeal says all kinds of upgrades, gerrit, jenkins, nexus, underlying slaves—basically everything but sonar (colindixon, 17:21:24)
    6. https://lists.opendaylight.org/pipermail/tsc/2015-July/003512.html please submit your GPG keys for the keysigning (colindixon, 17:22:23)

  5. events (again) (colindixon, 17:23:03)
    1. there is an OPNFV hackfest on Thursday and Friday, there will be some time for overlap on Thursday morning (colindixon, 17:23:24)
    2. the ETSi NFV folks are also in town, but at a different location, they will be coming to the OPNFV things on Thursday morning, for which we are also invited (colindixon, 17:23:52)
    3. these topics will be looking at the SDN parts of the OPNFV and ETSI activities (colindixon, 17:24:49)

  6. Future TSC meetings (colindixon, 17:24:55)
    1. No meeting next week (7/30/2015) because of the summit (colindixon, 17:25:07)
    2. AGREED: there will be a 2 hour TSC call on August 6th (colindixon, 17:27:57)
    3. ACTION: colindixon to send mail about extending the 2 hour TSC calls past 8/6 with broader TSC members being aware (colindixon, 17:28:24)

  7. Fabric as a Service creation review (colindixon, 17:29:02)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-July/003528.html the tail of the discussion on the malling list (colindixon, 17:29:20)
    2. ACTION: colindixon will start a vote when the scoping questions have at least been answered (colindixon, 17:32:11)

  8. OF circuit switching creation review (colindixon, 17:32:34)
    1. https://wiki.opendaylight.org/view/Project_Proposals:Openflowplugin-extension-circuitsw the proposal (colindixon, 17:32:45)
    2. https://lists.opendaylight.org/pipermail/project-proposals/2015-April/000305.html proposed on 4/3/2015 (colindixon, 17:33:36)
    3. https://www.opennetworking.org/images/stories/downloads/sdn-resources/onf-specifications/openflow/Optical_Transport_Protocol_Extensions_V1.0.pdf ONF’s Optical Transport Protocol Extensions spec (colindixon, 17:35:25)
    4. https://wiki.opendaylight.org/images/1/1d/OCS_OF_Protocol_Extensions_Rev._0.4.pdf Circuit Switching OF extensions from Calient (colindixon, 17:37:01)
    5. colindixon asks if the circuit switching spec is something that people are working with the ONF (colindixon, 17:39:00)
    6. Aneesha says the answer is they are not working with the ONF at the moment (colindixon, 17:39:48)
    7. colindixon points out that the topology supports multi-level modeling, so that should enable publishing optical circuit topologies into the topology model as Aneesha says they’d like to (colindixon, 17:40:39)
    8. colindixon also points out that the inventory model might be deprecated in Beryllium as it gets folded into the topology model (colindixon, 17:41:01)
    9. mohnish asks if modifications to openflow{plugin,java} are needed or if this will be separate (colindixon, 17:41:19)
    10. the answer seems to be yes, modifications and/or extensions will be needed, and edwarnicke says he’ll help with his openflowplugin committer hat on (colindixon, 17:41:57)
    11. ACTION: Aneesha to add an e-mail address or committed resources and initial committers (colindixon, 17:42:45)
    12. abhijitkumbhare says that experimental matches and experimental actions are there, but experimental multipart messages aren’t there yet and Aneesha would like to help build that (colindixon, 17:44:07)
    13. edwarnicke says that he’d like to see the multi-part message (or the fact that it needs to be there) likely shouldn’t be exposed out the top of the protocol protocol (colindixon, 17:45:11)
    14. colindixon asks if it makes sense to have more committers (colindixon, 17:46:33)
    15. Aneesha says for now she’s all there is (colindixon, 17:46:39)
    16. colindixon asks does it make sense for this to be it’s own project, or just a new effort inside openflow{java,plugin} (colindixon, 17:47:18)
    17. Aneesha says she would like her own project for this effort (colindixon, 17:49:18)
    18. colindixon says the project says circuit switches, but doesn’t metnion optical (tbachman, 17:49:41)
    19. Aneesha says they meant to mention optical in the scope (tbachman, 17:50:13)
    20. ACTION: Aneesha to put optical in the scope if that was the intent (colindixon, 17:50:27)
    21. edwarnicke says there’s a standing set of guidelines for repo names — want ones suitable for use as a java identifier (tbachman, 17:51:50)
    22. colindixon asks if we should have a long reponame like openflowplugin-extension-circuitsw instead of something simple like ofocs (colindixon, 17:51:59)
    23. edwarnicke and tykeal notes that dashes in the repo name will cause issues with things like maven groupIds (colindixon, 17:52:54)
    24. LuisGomez asks if Aneesha considered collaboration for a cycle with OpenFlow plugin first, and then possibly migrate to a new project (tbachman, 17:53:02)
    25. abhijitkumbhare asks TSC if all the experimenter extensions be in a single place or scattered in projects. (tbachman, 17:54:17)
    26. LuisGomez points out that running an ODL project is a lot of work and she will likely want help. Aneesha agrees. (colindixon, 17:54:17)
    27. edwarnicke feels it’s critically important to be able to have extensions outside of the openflowplugin (tbachman, 17:54:39)
    28. mohnish asks if that would encourage reuse of extensions if they aren’t centralized (tbachman, 17:54:57)
    29. edwarnicke says there’s a distinction of “can” and “should” — we “should” allow it, lacking a good extension repo (tbachman, 17:55:21)
    30. colindixon notes that it’s also possible to fold code from the project ot the openflowplugin if that’s more desireable in the future (tbachman, 17:56:21)
    31. it sounds like there’s loose agreement that maybe we should make the name ofextensions/circuitsw (colindixon, 17:57:38)
    32. tykeal notes that groupId would end up being org.opendaylight.ofextensions.circuitsw in that case (colindixon, 17:58:34)
    33. colindixon asks if there’s a preference for the naming? His is ofextensions (tbachman, 18:00:36)
    34. ACTION: Aneesha to rename the repository name to ofextensions/circuitsw (colindixon, 18:00:43)
    35. VOTE: Voted on "Shall the TSC approve the project under review with the required changes 1) add email address 2) change repo name 3) address scope project thto Incubation?" Results are, +1: 7 (colindixon, 18:02:31)
    36. AGREED: the openflow optical circuit switch OF extensions project is moved to incubation (colindixon, 18:02:59)

  9. cookies (colindixon, 18:03:10)


Meeting ended at 18:03:32 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1)
  2. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
  3. gzhao to send out exact cutoff dates/times for Lithium SRs and get him to if he hasn’t
  4. phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours
  5. phrobb to keep working on JIRA and let us know when we can use it
  6. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
  7. tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
  8. LuisGomez is looking into whether this is a regression from SR2/SR3 or not, if it’s not and we can find a workout, we might just ship it, otherwise we need a workaround
  9. ttkacik will stay in touch with LuisGomez and try to look into things, it appears that this is new to SR4, but is alos not present in the snapshots
  10. colindixon to send mail about extending the 2 hour TSC calls past 8/6 with broader TSC members being aware
  11. colindixon will start a vote when the scoping questions have at least been answered
  12. Aneesha to add an e-mail address or committed resources and initial committers
  13. Aneesha to put optical in the scope if that was the intent
  14. Aneesha to rename the repository name to ofextensions/circuitsw


Action items, by person

  1. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR1)
    2. colindixon to send mail about extending the 2 hour TSC calls past 8/6 with broader TSC members being aware
    3. colindixon will start a vote when the scoping questions have at least been answered
  2. gzhao
    1. gzhao to send out exact cutoff dates/times for Lithium SRs and get him to if he hasn’t
  3. LuisGomez
    1. LuisGomez is looking into whether this is a regression from SR2/SR3 or not, if it’s not and we can find a workout, we might just ship it, otherwise we need a workaround
    2. ttkacik will stay in touch with LuisGomez and try to look into things, it appears that this is new to SR4, but is alos not present in the snapshots
  4. phrobb
    1. phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours
    2. phrobb to keep working on JIRA and let us know when we can use it
  5. UNASSIGNED
    1. ChrisPriceAB to work with rovarga, jmedved, et. al. to look into leveraging OPNFV infrastructure for performance measurements and
    2. tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
    3. tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
    4. Aneesha to add an e-mail address or committed resources and initial committers
    5. Aneesha to put optical in the scope if that was the intent
    6. Aneesha to rename the repository name to ofextensions/circuitsw


People present (lines said)

  1. colindixon (98)
  2. tbachman (20)
  3. dfarrell07 (17)
  4. tykeal (12)
  5. odl_meetbot (10)
  6. abhijitkumbhare (10)
  7. ebrjohn (9)
  8. regXboi (8)
  9. dneary (6)
  10. edwarnicke (5)
  11. mohnish (4)
  12. gzhao (2)
  13. LuisGomez (2)
  14. Youcef (2)
  15. icbts (1)
  16. phrobb (0)


Generated by MeetBot 0.1.4.