17:01:12 <phrobb> #startmeeting tsc
17:01:12 <odl_meetbot> Meeting started Thu Aug 13 17:01:12 2015 UTC.  The chair is phrobb. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:12 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:12 <odl_meetbot> The meeting name has been set to 'tsc'
17:01:17 <colindixon> thanks phrobb
17:01:42 <LuisGomez> #info LuisGomez
17:01:47 <phrobb> #chair colindixon gzhao tbachman
17:01:47 <odl_meetbot> Current chairs: colindixon gzhao phrobb tbachman
17:02:01 <phrobb> #chair dfarrell07
17:02:01 <odl_meetbot> Current chairs: colindixon dfarrell07 gzhao phrobb tbachman
17:02:13 <colindixon> #topic roll call and agenda bashing
17:02:16 <colindixon> #info colindixon
17:02:29 <mohnish> #info mohnish anumala
17:02:30 <phrobb> #info TSC members please #info in
17:02:42 <dfarrell07> #info dfarrell07
17:02:44 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=35078#Agenda the agenda for today
17:02:55 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-08-06-17.00.html last weeks meeting minutes for action items
17:03:21 <colindixon> let me try rejoining webex and if that doesn’t work I’ll need to reboot :-(
17:03:32 <colindixon> if somebody else could walk through and restate the agenda items that would help a lot
17:04:29 <tykeal> :-/ I can't join the webex. I just get told that the meeting hasn't started and I can't join via the mobile app either *sigh*
17:04:45 <ChrisPriceAB> #info Chris Price
17:04:59 <dfarrell07> I'm getting webex errors, "194 548 370 is not valid", which is the normal number
17:05:01 <edwarnicke> #info edwarnicke
17:05:07 <alagalah> dfarrell07: I got a redirect
17:05:13 <alagalah> dfarrell07: Chrome on OSX
17:05:16 <alagalah> And it worked
17:05:27 <colindixon> #action gzhao to send out exact cutoff dates/times for Lithium SRs past SR-1
17:05:36 <dfarrell07> alagalah: I'm calling in, so no redirects
17:05:38 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2)
17:05:40 <tykeal> do we have a new number then?
17:05:53 <dfarrell07> alagalah: is there a new number associated with that meeting?
17:06:02 <colindixon> #action phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours
17:06:14 <colindixon> #action phrobb to keep working on JIRA and let us know when we can use it
17:06:26 <colindixon> #action tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
17:06:28 <gzhao> #link https://lists.opendaylight.org/pipermail/release/2015-August/003411.html <-- SR1 date proposal for TSC
17:06:34 <colindixon> #action tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
17:07:10 <dneary> Hi all
17:07:33 <colindixon> #info edwarnicke sasy that current sonar/jacoco coverage is not reporting stuff for IT as well as UT
17:07:33 <gzhao> dneary: Hello
17:07:40 <colindixon> dneary: hello!
17:07:51 <colindixon> #action edwarnicke and phrobb- to send out a mails for candidate dates for hackfest
17:08:07 <dneary> 194548370# to join?
17:08:15 <dfarrell07> tykeal: the issue for me was that the phone number changed, not the meeting number
17:08:23 <dfarrell07> tykeal: dneary I used +1-855-797-9485 for the US
17:08:32 <dfarrell07> dneary: and that meeting number
17:08:45 <dneary> OK - phone number I have is different
17:08:46 <dfarrell07> https://meetings.webex.com/collabs/#/meetings/detail?uuid=MA3SRND964PIX06V2LS3SXX3RE-9VIB&rnd=674952.90619
17:08:48 <tykeal> hrmm... were did you get that phone number?
17:08:52 <dneary> Happens every time
17:09:00 <colindixon> #action phrobb- will send out escalation instructions again
17:09:04 <dfarrell07> tykeal: that link
17:09:06 <jamoluhrsen> trouble with webex here as well.
17:09:38 <dfarrell07> I think the webex issue is that the number (and maybe link) changed, but the number is the same
17:09:39 <jmedved> #info jmedved
17:09:48 <tykeal> yet again, I hate on webex
17:09:53 <dfarrell07> colindixon: +1 to 2 hours
17:10:02 <ChrisPriceAB> sounds wonderful...  -.-
17:10:04 <jamoluhrsen> tykeal +1
17:10:06 <dfarrell07> ChrisPriceAB: ;)
17:10:07 <tykeal> finally in, thanks dfarrell07
17:10:08 <mohnish> +1
17:10:28 <colindixon> jmedved, dfarrell07, LuisGomez, edwarnicke, colindixon, ChrisPriceAB: are we good with 2 hour meeting
17:10:36 <ChrisPriceAB> +1
17:10:40 <edwarnicke> #vote +1
17:10:44 <jmedved> #vote 1
17:10:45 * dfarrell07 goes to update TSC meeting info on GCal and wiki/Meetings /cc phrobb
17:10:46 <LuisGomez> #vite +1
17:10:52 <LuisGomez> #vote +1
17:10:56 <colindixon> #agreed this meeting will be two hours
17:11:07 <colindixon> #topic mailing list votes
17:11:21 <odl-casey> ... The recording hasn't been started.  FYI.
17:11:29 <colindixon> #info first vote is on the way that a project can change it’s scope
17:11:39 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-July/003500.html starting the thread in July
17:11:52 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-August/003564.html continueing in August
17:12:08 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-August/003590.html 2 hour TSC meetings until we need them
17:12:36 <colindixon> #undo
17:12:36 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1b98ed0>
17:12:40 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-August/003590.html 2 hour TSC meetings until we no longer need them
17:12:43 <tykeal> give edwarnicke a gold star ;)
17:12:51 * ChrisPriceAB ponders how to spell pedantic...
17:12:52 <colindixon> edwarnicke: +1 gold star
17:12:55 <ChrisPriceAB> ;)
17:12:55 * edwarnicke would rather have a blue star for mathematics :)
17:13:11 <colindixon> #topic events
17:13:26 <colindixon> #link https://www.opendaylight.org/global-events
17:13:35 <colindixon> #Info we openstack in october
17:14:02 <colindixon> #info there will be a CFP for the mini-summit with SDN/OF world conference in dusseldorf will be out today
17:14:15 <colindixon> #topic stable/lithium
17:14:37 <colindixon> #info the cutoff date for patches is 11:59p UTC on Sunday
17:14:58 <colindixon> #info we’ll hopefully vote on artifacts next week assuming we don’t have problems (this is all for Lithium-SR1)
17:15:09 <colindixon> #info this is one week behind the original plan
17:15:19 <zxiiro> #link https://git.opendaylight.org/gerrit/25167/
17:15:23 <colindixon> #undo
17:15:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x194a950>
17:15:46 <colindixon> #link https://git.opendaylight.org/gerrit/25167/ this is a controller patch zxiiro needs before Lithium-SR1 so auto-release will run
17:16:06 <colindixon> #topic beryllium
17:16:09 <gzhao> #link https://docs.google.com/spreadsheets/d/1o9L1q5OYl9T6ZwBEkAuPSoostFMIsjp4mh2FDawuk20/edit?pli=1#gid=0 <-- Beryllium status spreadsheet.
17:16:19 <colindixon> gzhao: thanks
17:16:27 <edwarnicke> zxiiro: How did we happen to get in a position for a version downgrade?
17:16:35 <colindixon> #info we have 44 participating so far and 11 awaing approval
17:16:53 <edwarnicke> colindixon: I see weather on the agenda as well... I could do a brief weather report if you'd like
17:16:58 <zxiiro> edwarnicke: the patch was cherry-picked from master so it had a "higher" version than it should have
17:17:06 <edwarnicke> Easy-peasy
17:17:24 <edwarnicke> zxiiro: Merged
17:17:40 <zxiiro> edwarnicke: thanks i'll kick off autorelease build now. hopefully it works :)
17:17:50 <gzhao> https://lists.opendaylight.org/pipermail/release/2015-August/003402.html
17:18:09 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-August/003402.html some projects that we might have expected to join Beryllium, have not yet done so
17:18:42 * tykeal notes that maple _still_ hasn't passed all points needed for getting resources
17:19:01 <colindixon> #info tykeal notes that maple _still_ hasn't passed all points needed for getting resources
17:19:26 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the current weather
17:19:43 <colindixon> #Info colindixon notes that the netconf feature is likely to move soon, and projects should be getting ready
17:20:44 <colindixon> #topic community manager
17:21:14 <colindixon> #info we have some development on finding a community manager
17:21:42 <colindixon> #Info over the next few weeks we’ll be transitioning where gzhao will be moving into a community manager role, while a new huawei person takes over for him as a release manager
17:21:45 <dneary> Yay
17:21:50 <colindixon> congrats gzhao!!!!
17:22:25 <gzhao> colindixon: thanks
17:22:56 <ChrisPriceAB> hurrah: gzhao!
17:23:05 <edwarnicke> #congratulations gzhao !
17:23:08 <vina_ermagan> Congrats gzhao!
17:23:13 <abhijitkumbhare> Congrats gzhao
17:23:25 * odl-casey cheers gzhao
17:23:28 <gzhao> thanks everyone.
17:23:33 <ChrisPriceAB> #cookies gzhao!
17:23:43 <colindixon> #topic system integration test
17:23:50 <colindixon> #Info LuisGomez says nothing this week
17:23:59 <dfarrell07> congrats gzhao :D
17:24:01 <colindixon> #topic infrastructure
17:24:18 <zxiiro> #link https://nexus.opendaylight.org/content/sites/site/org.opendaylight.releng.builder/master/
17:24:23 <colindixon> #undo
17:24:23 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1c3f690>
17:24:27 <edwarnicke> +100000 on maven sites :)
17:24:28 <uri_> congrats gzhao
17:24:41 <gzhao> ChrisPriceAB: edwarnicke abhijitkumbhare dfarrell07 uri_ thank you
17:24:49 <colindixon> #link https://nexus.opendaylight.org/content/sites/site/org.opendaylight.releng.builder/master/ zxiiro has been workign on getting maven sites work and they will provide demos for projects on how to do this soon
17:24:49 <edwarnicke> zxiiro: I'd also like to get this into the startup archetype :)
17:25:10 <jmedved> edwanricke: +1 on that
17:25:33 <dfarrell07> zxiiro: that would be *awesome* :D
17:25:34 <colindixon> #info zxiiro says they plan to make shorter links
17:26:19 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-August/003559.html mailing list thread on forge authors
17:26:47 <colindixon> #info zxiiro says this allows for permission to push a patch on another person’s behalf (that is while leaving them as the formal Author in git)
17:27:02 <colindixon> #info we current allow this for committers on a given project
17:27:34 <colindixon> #info edwarnicke says he uses this on projects where he’s a committer to do simple rebases and other simple fixes
17:28:10 <ChrisPriceAB> All good on this, as long as it is not abused but those who know how to abuse it generally wont...
17:28:45 <colindixon> #link https://wiki.opendaylight.org/view/Documentation/Tools#Updating_an_Existing_Patch there is a hack-around to this listed here, but it’s a bit ugly as you “steal” credit
17:28:57 <dfarrell07> colindixon: I've read it and have no questions
17:29:18 <colindixon> #Info mohnish asks if there’s a way to tell if something was forged
17:29:32 <colindixon> #Info tykeal says yes, but only in the gerrit UI, but not in git itself
17:29:53 <colindixon> #info tykeal says the only way to be able to tell from git alone would be to have people GPG sign their commits, but he doesn’t know how it works
17:30:40 <colindixon> #info edwarnicke would like to allow projects to opt out of this
17:31:29 <colindixon> #startvote shall we enable forge-authors for everyone as the default with the option for projects to opt-out if the want? -1, 0, +1
17:31:29 <odl_meetbot> Begin voting on: shall we enable forge-authors for everyone as the default with the option for projects to opt-out if the want? Valid vote options are -1, 0, +1.
17:31:29 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:31:33 <colindixon> #vote +1
17:31:35 <ChrisPriceAB> #vote +1
17:31:37 <dfarrell07> #vote +1
17:31:40 <edwarnicke> #vote +1
17:31:43 <mohnish> #vote +1
17:31:44 <jmedved> #vote +1
17:31:45 <Ambika> +1
17:31:47 <LuisGomez> #vote +1
17:31:57 <colindixon> #endvote
17:31:57 <odl_meetbot> Voted on "shall we enable forge-authors for everyone as the default with the option for projects to opt-out if the want?" Results are
17:31:57 <odl_meetbot> +1 (7): dfarrell07, jmedved, LuisGomez, edwarnicke, ChrisPriceAB, mohnish, colindixon
17:32:09 <colindixon> #agree we will allow forge-authors by default
17:32:12 <tykeal> adding it now
17:32:21 <colindixon> #topic commmitter promotions
17:32:33 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-August/003623.html ryan gourdling on AAA
17:32:42 <zxiiro> edwarnicke: re: archetypes. I  may be able to even get it into odlparent only as a config so even easier :)
17:32:54 <edwarnicke> zxiiro: We should talk about that
17:33:08 <dfarrell07> colindixon: go for it imho
17:33:11 <colindixon> #startvote shall we make Ryan Goulding a committer on AAA? -1, 0, +1
17:33:11 <odl_meetbot> Begin voting on: shall we make Ryan Goulding a committer on AAA? Valid vote options are -1, 0, +1.
17:33:11 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:33:13 <colindixon> #vote +1
17:33:13 <edwarnicke> zxiiro: Or not now that I think about it
17:33:16 <ChrisPriceAB> #vote +1
17:33:16 <dfarrell07> #vote +1
17:33:17 <mohnish> #vote +1
17:33:18 <jmedved> #vote 1
17:33:18 <odl_meetbot> jmedved: 1 is not a valid option. Valid options are -1, 0, +1.
17:33:25 <Ambika> #vote +1
17:33:27 <jmedved> #vote +1
17:33:29 <edwarnicke> zxiiro: You are suggesting we just put the right stuff in odlparent pom.xml... the root parent, which would be awesome :)
17:33:39 <edwarnicke> #vote +1
17:33:44 <colindixon> Ambika: votes are typically only for TSC members
17:33:48 <LuisGomez> #vote +1
17:33:57 <colindixon> #endvote
17:33:57 <odl_meetbot> Voted on "shall we make Ryan Goulding a committer on AAA?" Results are
17:33:57 <odl_meetbot> +1 (8): dfarrell07, jmedved, LuisGomez, ChrisPriceAB, Ambika, mohnish, edwarnicke, colindixon
17:34:02 <edwarnicke> zxiiro: I had thought you meant adding a new archetype to odlparent, thus my confusion :)
17:34:23 <colindixon> #agree with 7 votes (note Ambika is not a TSC member) Ryan Gouding is a committer on AAA
17:34:43 <zxiiro> edwarnicke: yes, but the archetype might be useful too to generate the "src/site" directory in a project. We can discuss once I have some instructions and more testing done
17:34:45 <colindixon> #topic YANG PUB SUB vote
17:35:10 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-August/003632.html communtcation between YANG PUB SUB and NETCONF
17:35:30 <ChrisPriceAB> nothing to add/ask
17:35:51 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:YANG_PUBSUB the origitnal proposal for which the only real critique was that they talk to NETCONF to see if a new projet was the right approach
17:36:01 <colindixon> #info the communication says that a new project does make sense
17:36:08 * dfarrell07 just read the email colindixon linked, looks good to me
17:36:39 <colindixon> #action Ambika will add the two missing ODL user IDs for committers
17:37:07 <colindixon> #action Ambika to fix the link to the preseentation at the bottom
17:38:32 <colindixon> #startvote shall we move the YANG PUBSUB project to incubation? -1, 0, +1
17:38:32 <odl_meetbot> Begin voting on: shall we move the YANG PUBSUB project to incubation? Valid vote options are -1, 0, +1.
17:38:32 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:38:41 <dfarrell07> #vote +1
17:38:43 <jmedved> #vote +1
17:38:44 <colindixon> #vote +1
17:38:44 <ChrisPriceAB> #vote +1
17:38:47 <LuisGomez> #vote +1
17:38:49 <mohnish> #vote +1
17:39:04 <dfarrell07> edwarnicke:
17:39:11 <edwarnicke> #vote +1
17:39:12 <colindixon> #endvote
17:39:12 <odl_meetbot> Voted on "shall we move the YANG PUBSUB project to incubation?" Results are
17:39:12 <odl_meetbot> +1 (7): jmedved, LuisGomez, dfarrell07, ChrisPriceAB, mohnish, edwarnicke, colindixon
17:39:28 <colindixon> #agree congratulations to the YANG PUBSUB project on moving to incubation
17:39:38 <Ambika> Thanks a lot
17:39:47 <dfarrell07> Ambika: Congrats :)
17:39:56 <mohnish> Ambika: Congrats
17:40:01 <colindixon> #topic UNIMgr creation review
17:40:41 <colindixon> #link https://wiki.opendaylight.org/images/c/c8/UNI_Manager_Project_Proposal_to_OpenDaylight.pptx the presention
17:41:13 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:UNIMgr project proposal
17:41:26 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-July/000361.html proposed on 7/24/2015
17:41:57 <colindixon> #info this project is seeking to provide new features along standards in the metro ethernet forum
17:43:28 <colindixon> #info problem statement is around the fact that it’s hard to deploy carrier ethernet services, OpenDaylight could help make this eaiser and compensate for devices that dont’ support everything
17:44:00 <colindixon> #info  Project goal: Investigate and identify means to facilitate fulfillment of Ethernet/connectivity services using virtualization technologies (SDN and NFV) and open source SDN controller.
17:44:46 <colindixon> #info Current objectives:  (1) Develop information models and open standard APIs  (2) Compliant with MEF-defined Carrier Ethernet Service (3) Enable applications to leverage OpenDaylight capabilities to configure network components and connections
17:46:27 <colindixon> #action KevinLuehrs to add ODL user IDs for committers listed without them
17:46:52 <colindixon> #info slide 5 shows the high-level, layered architectured
17:47:10 <colindixon> #info KevinLuehrs says that they already have a prototype
17:47:27 <vina_ermagan> Can we ask for a sample use case? perhaps what does the prototype do now?
17:47:29 <colindixon> #info slide 6 shows the information model that they’re use
17:47:34 <colindixon> vina_ermagan: good question
17:47:42 <colindixon> vina_ermagan: you could ask if you wanted or I’ll bring it up a bit
17:47:52 <colindixon> vina_ermagan: or maybe this will do it
17:48:13 <vina_ermagan> Just wondering what the protocol ( TSC only questions or not). I'll ask then thanks
17:48:33 <colindixon> #info slide 7 shows the PoC they have: creating a tunnel of virtual ehternet
17:48:45 <colindixon> vina_ermagan: we let anyone talk
17:49:01 <colindixon> vina_ermagan: we always have and have yet to be bitten by it, thanks to dmm for making that decision
17:49:42 <colindixon> #info colindixon asks if the info model is in YANG? the answer is it’s in UML now and they have a very simple subset of that in YANG
17:49:46 <vina_ermagan> conlindixon: thanks :)
17:50:11 <colindixon> #Info part 2 of the answer is that MEF (metro ethernet model) has a much more full-featured version of the YANG model
17:50:40 <colindixon> #Info colindixon asks if there’s a tool to translate from UML to YANG? KevinLuehrs says yes, but they’re likely to use the MEF version
17:52:05 <colindixon> #Info jmedved asks how specifc to the ovsdb plugin is it? KevinLuehrs says that the current demo/PoC is dependent on that, but the intent is to be plugin agnostic
17:53:02 <colindixon> #info jmedved says that what would be really cool is if we had a YANG model of what feautres you actually need and then you can provide plugins for that model so that it’s as device agnostic as possible
17:53:07 <colindixon> #info KevinLuehrs says he agrees
17:53:27 <edwarnicke> edwarnicke: raises hand :)
17:55:11 <colindixon> #info edwarnicke says that using the ideas from GBP and SFC around renderers and maybe the current work on overlay layers, might be very useful for this project
17:56:23 <edwarnicke> #link https://lists.opendaylight.org/pipermail/discuss/2015-August/005478.html discussion around overlay manager layer (as well as Honeycomb and App Coexistence)
17:56:24 <colindixon> #Info Mufaddal Makati says they already have a lot of what jmedved suggests in terms of being device agnostic 
17:57:19 <colindixon> #Info KevinLuehrs says the initial use case is ethernet private ethernet line service
17:57:46 <colindixon> #info this requires creation of UNIs, creating of connections between pairs
17:58:10 <colindixon> #info this is the building blocks of going from point-to-point, to point-to-multipoint, to multipoint-to-multipoint
17:58:37 <colindixon> #info they walk through the demo showing classes of service, e.g., gold, silver, and bronze
17:58:45 <colindixon> #info jmedved asks if this GUI will come to DLUX
17:59:05 <colindixon> #info KevinLuehrs says right now the GUI is just for testing and it’s in OPNFV
17:59:33 <colindixon> #info KevinLuehrs says that it’s not their intent to build a GUI, but they wouldn’t oppose it if somebody really wanted it (or better yet to buid it)
18:00:03 <colindixon> #info KevinLuehrs says their focus in reality is just for the APIs and the minimum amout of stuff around that to do the demos
18:04:36 <colindixon> #action KevinLuehrs to provide links to the relevant OPNFV and MEF specs/models
18:05:19 <mohnish> Kevin: Also please add link to PPT slide deck to the proposal page
18:05:39 <gzhao> +1 you want your sys admin to be your friend
18:05:45 <colindixon> #action KevinLuehrs to link to the powerpoint slides from the proposal page
18:06:03 <colindixon> #startvote shall we move the UNI Manger Plugin project to incubation? -1, 0, +1
18:06:03 <odl_meetbot> Begin voting on: shall we move the UNI Manger Plugin project to incubation? Valid vote options are -1, 0, +1.
18:06:03 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:06:07 <ChrisPriceAB> #vote +1
18:06:08 <jmedved> #vote +1
18:06:08 <dfarrell07> #vote +1
18:06:09 <mohnish> #vote +1
18:06:09 <edwarnicke> #vote +1
18:06:11 <colindixon> #vote +1
18:06:22 <colindixon> #endvote
18:06:22 <odl_meetbot> Voted on "shall we move the UNI Manger Plugin project to incubation?" Results are
18:06:22 <odl_meetbot> +1 (6): dfarrell07, jmedved, edwarnicke, ChrisPriceAB, mohnish, colindixon
18:06:35 <colindixon> #agree the UNI Manager plugin project is moved to incubation
18:06:40 <dfarrell07> Congrats UNI Manager :)
18:07:11 <colindixon> #topic OFCONFIG creation review
18:07:18 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:OF-CONFIG the project proposal
18:07:21 <abhijitkumbhare> # vote +1 for OFCONFIG :)
18:07:34 <colindixon> #link https://wiki.opendaylight.org/view/File:Presentation-config-proposal-review.pdf the presentation
18:07:47 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-July/000333.html proposed on 7/3/2015
18:09:34 <colindixon> #info for those who don’t know, OFCONFIG is the ONF spec to enable the remote configuration of OpenFLow datapaths
18:10:22 <colindixon> #info OFCONFIG configures OpenFlow Capable Swichtes and OpenFlow Configuration Points, while the OpenFlow protocol controls OpenFlow Logical switches
18:10:30 <colindixon> #info OFCONFIG is based ON NETCONF
18:12:37 <colindixon> #Info the proposal is to add thre logical blocks to OpenDaylight: (1) any apps that want to use OFCONFIG, (2) and OFCONFIG API, and (3) and OFCONFIG plugin
18:13:36 <ChrisPriceAB> I did have the same question...
18:13:52 <colindixon> #info jmedved asks why do you need a separate plugin from NETCONF?
18:14:21 <colindixon> #info ChrisPriceAB, jmedved, and abhijitkumbhare say that they’re understanding is just implementing the OF-CONFIG model and they don’t need a new plugin
18:14:59 <mohnish> Please look into architecture diagram here: https://github.com/openvswitch/of-config
18:15:45 <colindixon> #link https://github.com/openvswitch/of-config#architectural-overview mohnish points out that in fact, the offical diagram shows it using NETCONF
18:16:05 <colindixon> #info jmedved would like to see a common model across OFCONFIG and OVSDB
18:17:29 <colindixon> #info everyone says that this is a really cool stuff, but that it likely makes sense to just use the existing NETCONF plugin
18:17:32 <abhijitkumbhare> yes - +1 for jmedved’s comment - that this is a useful activity/project - but only questions are how exactly it is implemented
18:18:37 <ChrisPriceAB> +1 to have a common model and transport for this and OVSDB OFCONFIG (if the project wants to, just seems like a good idea)
18:20:41 <colindixon> #info colindixon would like to note that he thinks having OF-CONFIG would be useful regardless and we should not gate things on having a unfied interface between OVSDB and OF-CONFIG
18:21:33 <abhijitkumbhare> +1 colindixon & ChrisPriceAB
18:22:27 * ChrisPriceAB still would strongly (strooongly) advise the team to look at what is available to be harvested in the netconf southbound to make this much much easier to achieve.
18:22:37 <colindixon> #info ChrisPriceAB, colindixon, abhijitkumbhare, and mohnish say they think we we should let them have the project and give them technical advice as it get started rather than blocking the project until they work them
18:22:39 <colindixon> #undo
18:22:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ab0690>
18:22:42 <colindixon> #info ChrisPriceAB, colindixon, abhijitkumbhare, and mohnish say they think we we should let them have the project and give them technical advice as it get started rather than blocking the project until they work them out
18:23:15 <colindixon> #info ChrisPriceAB points out that if they decide they really need their own NETCONF plugin, that’s likely fine, but he thinks it’s a bad idea that will cost them a lot of time
18:24:33 <colindixon> #info jmedved says that he would love to help work on the architecture so that it can leverage the existing NETCONF plugin if anyone wants
18:25:21 <colindixon> #info gzhao suggests that they contact the NETCONF committers and possibly add them as contributor or committer
18:25:45 <colindixon> #action OF-CONFIG project will add ODL user IDs for the committers  to the project proposal
18:26:12 <colindixon> #action OF-CONFIG project will reach to the NETCONF project to see how they can best interact
18:28:09 <colindixon> #info jmedved says he’s strongly encorage us to do a bit more architectural work before we approve a proposal
18:28:58 <dfarrell07> colindixon: we do have a history of recommending that projects go to the mailing list for discussions like this
18:29:08 <tykeal> I believe the term is 'rules lawyer' ;)
18:30:18 <colindixon> #Info colindixon says he’s not sure that we actually have the power to reject something based on technical/engineering issues
18:30:41 <colindixon> #info edwarnicke seconds colindixon’s understanding
18:30:53 <colindixon> #info dfarrell07 says we should defer it to the mailing list
18:33:18 <alagalah> colindixon: Can you give them the mailing list to use ?
18:33:27 <colindixon> #info Wei Meng says he’s not sure that the NETCONF plugin can do what he needs
18:33:39 <colindixon> #agree we will take this discussion to the mailing list
18:33:45 <colindixon> #undo
18:33:45 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Agreed object at 0x1c3ed90>
18:34:04 <colindixon> #action colindixon to start a thread on the tsc mailing list about approving the OF-CONFIG project
18:34:24 <colindixon> #topic Centinel creation review
18:34:29 <colindixon> alagalah: I’ll just start it and cc them
18:34:44 <colindixon> #link https://wiki.opendaylight.org/view/File:Centinel-08132015.pdf the presentation
18:34:52 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Centinel the project proposal
18:35:14 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-May/000317.html originally proposed as the SDN App SDK on 5/19/2015
18:35:34 <colindixon> #ink https://lists.opendaylight.org/pipermail/tsc/2015-July/003544.html significantly revised on 7/28/2015
18:36:28 <colindixon> #info centinel aims to proivde a distributed, reliable framework for efficienty collecting, aggregating, and sinking steaming data across the persistence DB and stream analyzers
18:36:55 <colindixon> #Info the scope is two things: (1) stream collector, (2) log service
18:37:36 <colindixon> #info stream collector sources include SDN ecosystem things (controllers, plugins, apps), general info (switches/routers), third-party tools (nagios, ganglia) etc.
18:37:53 <colindixon> #info input/output formats could be unstructured, semi-structured, or structured
18:38:07 <colindixon> #info the goal is to then sink them to the persistence DB project
18:38:30 <colindixon> #info also to push these streams out to stream processors if desired
18:40:59 <colindixon> #info the log service is a specifc set of plugins targeting streams of logs to provide alerts, troubleshooting, etc.
18:45:53 <colindixon> #info scope in beryllium: stream collector bases on flume and sqoop with a focus on ODL logs, log service using graylog to do analysis including events/alerts, a web interface, to leverage the TSDR persitence service
18:47:46 <colindixon> #Info mohnish says the centinel team had a very good discussion with the TSDR team about how they would integrate
18:48:25 <colindixon> #Info mohnish says kibana seems interesting to both centinel and TSDR, but that’s moot about the voting
18:49:17 <colindixon> #info mohnish points out that the TSDR dashboard isn’t in DLUX
18:49:33 <colindixon> #info jmedved asks if the intent to go toward being in DLUX? mohnish says yes, he’d like to see that
18:49:44 <colindixon> #info the centinel project says they intend to put things in DLUX
18:50:40 <colindixon> #Info jmedved suggests that maybe using the event topic broker APIs that were recently created would make people’s lives easier in Centinel
18:51:11 <colindixon> #info sumit_kapoor says that he will consider that broker
18:52:49 <colindixon> #info yuling says that when TSDR and Centinel talked, their hope is that they can find common elements and the share them
18:53:21 <colindixon> #info jmedved says that’s a good points out that there is some willingness to change APIs for the event topic broker if it’s useful
18:54:18 <colindixon> #startvote shall we move the Centinel project to incubation? -1, 0, +1
18:54:18 <odl_meetbot> Begin voting on: shall we move the Centinel project to incubation? Valid vote options are -1, 0, +1.
18:54:18 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:54:21 <jmedved> #vote +1
18:54:22 <dfarrell07> #vote +1
18:54:22 <mohnish> #vote +1
18:54:23 <colindixon> #vote +1
18:54:24 <edwarnicke> #vote +1
18:54:29 <LuisGomez> #vote +1
18:54:31 <ChrisPriceAB> #vote +1
18:54:32 <colindixon> #endvote 
18:54:32 <odl_meetbot> Voted on "shall we move the Centinel project to incubation?" Results are
18:54:32 <odl_meetbot> +1 (7): jmedved, ChrisPriceAB, LuisGomez, dfarrell07, edwarnicke, mohnish, colindixon
18:54:45 <colindixon> #agree the Centinel projec is moved to incubation
18:55:33 <colindixon> #topic NeXt UI toolkit
18:55:52 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:NeXt_UI_Toolkit project proposal
18:56:04 <colindixon> #link https://wiki.opendaylight.org/view/File:ODL_new_project_proposal_20150813.ppt.pdf presentation
18:56:14 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-July/000365.html proposed on 7/31/2015
18:56:55 <colindixon> #info NeXt has done lots of work on javascript-based rendering of topologys with expanding and collapsing nodes, switching different layouts
18:57:06 <dfarrell07> There are some pretty great demo videos linked from the proposal, FYI
18:57:15 <Aikepaer> http://devnet-stage.kpimdp.com/site/neXt/
18:57:26 <colindixon> #info dfarrell07 notes really cool demo videos linked from the proposals
18:57:27 <Aikepaer> NeXt developer site
18:57:43 <colindixon> #link http://devnet-stage.kpimdp.com/site/neXt/ the NeXt developer site
18:58:01 <colindixon> #info plan is to augment DLUX to just render topologies
18:58:21 <colindixon> #Info there are a number of apps being developed (some with jmedved ) that are already working on top of NeXt
18:58:22 <mohnish> Aikepaer: Committer details are missing .... BTW, you already have my vote
18:58:27 <gzhao> #info please add email for all initial committers
18:58:35 <dfarrell07> mohnish: agreed, this is solid
18:58:47 <colindixon> #action Aikepaer please add comitters
18:58:59 <colindixon> #startvote shall we move the NeXt UI toolkit project to incubation? -1, 0, +1
18:58:59 <odl_meetbot> Begin voting on: shall we move the NeXt UI toolkit project to incubation? Valid vote options are -1, 0, +1.
18:58:59 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:59:05 <dfarrell07> #vote +1
18:59:07 <mohnish> #vote +1
18:59:11 <colindixon> #vote +1
18:59:11 <ChrisPriceAB> #vote +1
18:59:11 <jmedved> #vote +1
18:59:12 <edwarnicke> #vote +1
18:59:21 <colindixon> #endvote
18:59:21 <odl_meetbot> Voted on "shall we move the NeXt UI toolkit project to incubation?" Results are
18:59:21 <odl_meetbot> +1 (6): jmedved, ChrisPriceAB, edwarnicke, dfarrell07, mohnish, colindixon
18:59:21 <ChrisPriceAB> lol
18:59:26 <tykeal> \0/
18:59:32 <colindixon> #agree NeXt Ui toolkit is a incubation project
18:59:36 <dfarrell07> well done @ all, productive :)
18:59:38 <colindixon> #topic cookies
18:59:40 <gzhao> 4 minutes
18:59:42 <gzhao> record
18:59:43 * ChrisPriceAB chews happiily
18:59:46 <colindixon> #endmeeting