17:00:08 <colindixon> #startmeeting tsc
17:00:08 <odl_meetbot> Meeting started Thu Aug 20 17:00:08 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:08 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:08 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:14 <colindixon> #topic rol call and agenda bashing
17:00:50 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=35398 the agenda for today
17:00:53 <ChrisPriceAB> #info Chris Price
17:00:55 <edwarnicke> #info edwarnicke
17:00:55 <colindixon> #info colindixon
17:01:02 <adetalhouet> #info adetalhouet
17:02:30 <afewell> is there a TSC meeting today/now?
17:02:37 <phrobb> yup
17:02:41 <colindixon> #action OF-CONFIG project will add ODL user IDs for the committers to the project proposal
17:02:45 <gzhao> afewell: yes
17:02:54 <colindixon> #undo
17:02:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x1d39590>
17:02:57 <colindixon> #undo
17:02:57 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19b8050>
17:03:01 <colindixon> #action OF-CONFIG project will add ODL user IDs for the committers to the project proposal
17:03:19 <colindixon> #action KevinLuehrs to add ODL user IDs for committers listed without them
17:03:20 <colindixon> #action KevinLuehrs to provide links to the relevant OPNFV and MEF specs/models
17:03:21 <colindixon> #action KevinLuehrs to link to the powerpoint slides from the proposal page
17:03:44 <afewell> it appears the last update for Ubuntu must have killed my webex again
17:03:50 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
17:04:29 <colindixon> #action phrobb to send out mail when the new infra person is up-to-speed so that he knows when he will not be waking people up after hours
17:04:55 <dfarrell07_con> #info dfarrell07_con
17:05:13 <colindixon> #info phrobb notes is that we should not wake up Thanh and Andy after hours immediately now as we now have staff in australia, please use the escalation process as usual to do that
17:05:14 * dfarrell07_con is irc only atm
17:05:40 <colindixon> #action phrobb to keep working on JIRA and let us know when we can use it
17:05:58 <colindixon> #action tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
17:06:07 <colindixon> #action tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
17:07:06 <colindixon> I only see 4 TSC member: colindixon, ChrisPriceAB, edwarnicke, dfarrell07_con
17:07:16 <colindixon> we have LuisGomez on webex
17:07:27 <LuisGomez> #info LuisGomez
17:07:48 <colindixon> jmedved: are you here?
17:08:10 * dfarrell07_con is getting invalid meeting number stuff from webex but it could be his fault
17:08:21 <dfarrell07_con> LuisGomez:
17:08:35 * ChrisPriceAB stares at the clouds...
17:08:40 <dfarrell07_con> ^^nvm, sorry, mobile
17:08:40 <colindixon> dlenrow: you here?
17:08:42 <jmedved> colindixon: on im only
17:08:46 <jmedved> will join voice later
17:08:50 <jmedved> #info jmedved
17:09:12 <colindixon> welcome mohnish
17:09:17 <mohnish> #info mohnish anumala
17:09:20 <gzhao> wow
17:09:31 <mohnish> Sorry, I am delayed
17:09:45 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-08-13-17.01.html last week’s minutes, we already got all the actions
17:10:11 * dfarrell07_con has audio
17:11:02 <colindixon> #info adding integration split to the agenda
17:11:11 <colindixon> #topic mailing list votes
17:11:29 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-July/003500.html this process to change a project’s scope
17:11:36 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-August/003564.html discussion continues here
17:12:29 <dfarrell07_con> colindixon: I've already voted on it I think, glad to do it again
17:12:36 * ChrisPriceAB likes the proposal...
17:12:53 * ChrisPriceAB doesn't see that it would affect a project participating in a release cycle.
17:12:55 <colindixon> do TSC members feel comfortable voting on this?
17:16:35 <colindixon> #startvote shall we adopt thie following policy for a project to extend or reduce the scope of a project https://lists.opendaylight.org/pipermail/tsc/2015-July/003500.html ? -1, 0, +1
17:16:35 <odl_meetbot> Begin voting on: shall we adopt thie following policy for a project to extend or reduce the scope of a project https://lists.opendaylight.org/pipermail/tsc/2015-July/003500.html ? Valid vote options are -1, 0, +1.
17:16:35 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:16:58 <colindixon> #vote +1
17:16:59 <mohnish> #vote +1
17:17:00 <edwarnicke> #vote +1
17:17:00 <jmedved> #vote +1
17:17:06 <ChrisPriceAB> #vote +1
17:17:07 <LuisGomez> #vote +1
17:17:19 <colindixon> #endvote
17:17:19 <odl_meetbot> Voted on "shall we adopt thie following policy for a project to extend or reduce the scope of a project https://lists.opendaylight.org/pipermail/tsc/2015-July/003500.html ?" Results are
17:17:19 <odl_meetbot> +1 (6): jmedved, LuisGomez, edwarnicke, ChrisPriceAB, mohnish, colindixon
17:17:44 * ChrisPriceAB thinks it will all come clear when someone tries to exercise the policy.
17:17:45 <colindixon> #agreee #startvote this is the policy for a project to extend or reduce the scope of a project https://lists.opendaylight.org/pipermail/tsc/2015-July/003500.html
17:18:03 <colindixon> #undo
17:18:03 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Vote object at 0x1aa8450>
17:18:09 <colindixon> #agreee this is the policy for a project to extend or reduce the scope of a project https://lists.opendaylight.org/pipermail/tsc/2015-July/003500.html
17:18:22 <ChrisPriceAB> +1 for ending early...   prefer not to be around but can be forced
17:18:22 <abhijitkumbhare> agreed - right colindixon ?
17:18:22 <dfarrell07_con> colindixon: I can be around for 2 hours
17:18:24 <colindixon> are TSC members available for the two hours today
17:18:34 <mohnish> ed: +1
17:18:48 <LuisGomez> +1
17:18:58 <colindixon> #topic events
17:19:01 <abhijitkumbhare> I think you wrote agreee (with an extra e)
17:19:11 <jmedved> colindixon: i will be available until 12:oo noon PST. starting 11:30 on voice
17:19:15 <colindixon> #undo
17:19:15 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1b946d0>
17:19:17 <colindixon> #undo
17:19:17 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x19be3d0>
17:19:23 <colindixon> #agree this is the policy for a project to extend or reduce the scope of a project https://lists.opendaylight.org/pipermail/tsc/2015-July/003500.html
17:19:25 <colindixon> #topic events
17:19:32 <colindixon> #link https://www.opendaylight.org/global-events the events page
17:20:00 * ChrisPriceAB can do negative feedback too!
17:20:22 <colindixon> #info the current plan for a hackfest is to be colocated with the OPFNV summit, 11/9-11/10 at the Hyatt Regency San Francisco Airport
17:20:41 <gzhao> #link http://events.linuxfoundation.org/events/opnfv-summit < -- opnfv summit
17:20:52 <colindixon> #info this is the last call for objections, all feedback so far has been positive
17:21:13 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-August/003653.html mailing list thread
17:21:39 <colindixon> #info ChrisPriceAB says he thinks it’s a great idea
17:21:39 <dfarrell07_con> I've given positive off-list feedback to phrobb already, that date is good as far as I know
17:21:56 <colindixon> #info phrobb will lock down the venue
17:22:07 <afewell> btw happy bday to Chris!
17:22:44 <colindixon> #info SDN OpenFlow world congress in dusseldorf has it’s CFP out now
17:22:47 <abhijitkumbhare> https://www.opendaylight.org/events/2015-10-12-000000-2015-10-16-000000/sdn-openflow-world-congress
17:22:52 <abhijitkumbhare> #link https://www.opendaylight.org/events/2015-10-12-000000-2015-10-16-000000/sdn-openflow-world-congress
17:22:57 <colindixon> thanks!
17:23:04 <dfarrell07_con> Happy birthday ChrisPriceAB
17:23:07 <dfarrell07_con> :D
17:23:07 <ChrisPriceAB> thanks guys!
17:23:13 <colindixon> #info happy birthday to ChrisPriceAB!
17:23:22 <gzhao> ChrisPriceAB: HBD
17:23:24 <afewell> He's turning 29 again ;)
17:23:29 <dfarrell07_con> lol
17:23:32 * edwarnicke starts singing happy birthday into mute
17:23:35 <gzhao> afewell: over and voer
17:23:44 <ChrisPriceAB> :O  29?  still early 20's guys... be nice
17:23:52 <colindixon> #topic Lithium-SR1
17:24:26 <abhijitkumbhare> Happy birthday ChrisPriceAB - have a good evening and drink to Beryllium & Brahmaputra :)
17:24:26 <Prem_> Happy Birthday ChrisPriceAB !
17:24:31 <gzhao> #link https://docs.google.com/spreadsheets/d/1udOk9ZmOCeMjpI-wl0zjLO_AXgO8wYrDjKiPQWkXKb4/edit#gid=0
17:24:37 <colindixon> #link https://docs.google.com/spreadsheets/d/1udOk9ZmOCeMjpI-wl0zjLO_AXgO8wYrDjKiPQWkXKb4/edit#gid=0 these are the test failures that we had with Lithium-SR1, all projects have said they are expected/non-regressions/non-blocking
17:24:41 <colindixon> #undo
17:24:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1ba9c50>
17:24:42 <colindixon> #undo
17:24:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1ba97d0>
17:24:44 <colindixon> #link https://docs.google.com/spreadsheets/d/1udOk9ZmOCeMjpI-wl0zjLO_AXgO8wYrDjKiPQWkXKb4/edit#gid=0 these are the test failures that we had with Lithium-SR1, all projects have said they are expected/non-regressions/non-blocking
17:25:50 <colindixon> #link https://nexus.opendaylight.org/content/repositories/automatedweeklyreleases-1083/org/opendaylight/integration/distribution-karaf/0.3.1-Lithium-SR1/ this is the relevant artifacts
17:26:13 <colindixon> #info LuisGomez says there are no regressions to his knowledge
17:26:27 * dfarrell07_con is ready to vote
17:26:36 * ChrisPriceAB drumroll
17:26:46 <colindixon> #startvote shall the TSC approve these as the Lithium-SR1 artifacts: https://nexus.opendaylight.org/content/repositories/automatedweeklyreleases-1083/ ? -1, 0, +1
17:26:46 <odl_meetbot> Begin voting on: shall the TSC approve these as the Lithium-SR1 artifacts: https://nexus.opendaylight.org/content/repositories/automatedweeklyreleases-1083/ ? Valid vote options are -1, 0, +1.
17:26:46 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:26:47 <gzhao> #info gzhao suggests Lithium SR1 is a go
17:26:48 <colindixon> #vote +1
17:26:51 <dfarrell07_con> #vote +1
17:26:53 <ChrisPriceAB> #vote +1
17:26:54 <LuisGomez> #vote +1
17:26:54 <mohnish> #vote +1
17:26:58 <edwarnicke> #vote +1
17:27:09 <colindixon> jmedved: want to vote?
17:27:28 <colindixon> #endvote
17:27:28 <odl_meetbot> Voted on "shall the TSC approve these as the Lithium-SR1 artifacts: https://nexus.opendaylight.org/content/repositories/automatedweeklyreleases-1083/ ?" Results are
17:27:28 <odl_meetbot> +1 (6): dfarrell07_con, LuisGomez, ChrisPriceAB, edwarnicke, mohnish, colindixon
17:27:38 <colindixon> #agree Lithium-SR1 is a go
17:27:42 <dfarrell07_con> *blastoff*
17:28:14 <colindixon> #topic Beryllium
17:28:17 * ChrisPriceAB likes the idea of Philsafes...
17:28:24 <colindixon> #link https://wiki.opendaylight.org/view/Weather the weather page
17:28:41 <colindixon> #undo
17:28:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1cd49d0>
17:29:01 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the current weather report
17:29:16 <colindixon> #info gzhao says the problem is that we have lots of new projects that are spinning up as fast as they can
17:29:32 * ChrisPriceAB feels the need for the TSC to start to think about project lifecycle progression...
17:29:44 <colindixon> ChrisPriceAB: noted
17:30:37 <colindixon> ChrisPriceAB: https://lists.opendaylight.org/pipermail/tsc/2015-July/003511.html
17:30:38 <colindixon> reply tere
17:30:41 <afewell> we should start a committee to assign titles to people :)
17:31:55 <colindixon> #info george says that as he steps down, the new person is stepping up but there will be an announcement as they come up to speed
17:32:25 <colindixon> #info edwarnicke suggests to give the new person some airtime to make it clear that people pay careful attention to their mails when they come
17:33:44 <colindixon> #info gzhao is actually worried about M2 and M3 more than M1 and so new projects may need more help then
17:34:32 <colindixon> #action colindixon to see if anyone wants to write survival guides for M2 and M3
17:34:58 <afewell> I could help with review/editing but I dont have the knowledge to produce the meat
17:35:23 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-August/003702.html gzhao had a question about how to acknowledge dependencies
17:36:40 <gzhao> #info gzhao would like to thank phrobb and edwarnicke for their help and support for working as RM.
17:36:54 <edwarnicke> gzhao: It was all you my friend :)
17:37:12 <phrobb> I concur with Ed.  you rock gzhao
17:37:19 <colindixon> #info system integration test
17:37:27 <colindixon> #undo
17:37:27 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1d31890>
17:37:37 <abhijitkumbhare> thanks for all your work gzhao
17:37:40 <colindixon> #topic infrastructure
17:37:58 <gzhao> edwarnicke: I am speechless, other than a big thanks
17:38:02 <dfarrell07_con> You're awesome gzhao, thanks for the great work! :)
17:38:13 <gzhao> abhijitkumbhare: dfarrell07_con thanks
17:38:49 <colindixon> #info the dial-in numbers for all WebEx meetings hosted by the LF changed, if you haven’t updated them, please check to make sure they’re right
17:39:19 <LuisGomez> gzhao, we will miss you
17:39:40 <afewell> +1 for something other than webex - poor Linux support
17:39:42 <colindixon> #info odl-casey did a lot of that on the meetings page and updated the calendar
17:39:50 <gzhao> LuisGomez: I will be around.
17:39:56 <jamoluhrsen> +1 to move from webex
17:40:07 <colindixon> #info abhijitkumbhare asks if we can help to have recordings from meetings that overlap
17:40:27 <afewell> + the ability for international participants including china
17:40:27 <colindixon> #info phrobb asks if we want to consider moving off WebEx
17:40:37 <LuisGomez> gzhao, i hope you will :)
17:40:48 <colindixon> #action phrobb to start a discussion on the idea of moving from WebEx to something else
17:41:08 <jmedved> #info jmedved
17:41:18 <jmedved> jmedved is back; joining hte call
17:41:39 <afewell> sadly every time you do anything more than a tiny upgrade in ubuntu you need to go re-resolve all the dependencies manually
17:42:11 <colindixon> #topic continuation of the OF-CONFIG creation review
17:42:25 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-August/003706.html lots of discussion happened here
17:42:45 <afewell> I do have a quick question I wanted to try to inject towards the end, or whenever would be good
17:42:52 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:OF-CONFIG the revised proposal
17:43:14 * ChrisPriceAB thinks its a good idea to vote on this
17:43:23 <colindixon> #startvote shall we move the OF-CONFIG project to incubatin? -1, 0 +1
17:43:23 <odl_meetbot> Begin voting on: shall we move the OF-CONFIG project to incubatin? Valid vote options are -1, 0, +1.
17:43:23 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:43:26 <jmedved> #vote +1
17:43:26 <ChrisPriceAB> #vote +1
17:43:27 <edwarnicke> #vote +1
17:43:27 <dfarrell07_con> #vote +1
17:43:29 <LuisGomez> #vote +1
17:43:30 <colindixon> #vote +1
17:43:33 <mohnish> #vote +1
17:43:37 <colindixon> #endvote
17:43:37 <odl_meetbot> Voted on "shall we move the OF-CONFIG project to incubatin?" Results are
17:43:37 <odl_meetbot> +1 (7): jmedved, dfarrell07_con, LuisGomez, ChrisPriceAB, edwarnicke, mohnish, colindixon
17:43:46 <colindixon> #agree the OF-CONFIG project is moved to incubation
17:43:54 <uri_> #vote +1
17:44:35 <colindixon> #topic Armoury creation review
17:45:00 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Armoury
17:45:18 <colindixon> #link https://wiki.opendaylight.org/images/c/c0/Armoury_Proposal.pdf the presentation
17:45:38 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-August/000367.html proposed on 8/5/2015
17:46:48 <colindixon> #info there is no way for OpenDaylight today ask for resources from a VM provisiioning service, e.g., OpenDaylight
17:47:07 <colindixon> #info it’s all requests from the VM provisioning system to OpenDaylight for networking
17:47:26 <colindixon> how is this related to tacker?
17:48:13 <colindixon> #link Armoury Overview: Just as compute needs to make requests to the controller to get networking resources in order to provide its services, so too does the controller sometimes need to make requests of the workload manager to get compute resources and/or network function (NF) (physical or virtual) orchestration to provide its services.
17:49:13 <colindixon> #info Uri says while the need for this is clear, it’s not clear to him whether this request should orginate from ODL or some orchestrator further north
17:50:51 <colindixon> #info edwarnicke says that there was a lot of this discussion at the summit which produced ths project proposal, and one thing that came out was that you need to have some way to hand off ODL-specific information to an orchestrator
17:51:12 * edwarnicke notes that colindixon is very very good at simplifying his statements ;)
17:52:01 <colindixon> #info AMOURY SCOPE
17:52:13 <colindixon> #info 1. A registry or catalog of the necessary information (images, metadata, templatized day 0 config, how to communicate with the NF, etc) to describe the NF to the workload manager and/or network function (NF) (physical or virtual) orchestration.
17:52:28 <colindixon> #info 2. The most minimal possible API to allow applications to request that the workload manager start/stop/etc the NF and some information from the workload manager/nf orchestrator about the state of the NF.
17:52:37 <colindixon> #info 3. Example Drivers to talk to various workload managers (OpenStack/Meseophere/Docker/Kubernetes/etc).
17:53:03 <colindixon> #info jmedved and adetalhouet say that this is aimed at both physical NFs and virtual NFs
17:53:51 <colindixon> #info tony asks if the scope is bascially to prove a facade to abstract the interface to different orchestrators?
17:54:54 <colindixon> #info jmedved says yes, but adetalhouet seems to be unable to get a word in edgewise over edwarnicke and adetalhouet.
17:55:04 <colindixon> #Undo
17:55:04 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a83dd0>
17:55:09 <colindixon> #info jmedved says yes, but adetalhouet seems to be unable to get a word in edgewise over edwarnicke and jmedved.
17:55:38 <afewell> curious if there are any related standards efforts or if Atrium is trying to do something similar?
17:55:49 <colindixon> afewell: tacker is the most obvious
17:56:00 <afewell> thx
17:56:08 <colindixon> https://wiki.openstack.org/wiki/Tacker
17:56:17 <colindixon> I don’t think Atrium is doing anythign like this
17:57:26 <colindixon> #info uri and edwarnicke go back and forth about where the relevant responsibilites should reside
18:00:45 <colindixon> #info ChrisPriceAB and Uri both argue that we should be more clear that responsiblity should be alloacated between compute and/or (V)NF manager and that the amoutn in each place might vary
18:01:08 * ChrisPriceAB thinks argue is such a strong word.
18:02:24 <colindixon> #undo
18:02:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x18b79d0>
18:02:33 <colindixon> #info ChrisPriceAB and Uri both say we should be clear that responsiblity should be alloacated between compute and/or (V)NF manager and that the amoutn in each place might vary
18:02:35 <colindixon> better?
18:03:44 * dfarrell07_con would sure love to vote on the Integration namespace split today
18:04:09 <colindixon> #info abhijitkumbhare asks what’s in OpenDaylight, adetalhouet says everything in orange boxes on slide 8
18:04:45 <colindixon> #info workloadproviders are drivers for different providers, e.g., mesosphere, docker, openstack
18:04:59 <colindixon> #info the workload manager is the thing which provides the ODL interfact to spin things up and down
18:05:02 <colindixon> dfarrell07_con: noted
18:05:08 <dfarrell07_con> colindixon: thanks :)
18:05:23 <colindixon> #info jmedved asks where NF images are going to be stored?
18:05:34 <colindixon> #info adetalhouet says that woudl be stored in the NF Repository
18:06:17 <colindixon> #Info colindixon says slide 9 says it’s actually going to be metadata or pointers to NFs that are in the NF repository, not the actual images
18:08:31 <ChrisPriceAB> #info ChrisPriceAB needs to drop, abhijitkumbhare will stand in for me for the rest of the call.
18:08:57 <colindixon> #info Prem_ and mohnish asks how this expands out to dealing with longer workflow, adetalhouet says that this would be the responsiblity of the ODL applicatin and/or orchestrator, not Armoury itself
18:12:28 <colindixon> #link https://wiki.openstack.org/wiki/Tacker colindixon asks if there’s a plan to interact with Tacker
18:13:36 <afewell> the other thing is that tackers scope says it includes vnf manager and nfv orchestrator so it looks like a broader scope than we want
18:14:14 <colindixon> #info there are no current plans, but it could be a workload provider to provide Armoury functionality
18:14:15 <afewell> but I would think we should rationalize our minimalistic approach with tacker to ensure what we are doing is compatible/useful from their perspective
18:15:00 <colindixon> #info afewell notes that tacker has a broader scope as it plans to be VNF manager, which includes more functions like lifecycle-managmement
18:15:35 <colindixon> #info edwarnicke says that a key element is avoiding welding us to a given provider
18:16:35 <colindixon> #info jmedved says it’s also the only thing he knows of that controls both physical and virtual NFs
18:16:50 <afewell> or phrased differently, it appears tacker has a broader scope, and it would be ideal if the portion of the scope that overlaps between tacker and armoury were on the same page ... they may even embrace this if they like the architecture and we are contributing resources ... food for thought
18:17:26 <colindixon> #info mohnish says he likes the idea, but he’s curious how much it overlaps and how it fits in with other similar ideas and architecture diagrams, e.g., ETSi
18:19:19 <mohnish> https://www.ietf.org/proceedings/92/slides/slides-92-nfvrg-7.pdf
18:20:51 <colindixon> #link https://www.ietf.org/proceedings/92/slides/slides-92-nfvrg-7.pdf if you look at the last slide here, they have the VNF manager is above OpenStack
18:21:06 <colindixon> #info mohnish asks where Armoury fits in the diagram
18:21:27 <afewell> if everyone could please check to make sure they are muted - there is background noise
18:22:48 <colindixon> #info edwarnicke says he can’t imagine drawing Armoury in this diagram because it doesn’t have a network controller
18:22:59 <colindixon> afewell: I think it’s coming from mohnish who is talking
18:24:31 <colindixon> #info edwarnicke says that if you chose openmano as your workload provider, then Armoury would make requests to it about what (V)NFs it needs, it woudl be allowed to either meet that request, not meet it, or return something it things was a better decision
18:25:52 <colindixon> #statvote shall we move Armoury to incubation? -1, 0, +1
18:25:56 <colindixon> #startvote shall we move Armoury to incubation? -1, 0, +1
18:25:56 <odl_meetbot> Begin voting on: shall we move Armoury to incubation? Valid vote options are -1, 0, +1.
18:25:56 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:25:59 <edwarnicke> #vote +1
18:26:02 <dfarrell07_con> #vote +1
18:26:04 <jmedved> #vote +1
18:26:11 <colindixon> #vote +1
18:26:13 <mohnish> #vote +1
18:26:15 <LuisGomez> #vote +1
18:26:17 <abhijitkumbhare> #vote +1
18:26:22 <colindixon> #end vote
18:26:30 <dfarrell07_con> #endvote
18:26:32 <dfarrell07_con> space
18:26:36 <colindixon> #endvote
18:26:36 <odl_meetbot> Voted on "shall we move Armoury to incubation?" Results are
18:26:36 <odl_meetbot> +1 (7): jmedved, dfarrell07_con, LuisGomez, edwarnicke, mohnish, colindixon, abhijitkumbhare
18:26:44 <colindixon> #info Uri also votes +1
18:26:53 <colindixon> #agree the Armoury project is moved to incubation
18:27:04 <colindixon> #topic integration split
18:27:29 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-August/000369.html
18:27:46 <mohnish> Armoury will be an interesting project. Congrats!
18:28:03 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Integration_Test
18:28:07 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Integration_Distribution
18:28:13 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Integration_Packaging
18:29:12 <colindixon> #info the TSC considers that for this special case the new projects have met the requirement for 2 weeks of public reviews, despite not being sent to project-proposals (all projects in the future are still expected to send mail to project-proposals)
18:29:22 <afewell> https://lists.opendaylight.org/pipermail/integration-dev/2015-August/003976.html
18:29:42 <colindixon> afewell: not to the project-proposals list
18:29:58 <colindixon> afewell https://lists.opendaylight.org/pipermail/project-proposals/
18:30:40 <colindixon> #info LuisGomez says there were always three folders in integration: test, distribution, and packaging, but there was no need to have separate proejcts
18:31:00 <colindixon> #info they are now big enoguh that they would like to split
18:31:28 <colindixon> #info also, it will enable faster movement because building each one will be faster than building all of them
18:32:16 <colindixon> #link https://lists.opendaylight.org/pipermail/integration-dev/2015-August/003976.html the explanation of the split
18:36:00 <dfarrell07_con> Integration/Test, Integration/Packaging, Integration/Distribution are the names I'll use, with init/pak, int/test, int/dist for short
18:36:40 <abhijitkumbhare> what about wiki names on the project list dfarrell07_con ?
18:36:57 <dfarrell07_con> project list?
18:37:17 <abhijitkumbhare> https://wiki.opendaylight.org/view/Project_list
18:37:29 <colindixon> #info was thre a methodology for coming up with the committers on the new projects?
18:37:53 <colindixon> #info all existing committers were offered to be on whatever projects they wanted, others were added if they felt it was required
18:38:02 <dfarrell07_con> abhijitkumbhare: the offical name is Integration-Packaging etc, so we'd ues thta
18:38:12 <colindixon> #info the only committer here that wasn’t on integration is Thanh on packaging
18:38:19 <abhijitkumbhare> OK dfarrell07_con
18:38:56 <edwarnicke> #info zxiro has a large contribution history to integration: https://git.opendaylight.org/gerrit/#/q/owner:thanh.ha%2540linuxfoundation.org+project:integration
18:39:13 <dfarrell07_con> #info The git history will be preserved after the split
18:39:20 <colindixon> #info colindixon asks what will happen to the current integration repo
18:39:42 <colindixon> #info LuisGomez the current repo will effectively archived as soon as that makes sense
18:40:49 <dfarrell07_con> colindixon: I'd call that a tech detail of the split, but that's imho. The decision was implied by the vote to split passing.
18:41:22 <colindixon> #info colindixon asks if the integration project voted to archive the original project, dfarrell07_con and LuisGomez say that it was implicit in the decision to split
18:42:49 <colindixon> #startvote shall we move the three new integration projects splitting out from integration? -1, 0, +1
18:42:49 <odl_meetbot> Begin voting on: shall we move the three new integration projects splitting out from integration? Valid vote options are -1, 0, +1.
18:42:49 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:42:54 <edwarnicke> #vote +1
18:42:55 <dfarrell07_con> #vote +1
18:42:55 <colindixon> #vote +1
18:42:59 <mohnish> #vote +1
18:42:59 <abhijitkumbhare> #vote +1
18:43:00 <LuisGomez> #vote +1
18:43:08 <colindixon> #endvote
18:43:08 <odl_meetbot> Voted on "shall we move the three new integration projects splitting out from integration?" Results are
18:43:08 <odl_meetbot> +1 (6): dfarrell07_con, LuisGomez, edwarnicke, mohnish, colindixon, abhijitkumbhare
18:43:15 <colindixon> #info Uri also votes +1
18:43:27 <colindixon> #agree the three new integration subprojects are moved to incubation
18:45:12 <colindixon> #topic next week
18:45:24 <colindixon> #info colindixon says next week will return to the normal 1 hour meeting
18:45:32 <colindixon> #topic cookies
18:45:36 <colindixon> #endmeeting