17:00:12 <colindixon> #startmeeting tsc
17:00:12 <odl_meetbot> Meeting started Thu Sep  3 17:00:12 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:12 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:12 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:17 <colindixon> #topic roll call and agenda bashing
17:00:19 <colindixon> #info colindixon
17:00:33 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=36179#Agenda the agenda in it’s usual place
17:00:42 <dfarrell07> #info dfarrell07
17:01:15 <ChrisPriceAB> #info Chris Price
17:01:22 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-08-27-17.00.html last week’s meeting minutes
17:01:58 <colindixon> #info thanks to anipbu for writing M2/M3 survival guides
17:02:21 <colindixon> #action phrobb to start a discussion on the idea of moving from WebEx to something else
17:02:26 <LuisGomez> #info LuisGomez
17:02:34 <mohnish_> #info mohnish anumala
17:02:38 <colindixon> #action tony to send out an e-mail explaining his alternative solution to version bumping and branch cutting
17:02:46 <colindixon> #action tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
17:02:59 <colindixon> #action phrobb to keep working on JIRA and let us know when we can use it
17:03:11 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
17:03:19 <anipbu2> M2 survival guide https://wiki.opendaylight.org/view/Simultaneous_Release/Guides/M2
17:03:47 <phrobb> Current TSC members colindixon dfarrell07 LuisGomez ChrisPriceAB mohnish_
17:03:57 <colindixon> #chair phrobb dfarrell07
17:03:57 <odl_meetbot> Current chairs: colindixon dfarrell07 phrobb
17:03:59 <edwarnicke> #info edwarnicke
17:05:06 <colindixon> #topic events
17:05:24 <colindixon> #link https://www.opendaylight.org/global-events the events page in it’s usual place
17:05:39 <colindixon> #info CFP for dusseldorf (with 16 entries) closed on Friday
17:05:53 <ebrjohn> #info I submit a CFP to desseldorf for SFC
17:06:09 <colindixon> #info phrobb will try to get people notified of acceptances for dusseldorf by mid next week
17:06:42 <gzhao> #info phrobb says need to have a good exposure in Openstack for ODL
17:06:46 <colindixon> #link https://www.opendaylight.org/events/2015-10-27-000000-2015-10-30-000000/openstack-summit openstack summit didn’t get many ODL or OPNFV talks, we should figure out how to ahve a strong showing
17:07:22 <colindixon> #info ODL hackfest will be colocated with the OPFNV summit, 11/9-11/10 at the Hyatt Regency San Francisco Airport (
17:07:31 <colindixon> #topic OpenDaylight Summit feedback and planning
17:07:51 <colindixon> #info phrobb asks for feedback, notes attendance on Friday was light
17:08:16 <colindixon> #info dfarrell07 said he thought it was awesome, he really liked recording and posting talks—said it was better than everything else he’s been to including LinuxCon
17:08:50 <colindixon> #info edwarnicke said he liked the organization, he liked keeping the dev forum separate from the summit so that people weren’t overcommited, he wants to keep that
17:09:34 <colindixon> #info edwarnicke notes that he got a lot of positive feedback on the tutorials
17:10:14 <dlenrow> #info dlenrow
17:10:17 <colindixon> #Info colindixon says 4 days would be better than 5, edwarnicke points out that’s true, but you need to figure out how that plays with the trade-offs of fitting everything in
17:10:43 <gzhao> #info abhijitkumbhare said most developers would like to be part in user tutorials as well.
17:10:44 <colindixon> #info abhijitkumbhare and dfarrell07 say that they would have liked to attend more of the tutorials, e.g., both developer and user
17:11:20 <jamoluhrsen> I would also have liked to attend dev forum + user
17:11:46 <colindixon> #info phrobb said he heard from some people would have liked to have heard higher-level, strategic content over deeper content
17:13:12 <colindixon> #info dfarrell07 said there was not enough coffee
17:13:44 <colindixon> #Info ChrisPriceAB would have liked to see things more concetrated into less floorspace
17:13:50 <ebrjohn> #info I was not happy at all that I had to buy coffee several times
17:14:00 <colindixon> #info dlenrow says it would be good to fix the date as soon as possible
17:14:00 <dfarrell07> ebrjohn: rofl ;)
17:14:17 <colindixon> #topic OpenDaylight summit 2016 planning
17:14:43 <colindixon> #info other feedback came back that doing it in the summer (in particular July/August) is a bad idea, especially for Europeans
17:14:57 * ebrjohn who doesnt take their vacation??? ;)
17:15:10 <colindixon> #info phrobb says that the LF canvassed a bunch of loations to taget next fall (instead of summer)
17:15:35 <colindixon> #info in the bay area, there is nothing available in the Fall
17:15:48 <tykeal> *blech* Bellevue, so little to see there ;)
17:16:03 <dfarrell07> Seattle was really cool, btw
17:16:14 <tykeal> Seattle is great, Bellevue sort of sucks
17:16:33 <abhijitkumbhare> We should have in Hawaii :)
17:16:39 <tykeal> that would be "Bellingham" around here ;)
17:16:55 <colindixon> #info they looked at doing something the last week of September in Bellevue, but the board gave feedback on doing things maybe a different time and staying in the Bay area if we can
17:17:12 <colindixon> #info the idea of the bay area in June was floated and is being looked at
17:17:52 <colindixon> #info phrobb says that assuming a normal 6 month cadence Boron release would be sometime around august 2016
17:20:28 <abhijitkumbhare> June is also start of summer vacations (for kids schools) - so works easier for vacations
17:20:38 <jmedved> #info jmedved
17:20:55 <colindixon> #info thus if we did a june-ish date for the summit with a hackfest, we would move the dev forum to a different time after the boron release
17:21:56 <colindixon> #info phrobb asks how early June in the bay area would work for a summit for the technical community
17:22:13 <tykeal> ChrisPriceAB: you should be careful about saying you don't have a life ;)
17:22:29 <colindixon> #info ChrisPriceAB asks that we try avoid conflicting with others, e.g., the OPNFV summit in June in Europe
17:23:19 <colindixon> #info phrobb notes that the board worries about moving things from the bay area in terms of losing attendance
17:24:37 <colindixon> #info phrobb noes that the LF events staff says that as you move things around you tend to get local attendees (and retain some of them across years)
17:24:38 <dneary> Doesn't Bellevue stand for "beautiful view"?
17:24:43 * tykeal notes that Bellevue doesn't have the same connotation to those in Washington, it would be Bellingham that has that connotation to us ;)
17:24:45 <abhijitkumbhare> +1 to September (as opposed to June due to vacations for many folks and possibly the OPNFV summit as ChrisPriceAB suggested)
17:24:54 <gzhao> colindixon: may not be a bad thing, because people has nothing to do but concentrate on ODL
17:24:54 <ebrjohn> dneary: maybe it did 100 years ago
17:25:19 <ttkacik1> given it will be in September - No summit for beryllium?
17:25:31 <dneary> Is it Bellevue, Bellview, or some other spelling?
17:25:40 <colindixon> Bellevue
17:25:49 <edwarnicke> I think that conference fatigue can be solved with dfarrell07 's plan to provide more coffee ;)
17:25:53 <dfarrell07> #info dfarrell07 +1s moving the Summit through various large cities, hoping to get the "pick up locals who now travel to Summit" benifit LF has seen
17:25:58 <dfarrell07> edwarnicke: ;)
17:26:16 <colindixon> #info abhijitkumbhare says he’d prefer the september dates
17:26:42 <dneary> phrobb: Can I suggest a Yang/network application developer tutorial? Something like what was done in the boot camp in China?
17:26:52 <dneary> colindixon, Bellevue, FL?
17:26:54 <gzhao> dneary: +1
17:26:57 <ChrisPriceAB> Likes that approach, worth a try
17:27:01 <colindixon> dneary: Bellevue, WA
17:27:02 <ttkacik1> dneary: +1
17:27:17 <ttkacik1> dneary: app dev tutorials will be critical
17:27:22 <dneary> colindixon, OK, thanks
17:27:29 <colindixon> #info dneary suggests a YANG network application developer tutorial something like what was done in the China bootcammp
17:27:32 <abhijitkumbhare> edwarnicke dfarrell07 - we can make sure to get enough sleep in the night with a drinks session in the evenings :)
17:27:58 <dneary> colindixon, Bellevue is in Seattle
17:28:00 <edwarnicke> abhijitkumbhare: Due to my particular proclivities for libations, I can drink heavily and still be fine the next day :)
17:28:01 <dneary> Right?
17:28:03 <colindixon> #info phrobb says there’s an idea of a new format which might hit good trade-offs in terms of 4 days, developer forum, summit, tutorials, etc.
17:28:08 <colindixon> dneary: no, it’s not
17:28:15 <colindixon> dneary: it’s on the others side of a lake
17:28:16 <abhijitkumbhare> sure edwarnicke :)
17:28:27 <colindixon> dneary: the lake eats all the culture, bars, food, and life
17:28:34 <colindixon> it doesn’t make it across
17:28:56 <ebrjohn> what about Boulder, CO ?
17:29:22 <colindixon> #action phrobb to send an e-mail asking for any feedback about planning the ODL summit for 2016
17:29:38 <abhijitkumbhare> ebrjohn: is that for legalization of something - I forgot what it was that got legalized : )
17:29:53 <colindixon> #topic Beryllium
17:29:56 <ebrjohn> abhijitkumbhare: ;)
17:30:26 <colindixon> #info anipbu says that they’re addressing build issues with a cycle between aaa/netconf, patches are coming
17:30:31 <dfarrell07> ebrjohn abhijitkumbhare Seattle too ;)
17:30:35 <zxiiro> #link https://git.opendaylight.org/gerrit/26205/
17:30:59 <colindixon> #info zxiiro has been looking at sonar coverage this week to give all projects sonar code coverage for unit tests
17:32:55 <colindixon> #info the above patch when merged should give sonar unti test coverage for all projects
17:33:50 <dneary> colindixon, The floating bridge has to float on the bodies of something
17:33:59 <colindixon> #info ttkacik1 says that he figured out what the difference betwen jenkins code coverage and sonar code coverage reporting was, it was that sonar only counts UT in the same artifact
17:34:00 <tykeal> dneary: LOL
17:35:09 <colindixon> #info M2 offset 2 is today, send your things in
17:35:42 <colindixon> #Info zxiiro says that once the odlparent patch goes in, he will be proposing patches to remove the (often incorrect) jacoco config from their pom files
17:36:48 <colindixon> #info zxiiro says that IT stuff has to be done in the IT pom, integration-parent might be a good choice
17:36:59 <colindixon> #topic stable/lithium
17:37:33 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003754.html thread on moving Lithium-SR3
17:37:48 <colindixon> #topic system integration and test
17:37:52 <gzhao> anipbu2: thank you, well done.
17:38:08 <colindixon> #info not too much this week, the split happened and the issues seem to have been resolve
17:39:11 <colindixon> #info colindixon notes that only distribution of the integration projects is formally participating in Beryllium, he asks if there are any problems with that
17:39:58 <colindixon> #info edwarnicke asks if packaging needs to participate, dfarrell07 says that there was a long thread on that and decided intentionally not to, they package after the release
17:40:20 <colindixon> #Info dfarrell07 says that right now there is no continuous packaging delivery, but they’re moving that way
17:41:42 <colindixon> #topic infastructure
17:42:19 <colindixon> #Info yesterday they were having API issues with Rackspace, seems to have sorted itself out now
17:42:43 <colindixon> #info tykeal says that he now has a very, very basic Ubuntu image, but it’s yet to be tested in the sandbox
17:43:46 * edwarnicke turns cartwheels in his living room
17:43:53 <colindixon> #info tykeal says now is the time for people to start submitting patches to the ubutu vagrant in releng to see if they work
17:44:06 <rovarga_> any ETA on JIRA? :)
17:44:10 <colindixon> #topic mature projects/stable features
17:44:22 <colindixon> #Undo
17:44:22 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Topic object at 0x1d33350>
17:44:32 * edwarnicke would also like to ask about odlforge
17:44:35 <rovarga_> tykeal: cool, thanks
17:44:53 <colindixon> #info tykeal says JIRA is next on his list and odlforge is somewhat further down on his list
17:44:58 <colindixon> #topic mature projects/stable features
17:45:06 <dfarrell07> we <3 tykeal
17:45:19 <colindixon> everyone <3 tykeal
17:45:44 <colindixon> #info edwarnicke says there’s lots of stuff about stable feautres in the Beryllium release plan
17:46:10 <colindixon> #info edwarnicke notes that if we wait until the release review for the TSC to bless stable features, we will not get the results that we want
17:46:58 <colindixon> #info edwarnicke suggests instead (as PTL of distribution) that we start anipbu putting together a list of stable candiate feautres which could then be includied in a stable candidate distribution so we can start testing this stuff sooner
17:47:09 <colindixon> edwarnicke: huge +1
17:47:15 <colindixon> LuisGomez: also says huge +1
17:47:35 <anipbu2> Okay, will put together spreadsheet for stable candidate features.
17:47:51 <colindixon> anipbu: my suggestion would be to create another tab of the existing spreadsheet
17:49:11 <anipbu2> okay
17:49:58 <colindixon> #info edwarnicke notes that this would not be an official stable release, but a candidate one, i.e., we wouldn’t need to enforce everything
17:52:23 <edwarnicke> +10000 for use of extended
17:52:50 <colindixon> #info ttkacik1 notes that you have to have two feaute repositories, e.g., one stable and one for everythign else (called extended)
17:58:11 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003763.html proposed clarifications to the graudation review for a projec to be mature
18:00:15 <colindixon> #topic cookies
18:00:22 <edwarnicke> Apologies, I have to drop
18:00:33 <colindixon> #info dlenrow says the first ODL user group is on Tuesday in Caimbridge, MA
18:00:49 <tykeal> I've added links to pictures ;)
18:01:02 <phrobb> #link https://www.opendaylight.org/events/2015-09-08-000000/odlug-northeast-usa-initial-f2f-meeting  First NorthEast ODLUG Meeting
18:01:02 <ChrisPriceAB> will be cookies, dave promised
18:01:18 <colindixon> #endmeeting