17:00:20 <colindixon> #startmeeting tsc
17:00:20 <odl_meetbot> Meeting started Thu Sep 10 17:00:20 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:20 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:24 <colindixon> #topic roll call and agenda bashing
17:00:32 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=36541#Agenda the agenda in it’s usual place
17:00:34 <colindixon> #info colindixon
17:00:59 <edwarnicke> #info edwarnicke
17:01:02 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-09-03-17.00.html last week’s meeting minutes
17:01:32 <phrobb> I hate webex....
17:01:43 <edwarnicke> Agenda Bashing: I think we have another committer promotion: https://lists.opendaylight.org/pipermail/odlparent-dev/2015-September/000144.html
17:01:51 <phrobb> LuisGomez did you end the Integration meeting?.. webex tells me it's still going on
17:01:53 <tykeal> phrobb: LOL
17:02:11 <colindixon> lol
17:02:23 <phrobb> Whoever ran the SFC meeting... same question... Webex says it's still going on.. can you stop that meeting
17:02:34 <alagalah> phrobb, I think they are integrating the meetings
17:02:39 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
17:02:43 <ChrisPriceAB> #info Chris Price
17:02:43 <alagalah> no I'm not
17:02:44 <alagalah> I left
17:03:00 <alagalah> I wasn't host and I clicked leave meeting
17:03:20 <colindixon> phrobb: ebrjohn wants to know if he needs to end the SFC meeting somehow
17:03:20 <alagalah> #info alagalah (for Jan)
17:03:26 <colindixon> phrobb: ebrjohn says it’s over
17:03:37 <dfarrell07> #info Daniel Farrell
17:03:42 <ebrjohn> phrobb: we had the meeting previous to this, and Im pretty sure I ended it
17:03:52 <phrobb> yea... I'm going to call webex support... I seem to be hosed
17:03:53 <ebrjohn> Im completely disconnected from it
17:04:06 <Youcef> #info Youcef Laribi
17:04:27 <mohnish_> #info mohnish anumala
17:05:17 <ChrisPriceAB> padowan, have pateince
17:05:24 <colindixon> phrobb: is it save to use the host key yet?
17:05:35 <phrobb> sure, try
17:05:49 <phrobb> it should work as no one else is recording... I think
17:05:55 <colindixon> 30 seconds
17:05:57 <phrobb> I, as the owner am just locked out
17:06:10 <colindixon> nope
17:06:27 <colindixon> phrobb: kicked everyone out on using the host key
17:06:33 <phrobb> bummer
17:06:58 <ebrjohn> I got kicked out, shall we wait to connect again? or just go for it?
17:07:03 <colindixon> go for it
17:07:03 <LuisGomez> #info LuisGomez
17:07:05 * dfarrell07 is back and properly grumpy at WebEx
17:07:28 <colindixon> everyone feel free to rejoin and sorry for kicking everyone out
17:08:06 * edwarnicke is back and his normal cheery self
17:08:19 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003764.html phrobb started discussion on the idea of moving from WebEx to something else
17:08:25 <colindixon> #action phrobb to keep working on JIRA and let us know when we can use it
17:09:16 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003791.html phrobb sent mail asking for feedback on the 2016 ODL summit
17:09:37 <colindixon> #action tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
17:10:01 <tykeal> err... did we netsplit in the audio conference???
17:10:14 <colindixon> can people hear me?
17:10:18 <tykeal> I can't hear you
17:10:20 <dfarrell07> tykeal: +1, quite here
17:10:23 <abhijitkumbhare> No colindixon
17:10:24 <alagalah> colindixon, I can't hear you
17:10:25 <colindixon> any other topics people want to add to the agenda?
17:10:26 <mohnish_> i can
17:10:32 <oflibMichal> colindixon: i can hear you
17:10:32 <colindixon> yes, we’re netsplit
17:10:35 <alagalah> I heard tykeal
17:10:39 <alagalah> I hear dfarrell07
17:10:44 <colindixon> I can hear you two
17:10:50 <colindixon> I can hear dfarrell07 and tykeal
17:11:08 <colindixon> alagalah: sure if you come to Tokyo
17:11:32 <phrobb> ... still working with the webex guy... so netsplit on audio now... some can hear each other but others can't?
17:11:34 <colindixon> we’re still missing a Phil
17:11:49 <edwarnicke> Agenda Bashing: I think we have another committer promotion: https://lists.opendaylight.org/pipermail/odlparent-dev/2015-September/000144.html
17:12:06 <abhijitkumbhare> I think we are good now phrobb
17:13:22 <colindixon> #info note we are not recording becasue we don’t want to kick everyone out
17:13:51 <colindixon> #link https://lists.opendaylight.org/pipermail/odlparent-dev/2015-September/000144.html more committer nominations
17:14:06 <phrobb> recording started...
17:14:13 <colindixon> #topic events
17:14:28 <colindixon> #link https://www.opendaylight.org/global-events events in their normal place
17:15:07 <colindixon> #info most relevant upcoming events are  October 12, 2015 SDN & OpenFlow World Congress Düsseldorf, Germany  and  October 27, 2015 OpenStack Summit Tokyo, Japan
17:15:35 <colindixon> #info linuxcon europe is in a couple of weeks, dfarrell07 has a talk there
17:15:50 <abhijitkumbhare> #info recording started a minute ago
17:16:46 <colindixon> #info folks have been notified for presentations in dusseldorf and there’s a schedule up ther
17:17:11 <colindixon> #topic beryllium
17:17:37 <colindixon> #Info we have 5 projecst that haven’t reported M2: capwap, l2switch, lacp, reservation and snbi
17:18:10 <colindixon> #info offset 0 M3 is due next week and anipbu will send out an M3 template and reminder over e-mail next week
17:18:39 <colindixon> #info zxiiro has unit test coverage sonar reporting globally enabled and we have 27 projects with non-zero unit test coverage
17:19:01 <zxiiro> #link https://jenkins.opendaylight.org/releng/view/All-Sonar/
17:19:29 <colindixon> #link https://wiki.opendaylight.org/view/Weather note that NETCONF is moving to it’s own project and being removed crom controller
17:20:14 <colindixon> #Info anipbu2 and zxiiro have been hunting things breaking the autorelease builds, but it’s still failing and they’re still working to fix that
17:20:34 <colindixon> #topic stable/lithium
17:20:49 <colindixon> #info anipbu2 says we need a new date for SR3
17:21:14 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003760.html proposed movement
17:22:03 <colindixon> #action TSC members look at the mailing list thread on moving Lithium-SR3 to a better time here: https://lists.opendaylight.org/pipermail/tsc/2015-September/003760.html
17:22:31 <colindixon> #action colindixon to add a vote on the Lithium-SR3 date to the TSC agenda next week if we haven’t resovled
17:22:57 <colindixon> #topic system integration and test
17:23:17 <colindixon> #Info jamo is on jury duty and dfarrell07 covers
17:24:18 <colindixon> #info OPNFV/ODL sync meeting for a week from today (9/17) at 7a pacific with a focus on testing, so if you’re interested join
17:24:55 <colindixon> #info big effort in integration to create libraries to write clustering tests right now, so people who are intrested, so they should track it
17:26:25 <colindixon> #info colindixon asks edwarnicke if the stable/helium and stable/lithium distributions were moved to the integration/distribution project in addition to the beryllium distribution
17:27:41 <colindixon> #info colindixon asks if this changes the location in nexus because they will be org.integration.distribution groupId instead of org.integration groupId
17:28:57 <colindixon> #info for right now all integration subprojects can publish artifacts to any org.integration groupId, which means that might not be able stomp all over each other
17:29:31 <colindixon> #Info edwarnicke says that neither integration/test or integration/packaging write to nexus today, so it’s not an immediate issue
17:30:17 <colindixon> #action edwarnicke to start a conversation on the list about how we should manage groupIds for integration
17:31:43 <colindixon> #info edwarnicke notes that this is the first time we’ve ever migrated stable branches with a project splitting out, this might cause problems going forward
17:32:54 <jmedved> #info jmedved
17:33:00 <colindixon> #topic infrastructure
17:33:33 <colindixon> #info as of this morning, tykeal has an EL7 docker image working in the sandbox
17:33:59 <colindixon> #info tykeal has yet to see any patches coming in against the ubuntu images, but he thinks alagalah has been playing with it
17:34:31 <colindixon> #info tykeal’s next priority is working on getting JIRA up in the next week or two
17:34:49 <colindixon> #info as stated above we have sonar unit test coverage for all project thanks to zxiiro
17:35:50 <colindixon> #info colindixon asks if it’s a relevant question about our priorites betwen JIRA and odlforge
17:36:15 <colindixon> #info edwarnicke says that odlforge would be higher priority for him, but the fact that JIRA is more tractible immediately might make it the right first priority to have
17:36:29 <alagalah> #info Please note that jmedved is now present, and I am cede'ing my #info from earlier as his proxy
17:36:43 <colindixon> #Info tykeal says that there is still work going on the LF side to make odlforge a lot easier/possible to bring up
17:37:04 <alagalah> odlforge == more strategic
17:37:10 <alagalah> jira == more tactical
17:37:38 <colindixon> #topic topoprocessing committer promotions
17:37:42 <colindixon> #link https://lists.opendaylight.org/pipermail/topoprocessing-dev/2015-September/000072.html
17:38:31 <colindixon> #info Giorgio Garziano, Matej Perina, Andrej Zan have been nominated and gotten +1s from all current committers
17:39:10 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/owner:%22Matej+Perina+%253Cmatej.perina%2540pantheon.sk%253E%22 matej’s contributions
17:39:19 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/owner:%22Andrej+Zan+%253Candrej.zan%2540pantheon.sk%253E%22 andrej’s contributions
17:40:33 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/owner:%22Giorgio+Garziano+%253Cgiorgio.garziano%2540ericsson.com%253E%22+project:topoprocessing giorgio’s contributions
17:40:49 * dfarrell07 sanity checked the links
17:40:59 * edwarnicke can always count on dfarrell07
17:41:10 <dfarrell07> colindixon: group vote is fine w/ me
17:41:23 <colindixon> #startvote shall the TSC approve Giorgio Garziano, Matej Perina, Andrej Zan as committers on the topoprocessing project? -1, 0, +1
17:41:23 <odl_meetbot> Begin voting on: shall the TSC approve Giorgio Garziano, Matej Perina, Andrej Zan as committers on the topoprocessing project? Valid vote options are -1, 0, +1.
17:41:23 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:41:28 <mohnish_> #vote +1
17:41:30 <jmedved> #vote +1
17:41:30 <colindixon> #vote +1
17:41:33 <dfarrell07> #vote +1
17:41:34 <LuisGomez> #vote +1
17:41:36 <edwarnicke> #vote +1
17:41:38 <uri_> #vote +1
17:41:40 <ChrisPriceAB> #vote +1
17:41:47 <colindixon> #endvote
17:41:47 <odl_meetbot> Voted on "shall the TSC approve Giorgio Garziano, Matej Perina, Andrej Zan as committers on the topoprocessing project?" Results are
17:41:47 <odl_meetbot> +1 (8): jmedved, ChrisPriceAB, LuisGomez, edwarnicke, dfarrell07, uri_, colindixon, mohnish_
17:41:55 * tykeal fires up his LDAP client
17:42:06 <colindixon> #agreed Giorgio Garziano, Matej Perina, Andrej Zan are now committers on the topoprocessing project
17:42:20 <colindixon> #topic new committers on the odlparent project
17:42:24 <colindixon> #link https://lists.opendaylight.org/pipermail/odlparent-dev/2015-September/000144.html
17:42:29 <oflibMichal> thank you all TSC members
17:42:40 <dfarrell07> oflibMichal: Thank *you* for your contributions :)
17:42:45 <colindixon> #info Vaishali nominated rovarga and zxiiro  as contributors
17:42:45 <abhijitkumbhare> Congrats Giorgio Garziano, Matej Perina, Andrej Zan
17:43:37 <colindixon> #Info the thread with the starting at the above link has +1s from all 3 current odlparetn commiters
17:43:52 * dfarrell07 sanity checked the link (and link to contributions in that email)
17:44:42 <colindixon> #link https://git.opendaylight.org/gerrit/#/q/status:merged+project:odlparent this shows a lot of activity from rovarga (Robert) and zxiiro (Thanh)
17:45:08 <colindixon> #startvote shall the TSC approve Robert Varga and Thanh Ha as committers on odlparent? -1, 0, +1
17:45:08 <odl_meetbot> Begin voting on: shall the TSC approve Robert Varga and Thanh Ha as committers on odlparent? Valid vote options are -1, 0, +1.
17:45:08 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:45:10 <dfarrell07> #vote +1
17:45:11 <colindixon> #vote +1
17:45:12 <ChrisPriceAB> #vote +1
17:45:17 <mohnish_> #vote +1
17:45:19 <LuisGomez> #vote +1
17:45:20 <uri_> #vote +1
17:45:33 <colindixon> #endvote
17:45:33 <odl_meetbot> Voted on "shall the TSC approve Robert Varga and Thanh Ha as committers on odlparent?" Results are
17:45:33 <odl_meetbot> +1 (6): LuisGomez, dfarrell07, ChrisPriceAB, uri_, colindixon, mohnish_
17:45:34 <edwarnicke> #vote +1
17:45:36 <colindixon> #startvote shall the TSC approve Robert Varga and Thanh Ha as committers on odlparent? -1, 0, +1
17:45:37 <odl_meetbot> Begin voting on: shall the TSC approve Robert Varga and Thanh Ha as committers on odlparent? Valid vote options are -1, 0, +1.
17:45:37 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:45:41 <colindixon> #endvote
17:45:41 <odl_meetbot> Voted on "shall the TSC approve Robert Varga and Thanh Ha as committers on odlparent?" Results are
17:46:01 <colindixon> #agreed Robert Varga (rovarga) and Than Ha (zxiiro) are now committers on odlparent (also with edwarnicke’s +1)
17:46:24 <edwarnicke> Congratulations all :)
17:46:32 <dfarrell07> Congrats @ all! :)
17:46:37 <rovarga> thanks ;-)
17:46:59 <colindixon> #topic mature projects/stable features
17:47:15 <abhijitkumbhare> Congrats rovarga and zxiiro :)
17:47:22 <colindixon> #link https://wiki.opendaylight.org/view/Graduation_Reviews/Template the proposed template mostly by edwarnicke on how to do graduation reveiws to make projects mature
17:47:35 <jmedved> congrats all!
17:47:53 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003783.html thread asking for (and receiving) feedback on the template
17:48:57 <colindixon> #link https://www.opendaylight.org/project-lifecycle-releases the project lifecycle that informed this template
17:50:06 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003763.html a list of proposed clalifications from colindixon a while back, some of which are incorporated into the template, but others of wihch might or might not be
17:52:57 <colindixon> #Info colindixon notes that handling security vulnerabilities feel like “working code”, but that will likely be put into the marture release process bullet
17:53:50 <abhijitkumbhare> does upper case “I” work in #Info colindixon ?
17:53:58 <rovarga> odlparent/yangtools may have trouble providing a systemtest in the sense other projects provide it
17:53:58 <colindixon> abhijitkumbhare: it does
17:54:02 <abhijitkumbhare> ok
17:54:04 <colindixon> #info colindixon says he feels like passing system tests are too low a bar for “working code”, really he feels as though the test should revolve around a user being able to get the code, and use it to accomplish the primary task
17:55:20 <colindixon> #info dfarrell07, alagalah, edwarnicke, and colindixon seem to say that system tests are good, but not sufficient to meet the “working code”
17:55:53 <colindixon> #link https://wiki.opendaylight.org/index.php?title=Graduation_Reviews%2FTemplate&diff=36559&oldid=36548 edwarnicke made an edit to reflect this discussion
17:58:28 <colindixon> #info colindixon says that the revision look good, it seems to summarize the notion that a user can get and use the code to do it’s primary focus
17:59:32 <colindixon> #info dfarrell07 asks can we add a request to provide evidence that there’s a clean way for new people to get involved in the project without needing to know secret phone numbers, etc.
18:00:02 <colindixon> #Info colindixon asks if having a regular meeting is something we should ask for, edwarnicke and dfarrell07 say no
18:00:31 <dfarrell07> edwarnicke: that looks good to me
18:01:51 <rovarga> do we have a map of where the web of trust has presence?
18:03:42 <colindixon> #info colindixon asks if we’d like to see at least one committer with a GPG key attached to the web of trust, there is strong pushback
18:04:02 <abhijitkumbhare> edwarnicke: this is a good template
18:04:19 <tykeal> rovarga: https://wiki.opendaylight.org/view/GPG there's a link into a google map here: https://www.google.com/maps/d/edit?mid=zwZXpcl93umw.kiVCOviyTqE0
18:04:25 <tykeal> folks haven't been adding themselves
18:04:27 <edwarnicke> abhijitkumbhare: Many thanks :)
18:04:37 <colindixon> #action TSC members (and others) please do review the mature template online here https://wiki.opendaylight.org/view/Graduation_Reviews/Template
18:04:49 <edwarnicke> tykeal: How does one update ones location on the map?
18:04:51 <colindixon> #action tykeal to send out the map of people who are attached to the odl GPG web of trust
18:04:53 * edwarnicke relocates frequently
18:05:01 <abhijitkumbhare> may be some things may be added/removed/modified edwarnicke - but by & large in the right direction
18:05:03 <tykeal> edwarnicke: info is in the map description
18:05:08 <colindixon> #endmeeting