17:00:15 <colindixon> #startmeeting tsc
17:00:15 <odl_meetbot> Meeting started Thu Sep 17 17:00:15 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:00:15 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:15 <odl_meetbot> The meeting name has been set to 'tsc'
17:00:21 <colindixon> #topic agenda bashing and roll call
17:00:35 <colindixon> #chair phrobb- phrobb dfarrell07 tbachman
17:00:35 <odl_meetbot> Current chairs: colindixon dfarrell07 phrobb phrobb- tbachman
17:01:35 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=36794#Agenda the agenda in it’s usal place
17:01:48 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-09-10-17.00.html last week’s meeting minutes
17:01:58 <colindixon> #info colindixon
17:02:06 <ChrisPriceAB> #info Chris Price
17:02:12 <vishnoianil> #info vishnoianil
17:02:15 <phrobb> #info TSC members please #info in
17:02:25 <dfarrell07> #info Daniel Farrell
17:02:33 <edwarnicke> #info edwarnicke
17:02:35 <mohnish_> #info mohnish
17:03:02 <colindixon> #info colindixon notes that Anil Vishnoi is standing in for Luis Gomez and Mahesh Venkat is standing in for Dave Lenrow
17:03:27 <KLuehrs> #info Kevin Luehrs (UNIMgr)
17:03:46 <phrobb> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
17:04:22 <colindixon> #action edwarnicke to start a conversation on the list about how we should manage groupIds for integration
17:04:31 <colindixon> #action phrobb to keep working on JIRA and let us know when we can use it
17:04:50 <dfarrell07> KLuehrs: are you standing in as a TSC member today?
17:05:06 * dfarrell07 is trying to figure out if we have quorum
17:05:27 <colindixon> #action tony and zxiiro to look at the sonar/jacoco reports and try to figure out how (and if) we can reasonby get feature-level code coverage information
17:05:46 <phrobb> KLuehrs we only have the actuall TSC members #info in... that way it's easy for us to track quorum :-)
17:06:09 <colindixon> #info ttkacik says that he has an idea for how to do this, which is basically using the sonar APIS
17:07:19 <Youcef> #info Youcef Laribi
17:07:33 <phrobb> FYI we have quorum with 7 TSC members present
17:07:46 <phrobb> Welcome Youcef
17:08:03 * ChrisPriceAB is loving webex today.... be with you soon.
17:08:23 <Youcef> Thanks Phil
17:08:25 * dfarrell07 just added his location info to id.odl.org /cc tykeal
17:08:46 <colindixon> #topic locations for ODL community members
17:09:14 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003825.html there’s an e-mail looking for people voluntarily list their locations so that we have an idea of who is where and can help create connections
17:09:46 <colindixon> #link https://identity.opendaylight.org/ tykeal points out we have this information in a database there, you can update yours
17:10:42 <colindixon> #Info many people feel like we likley want to only expose city-level information at the finest granularity
17:10:54 * tykeal mutters things about his VoIP falling over
17:11:26 <colindixon> #topic events
17:11:59 <colindixon> #link https://www.opendaylight.org/global-events the events page
17:12:14 <colindixon> #info OF world congress in dusseldorf on 10/7
17:12:35 <colindixon> #Info hackfest on 11/9 with the OPNFV summit
17:12:39 <ChrisPriceAB> :O
17:12:56 <colindixon> #info the ODL summet will be the week of 9/26 in Bellevue, WA
17:13:23 <tykeal> finally back in the call *sigh*
17:13:31 <colindixon> #link http://regonline.com/ODLHackfest2015 register fo the november hackfest here
17:13:50 <abhijitkumbhare> Good call on the date phrobb (Sept)
17:14:01 <colindixon> #info openstack summit in tokyo on 10/27
17:14:17 <colindixon> #topic TSC at large elections
17:14:43 <colindixon> #info phrobb says that it’s time to do our TSC at large elections, we currently have two seats which went to edwarnicke and colindixon
17:15:00 <colindixon> #info phrobb asks if we want to stay at 2 seats or change the number
17:16:04 <colindixon> #info edwarnicke says his feeling is that it should be more than 2
17:17:01 <colindixon> #info mohnish_ asks why and why it was 2, edwarnicke says his recollection that 2 was sort of the right amoutn given the relative immaturity of the community
17:17:42 <colindixon> #Info colindixon says more than 2 and less than 5 makes snese in his gut
17:18:32 <colindixon> #info dfarrell07 says that OPNFV seems to be strugging with thie issue of the size of the TSC, there are some issues that we should think about
17:19:00 <colindixon> #info ChrisPriceAB says he’d like to see us move projects through the lifecycle and see project leads be TSC members
17:20:10 <colindixon> #info colindixon notes that requires projects moving to core, which is likely to not happen at least until Boron and maybe beyond
17:20:33 <colindixon> #info colindixon asks how big the OPNFV TSC is, ChrisPriceAB says it’s 18 and he hasn’t found problems with that
17:21:13 <ChrisPriceAB> lets hear from someone who doesn't want more people...
17:21:26 <colindixon> #info there is coverage of the long-term plan that we don’t have platinum-appointees as TSC members but that TSC members come from the projects, we would lke to ge tthere sooner rather than later
17:21:48 <edwarnicke> ChrisPriceAB:  We need an advocate for -1 ;)
17:21:54 <ChrisPriceAB> hehe
17:22:36 <vishnoianil> ChrisPriceAB, edwarnicke -1 is even more complex number, becaues then you have to decide to whom to kick out :D
17:22:51 <edwarnicke> vishnoianil: Only if you try to take its square root ;)
17:23:00 <vishnoianil> ChrisPriceAB, edwarnicke i am not tsc member, so watching that would be fun :D
17:23:01 <colindixon> #info mohnish_ says he’d like to advocate avoid too much churn because it might weaken the TSC
17:23:10 <ChrisPriceAB> :D
17:23:20 <abhijitkumbhare> I was going to say square root of -1 edwarnicke vishnoianil
17:23:27 <abhijitkumbhare> :)
17:23:33 <colindixon> #info mohnish_ asks if we shoudl consider the PTLs of mature projects as well
17:23:39 <ChrisPriceAB> The dark side I sense in you vishnoianil
17:24:06 <abhijitkumbhare> vishnoianil has too much force in him ChrisPriceAB :)
17:24:32 <jmedved> #info jmedved
17:24:34 <vishnoianil> ChrisPriceAB, just like any normal human being, i too like fun.. given that i am not the target :D
17:25:04 <edwarnicke> abhijitkumbhare: Are you implying that  there isn't enough light side of the force and so vishnoianil is only explainable by also drawing from the dark side? :)
17:25:39 <colindixon> #info ChrisPriceAB says that given we won’t have core projects and thus PTLs automatically on the TSC, we might consider having more at large seats until that point
17:25:57 <abhijitkumbhare> edwarnicke: vishnoianil has both sides of the force - light & dark side
17:26:29 * edwarnicke has never been a numberist ;)
17:26:41 <colindixon> #startvote shall the TSC approve 4 seats for the upcoming TSC at large election? -1, 0, +1
17:26:41 <odl_meetbot> Begin voting on: shall the TSC approve 4 seats for the upcoming TSC at large election? Valid vote options are -1, 0, +1.
17:26:41 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:26:47 <dfarrell07> #vote +1
17:26:48 <edwarnicke> #vote +1
17:26:49 <colindixon> #vote +1
17:26:54 <ChrisPriceAB> #vote +1
17:26:57 <mohnish_> #vote +1
17:26:58 <vishnoianil> #vote  +1
17:26:59 <Youcef> #vote 0
17:27:14 <colindixon> #endvote
17:27:14 <odl_meetbot> Voted on "shall the TSC approve 4 seats for the upcoming TSC at large election?" Results are
17:27:14 <odl_meetbot> 0 (1): Youcef
17:27:14 <odl_meetbot> +1 (6): ChrisPriceAB, dfarrell07, edwarnicke, colindixon, mohnish_, vishnoianil
17:27:26 <colindixon> #agreed in the upcoming at large electin, there will be four seats available
17:27:32 <ChrisPriceAB> ooh exciting!
17:27:54 <colindixon> #info edwarnicke asks when the next board elections are, phrobb says the terms are 2 years, so not until next year
17:28:19 <colindixon> #Info phrobb says that alternating two-year terms are in the board by-laws
17:29:02 <colindixon> #info phrobb says that in our bylaws we have a statement to the effect “platinum members are allowed to appoint a representative unless they are otherwise represented"
17:29:42 <colindixon> #info this would technically force out appointed members if a non-appointed members of the same platinum compnay won an at-large seat
17:29:53 <colindixon> #info the board waived this for a year with the last election
17:30:10 <colindixon> #Info we don’t have the power to make that decision, but we can make a recommendation
17:30:57 <colindixon> #action phrobb will send the detailed language about how at-large elections and platinum appointees interact
17:32:16 <dfarrell07> phrobb: clear to me fyi
17:32:42 <mohnish_> colin: can you please repeat the max number of TSC at-large?
17:32:52 <mohnish_> from a single company?
17:33:03 <dfarrell07> mohnish_: I think 1 at-large per company was what he said
17:33:12 <mohnish_> Ok, thanks
17:33:15 <dfarrell07> np :)
17:33:16 <colindixon> #info ChrisPriceAB asks what the maxiumum number of votes for a single company is
17:33:32 <colindixon> #info colindixon says that only one at-large member is allowed per company
17:34:03 <colindixon> #info colindixon also notes that is no restriction on the nubmer of PTLs that can come from a given company
17:35:25 <colindixon> are people conformtable making a recommendation on this waiver right now or not
17:37:33 <colindixon> #info colindixon and ChrisPriceAB say they might abstain because they’re affected, phrobb notes that logic might result in nobody that could vote
17:38:57 <gzhao> -:)
17:39:06 <colindixon> #info ChrisPriceAB says he thinks the current plantinum delegates/appointees add value, so he thinks it works out well, but he wouldn’t oppose letting waiver lapse
17:39:23 * ChrisPriceAB is also recalling that point yep.
17:39:48 * ChrisPriceAB stares threateningly at colleagues!
17:39:49 <colindixon> #info colindixon says the other reason we approved the waiver because it might discourage technical community members from running becuase they might oust their delegates (who are likely people of authority in their company)
17:39:51 <gzhao> Question: the person has to be PTL in order to run at large TSC, is that right?
17:40:14 <colindixon> gzhao: no, just a committer
17:40:17 * dfarrell07 would vote to keep the waver given the current arguments
17:40:27 <colindixon> I’d say keep the waiver
17:41:52 <gzhao> #info gzhao asks if TSC at large  needs to be PTL, colindixon says committers will qualify for running.
17:41:58 * ChrisPriceAB +1 dfarrell07
17:42:07 <Youcef> I think we should keep the waiver
17:42:23 <colindixon> #info it seems like there’s generally consensus that keeping the waiver is a good idea
17:42:48 <colindixon> #topic beryllium
17:42:49 <colindixon> #info M3 for offset 0 is due today
17:42:59 <colindixon> #info we still have one project without an M2 status: SNBI
17:43:25 <colindixon> #info we recently added all the new beryllium project to autorelease
17:43:50 <colindixon> #info weather: all projects have merged their netconf migration patches, half projects have merged the md-sal migration patches (thanks ttkacik!)
17:44:10 <colindixon> #info beryllium autorelease build is still broken, waiting on it to be merged by centinel
17:44:20 <colindixon> #topic stable/lithium
17:44:38 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003754.html moving the Lithium-SR3 date
17:45:15 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003824.html colindixon recommendation would be to target 11/19 (which is 6 weeks after SR2)
17:45:56 <colindixon> #info if we did SR3 on 11/19 the normal calculations would but SR4 to march 3rd
17:46:17 <ChrisPriceAB> double negative! sir!
17:46:42 <colindixon> #agreed that we’ll move Lithium-SR3 to 11/19 and Lithium-SR4 to 3/3 (2016)
17:47:02 <colindixon> #topic system integration & test
17:47:17 <colindixon> #info they finished the template for offest 0 projects to use at M3
17:47:27 <colindixon> #infrastructure
17:47:32 <colindixon> #topic infrastructure
17:47:50 <colindixon> #info zxiiro has modified thigns so that build and merge now run on EL7 systems
17:48:00 <dfarrell07> huzzah for both JIRA and CentOS 7! :D
17:48:20 <colindixon> #link https://nexus.opendaylight.org/content/sites/site/org.opendaylight.releng.autorelease/beryllium/dnvtools/dnvtool.html#version_skew ahbishek (who was an inter) and zxiiro  have gotten live update version skew dependency tracking
17:49:01 <colindixon> #Info it’s not tottally live now, but that’s coming
17:49:52 <colindixon> #topic mature projects and graduation review template
17:50:23 <edwarnicke> #link https://wiki.opendaylight.org/view/Graduation_Reviews/Template
17:50:42 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003833.html this is the tail of the mailing list thread
17:50:44 <ttkacik> dependency graph is Lithium based, version skew is Beryllium
17:54:22 <ChrisPriceAB> it's creation to incubation -> incubation==try new things
17:54:58 <colindixon> #info edwarnicke asks if sending the graduation review to the tsc list instead of the project-proposals list, colindixon says it’s too bad we didn’t have a lifecycle-changes list instead of project-proposals, but for now just using TSC
17:55:03 <colindixon> #undo
17:55:03 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1cb9b90>
17:55:12 <colindixon> #info edwarnicke asks if sending the graduation review to the tsc list instead of the project-proposals list, colindixon says it’s too bad we didn’t have a lifecycle-changes list instead of project-proposals, but for now just using TSC is probably right since we just don’t need more mailing lists
17:56:05 <ChrisPriceAB> IMHO: review to maturity should be more or less straightforward as well if the criteria is clear.  Core is another story all together.
17:56:47 <colindixon> #info mohnish_ asks if there’s a way we can have a phase before a graudation review where the TSC can think about things
17:57:44 <colindixon> #info colindixon says there is a 2 week waiting peroid that is required
17:58:20 <colindixon> #info mohnish_ asks if we can figure what we need to in those two weeks, ChrisPriceAB says these projects should be ones we’re pretty familiar with, so maybe it’s OK
17:58:31 <edwarnicke> #link https://www.opendaylight.org/project-lifecycle-releases
18:01:36 <colindixon> #info colindixon notes that while he agrees with letting it slide here, technically the graduation review in the lifecycle seems to (erroneously?) state that a project must join a top-level projct, we shouldprobalby fix that
18:01:42 <mohnish_> I have to leave.
18:03:16 <colindixon> #action colindixon to rally TSC members to engage on the mailing list
18:03:17 <mohnish_> Coli/Ed: Thanks for putting time in graduation reviews.
18:03:18 <colindixon> #topic cookies
18:03:27 <dfarrell07> thanks @ all :)
18:03:32 <colindixon> #endmeeting