16:59:37 <colindixon> #startmeeting tsc
16:59:37 <odl_meetbot> Meeting started Thu Oct  1 16:59:37 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:59:37 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:37 <odl_meetbot> The meeting name has been set to 'tsc'
16:59:43 <colindixon> #topic agenda bashing and roll call
16:59:53 <colindixon> #info TSC members please #info in
16:59:55 <colindixon> #info colindixon
17:00:13 <colindixon> #chair phrobb phrobb- tbachman dfarrell07 anipbu gzhao
17:00:13 <odl_meetbot> Current chairs: anipbu colindixon dfarrell07 gzhao phrobb phrobb- tbachman
17:00:39 <mohnish_> #info mohnish anumala
17:00:47 <dneary> Joining late for the TSC meeting - need to get some calories
17:00:53 <dfarrell07> #info Daniel Farrell
17:01:05 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=37106#Agenda the agenda in it's usual place
17:01:12 <ghall> #info Greg Hall proxy for Luis G P
17:01:24 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-09-24-17.00.html last week's minutes part 1
17:01:45 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-09-24-17.44.html last weeks minutes part 2
17:02:15 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR2) https://bugs.opendaylight.org/show_bug.cgi?id=3160
17:02:40 <ChrisPriceAB> #info Chris Price
17:02:43 <dlenrow> #info dlenrow
17:03:14 <phrobb> #info add committer-at-large discussion to the agenda
17:04:08 <edwarnicke> #info edwarnicke
17:04:39 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003889.html colindixon started a thread on JIRA, he's waitin on interested parties to pick it up
17:05:13 <colindixon> #topic events
17:05:26 <colindixon> #link https://www.opendaylight.org/global-events the events page in it's usual place
17:06:04 <colindixon> #link https://www.opendaylight.org/events/2015-11-09-000000-2015-11-10-000000/opendaylight-hackfest register for the hackfest near SFO on 11/9/2015
17:06:04 <dfarrell07> #info dfarrell07 has an ODL talk at LinuxCon EU next week
17:06:15 <colindixon> #info other information and details are on the page above
17:06:41 <ChrisPriceAB> #info The OPNFV dev summit will likely include Jira training for users and project planners, ODL members welcome
17:06:47 <colindixon> #topic beryllium
17:07:03 <dfarrell07> ChrisPriceAB: ACK, good idea
17:07:13 <colindixon> #Info anipbu M3 offset 1 is due today, we have some things coming in
17:07:37 <zxiiro> #link https://bugs.opendaylight.org/show_bug.cgi?id=4371 Alto bug blocking beryllium build
17:07:46 <colindixon> #info alto is breaking the build, has been removed from the autorelease until it's fixed
17:08:25 <colindixon> #topic beryllium weather
17:09:02 <colindixon> #info some jobs were stalling during feature tests and it seems like TomP and zxiiro have fixed it
17:09:14 <colindixon> #info it appears as though it may have been related to the new yang parser
17:09:29 <colindixon> #link https://wiki.opendaylight.org/view/Weather#2015-09-29_YANG_Parser_implementation_switch this appears to be related to this weather event
17:10:24 <colindixon> #info mohnish_ says he definitely ran into these issues, he's now able to build this morning, but seeing lots more warnings
17:10:51 <colindixon> #info ttkacik says the new warnings are because the new parser is a bit stricter
17:12:00 <colindixon> #info ttkacik says he thinks two projects actually had failed builds because of this, e.g., Armoury and NIC
17:14:23 <cdub> colindixon: agreed re: not good to break, despite better spec conformance
17:15:12 <colindixon> #info colindixon says that the most important thing here is to just make sure make sure to respect developer time and expectations, so saying that you failed to write valid yang even though we accepted it in the past makes it your fault is probably not the right approach
17:16:50 <colindixon> #info colindixon notes that the performance issues reported about the weather event were noted only 2 hours before the patches were merged despite many people asking about possible issues many times
17:17:14 <colindixon> #link https://lists.opendaylight.org/pipermail/release/2015-October/003838.html discussion on the mailing list
17:19:32 <colindixon> #info to get around this, rovarga says we need either (i) a staging pipeline to test a set of patches across projects together, and (ii) continuous release in some form
17:20:30 <dfarrell07> colindixon: big +1 to bringing up the CR planning
17:21:43 <phrobb> Hey Andy.  All of the project's info boxes seem to have bad pointers to their repos... they all take the form "https://git.opendaylight.org/gerrit/<projname> ... and that URL returns a 404 error.  Did something change causing that or have they all been wrong forever?
17:22:07 <phrobb> sorry folks... wrong window
17:22:26 <colindixon> #info cdub agrees about continuous release, colindixon notes that there are efforts and we should talk about it boron
17:22:44 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Upstream_version_upgrades upstream version upgrades
17:23:22 <colindixon> #info there's a process of upgrading external dependencies to get security patches and bug fixes
17:24:00 <colindixon> #info a lot of attention is going into making sure this is a painless as possible, but it's possible unexpected things could happen
17:24:54 <colindixon> #info this was discussed on the TWS call on Monday and there was a recording, we've done 5 of 11 upgrades, the next one is Karaf which is happening on Monday next week
17:26:54 <cdub> is there a downside?
17:27:07 <phrobb> #topic Stable Li
17:28:57 <phrobb> #info Li SR2 cutoff is this coming Sunday at midnight UTC
17:29:05 <ghall> #info question, did we skip over "Timing of branch cutting" for Be?
17:35:04 <ChrisPriceAB> Would like project lead input, maybe on mailing list.
17:37:05 <phrobb> #info colindixon notes that we will need to vote on the timing of branch cutting within two weeks and we will continue the discussion on the thread.
17:37:30 <phrobb> #topic System Integration and Testing
17:37:42 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003879.html Thread about version bumping, please comment in the next week or so
17:38:10 <phrobb> #topic Infrastructure
17:38:15 <phrobb> thnaks dfarrell07
17:38:53 <gzhao> #info tykeal said Jira is running but need people feedback
17:39:00 <phrobb> #info testing of Ubuntu images ongoing.... Jira site got running last week and Andy hasn't heard anything from anyone yet
17:39:40 <gzhao> #info zxiiro is going to be on vacation
17:39:49 <phrobb> #info the info in Jira is over a week old and getting stale... *if* we choose to go with Jira we will be deleting everything in the current instance... this is just a "test" instance
17:40:22 <phrobb> #info Rackspace private cloud making progress.. no more details there yet
17:40:53 * colindixon is back
17:40:57 <colindixon> #topic committer-at-large elections
17:41:27 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-October/003905.html phrobb's email
17:41:42 <colindixon> #undo
17:41:42 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x189f790>
17:42:47 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-October/003903.html phrobb's mail on the topic and colin's clarifications
17:42:52 <dfarrell07> colindixon: yes
17:43:15 <colindixon> #info colindixon says his memory from last week was that we decide the pros of extending the waiver outweighed the cons
17:44:08 <colindixon> #startvote shall the TSC formally ask the board to extend the waiver for another year for platinum appointed TSC members to remain on the TSC even if at-large members also represent their organziation? -1, 0, +1
17:44:08 <odl_meetbot> Begin voting on: shall the TSC formally ask the board to extend the waiver for another year for platinum appointed TSC members to remain on the TSC even if at-large members also represent their organziation? Valid vote options are -1, 0, +1.
17:44:08 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:44:11 <dlenrow> #vote +1
17:44:12 <dfarrell07> #vote +1
17:44:17 <colindixon> #vote +1
17:44:19 <ChrisPriceAB> #vote +1
17:44:20 <mohnish_> #vote +1
17:44:33 <edwarnicke> #vote +1
17:44:41 <alagalah> #vote +1 (proxy for Jan)
17:44:41 <odl_meetbot> alagalah: +1 (proxy for Jan) is not a valid option. Valid options are -1, 0, +1.
17:44:48 <alagalah> #vote +1
17:45:19 <uri_> #vote +1
17:45:25 <colindixon> #endvote
17:45:25 <odl_meetbot> Voted on "shall the TSC formally ask the board to extend the waiver for another year for platinum appointed TSC members to remain on the TSC even if at-large members also represent their organziation?" Results are
17:45:25 <odl_meetbot> +1 (8): dlenrow, ChrisPriceAB, dfarrell07, edwarnicke, uri_, colindixon, mohnish_, alagalah
17:45:46 <colindixon> #agreed the TSC will ask the board to extend the waiver around platinum appointed TSC members
17:45:46 <ghall> #vote +1 ( proxy for Luis )
17:46:41 <dfarrell07> ghall: (for the sake of feedback/learning) the vote has ended, needed to be between #startvote and #endvote. Also, it wouldn't have accepted the part in parens, as alagalah demoed
17:47:04 <colindixon> #info note that ghall votes +1 for LuisGomez as well
17:47:14 <dfarrell07> ghall: if you care a lot about being on the record vote-wise, you can #info your desire to vote in
17:48:30 <ChrisPriceAB> next time we vote -1 ;)
17:48:54 <colindixon> #topic mature projects/stable features
17:49:25 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003783.html a lenghty thread on graduation reviews
17:49:41 <colindixon> #link https://wiki.opendaylight.org/view/Graduation_Reviews/Template the draft template for graduation reviews
17:50:52 * ChrisPriceAB thinks it's time to push the button
17:52:23 <ChrisPriceAB> who is chaired in?
17:52:23 <colindixon> #startvote the TSC would like to use this template for graudation reviews and invidual members can vote their conscience based on the information in the thread discussion it https://wiki.opendaylight.org/view/Graduation_Reviews/Template ? -1, 0, +1
17:52:23 <odl_meetbot> Begin voting on: the TSC would like to use this template for graudation reviews and invidual members can vote their conscience based on the information in the thread discussion it https://wiki.opendaylight.org/view/Graduation_Reviews/Template ? Valid vote options are -1, 0, +1.
17:52:23 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
17:52:35 <dneary> colindixon, I saw a startvote
17:52:43 <ChrisPriceAB> #vote +1
17:52:45 <colindixon> #vote +1
17:52:46 <edwarnicke> #vote +1
17:52:46 <dfarrell07> #vote +1
17:52:47 <ghall> #vote +1
17:52:48 <mohnish_> #vote +1
17:52:50 <alagalah> #vote +1
17:53:03 <uri_> #vote +1
17:53:20 <colindixon> #endvote
17:53:20 <odl_meetbot> Voted on "the TSC would like to use this template for graudation reviews and invidual members can vote their conscience based on the information in the thread discussion it https://wiki.opendaylight.org/view/Graduation_Reviews/Template ?" Results are
17:53:20 <odl_meetbot> +1 (8): ghall, dfarrell07, ChrisPriceAB, uri_, edwarnicke, colindixon, mohnish_, alagalah
17:53:38 <colindixon> #agreed the TSC is now open to accepting requests for graudation reviews based on this template: https://wiki.opendaylight.org/view/Graduation_Reviews/Template
17:54:10 <edwarnicke> Let the Boron puns begin! :)
17:54:12 <ChrisPriceAB> bring it on projects!!!
17:54:15 <colindixon> #topic boron planning
17:54:32 * ChrisPriceAB think's Ed's being a ...
17:55:26 <edwarnicke> LOL
17:56:14 <colindixon> #info colindixon asks if there are focus ares people are interested in and/or would like to see in Boron
17:56:51 <dfarrell07> It seems like CR stuff has come up many times as a possible future solution to various problems, which sounds like a good Boron goal
17:56:55 <colindixon> #info colindixon has heard from people that they'd be interested in a bunch of things including
17:57:01 <colindixon> #info continous release
17:57:02 * ChrisPriceAB is thinking the cPerf dashboard could be used to provide daily stats of that type.
17:57:18 <colindixon> #info faster than 6-month reelase cadence
17:57:47 <colindixon> #info lighter-weight process
17:57:53 <colindixon> #info scale improvments
17:58:08 <phrobb> #info alagalah  asks that we have a round table of Advisory Group members and a good group of PTLs to discuss Boron planning
17:58:19 <uri_> +1
17:58:22 <colindixon> #info cross-release compatibility, e.g., boron openflow plugin could run in an otherwise-beryllium controller
17:59:11 <colindixon> #action colindixon to reach out to the advisory gorup for input on Boron
17:59:35 <ChrisPriceAB> Could the advisory group have some time on this call?
18:00:12 <colindixon> #action alagalah to organize a panel/mailing list thead for the PTLs to also provide info on Boron
18:00:20 <ghall> #info If CR or any other solution can provide stability for projects which depend on yang/netconf/restconf/mdsal/aaa as those projects get big changes ... then that's a priority.
18:00:34 <colindixon> #action colindixon to see if we can find some time for the advisory group on the TSC call in the future
18:00:44 <phrobb> #info colindixon notes that ramp up time for somethings like moving to CI/CB and migration strategies is needed hence the reason to getting the Boron discussions going on now
18:00:51 * ChrisPriceAB is always happy to create work for others...
18:01:22 <colindixon> #topic cookies
18:01:25 <colindixon> #endmeeting