#opendaylight-meeting: tsc

Meeting started by colindixon at 17:02:10 UTC (full logs).

Meeting summary

  1. roll call and agenda bashing (colindixon, 17:02:17)
    1. edwarnicke (edwarnicke, 17:02:36)
    2. mohnish anumala (mohnish_, 17:02:36)
    3. https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=37552#Agenda the agenda in it's usual place (colindixon, 17:02:49)
    4. https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-10-08-17.00.html last week's meeting minutes (colindixon, 17:03:04)
    5. ACTION: colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR3) https://bugs.opendaylight.org/show_bug.cgi?id=3160 (colindixon, 17:03:12)
    6. dlenrow (dlenrow, 17:03:15)
    7. Daniel Farrell (dfarrell07, 17:03:18)
    8. colindixon is planning to present Advisory Group about Boron on next week on 10/22 (colindixon, 17:03:38)
    9. colindixon (colindixon, 17:04:07)
    10. jmedved (jmedved, 17:05:07)
    11. LuisGomez (LuisGomez, 17:05:38)
    12. ACTION: ttcacik and zxiiro to work on getting feature-level code coverage numbers (colindixon, 17:06:42)
    13. ACTION: colindixon to figure out where we lost action items, e.g., feature-level code coverage and make sure we didn't lose any others (colindixon, 17:07:04)
    14. abhijitkumbhare (abhijitkumbhare, 17:08:00)

  2. TSC at-large Elections (colindixon, 17:08:11)
    1. ACTION: phrobb to send a mail trying to come up with a responsible way to extend the exemption for platinum designates, but not forever (colindixon, 17:08:55)

  3. events (colindixon, 17:09:03)
    1. https://www.opendaylight.org/global-events (colindixon, 17:09:10)
    2. phrobb (and other folks) are at the dusseldorf ODL mini-summit, it seems like the different mini summits got much less attendance (colindixon, 17:09:57)
    3. dfarrell07 gave an ODL talk (the only one) at LinuxCon EU, full session, pretty user-focused and well-received (dfarrell07, 17:10:07)
    4. phrobb says it seems to be less about technical things this time, and more about sales people and customers (colindixon, 17:10:28)
    5. https://www.opendaylight.org/events/2015-11-09-000000-2015-11-10-000000/opendaylight-hackfest-opnfv-summit register for the 11/9 and 11/10 hackfest (colindixon, 17:10:51)
    6. https://www.opendaylight.org/events/2015-11-16-000000-2015-11-18-000000/mef-lso-hackathon MEF hackfest on 11/16 to 11/18 (colindixon, 17:11:13)
    7. phrobb to get details about design summit sometime in the end of February and plan around that (colindixon, 17:11:49)

  4. beryllium (colindixon, 17:12:21)
    1. M3 for offset 2 and M4 for offset 0 are due today. (anipbu, 17:12:29)
    2. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-daily-beryllium/229/org.opendaylight.mdsal$mdsal-binding-generator-impl/ (anipbu, 17:13:26)
    3. anipbu is working with ttkacik and tykeal to resolve autorelease issues (colindixon, 17:13:53)
    4. colindixon asks if we should try to have two autorelease jobs one stable and one that's less stable so that we can try to maximize our visibility into what's going on (colindixon, 17:17:30)
    5. colindixon notes that if we run two autorelease streams (autorelease-stable, and autorelease-everything) if a project is not in "stable" it will not necessarilty be dropped from the release now, but it could be in the future. Projects need to actively work to stay properly executing in autorelease throughout the build cycle... Further discussion is needed here on the mailing list. (phrobb_, 17:20:06)
    6. ACTION: colindixon to start an e-mail offline around these issues, there's a broader question about minimum requirements and when projects to meet them to be in the SR (colindixon, 17:20:19)

  5. branch cutting for Beryllium (colindixon, 17:21:45)
    1. https://lists.opendaylight.org/pipermail/tsc/2015-September/003879.html thread on branch cutting timing and strategy (colindixon, 17:22:25)
    2. https://lists.opendaylight.org/pipermail/tsc/2015-October/003984.html newer proposals (colindixon, 17:23:37)
    3. https://docs.google.com/presentation/d/1snubwW6M8q6jo4laLvZ0WEVtaM783Qc6Gf4qe7UQZtw/edit#slide=id.p <- attempt to sketch (edwarnicke, 17:40:34)
    4. rovarga asks if this happens, then how can you move in-flight patches on pre-boron to master in an automated way? (colindixon, 17:44:09)
    5. VOTE: Voted on "what shall we do for cutting stable/beryllium branches (1) all-at-once at offset 0 M5 without a pre-boron, (2) all-at-once at offset 2 M5, (3) staged, (4) all-at-once at offset 0 M5 with pre-boron, (5) abstain?" Results are, 4: 6 (colindixon, 17:59:23)
    6. AGREED: the we will cut stable/beryllium branch at offset 2 M5, we will create pre-boron branches for everyone at offest 0 M5 if there is any interest, if there is literally zero interest, we don't have to (colindixon, 18:00:40)
    7. VOTE: Voted on "what shall we do for cutting stable/beryllium branches (1) all-at-once at offset 0 M5 without a pre-boron, (2) all-at-once at offset 2 M5, (3) staged, (4) all-at-once at offset 2 M5 with pre-boron, (5) abstain?" Results are, 4: 6 (colindixon, 18:02:46)
    8. the second vote was to correct a mistake the phrasing of the first vote, and now agrees with #agree statement (colindixon, 18:03:09)
    9. ACTION: colindixon to send mail about possibly having two hour meetings to deal with our backlog (colindixon, 18:03:38)

  6. cookies (colindixon, 18:03:40)


Meeting ended at 18:03:43 UTC (full logs).

Action items

  1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR3) https://bugs.opendaylight.org/show_bug.cgi?id=3160
  2. ttcacik and zxiiro to work on getting feature-level code coverage numbers
  3. colindixon to figure out where we lost action items, e.g., feature-level code coverage and make sure we didn't lose any others
  4. phrobb to send a mail trying to come up with a responsible way to extend the exemption for platinum designates, but not forever
  5. colindixon to start an e-mail offline around these issues, there's a broader question about minimum requirements and when projects to meet them to be in the SR
  6. colindixon to send mail about possibly having two hour meetings to deal with our backlog


Action items, by person

  1. colindixon
    1. colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade from Helium to Lithium (for SR3) https://bugs.opendaylight.org/show_bug.cgi?id=3160
    2. colindixon to figure out where we lost action items, e.g., feature-level code coverage and make sure we didn't lose any others
    3. colindixon to start an e-mail offline around these issues, there's a broader question about minimum requirements and when projects to meet them to be in the SR
    4. colindixon to send mail about possibly having two hour meetings to deal with our backlog
  2. phrobb
    1. phrobb to send a mail trying to come up with a responsible way to extend the exemption for platinum designates, but not forever


People present (lines said)

  1. colindixon (47)
  2. alagalah (14)
  3. dfarrell07 (13)
  4. odl_meetbot (13)
  5. dlenrow (9)
  6. ghall_ (5)
  7. edwarnicke (5)
  8. abhijitkumbhare (5)
  9. anipbu (4)
  10. LuisGomez (4)
  11. mohnish_ (3)
  12. phrobb_ (2)
  13. ttkacik1 (1)
  14. jmedved (1)
  15. tykeal (1)
  16. rovarga (1)
  17. phrobb (0)


Generated by MeetBot 0.1.4.