18:00:45 <colindixon> #startmeeting tsc
18:00:45 <odl_meetbot> Meeting started Thu Dec  3 18:00:45 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:45 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:45 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:53 <colindixon> #topic roll call and agenda bashing
18:00:59 <colindixon> TSC members please #info in
18:00:59 <edwarnicke> #info edwarnicke
18:01:01 <colindixon> #info colindixon
18:01:03 <dfarrell07> #info Daniel Farrell
18:01:12 * edwarnicke will be a little late on audio
18:01:18 <colindixon> #chair phrobb dfarrell07 anipbu
18:01:18 <odl_meetbot> Current chairs: anipbu colindixon dfarrell07 phrobb
18:01:30 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=38891#Agenda the agenda in it's usual place
18:01:42 <colindixon> #ink https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-11-19-18.00.html last week's meeting minutes are here
18:02:11 <colindixon> zxiiro: do you know if phrobb is around?
18:02:34 <ChrisPriceAB> #info Chris Price
18:03:05 <zxiiro> colindixon: I do not
18:03:13 <mohnish_> #info mohnish anumala
18:04:05 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Beryllium?
18:05:29 <colindixon> #action zxiiro to open a bug against releng/builder about figuring out a process to get feature-level code coverage
18:05:38 <colindixon> #action rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
18:05:48 <colindixon> #action LuisGomez to give an estimate for a drop-dead date on when we'd need to decide if we actually need a stable distribution
18:06:23 <colindixon> edwarnicke: do you know anything about the above
18:06:25 <colindixon> #action phrobb to poll the PTLs about hackfest attendance
18:06:53 <colindixon> #action jamoluhrsen to figure out how to start doing testing with JDK8
18:08:10 <colindixon> #info edwarnicke says his gut is that we're past the drop-dead date for having a stable distribution
18:09:23 <colindixon> #action colindixon to start a discussion if we could have a stable release in Beryllum noting that it might not be possible
18:09:35 * ChrisPriceAB has to drop off at the top of the hour...
18:09:45 <ChrisPriceAB> yay thanks
18:09:56 <rovarga_> edwarnicke: +1, I do not think it's doable in this release
18:10:01 <colindixon> #topic events
18:10:12 <colindixon> #link https://www.opendaylight.org/global-events the events page
18:10:44 <ChrisPriceAB> #info OpenDaylight user group, Stockholm chapter had an inaugural meet-up last night.
18:11:10 <colindixon> #Info phrobb says the current plan is have a design forum for boron in the first week of march in the bay area
18:11:58 <uri> 2/29 or first full week of March?
18:12:46 <colindixon> #Info ChrisPriceAB said one of the topics at the Stockholm ODLUG was the hard ramp up for ODL, there was the idea of doing a boot camp in Europe, akin to the application tutorial that was done at the OpenDaylight summit
18:15:22 <colindixon> #action colindixon to send a mail with some ideas about running tutorials with new known knows
18:15:55 <colindixon> #info ChrisPriceAB sasy that SDN Hub OpenDaylight tutorials were referenced a lot, but maybe not idea for us
18:16:42 <colindixon> #action phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp
18:17:34 <gzhao> ack
18:18:45 <colindixon> #topic beryllium
18:19:04 <colindixon> #info today is M5 for offset 0 and M4 for offset 2
18:19:11 * zxiiro will be creating pre-boron branches today
18:19:34 <colindixon> #info autrelease was broken by SNBI, fixed, but is now broken by OVSDB but it's been looked it
18:19:49 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Current_Weather_Report the weather upcoming
18:20:03 <colindixon> #Info there are some thigns coming up, please go look at them
18:20:23 <colindixon> #Info the big one that's coming is removing AD-SAL
18:20:51 <colindixon> #link https://docs.google.com/spreadsheets/d/1Kfp5HVQGydNegEjp6dD2V3XsUnqpice0bysWbdxABA4/edit#gid=1862710416 the beryllium status
18:21:10 <colindixon> #info zxiiro says he's going to be creating per-boron branches today
18:22:24 <zxiiro> #link https://lists.opendaylight.org/pipermail/release/2015-November/004645.html pre-boron branch cutting
18:22:34 <colindixon> #topic stable/lithium
18:22:40 <anipbu> #link https://docs.google.com/spreadsheets/d/1ktL11ElNdf4D3RUeRNUd8SPnYO0to0DxzSZGst0KdMQ/edit#gid=1055423260
18:22:59 <colindixon> #info it looks like Lithium-SR3 is ready to go (the above sheet shows every issue signed off by the relevant project)
18:23:37 <anipbu> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Lithium_Release_Plan#Lithium_SR3_Download
18:23:57 <colindixon> #startvote shall the TSC bless teh SR3 artifacts as describe above? -1, 0, +1
18:23:57 <odl_meetbot> Begin voting on: shall the TSC bless teh SR3 artifacts as describe above? Valid vote options are -1, 0, +1.
18:23:57 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:24:07 <edwarnicke> #vote +1
18:24:08 <colindixon> #vote +1
18:24:08 <dfarrell07> #vote +1
18:24:10 <ChrisPriceAB> #vote +1
18:24:11 <uri> #vote +1
18:24:12 <mohnish_> #vote +1
18:24:27 <colindixon> #endvote
18:24:27 <odl_meetbot> Voted on "shall the TSC bless teh SR3 artifacts as describe above?" Results are
18:24:27 <odl_meetbot> +1 (6): dfarrell07, uri, ChrisPriceAB, edwarnicke, colindixon, mohnish_
18:24:39 <colindixon> #agree we will promote the staging repo and release Lithium-SR3
18:25:14 <colindixon> #topic infrastructure
18:25:41 <colindixon> #info rackspace has provided us the new private cloud, we're still working on getting the VPN link up and working, then we'll start kicking the tires, and start moving into it in the next month or so
18:26:11 <odl-casey> Sorry I'm late.  Internet has been down for the last 2 hours.  :(
18:26:15 <ChrisPriceAB> o.o
18:26:46 <edwarnicke> tykeal: So no CI on Raspberry Pi? ;)
18:26:47 <colindixon> #info colindixon asks if this would enable us to install our own hardware in the infrastructure, tykeal says no, it has to be rackspace-offered hardware
18:27:05 <ChrisPriceAB> need to move to a high tech state odl-casey...
18:27:32 <odl-casey> I have 1GB fiber internet.  It should be "high tech".
18:27:43 <colindixon> odl-casey: Andrew McLachlan was asking about revamping the wiki, I told him to check out the TWS call
18:28:31 <colindixon> #topic kafka producer creation review
18:28:38 <colindixon> #info andrew will post slides after the call
18:28:46 <colindixon> #link https://wiki.opendaylight.org/view/Project_Proposals:Kafkaproducer project proposal
18:29:03 <colindixon> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-November/000377.html proposed on 11/16/2015
18:29:44 <colindixon> #action colindixon to add instructions to upload materials before creation reviews to the proposal instructions
18:30:10 <colindixon> #info andrew says that this is something they've already built for another thing, but there was enough interest that they thought they would bring it here
18:30:30 <colindixon> #info it's a way to push ODL data to a Kafka cluster
18:30:59 <colindixon> #info supports compression (gzip and snappy  now), supports codec types (raw and avro now), supports sycn and async
18:31:19 <colindixon> #Info currently pulls data from the event topic broker, but going forward could pull data from other places in ODL
18:31:57 <colindixon> #Info right now there are two things that publish to the Event Topic Broker: NETCONF connector and a hweventsource for other things
18:32:09 <colindixon> #info right now it works with stable/lithium, but obviously would roll forward on joining
18:32:59 <colindixon> #info have working code, willing committers, looking to update, looking for new ideas and/or suggestions
18:33:23 <colindixon> #info abhijitkumbhare asks what the relationship between this Kafka cluster and Akka cluster
18:34:13 <colindixon> #info andrew answers no relationship now
18:35:03 <colindixon> #info colindixon asks what Kafka is, Willis says that it's a scale-out messaging system, designed to do very high throughput messaing in a pub-sub, reliable system
18:36:57 <colindixon> #info basically this is a way to get data/events out of ODL to an off-the-shelf, popular, easy-to-install message bus
18:37:26 <colindixon> #Info Willis says that one reason Kafka is more interesting than RabbitMQ or others is because it's able to elastically scale-out
18:37:56 <colindixon> #info mohnish_ asks what data they're looking to expose, andrew answers mostly telemetry from southbound devices for now
18:39:26 <colindixon> #link https://wiki.opendaylight.org/view/Messaging4Transport:Main colindixon asks what the relationsihp is between this and the messaging4transport project which seemingly does this with AMQP
18:40:32 <colindixon> #info andrew says his impression was that M4T was more of a message bus and had more stuf in the controller, this las less stuff
18:42:13 <colindixon> #Info edwarnicke says his take is that M4T is trying to do things for *all* the messages/events in the MD-SAL vs. this which is looking to just do it for specific things, e.g,, event topic broker
18:43:57 <phrobb_> #action Andrew M. to get with Phil Robb to perform Inbound Code Review on initial code to be contributed
18:44:08 <colindixon> https://wiki.opendaylight.org/view/Project_Proposals:Kafkaproducer#Scope
18:45:13 <colindixon> #Info colindixon says the first paragaph of the description reads like the scope
18:46:30 <gzhao> #action Andrew McLachlan to add presented slides and initial committers to the wiki proposal page: <= https://wiki.opendaylight.org/view/Project_Proposals:Kafka_Transport
18:46:50 * phrobb_ thanks edwarnicke for saying what he actually intended
18:46:59 <colindixon> #startvote shall the TSC move the kafkaproducer project to incubation? -1, 0, +1
18:46:59 <odl_meetbot> Begin voting on: shall the TSC move the kafkaproducer project to incubation? Valid vote options are -1, 0, +1.
18:46:59 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:47:02 <edwarnicke> phrobb_: I live to serve ;)
18:47:25 <dfarrell07> #vote +1
18:47:36 <colindixon> #vote +1
18:47:46 <mohnish_> #vote +1
18:47:53 <ChrisPriceAB> #vote +1
18:48:15 * ChrisPriceAB is still waiting on the page to refresh...
18:48:44 <colindixon> #info andrew says the plan is to possibly expand beyond just the event topic broker in the future
18:49:00 <dfarrell07> uri: edwarnicke
18:49:00 <edwarnicke> #vote +1
18:49:12 <colindixon> #vote +1
18:49:24 <colindixon> uri: can you vote?
18:49:26 <uri> #vote +1
18:49:30 <colindixon> #endvote
18:49:30 <odl_meetbot> Voted on "shall the TSC move the kafkaproducer project to incubation?" Results are
18:49:30 <odl_meetbot> +1 (6): dfarrell07, uri, ChrisPriceAB, edwarnicke, colindixon, mohnish_
18:49:46 <colindixon> #agree the kafkaproducer project will be moved to incubation after incoming code review
18:49:54 <ChrisPriceAB> congrats
18:50:14 <colindixon> #topic TSC make up and elections
18:50:46 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-October/004026.html
18:51:04 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-November/004101.html
18:51:16 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-December/004298.html
18:51:42 <colindixon> #info the above three links are the thread about how to change the TSC make up and eleections across three months
18:52:06 <colindixon> #info dfarrell07 says this started to avoid the waiver enabling platinum designates to sit even if another person from their compnay was election
18:52:08 <colindixon> #undo
18:52:08 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x20bb510>
18:52:10 <colindixon> #info dfarrell07 says this started to avoid the waiver enabling platinum designates to sit even if another person from their compnay was elected
18:52:28 <colindixon> #info most proposals seem to do this by eleminating platinum designates
18:53:10 <colindixon> #info dfarrell07 says he thinks of this as having a list of represented groups, then you do STV (single transferrable votes) elections per group
18:53:41 <colindixon> #info groups serve two purposes: one to balance different views within opendaylight, and to provide incentives for projets to do things like move to mature
18:54:29 <colindixon> #info there are discussion about what the represented groups should be, e.g,, just one big group, lifecycle state, project type (kernel, apps, protocol), etc.
18:55:11 <colindixon> #info there's also a question of if we want to limit the number of elected people from a single company
18:58:22 <colindixon> #info colindixon asks if there is anyone that objects to removing platinum designates
18:58:36 <colindixon> #info uri says yes, as long as that's coupled with projects moving thorugh the maturity states
19:00:31 * ChrisPriceAB had to drop
19:01:01 <phrobb_> That is correct.  We will change the bylaws to remove that as a benefit of platinum members
19:01:37 <colindixon> #info colindixon says he thinks there are three or four main decisions points: (i) will we eliminate platinum designates, (ii) do we want to have both project leads and committers at large on the TSC, (iii) do we want to have per-company cap on representatives, (iv) do we want to do this now or in a year
19:03:16 <colindixon> #undo
19:03:16 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1f45490>
19:03:57 <colindixon> #info colindixon says he thinks there are three or four main decisions points: (i) do we want to have per-company cap on representatives (ii) do we want to have both project leads and committers at large on the TSC, (iii) will we eliminate platinum designates,, (iv) do we want to do this now or in a year
19:04:17 <edwarnicke> #info dfarrell07 just suggested compiling governance
19:04:20 <edwarnicke> ;)
19:04:41 <colindixon> #action dfarrell07 to try to drive this to a vote
19:06:16 <colindixon> #info edwarnicke points out that per-company caps need to have a clear mechanism if we adopt them, colindixon says there have been some proposals for that on th elist
19:06:34 <edwarnicke> #info mohnish_ suggested we also look at how the transition will work
19:06:34 <colindixon> #info mohnish_ asks if there's a plan for a transition, and or discussion of the size
19:07:04 <colindixon> #info colindixon says the transition would likely be aided by people showing up and continuing to speak their minds even if votes transition quickly
19:07:13 <colindixon> #info I think the thread suggeted sizes of ~8-15 members
19:07:46 <colindixon> #topic cookies
19:07:46 <odl-casey> Wait
19:08:19 <gzhao> odl-casey: link?
19:08:47 <colindixon> #lnk https://wiki.opendaylight.org/view/Special:Preferences#mw-prefsection-rendering you can change you them to the strapping them if you want on per-user base
19:08:56 <colindixon> #info that's from odl-casey
19:09:08 <colindixon> #endmeeting