17:59:19 <dfarrell07> #startmeeting tsc
17:59:20 <odl_meetbot> Meeting started Thu Dec 10 17:59:19 2015 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:59:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:59:20 <odl_meetbot> The meeting name has been set to 'tsc'
17:59:36 <dfarrell07> #topic Roll call and agenda bashing
17:59:43 <dfarrell07> TSC members please #info in
17:59:50 <dfarrell07> #chair phrobb anipbu
17:59:50 <odl_meetbot> Current chairs: anipbu dfarrell07 phrobb
18:00:01 <dfarrell07> #info Daniel Farrell is the proxy for Colin Dixon's CAL seat and acting TSC Chair
18:00:12 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-December/004331.html Colin's proxy to Daniel
18:00:20 <dfarrell07> #info Jamo Luhrsen is the proxy for Red Hat's TSC seat
18:00:26 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-December/004368.html Daniel's proxy to Jamo
18:00:32 <dfarrell07> #info Ryan Goulding is the proxy for Luis Gomez/Brocade
18:00:39 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-December/004373.html Luis' proxy to Ryan
18:00:52 <dfarrell07> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=39114 This week's agenda
18:00:57 * tykeal wonders if we're going to have an entire TSC meeting sometimes that is all proxies ;)
18:01:31 <dfarrell07> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-12-03-18.00.html Last week's meeting minutes
18:01:48 <dfarrell07> #info Adding #actions carried over from past weeks
18:02:02 <dfarrell07> #info First, #actions that may have happened and need discussion
18:02:11 <dfarrell07> #info Drop-dead date for stable distribution was resolved last week, we're past it
18:02:16 <ChrisPriceAB> #info Chris Price (on the roll)
18:02:21 <jamoluhrsen> #info jamoluhrsen
18:02:25 <dfarrell07> #action colindixon to start a discussion if we could have a stable release in Beryllum noting that it might not be possible
18:02:38 <dfarrell07> #action phrobb to poll the PTLs about Hackfest attendance
18:03:11 <dfarrell07> #info ChUsama is working on JDK8 for jamoluhrsen, blocked by login bug/issue atm, people are looking at it and progress is being made
18:03:45 <alagalah> #info alagalah for Ed Warnicke (sorry I'm late)
18:04:03 <dfarrell07> #info zxiiro has a bug for feature-level code coverage
18:04:13 <rgoulding> #info Ryan Goulding
18:04:24 <ChrisPriceAB> no progress
18:04:29 <zxiiro> #link https://bugs.opendaylight.org/show_bug.cgi?id=4717 feature level code coverage bug
18:04:30 <dfarrell07> #action phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp
18:04:47 <gzhao> no update for me either
18:04:48 <dfarrell07> #action Andrew M. to get with Phil Robb to perform Inbound Code Review on initial code to be contributed
18:04:59 <dfarrell07> #action dfarrell07 to continue to drive TSC election refactoring to a vote
18:05:12 <dfarrell07> #info Dump of #actions I don't think have happened and just need to be carried over
18:05:19 <dfarrell07> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Beryllium?
18:05:25 <dfarrell07> #action colindixon to send a mail with some ideas about running tutorials with new known knows
18:05:29 <dfarrell07> #action colindixon to add instructions to upload materials before creation reviews to the proposal instructions
18:05:42 <dfarrell07> #action rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
18:05:47 <dfarrell07> #topic Events
18:05:52 <dfarrell07> #link https://www.opendaylight.org/global-events OpenDaylight events page
18:05:57 <dfarrell07> #info Neela spoke at the BTE Executive Summit this week in Dublin
18:06:03 <dfarrell07> #info The Okinawa Open Days are next week, 12/14/2015. Neela is speaking.
18:06:08 <dfarrell07> #info Open Networking Summit CFP is open. Apply!
18:06:14 <dfarrell07> #link http://opennetsummit.org/program/ Open Networking Summit CFP page
18:06:33 <dfarrell07> #action phrobb to send ONS CFP reminder, get it on the ODL website
18:06:35 <mohnish_> #info mohnish anumala
18:07:09 <ChrisPriceAB> #info OPNFV will be running an OPNFV dev event on the Monday and Tuesday of the ONS
18:07:23 <dfarrell07> #info we have quorum
18:07:38 <dfarrell07> #topic Pre-Boron
18:07:48 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-December/004359.html Latest pre-Boron updates from Thanh
18:07:56 <dfarrell07> #info SFC <-> OVSDB cyclic dependency issue was handled, long-term solution is to spin out netvirt into a new project as planned
18:08:11 <dfarrell07> #info that everything's working except SNMP4SDN, which is breaking both pre-Boron and Beryllium
18:08:23 <dfarrell07> #topic Beryllium
18:08:29 <dfarrell07> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Schedule Beryllium schedule
18:08:30 <dlenrow> #info dlenrow
18:08:37 <dfarrell07> #info 9 projects missing
18:08:45 <dfarrell07> #info M4 offset-2 and M5 offset-0 were last week, 12/3/2015
18:08:48 <dlenrow> #info dlenrow (irc only)
18:09:15 <dfarrell07> #info FaaS is blocking autorelease, ACKd, bug documented
18:09:25 <dfarrell07> #info dfarrell07 and zxiiro need to get Be building so they can start providing "Experimental Release Previews" to OPNFV
18:10:13 <dfarrell07> #info anipbu has sent out a poll for sync meeting times, please fill it out
18:10:56 <dfarrell07> #info Be build time has slowed down by a few hours
18:11:17 <dfarrell07> #info zxiiro is still looking into autorelease build time issues
18:11:23 <dfarrell07> #topic Stable/Lithium
18:11:31 <dfarrell07> #link https://docs.google.com/spreadsheets/d/1ktL11ElNdf4D3RUeRNUd8SPnYO0to0DxzSZGst0KdMQ/edit#gid=1055423260 Lithium status spreadsheet
18:11:39 <dfarrell07> #info Lithium SR3 was released last week
18:11:49 <dfarrell07> #link https://nexus.opendaylight.org/content/repositories/opendaylight.release/org/opendaylight/integration/distribution-karaf/0.3.3-Lithium-SR3/ Lithium SR3 release artifacts
18:11:56 <dfarrell07> #info Li SR3 isn't on the official Downloads page yet, need to get it there
18:12:01 <dfarrell07> #link https://www.opendaylight.org/downloads ODL downloads page, no Li SR3 atm
18:12:55 <dfarrell07> #topic System integration and test
18:12:59 <dfarrell07> #info Everything seems to be working
18:13:07 <dfarrell07> #topic Infrastructure
18:13:12 <dfarrell07> #info dfarrell07 heard some mentions of Jenkins issues (slowness). Asks if it's good to go now.
18:13:26 <dfarrell07> #info tykeal has been poking the Rackspace private cloud
18:13:36 <gzhao> dfarrell07: I like that summary.
18:13:38 <dfarrell07> #info tykeal is looking at January at the soonest for moving into it
18:13:51 <ChrisPriceAB> privately I hope
18:14:06 <dfarrell07> #topic Wiki updates
18:14:43 <dfarrell07> #info Casey Cain has been working on creating a better ODL wiki main page, updating ODL wiki themes, generally making the wiki less haphazard
18:15:04 <dfarrell07> #info Casey reports that most work is nearly done, about go into production
18:15:26 <dfarrell07> #info (from wiki) Name -> pref -> appearance to get the new theme
18:16:17 <dfarrell07> #info everyone should go demo the wiki and give feedback
18:16:45 <CaseyODL> To change your theme on the wiki, click your name in the upper right > Preferences > Appearance: Skin - Strapping
18:18:04 <dfarrell07> #topic RelEng/Builder committer promotion
18:18:12 <dfarrell07> #info Jamo Luhrsen up for committer promotion for RelEng/Builder
18:18:25 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-December/004364.html Request for TSC vote
18:18:30 <dfarrell07> #link https://lists.opendaylight.org/pipermail/dev/2015-December/001477.html Thread with +1s from all committers
18:18:36 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/q/owner:%22Jamo+Luhrsen%22+project:releng/builder Jamo's contributions to RelEng/Builder
18:19:17 <dfarrell07> #vote Shall the TSC approve Jamo Luhrsen as a committer to RelEng/Builder? -1,0,+1
18:19:23 <dfarrell07> #startvote Shall the TSC approve Jamo Luhrsen as a committer to RelEng/Builder? -1,0,+1
18:19:23 <odl_meetbot> Begin voting on: Shall the TSC approve Jamo Luhrsen as a committer to RelEng/Builder? Valid vote options are -1, 0, +1.
18:19:23 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:19:35 <alagalah> #vote +1
18:19:36 <dfarrell07> #vote +1
18:19:36 <mohnish_> #vote +1
18:19:41 <rgoulding> #vote +1
18:19:46 <dfarrell07> jamoluhrsen
18:19:53 <dfarrell07> ChrisPriceAB
18:19:57 <jamoluhrsen> do I vote for myself?
18:20:04 <jamoluhrsen> #vote +1
18:20:04 <ChrisPriceAB> ahh sorry
18:20:07 <ChrisPriceAB> #vote +1
18:20:13 <gzhao> jamoluhrsen: yes
18:20:23 <uri_> VOTE +1
18:20:31 <tykeal> uri_: that's #vote
18:20:37 <uri_> #Vote +1
18:20:49 <dfarrell07> #endvote
18:20:49 <odl_meetbot> Voted on "Shall the TSC approve Jamo Luhrsen as a committer to RelEng/Builder?" Results are
18:20:49 <odl_meetbot> +1 (7): rgoulding, ChrisPriceAB, dfarrell07, uri_, jamoluhrsen, alagalah, mohnish_
18:20:58 <uri_> #vote +1
18:21:04 * ChrisPriceAB congratulates Jamo
18:21:08 <gzhao> jamoluhrsen: congratulations
18:21:15 <dfarrell07> #topic OpenFlow Plugin committer promotion
18:21:17 <Prem> jamoluhrsen: Congrats!!
18:21:23 <dfarrell07> #info Kamal Rameshan up for committer promotion for OpenFlow Plugin
18:21:31 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-December/004366.html Request for TSC vote
18:21:32 <jamoluhrsen> thanks ChrisPriceAB gzhao Prem
18:21:36 <dfarrell07> #link https://lists.opendaylight.org/pipermail/openflowplugin-dev/2015-December/004382.html Thread with +1s from 4/7 committers, 4/5 active committers
18:21:38 <abhijitkumbhare> https://git.opendaylight.org/gerrit/#/q/owner:%22Kamal+Rameshan%22+project:openflowplugin
18:21:44 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/q/project:openflowplugin+owner:Kamal+Rameshan Kamal's contributions to OpenFlow Plugin
18:22:08 <dfarrell07> #info Lots of good OF clustering work
18:23:24 <dfarrell07> #startvote Shall the TSC approve Kamal Rameshan as a committer to OpenFlow Plugin? -1,0,+1
18:23:24 <odl_meetbot> Begin voting on: Shall the TSC approve Kamal Rameshan as a committer to OpenFlow Plugin? Valid vote options are -1, 0, +1.
18:23:24 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:23:29 <ChrisPriceAB> #vote +1
18:23:30 <alagalah> #vote +1
18:23:33 <rgoulding> #vote +1
18:23:34 <dfarrell07> #vote +1
18:23:36 <uri_> #vote +1
18:23:40 <jamoluhrsen> #vote +1
18:23:41 <mohnish_> #vote +1
18:23:48 <dfarrell07> #endvote
18:23:48 <odl_meetbot> Voted on "Shall the TSC approve Kamal Rameshan as a committer to OpenFlow Plugin?" Results are
18:23:48 <odl_meetbot> +1 (7): rgoulding, dfarrell07, ChrisPriceAB, uri_, jamoluhrsen, alagalah, mohnish_
18:24:26 <dfarrell07> #topic Messaging4Transport committer promotion
18:24:37 <dfarrell07> #info Thanh Ha up for committer promotion for Messaging4Transport
18:24:44 <dfarrell07> #info Missing second committer +1 documentation (was in IRC, waiting on email we can link to)
18:24:50 <abhijitkumbhare> jamoluhrsen & Kamal Rameshan congrats for committer promotions :)
18:25:28 <dfarrell07> #info we are working under the assumption that the in-mail +1 will happen
18:25:34 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-December/004343.html Request for TSC vote
18:25:41 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/q/owner:%22Thanh+Ha+%253Cthanh.ha%2540linuxfoundation.org%253E%22+project:messaging4transport Thanh's contributions to Messaging4Transport
18:25:59 <tykeal> lol do you need that for zxiiro? ;)
18:26:02 <dfarrell07> #startvote Shall the TSC approve Thanh Ha as a committer to Messaging4Transport, assuming the final committer +1 happens? -1,0,+1
18:26:02 <odl_meetbot> Begin voting on: Shall the TSC approve Thanh Ha as a committer to Messaging4Transport, assuming the final committer +1 happens? Valid vote options are -1, 0, +1.
18:26:02 <odl_meetbot> Vote using '#vote OPTION'. Only your last vote counts.
18:26:08 <mohnish_> #vote +1
18:26:14 <rgoulding> #vote +1
18:26:15 <dfarrell07> #vote +1
18:26:18 <jamoluhrsen> #vote +1
18:26:18 <alagalah> #vote +1
18:26:20 <ChrisPriceAB> #vote +1
18:26:22 <uri_> #vote +1
18:26:31 <dfarrell07> #endvote
18:26:31 <odl_meetbot> Voted on "Shall the TSC approve Thanh Ha as a committer to Messaging4Transport, assuming the final committer +1 happens?" Results are
18:26:31 <odl_meetbot> +1 (7): rgoulding, ChrisPriceAB, dfarrell07, uri_, jamoluhrsen, alagalah, mohnish_
18:26:42 <mohnish_> Thanh: Thanks for helping them out
18:26:51 <dfarrell07> #topic TSC election refactoring
18:26:58 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-October/004026.html TSC election refactoring discussion
18:27:03 <dfarrell07> #link https://wiki.opendaylight.org/view/TSC:Election_Proposal Proposed framework
18:27:10 <dfarrell07> #info dfarrell07 has attempted for nail-down details in an Election Proposal wiki
18:27:12 <gzhao> zxiiro: you can be committer for every project -:)
18:27:16 <dfarrell07> #info Election Proposal wiki includes framework of ideas that seem to have consensus and subs for ideas that don't, with pointers to proposals
18:27:40 <zxiiro> gzhao: haha
18:27:46 <dfarrell07> #info dfarrell07 thinks the main questions remaining are: 1) Election frequency 2) Company caps 3) Represented Groups {# seats, candidates, voters} for this election
18:27:52 <dfarrell07> #link https://en.wikipedia.org/wiki/Condorcet_method edwarnicke pointed out that Condorcet may be a good alternative to STV, dfarrell07 needs to look into it
18:36:57 <abhijitkumbhare> is everyone able to hear? suddenly lost audio
18:37:26 <mohnish_> yes
18:37:36 <abhijitkumbhare> will dial back in
18:37:40 <dfarrell07> #info rovarga_ ChrisPriceAB abhijitkumbhare voice support for PTL-heavy Represented Groups vs "CAL Heavy" proposals
18:38:05 <dfarrell07> #info PTLs have the most direct interaction with TSC
18:38:07 <ChrisPriceAB> Ack
18:38:15 <abhijitkumbhare> Ack
18:38:38 * ChrisPriceAB Syn's abhijitkumbhare
18:38:39 <phrobb_> #info dfarrell07 notes that the proposals that are *not* CAL heavy are getting more support in the discussion
18:38:55 <abhijitkumbhare> Syn-ack ChrisPriceAB :)
18:39:24 <phrobb_> #info dfarrell07 asks for thought on election frequency
18:39:38 <dfarrell07> #info ChrisPriceAB thinks frequencies linked with milestones may cause more time crunch
18:40:23 <alagalah> I don't think Release based governance is a bad idea
18:40:29 <alagalah> Aren't we going to CI/CD ?
18:40:34 <dfarrell07> #info abhijitkumbhare points out that 6 month (ODL cycles) may be too frequent, others agree
18:40:39 <phrobb_> #info discussion ensues on the benefits/concerns with doing elections tied to release schedule
18:40:47 <ChrisPriceAB> Could do it after every second release, that would work pretty well I think
18:40:53 <alagalah> Weekly TSC meetings take on a whole new meaning :)
18:40:54 <ChrisPriceAB> +1 alagalah
18:41:05 <dfarrell07> #info gzhao points out that self-nomination is critical
18:41:10 <mohnish_> I think it makes sense to have 2 release cycle for TSC
18:41:19 <dfarrell07> #info gzhao wants to be sure we promote mature and core projects
18:41:40 <dfarrell07> #info various people voice support for bi-release TSC elections
18:42:35 <ChrisPriceAB> Pre-M1 could work
18:42:42 <rovarga_> #info release 'themes' do not really work for SRs, as the focus tends to differ across projects
18:42:56 <gzhao> +1 pre M1 or M1
18:43:01 <dfarrell07> #info dfarrell07 asks hould we pin to a milestone or a date?
18:43:31 <abhijitkumbhare> Sounds good to me as well - may be M0 can have that as a purpose?
18:43:45 <dfarrell07> #action dfarrell07 will drive Pre-M1, bi-election discussion
18:44:18 <dfarrell07> #info should we do elections before next release planning? the incoming TSC may not want to support the ideas of previous TSC
18:44:22 <alagalah> I agree with rovarga_
18:44:29 <alagalah> Any new TSC would have to be able to define the release
18:44:31 <abhijitkumbhare> +1 rovarga_
18:44:58 <ChrisPriceAB> I wouldn't want to start the process before the RC phase of the outgoing release though.  After CF and Before release planning.
18:45:17 <alagalah> ChrisPriceAB, right
18:45:24 <rovarga_> ChrisPriceAB: +1
18:45:45 <dfarrell07> #topic Advancing projects to Mature
18:45:57 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-November/004144.html Moving projects to Mature discussion
18:46:01 <dfarrell07> #link https://lists.opendaylight.org/pipermail/tsc/2015-September/003783.html Lengthy thread on our current approach
18:46:06 <dfarrell07> #info Integration/Test was the first to submit a completed Graduation Review template, posted on 12/5/2015
18:46:11 <dfarrell07> #link https://lists.opendaylight.org/pipermail/project-proposals/2015-December/000382.html Integration/Test Graduation Review template public posting, 12/5/2015.
18:46:18 <dfarrell07> #info Int/Test's two-week waiting period will end on 12/19/2015. The next TSC after that is 12/24/2015 (Christmas Eve), so likely will not be able to hear Graduation Review at TSC until after the holidays.
18:47:37 <alagalah> dfarrell07, Easy
18:47:49 <alagalah> dfarrell07, Finding links to emails is a PITA
18:48:06 <alagalah> Can't search archives easily but thats always been an issue
18:48:08 <phrobb_> The TSC should decide if we are meeting on either 12/24 or 12/31 during this meeting, so we can set everyone's expectations
18:48:27 <rgoulding> Just need a bit of time.
18:48:28 <ChrisPriceAB> that's an easy one phrobb_
18:48:39 <alagalah> dfarrell07, Is there a deadline ?
18:48:43 <phrobb_> prolly ChrisPriceAB  but just want it documented :-)
18:49:30 <alagalah> :)
18:50:34 * alagalah as a proxy for Ed, I'm all for tasking him with another meeting :)
18:50:51 <phrobb_> #info abhijitkumbhare asks "do holidays count toward the 2 week public review period?"... the answer is "yes, the holiday period does count toward the public review period.
18:50:52 <jamoluhrsen> alagalah, LOL
18:51:33 <dfarrell07> #topic ODL TSC Meetings During Holidays
18:51:38 <phrobb_> #info dfarrell07 asks "do we have consensus to not have tsc mtgs on 12/24 and 12/31?
18:51:39 <dfarrell07> #agreed The TSC will not meet on 12/24 or 12/31
18:51:59 <dfarrell07> #topic cookies
18:52:07 <alagalah> dfarrell07, Nice job
18:52:08 <gzhao> dfarrell07: good job
18:52:14 <mohnish_> good job
18:52:20 <ChrisPriceAB> #info great job Dan!
18:52:21 <tykeal> #info https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=6&cad=rja&uact=8&ved=0ahUKEwjSg4mg-9HJAhUO8WMKHVc4A04QtwIIKzAF&url=https%3A%2F%2Fwww.youtube.com%2Fwatch%3Fv%3DKeaehxEdpgo&usg=AFQjCNEjE8Ze6Z2akm2Gst_WmQUGYA_IYQ&sig2=pwfDPqTXbVbw2OSxILxrfg&bvm=bv.109395566,d.cGc
18:52:22 <gzhao> sync with alagalah
18:52:23 <tykeal> ;)
18:52:28 <ChrisPriceAB> #info #cookies for Dan
18:52:29 <rovarga_> dfarrell07: good (and speedy) job! :)
18:52:44 * dfarrell07 has a new level of appreciation for Colin's TSC Chair work
18:52:56 <dfarrell07> #topic cookies
18:52:59 <dfarrell07> #endmeeting