18:00:23 <colindixon> #startmeeting tsc
18:00:23 <odl_meetbot> Meeting started Thu Dec 17 18:00:23 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:00:23 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:23 <odl_meetbot> The meeting name has been set to 'tsc'
18:00:29 <colindixon> #topic agenda bashing and roll call
18:00:39 <colindixon> TSC members please #info in?
18:00:42 <colindixon> #info colindixon
18:01:25 <edwarnicke> #info edwarnicke
18:01:44 <dfarrell07> #info Daniel Farrell
18:02:10 <colindixon> #link https://wiki.opendaylight.org/index.php?title=TSC:Main&oldid=39484 agenda in it's usual place
18:02:15 <dfarrell07> LuisGomez is here this week :)
18:02:15 <dlenrow> #info dlenrow
18:02:24 <dfarrell07> Jamo is not
18:02:35 <colindixon> #link https://meetings.opendaylight.org/opendaylight-meeting/2015/tsc/opendaylight-meeting-tsc.2015-12-10-17.59.html last week's minutes
18:03:02 <colindixon> #action colindixon to start a discussion if we could have a stable release in Beryllum noting that it might not be possible
18:03:06 <LuisGomez> #info LuisGomez
18:03:29 <colindixon> #action phrobb to poll the PTLs about Hackfest attendance
18:03:37 <colindixon> #action phrobb and/or gzhao to work with ChrisPriceAB to figure when/where/who would run a Europe boot camp
18:04:15 <abhijitkumbhare> #info abhijitkumbhare for ChrisPriceAB
18:04:16 <colindixon> #action colindixon to try to find somebody to help with documenting the general procedure for the platform upgrade to Boron?
18:04:30 <colindixon> #action colindixon and tbachman to send a mail with some ideas about running tutorials with new known knows
18:04:38 <colindixon> #action colindixon to add instructions to upload materials before creation reviews to the proposal instructions
18:04:46 <colindixon> #action rovarga, alagalah, mohnish, ttkacik, vishnoianil, ebrjohn, RPenno, abhijitkumbhare will try to draft a paragraph around the best practices including this discussion and feedback (to be gotten) from PTLS, they should also feel free to provide feedback around tools and technical solutions to help with upstream/downstream breakages
18:05:11 <colindixon> #action dfarrell07 will drive Pre-M1, bi-election discussion
18:05:15 * tbachman pokes head in, sees he was just actioned :)
18:05:25 <colindixon> tbachman: it's a good action
18:05:31 <tbachman> :)
18:05:31 <tykeal> great tbachman is here, he can take notes now ;)
18:05:32 <tbachman> lol
18:05:38 <tbachman> I’m double-booked ;)
18:05:42 <colindixon> tbachman: if you want o
18:06:04 <tbachman> the openstack team had the nerve to schedule a meeting the same time as the TSC :(
18:06:07 <tbachman> lol
18:06:25 <colindixon> #action colindixon to try to bump boron planning back up the prioirty list
18:06:40 <mohnish_> #info mohnish anumala
18:06:43 <colindixon> #topic events
18:06:48 <colindixon> #link https://www.opendaylight.org/global-events
18:07:15 <colindixon> #action phrobb to make sure ONS is listed under ODL's events page
18:07:42 <colindixon> #info we're locking in our boron design forum on 2/29-3/1 at a hotel near the airprot
18:07:56 <colindixon> #info Open Networkign Summit (now a LF event) has it's CFP up
18:08:01 * tykeal should probably send out a GPG keysigning mail now ;)
18:08:39 <colindixon> #info there's a modeling forum in the denver area looking at how to integrate SDO effots and Open Source efforts when it comes to models and the like with respect to NFV
18:08:56 <colindixon> #info if you're interested in the above, then talk to phrobb, it's happening on 1/5
18:09:04 <colindixon> #info dlenrow will also be there, alongside phrobb
18:09:35 <colindixon> #link https://lists.opendaylight.org/pipermail/tsc/2015-December/004433.html discussion on the design forum for boron
18:09:58 <phrobb_> #link http://opennetsummit.org/program/ <-- link to ONS CFP
18:10:27 <alagalah> phrobb_, Link to the NFV model thing?
18:10:49 <phrobb_> I don't think thre is a link to that alagalah .
18:10:58 <jmedved> #info jmedved
18:11:29 <colindixon> dneary: link?
18:11:46 <colindixon> #Info colindixon talks about presenting at the Future Network Forum in Nanjing last week
18:12:58 <tykeal> https://fosdem.org/2016/
18:13:31 <colindixon> #link https://fosdem.org/2016/ dnear says FOSDEM last weekend of January in Brussels there's a track on Sunday on SDN/NFV that loks cool
18:13:32 <dneary> Thanks tykeal
18:13:57 <colindixon> #topic pre-boron
18:14:22 <colindixon> #info zxiiro has nothing to report here, a few projects seem to be using it, but not many
18:14:39 <zxiiro> #link https://lists.opendaylight.org/pipermail/release/2015-November/004645.html branch cutting strategy
18:15:09 <colindixon> #info please read the above to understand the plan for branch cutting at offest 2 M5
18:15:18 <colindixon> #topic beryllium
18:15:36 <colindixon> #info missing status updates from 8 projects, they've been contacted
18:15:41 <colindixon> #info M5 for offset 1 is today
18:15:56 <colindixon> #info autorelease has generated the first staging repo with a complete release
18:16:24 <colindixon> #info all projects but 4 projects in autorelease: CAPWAP, OpFlex, NEXT, and SNMP4SDM
18:17:11 <colindixon> #info those are all expected except SNMP4SDN; CAPWAP dropped from Be, OpFlex doesn't ship with Karaf, NEXT has no features yet,
18:17:32 <colindixon> #info they have all been contacted
18:17:52 <colindixon> #link https://wiki.opendaylight.org/view/Weather#Current_Weather_Report weather report
18:18:13 <colindixon> #info anipbu says please don't disable license header checks in your build, also notes there were some issues on the weather, but they've been fixed
18:19:24 <colindixon> #info enforcement of config=false was merged, which caused now-fixed problems in LISP
18:20:11 <colindixon> #Info mandatory=true enforcement will happen on 1/5 and might cause some issues, but trying to minimize them, fixed some in BGPCEP
18:20:26 <colindixon> #topic stable/lithium
18:20:32 <colindixon> #info none for now
18:20:43 <colindixon> #topic system integration and testing
18:21:13 <colindixon> #info JamO's not here today, no real updates
18:23:03 <colindixon> #info we'll plan to have a graduation review for integration/test as well as OVSDB netvirt when we get back
18:23:04 <colindixon> #topic infrastructure
18:23:14 <colindixon> #Info queues are really large, we don't quite know how to fix it yet
18:23:26 <colindixon> #info tykeal is still working on private cloud, migrations should start in January
18:23:38 <colindixon> #info he's working though a few enivironmental issues found while kicking the tires
18:25:07 <colindixon> #info edwarnicke asked if the issue with queues is just that we're running out of issues, tykeal says yes and asking for a bigger quota is what will fix it, but that will take 2-4 weeks
18:25:32 <colindixon> #info tykeal says he's not 100% sure what's causing the long queues, it was the longer jobs, but that's mostly fixed, now it's less clear, maybe just more projects and more tests
18:27:15 <colindixon> #info tykeal says they talked on the integration call and one problem is that ever merge runs all CSIT jobs
18:27:33 <dneary> tykeal: What is the throughput of jobs? As in, how many jobs per hour?
18:27:57 <dneary> tykeal, In other words: are there more jobs arriving than the system is capable of handling?
18:28:14 <abhijitkumbhare> +1 colindixon
18:28:34 <alagalah> Continuous Continuous System Integraiton Test Test
18:28:42 <abhijitkumbhare> alagalah: :)
18:28:53 <colindixon> #info colindixon asks if there's a way to create a singleton-task pattern to just run CSIT onces at a time to test all the merges since it was last run
18:29:39 <colindixon> #info zxiiro suggested maybe running CSIT just off the dailies and factor faster integration smoke tests that can run on every merge
18:31:02 <colindixon> #action zxiiro to lead a discussion on how we might reduce our load and thus queue sizes with these ideas
18:31:23 <tykeal> way to get an action zxiiro ;)
18:31:45 <zxiiro> hah
18:31:58 <colindixon> #info rovarga says we could maybe run singlefeaturetests first and allfeaturestests second only if the first start
18:34:38 <colindixon> #link https://git.opendaylight.org/gerrit/#/c/31512/ example of it taking 20 minutes to kick off a verify job
18:35:07 <dneary> tykeal, Is that O(n) with a big multiple, or O(n^x) where x > 1?
18:35:27 <tykeal> dneary: I haven't done the analysis
18:35:50 <colindixon> #info tykeal says the UI is really slow because of the design of jenkins, no easy weay to fix it
18:38:25 <colindixon> #info rovarga says that even getting the logs for failed verify jobs, for example, takes too long to be useful
18:38:45 <colindixon> #info edwarnicke asks how bad things have gotten
18:39:28 <colindixon> #info zxiiro has noticed that it's gotten slow to interact with jenkins recently, but seems less overall less worried than rovarga
18:40:30 <colindixon> #info ttkacik1 says in his mind that jenkins is unusable at this point, it actaully caused a scheduled weather event to be delayed by a week
18:41:15 <alagalah> colindixon, To answer your question, there's two things...
18:41:25 <alagalah> colindixon, Verify/Merge performance is sporadic...
18:41:33 <alagalah> colindixon, Jenkins web UI is unusable
18:42:16 <alagalah> LuisGomez, I am around
18:43:04 <alagalah> zxiiro, Understand that Jenkins UI and the queue are two different things but I heard both topics come up
18:44:17 <colindixon> #action zxiiro to start a plan of atack on jenkins queues pulling in tykeal, rovarga, LuisGomez, edwarnicke, and others as needed
18:44:37 <alagalah> LuisGomez, colindixon zxiiro Do we need to make a distinction between the run times of jobs (https://jenkins.opendaylight.org/releng/view/CSIT-Jobs/ sort duration) and the time it takes to get a slave ?
18:45:02 <colindixon> can TSC members vote on the thread for committers on centinel in the background?
18:45:31 <colindixon> edwarnicke, jmedved, mohnish_, dlenrow
18:46:14 <colindixon> alagalah: and the time it takes to get logs/info from Jenkins UI
18:46:29 <dfarrell07> colindixon: I'm okay with this cutting into Election topic, FYIU
18:46:31 <colindixon> #info it sounds like the first stab is to run CSIT jobs on daily rather than every merge, then go from there
18:48:04 <vina_ermagan> #info in lispflowmapping we also mostly end up ignoring csit results because of the delay recently . I also think Robert's suggestion on pending csit for 3 node pending single node passing would probably be a big help
18:48:18 <colindixon> vina_ermagan: thanks
18:48:34 <alagalah> colindixon, vina_ermagan +1
18:49:15 <rovarga> #info https://issues.jenkins-ci.org/browse/JENKINS-20046 tracks the jenkins scalability issue
18:49:18 <vina_ermagan> with the maturity reviews becoming more prominent, more projects will ramp up on adding more tests
18:50:58 <vina_ermagan> colindixon: thanks
18:51:15 <colindixon> #topic TSC elections
18:51:52 <zxiiro> LuisGomez: I'll send an email after this call to kick off an action plan regarding the CSIT jobs
18:52:08 <LuisGomez> thanks zxiiro
18:53:14 <colindixon> #link https://wiki.opendaylight.org/view/TSC:Election_Proposal#Scaled_Popularity this is the summary that dfarrell07 provided
18:54:02 <colindixon> #info dfarrell07 says that we really need new blood in the discussion at this point
18:54:26 <colindixon> #info edwarnicke and dfarrell07 suggest that we start having a discussion on the list with links to the wiki to help out
18:54:44 <colindixon> #info the wiki is the right place to start now as it summarizes everything but maybe the last 5 or so posts
18:54:57 <colindixon> #info so, you won't need to read everything
18:56:10 <alagalah> colindixon, yay!
18:56:12 <colindixon> #action dfarrell07 to start a new thread pointing just to the wiki summary and the longer thread if people want to read it
18:57:02 <abhijitkumbhare> edwarnicke: dfarrell07 - I was thinking of http://tinyurl.com/ to shorten the URL & put it into the subject line
19:00:21 <colindixon> #info it would be good to get input on this over the time between now ant 1/7
19:00:58 <colindixon> #topic cookies
19:01:00 <colindixon> #endmeeting