18:03:11 <colindixon> #startmeeting tws
18:03:11 <odl_meetbot> Meeting started Mon Feb 23 18:03:11 2015 UTC.  The chair is colindixon. Information about MeetBot at http://ci.openstack.org/meetbot.html.
18:03:11 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:03:11 <odl_meetbot> The meeting name has been set to 'tws'
18:03:28 <colindixon> #topic slides, agenda, waiting, etc.
18:03:35 <colindixon> #chair tbachman alagalah regXboi dfarrell07
18:03:35 <odl_meetbot> Current chairs: alagalah colindixon dfarrell07 regXboi tbachman
18:03:39 <colindixon> #link https://wiki.opendaylight.org/view/File:OVSDB_Neutron_Support_in_Li_and_Beyond.pdf the slides
18:03:39 <tbachman> :)
18:03:52 * regXboi mutters "no good deed goes unpunished"
18:04:17 * tbachman gives vapid stare
18:04:28 <colindixon> #info today, we’ll cover the Lithium plans for Neutron support in the OVSDB project
18:04:33 <alagalah> #topic OVSDB/Neutron support in Li - Colin Dixon, Kyle Mestery, Chris Wright
18:06:23 <tbachman> #info OpenSTack Neutron has been a target use case for ODL since the beginning (OpenDOVE, OVSDB, and VTN all provided Neutron interfaces in Hydrogen)
18:07:00 <tbachman> #info OpenStack Neutron continues to be important (raised at the board and TSC levels; considerable developer/community)
18:07:44 <tbachman> #info shague says a lot has changed with OpenStack neutron. Since the initial integration with Hydrogen, neutrons progressed a lot
18:08:21 <tbachman> #info One fo the questions is how can we foster the relationship betweeen ODL and OpenStack
18:09:24 <tbachman> #info colindixon says even though ODL community recognizes the importance of the use case with Neutron, the ODL community hasn’t engaged enough with OpenStack
18:11:37 <tbachman> #info alagalah asks what the groups thoughts are on the newly created neutron project — will that project act as a liason to the OpenStack project
18:11:54 <tbachman> #info shague says that will be discussed later on in the presentation
18:12:12 <tbachman> #info shague says we’ve got some great first steps, but we need to go beyond what we’ve done
18:12:54 <tbachman> #info relevant projects in ODL include OVSDB, OpenDOVE, VTN, Plugin to OpenContrail, LISP, VPN Services, and Group Based Policy
18:13:14 <tbachman> #info shague points out that this list will probably only grow in subsequent releases
18:13:23 <tbachman> regXboi sets the rules
18:14:05 <tbachman> #info regXboi says projects shouldn’t go to the neutron community with an ask for an interface feature in a blueprint that hasn’t been approved
18:15:39 <tbachman> #info Prem asks for the best way to engage with the OpenStack community to do this
18:16:09 <tbachman> #info colindixon asks if the current neutron interface covers everything in neutron
18:16:19 <tbachman> #info regXboi says there are things that need to be implemented
18:16:24 <tbachman> #undo
18:16:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1a8be10>
18:16:35 <tbachman> #info regXboi says there are things that need to be approved and implemented
18:16:46 <tbachman> #info edwarnicke says there are calls in tempest tests that aren’t documented
18:17:08 <tbachman> #info edwarnicke  says he doesn’t know how you can tell what’s been approved and implemented, b/c it’s not covered in the documentation
18:17:26 <tbachman> #info edwarnicke asks for guidance on how to determine what’s been approved in Neutron
18:18:02 <tbachman> #info regXboi says the two best answers are: 1) he’ll ask for an approved BP in OpenStack; the other is some acronym which I didn’t get
18:18:30 <tbachman> #info alagalah says these are good questions, but lets reserve those until the end of the presentation
18:18:40 <regXboi> #undo
18:18:40 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b71fd0>
18:18:44 <regXboi> #info 2) is RTC
18:18:46 <regXboi> #undo
18:18:46 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1b71990>
18:18:46 <edwarnicke> alagalah: Thank you for pulling us back on track :)
18:18:54 * edwarnicke sometimes gets rat holed :(
18:18:54 <regXboi> #info 2) is RTSC
18:18:59 <regXboi> #info alagalah says these are good questions, but lets reserve those until the end of the presentation
18:19:09 <regXboi> tbachman: wanted to get things back in order
18:19:12 <tbachman> regXboi: I think you removed item #1 :)
18:19:27 <tbachman> ah
18:19:30 <tbachman> no you idn't
18:19:31 <tbachman> sorry
18:19:46 <regXboi> no, I reorder alagalah's point of order
18:20:17 <tbachman> #info The OVSDB project in ODL houses the ODL OpenStack CI for the default ODL Neutron plugin (
18:20:52 <tbachman> #info ODL developers need to engage the OpenStack community
18:21:07 <tbachman> #info Engagement at the upcoming OpenStack Summit is important
18:21:35 <tbachman> #info shague says the overall goal is can we make neutron better, networking better
18:22:06 <alagalah> shague: colindixon flaviof I have a question on the previous slide.
18:22:54 <tbachman> #info OVSDB tasks for Lithim: abstract net virt from OVSDB library and plugin; remove AD-SAL dependencies; Support existing OVSDB plugin interface for VTN; add MD-SAL southbound plugin; migrate net virt to MD-SAL southbound plugin; test and importve scale, stability and performance; close feature gap with Neutron and OpenSTack OVS plugin (e.g. L3, LBaaS, FWaaS, VPNaaS)
18:23:17 <flaviof> alagalah: np. want to as it on irc or webex?
18:23:47 <alagalah> flaviof: That's ok, lets keep trucking....
18:23:57 <flaviof> alagalah: k
18:24:23 <tbachman> #info shague says a lot of code came in during Helium; project is trying to focus on the scale, stability and perfomance and closing the feature gaps is high priority
18:24:56 <colindixon> alagalah: what’s the questions?
18:24:58 <tbachman> #info shague says flaviof has done a lot of work on L3; srini084 has done a lot of work on LBaaS; FWaaS and VPNaaS still need more work
18:25:15 <tbachman> #info Uri asks if L3 means DVR
18:25:38 <tbachman> #info flaviof says it’s not DVR — it’s OVS-based, using OpenFlow rules to do L3 forwarding (TTL decrement, etc.)
18:25:51 <tbachman> #info flaviof says they’re still looking into how scalable that solution is
18:26:15 <tbachman> #info Uri asks if DVR can be added to the list
18:26:48 <tbachman> #info Uri asks for the projects thoughts on the “xaaS” features, and how they relate to SFC
18:27:02 <tbachman> #info shague says those are all good questions, but are still open items
18:27:23 <regXboi> alagalah: can I inject a point of order?
18:27:38 <regXboi> that last question needs an answer from neutron project as well
18:27:48 <alagalah> regXboi: Yes.. I am not the thought police dude, just keeping us on agenda
18:28:40 <tbachman> #info shague says that this all presumes that Neutron passes this information to ODL
18:29:11 <tbachman> #info Uri asks if the list on the presentation is prioritized
18:30:00 <tbachman> #info colindixon says that is a somewhat prioritized list — where the first 5 items are being done as part of the “paying down technical debt”, and the last two items are the things are the end-goal
18:31:16 <tbachman> #inf mohnish asks which pieces are considered plugin — seems like whole OVSDB is a plugin once its migrated to the MD-SAL
18:31:26 <tbachman> #info mohnish asks which pieces are considered plugin — seems like whole OVSDB is a plugin once its migrated to the MD-SAL
18:31:46 <tbachman> #info shague says the current architecture uses the AD-SAL Node; migrating to the MD-SAL includes migrating to the MD-SAL node
18:32:15 <tbachman> #info shague says the netvirt layer which sits on top of the lib, and the layers above it, aren’t considered plugins
18:33:18 <tbachman> #info shague says there are two parallel paths — existing plugin interface and the new MD-SAL interface; as time goes on, this will converge to the MD-SAL plugin
18:34:00 <tbachman> #info Neutron tasks for Lithium include: migrate Nuetron to its own project; rework bundles and features to better represent the Neutron implementation; Triage existing bugs; add YANG model and MD-SAL provider
18:34:15 <tbachman> #info edwarnicke, regXboi, and flaviof have been doing a fantastic job tackling these tasks
18:34:23 * tbachman gives applause
18:35:31 <tbachman> #info see regXboi  for meeting minutes
18:35:41 <regXboi> nice :)
18:35:41 <tbachman> #undo
18:35:41 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x18b7d90>
18:35:43 <tbachman> lol
18:36:24 <tbachman> #info regXboi encourages the community to contribute code to the Neutron project
18:36:46 <tbachman> #info regXboi says if there’s something a project wants in Juno or Kilo, then please contribute
18:38:05 <tbachman> #info ODL stackforge: migrates ODL ML2 plugin to its own repo; leverage the plugin functionality in devsatck, so new plugin (aka networking-odl) is seamlessly integrated with local.conf; enable tempest tests; integrate with OVSDB Jenkins jobs to enable robust integration testing
18:44:18 <tbachman> #info Future Work Items: close feature gap with Neutron and OpenStack OVS plugin; migrate netvirt northbound to use MD-SAL neutron; migrate net virt from OVS specific to tunnel management and traffic direction (into tunnels)
18:45:41 * tbachman can’t #info diagrams
18:46:21 <regXboi> wow - that diagram is actually wrong
18:46:35 <tbachman> regXboi: speak :)
18:47:21 <tbachman> #info regXboi says that the OVSDB Evolution diagram doesn’t show the controller in the Current World
18:47:35 <tbachman> #info colindixon says the functionality provided is from the controller
18:48:32 <tbachman> #info LuisGomez says in “near future”, there is a NetCONF piece. Asks about this feature
18:48:58 <tbachman> #info colindixon says that the hope is to provide a set of YANG APIs where you could plugin whatever you want into tunnel management and traffic direction
18:50:46 <tbachman> #info mohnish ass what the policy adapter is in the diagram
18:51:47 <tbachman> #info colindixon says that there’s a collaborative push between GBP and NIC to define a broader policy framework to do things that get realized in neutron, but enable richer behaviors than what neutron currently provides
18:51:49 <Prem> tbachman: You may want to undo the last info message due to a typo
18:51:56 <tbachman> lol!
18:52:00 <tbachman> Prem: thx ;)
18:52:01 <tbachman> #undo
18:52:01 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19aaf10>
18:52:02 <tbachman> #undo
18:52:02 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x19aa890>
18:52:15 <tbachman> #info mohnish asks what the policy adapter is in the diagram
18:52:22 <tbachman> #info colindixon says that there’s a collaborative push between GBP and NIC to define a broader policy framework to do things that get realized in neutron, but enable richer behaviors than what neutron currently provides
18:53:00 * dfarrell07 just got down giving an interview, *super sad* at having missed most of the meeting, will listen to recording ASAP /cc cdub
18:53:40 <tbachman> dfarrell07: yeah — alagalah recorded it, so you didn’t miss anything :)
18:54:04 <dfarrell07> tbachman: perfect, thanks alagalah :)
18:55:25 <tbachman> #info abhijitkumbhare asks about the opendaylight neutron plan and GBP — will they be mapping this architecture into the neutron diagram
18:55:43 <tbachman> #info alagalah says this is a bit out of scope for the TWS, but is happy to address in the GBP meetings
18:56:01 <abhijitkumbhare> https://docs.google.com/presentation/d/1vsYddlHFRnVG9cDwWxyldT2BNSfYUTPcR1lYtUrFA8U/edit#slide=id.g612a6349b_00
18:56:26 <tbachman> #link : https://docs.google.com/presentation/d/1vsYddlHFRnVG9cDwWxyldT2BNSfYUTPcR1lYtUrFA8U/edit#slide=id.g612a6349b_00  abhijitkumbhare just requests if GBP could map this to the slide deck presented here
18:58:06 <tbachman> #info Opportunities to help: MD-SAL migration; MD-SAL southbound plugin; Future work items: advanced services, MD-SAL neutron, tunnel-like southbound; OpenStack engagement
18:58:24 <tbachman> #link https://trello.com/b/ctunVAEr/ovsdb-mdsal-southbound MD-SAL southbound trello board
18:58:40 <tbachman> #link https://trello.com/b/lKnNc7PB/ovsdb-mdsal-migration OVSDB MD-SAL migration trello board
18:58:53 <tbachman> #link https://trello.com/b/ddIvDQE0/ovs-openstack OVSDB trello board
19:00:24 <tbachman> #info alagalah asks what the appropriate mailing list to be used for discussions on this topic
19:00:58 <tbachman> #info regXboi says the community interface should be on discuss
19:01:08 <tbachman> #info regXboi says code-related questions should be on neutron-dev
19:01:31 <tbachman> #info colindixon asks if we have topics set up on discuss
19:01:46 * tbachman suspects everyone is talking over phrobb
19:01:50 <shague> #info big thanks to Ed for getting the mdsal sb crud
19:02:21 <tbachman> #action alagalah to ask if we have topics set up on discuss
19:02:32 <zxiiro> +1
19:03:00 <mohnish> good presentation. thanks.
19:03:50 <Prem> +1 Good presentation and it cleared lots of doubts around OS and ODL integration
19:04:17 <tbachman> #endmeeting